aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-04-30 20:34:27 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-04-30 20:34:27 +0000
commitdc16e8d275834833fa72b294e3ed1c8aafbd3381 (patch)
tree883ec69c8f0f0fb9e21718398d13902e85622889 /graphics
parentb1aeb76930728e7eb620c9cd6a4addbcccac42b8 (diff)
downloadports-dc16e8d275834833fa72b294e3ed1c8aafbd3381.tar.gz
ports-dc16e8d275834833fa72b294e3ed1c8aafbd3381.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/py-imaging/Makefile27
-rw-r--r--graphics/py-imaging/pkg-plist108
2 files changed, 36 insertions, 99 deletions
diff --git a/graphics/py-imaging/Makefile b/graphics/py-imaging/Makefile
index 43e3e475add0..f3c05a6b2c60 100644
--- a/graphics/py-imaging/Makefile
+++ b/graphics/py-imaging/Makefile
@@ -7,6 +7,7 @@
PORTNAME= imaging
PORTVERSION= 1.1.5
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= http://effbot.org/downloads/ \
http://www.pythonware.net/storage/
@@ -16,29 +17,41 @@ DISTNAME= Imaging-${PORTVERSION}
MAINTAINER= mainland@apeiron.net
COMMENT= The Python Imaging Library
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
freetype.9:${PORTSDIR}/print/freetype2
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
-DIST_SUBDIR= python
-USE_PYTHON= yes
+LATEST_LINK= py-${PORTNAME}
+
+DIST_SUBDIR= python
+USE_PYTHON= yes
USE_PYDISTUTILS=yes
-DOCDIRS= ${PREFIX}/share/doc/py-imaging
+PORTDOCS= *
+
+DOCDIRS= ${PREFIX}/share/doc/py-imaging
EXAMPLESDIR= ${PREFIX}/share/examples/py-imaging
+OPTIONS= TKINTER "Build with tkinter for X support" off
+
.include <bsd.port.pre.mk>
+.if defined(WITH_TKINTER) || exists(${PYTHON_SITELIBDIR}/_tkinter.so)
+BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+PLIST_SUB+= TKINTER=""
+.else
+PLIST_SUB+= TKINTER="@comment "
+.endif
+
post-install:
.for file in ImPlatform.h Imaging.h
${INSTALL_DATA} ${WRKSRC}/libImaging/${file} ${PYTHON_INCLUDEDIR}
.endfor
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Scripts/* ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/Docs/* ${DOCSDIR}
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/Scripts/* ${EXAMPLESDIR}
.endif
.include <bsd.port.post.mk>
diff --git a/graphics/py-imaging/pkg-plist b/graphics/py-imaging/pkg-plist
index ff5dbd1701c1..55fd002ac413 100644
--- a/graphics/py-imaging/pkg-plist
+++ b/graphics/py-imaging/pkg-plist
@@ -229,97 +229,21 @@ include/%%PYTHON_VERSION%%/Imaging.h
%%PYTHON_SITELIBDIR%%/PIL/__init__.pyo
%%PYTHON_SITELIBDIR%%/PIL/_imaging.so
%%PYTHON_SITELIBDIR%%/PIL/_imagingft.so
-%%PYTHON_SITELIBDIR%%/PIL/_imagingtk.so
+%%TKINTER%%%%PYTHON_SITELIBDIR%%/PIL/_imagingtk.so
%%PYTHON_SITELIBDIR%%/PIL.pth
@dirrm %%PYTHON_SITELIBDIR%%/PIL
-%%PORTDOCS%%%%DOCSDIR%%/effbot.css
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ArgImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.BdfFontFile.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.BmpImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.BufrStubImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ContainerIO.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.CurImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.DcxImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.EpsImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ExifTags.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.FitsStubImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.FliImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.FontFile.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.FpxImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.GbrImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.GdImageFile.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.GifImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.GimpGradientFile.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.GimpPaletteFile.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.GribStubImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.Hdf5StubImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.IcnsImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.IcoImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ImImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.Image.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ImageChops.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ImageColor.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ImageDraw.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ImageEnhance.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ImageFile.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ImageFileIO.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ImageFilter.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ImageFont.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ImageGL.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ImageGrab.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ImageOps.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ImagePalette.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ImagePath.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ImageSequence.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ImageStat.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ImageTk.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ImageTransform.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ImageWin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.ImtImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.IptcImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.JpegImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.McIdasImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.MicImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.MpegImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.MspImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.OleFileIO.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.PSDraw.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.PaletteFile.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.PalmImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.PcdImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.PcfFontFile.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.PcxImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.PdfImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.PixarImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.PngImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.PpmImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.PsdImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.SgiImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.SpiderImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.SunImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.TarIO.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.TgaImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.TiffImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.TiffTags.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.WalImageFile.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.WmfImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.XVThumbImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.XbmImagePlugin.html
-%%PORTDOCS%%%%DOCSDIR%%/pythondoc-PIL.XpmImagePlugin.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTDOCS%%%%EXAMPLESDIR%%/README
-%%PORTDOCS%%%%EXAMPLESDIR%%/enhancer.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/explode.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/gifmaker.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/image2py.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/painter.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/pilconvert.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/pildriver.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/pilfile.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/pilfont.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/pilprint.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/player.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/thresholder.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/viewer.py
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%EXAMPLESDIR%%/README
+%%EXAMPLESDIR%%/enhancer.py
+%%EXAMPLESDIR%%/explode.py
+%%EXAMPLESDIR%%/gifmaker.py
+%%EXAMPLESDIR%%/image2py.py
+%%EXAMPLESDIR%%/painter.py
+%%EXAMPLESDIR%%/pilconvert.py
+%%EXAMPLESDIR%%/pildriver.py
+%%EXAMPLESDIR%%/pilfile.py
+%%EXAMPLESDIR%%/pilfont.py
+%%EXAMPLESDIR%%/pilprint.py
+%%EXAMPLESDIR%%/player.py
+%%EXAMPLESDIR%%/thresholder.py
+%%EXAMPLESDIR%%/viewer.py
+@dirrm %%EXAMPLESDIR%%