aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-04-15 14:11:16 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-04-15 14:11:16 +0000
commite41aae26650b2ce44c47aee040318822098d8607 (patch)
tree903566cb9b8e3e91f5bf0a632fc135305066cad1 /graphics
parenta23b7444b22a16a604c3d74cdab62814ad6fd65a (diff)
downloadports-e41aae26650b2ce44c47aee040318822098d8607.tar.gz
ports-e41aae26650b2ce44c47aee040318822098d8607.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/zgv/Makefile52
-rw-r--r--graphics/zgv/distinfo2
-rw-r--r--graphics/zgv/pkg-descr8
4 files changed, 63 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 189cb20f179f..67bf6ca16243 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -473,6 +473,7 @@
SUBDIR += xwpick
SUBDIR += xzgv
SUBDIR += yafray
+ SUBDIR += zgv
SUBDIR += zimg
SUBDIR += zphoto
diff --git a/graphics/zgv/Makefile b/graphics/zgv/Makefile
new file mode 100644
index 000000000000..c5e5961c4d45
--- /dev/null
+++ b/graphics/zgv/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: zgv
+# Date created: 2004-04-15
+# Whom: Radim Kolar
+#
+# $FreeBSD$
+#
+
+PORTNAME= zgv
+PORTVERSION= 5.8
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= apps/graphics/viewers/svga
+
+MAINTAINER= hsn@netmag.cz
+COMMENT= Graphics viewer for SVGAlib
+
+LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
+ vga.1:${PORTSDIR}/graphics/svgalib \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png
+
+ONLY_FOR_ARCHS= i386
+USE_GMAKE= yes
+ALL_TARGET= all info
+
+PLIST_FILES= bin/zgv etc/zgvrc.sample
+.if !defined(NO_INSTALL_MANPAGES)
+MAN1= zgv.1
+.endif
+.if !defined(NOPORTDOCS)
+INFO= zgv
+PORTDOCS= NEWS README SECURITY TODO
+.endif
+
+post-patch:
+ ${RM} ${WRKSRC}/doc/zgv
+
+do-install:
+ ${INSTALL} -c -g wheel -o root -m 4755 ${WRKSRC}/src/zgv ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/doc/sample.zgvrc ${PREFIX}/etc/zgvrc.sample
+.if !defined(NOPORTDOCS)
+ ${INSTALL_DATA} ${WRKSRC}/doc/zgv ${PREFIX}/${INFO_PATH}/zgv.info
+ ${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+.if !defined(NO_INSTALL_MANPAGES)
+ ${INSTALL_MAN} ${WRKSRC}/doc/zgv.1 ${MAN1PREFIX}/man/man1
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/zgv/distinfo b/graphics/zgv/distinfo
new file mode 100644
index 000000000000..f370d367eeea
--- /dev/null
+++ b/graphics/zgv/distinfo
@@ -0,0 +1,2 @@
+MD5 (zgv-5.8.tar.gz) = 016bb8f3b9f3d1aa01a837dbbb67c5dc
+SIZE (zgv-5.8.tar.gz) = 391623
diff --git a/graphics/zgv/pkg-descr b/graphics/zgv/pkg-descr
new file mode 100644
index 000000000000..a6e027b7a43c
--- /dev/null
+++ b/graphics/zgv/pkg-descr
@@ -0,0 +1,8 @@
+zgv is an svgalib-based viewer which views GIF, JPEG, PNG,
+PBM/PGM/PPM, TIFF, BMP, TGA, PCX, mrf, XBM, and XPM files, with a
+full-screen file selector front-end. It can be used as a simple
+command, with zgv filename(s), which bypasses the front-end. For
+more on how zgv works and how to use it, do `info zgv' or `man zgv'
+once it's installed.
+
+WWW: http://www.svgalib.org/rus/zgv/