aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-10-25 04:32:36 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-10-25 04:32:36 +0000
commit315855ac364702ef5fcaecb83f00afe55bcab8e7 (patch)
tree74f6e42bd752280ec0873cfa83888e04e5ace0c9 /graphics
parent66743463bd352c1ad4917b749dca3b89f7431f18 (diff)
downloadports-315855ac364702ef5fcaecb83f00afe55bcab8e7.tar.gz
ports-315855ac364702ef5fcaecb83f00afe55bcab8e7.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ming/Makefile15
-rw-r--r--graphics/ming/distinfo2
-rw-r--r--graphics/ming/files/Makefile44
-rw-r--r--graphics/ming/pkg-plist69
-rw-r--r--graphics/py-ming/Makefile8
-rw-r--r--graphics/py-ming/files/patch-Makefile8
-rw-r--r--graphics/ruby-ming/Makefile7
-rw-r--r--graphics/ruby-ming/files/patch-depend18
8 files changed, 72 insertions, 99 deletions
diff --git a/graphics/ming/Makefile b/graphics/ming/Makefile
index 8197e6db15bb..8077e30e6c75 100644
--- a/graphics/ming/Makefile
+++ b/graphics/ming/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ming
-PORTVERSION= 0.0.2e
+PORTVERSION= 0.0.3a
CATEGORIES= graphics
MASTER_SITES= http://www.opaque.net/ming/
EXTRACT_SUFX= .tgz
@@ -24,17 +24,4 @@ DOCS= CHANGES \
pre-build:
${CP} ${FILESDIR}/Makefile ${WRKSRC}/
-pre-install:
- ${MKDIR} ${PREFIX}/include/ming
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/ming
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/../${f} ${PREFIX}/share/doc/ming/
-.endfor
- ${CP} -R ${WRKSRC}/../docs/* ${PREFIX}/share/doc/ming/
- ${LN} -sf ../doc/ming/examples ${PREFIX}/share/examples/ming
-.endif
-
.include <bsd.port.mk>
diff --git a/graphics/ming/distinfo b/graphics/ming/distinfo
index b8dba8e29c9a..2e0b33b86372 100644
--- a/graphics/ming/distinfo
+++ b/graphics/ming/distinfo
@@ -1 +1 @@
-MD5 (ming-0.0.2e.tgz) = affc6a0a45d76674cd4dba738a07efc2
+MD5 (ming-0.0.3a.tgz) = 6bf8c311a76c9fd6aefab9536e31bdd4
diff --git a/graphics/ming/files/Makefile b/graphics/ming/files/Makefile
index c16ed8c6fcc9..130a2a2731b9 100644
--- a/graphics/ming/files/Makefile
+++ b/graphics/ming/files/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
LIB= ming
-SHLIB_MAJOR?= 0
+SHLIB_MAJOR?= 1
SHLIB_MINOR?= 0
CFLAGS+= -I${.CURDIR}/actioncompiler -I${.CURDIR}/blocks -I${LOCALBASE}/include
LDADD= -lm
@@ -10,24 +10,29 @@ SRCS= blocklist.c \
movie.c \
movieclip.c \
position.c \
+ shape.c \
actioncompiler/compile.c \
actioncompiler/compileaction.c \
actioncompiler/compiler.tab.c \
actioncompiler/lex.yy.c \
blocks/action.c \
+ blocks/bitmap.c \
blocks/block.c \
blocks/browserfont.c \
blocks/button.c \
blocks/character.c \
blocks/cxform.c \
blocks/dbl.c \
- blocks/fill.c \
+ blocks/fillstyle.c \
blocks/font.c \
blocks/fontinfo.c \
+ blocks/gradient.c \
blocks/jpeg.c \
+ blocks/linestyle.c \
blocks/loadfont.c \
blocks/matrix.c \
blocks/method.c \
+ blocks/morph.c \
blocks/mp3.c \
blocks/output.c \
blocks/outputblock.c \
@@ -37,11 +42,42 @@ SRCS= blocklist.c \
blocks/sprite.c \
blocks/text.c \
blocks/textfield.c
-INCS= blocktypes.h \
+INCS= blocklist.h \
+ displaylist.h \
+ fill.h \
+ libming.h \
ming.h \
- swf.h
+ movie.h \
+ movieclip.h \
+ position.h \
+ shape.h \
+ blocks/swf.h
+
NOMAN= YES
LIBDIR= ${LOCALBASE}/lib
INCDIR= ${LOCALBASE}/include/ming
.include <bsd.lib.mk>
+
+# For FreeBSD 3.x or older
+.if !target(_includeinstall)
+_includeinstall:
+.if defined(INCS)
+.for header in ${INCS}
+ cd ${.CURDIR} && \
+ ${INSTALL} -C -o ${INCOWN} -g ${INCGRP} -m ${INCMODE} \
+ ${header} ${DESTDIR}${INCDIR}
+
+.endfor
+.endif
+
+beforeinstall: _includeinstall
+.endif
+
+_includeinstall: pre-_includeinstall
+
+pre-_includeinstall:
+ mkdir -p ${INCDIR}/blocks
+
+beforeinstall:
+ mv ${INCDIR}/swf.h ${INCDIR}/blocks/
diff --git a/graphics/ming/pkg-plist b/graphics/ming/pkg-plist
index f630f1f53249..d2cffe3faf2f 100644
--- a/graphics/ming/pkg-plist
+++ b/graphics/ming/pkg-plist
@@ -1,62 +1,15 @@
-include/ming/blocktypes.h
+include/ming/blocklist.h
+include/ming/displaylist.h
+include/ming/fill.h
+include/ming/libming.h
include/ming/ming.h
-include/ming/swf.h
+include/ming/movie.h
+include/ming/movieclip.h
+include/ming/position.h
+include/ming/shape.h
+include/ming/blocks/swf.h
+@dirrm include/ming/blocks
@dirrm include/ming
lib/libming.a
lib/libming.so
-lib/libming.so.0
-share/doc/ming/CHANGES
-share/doc/ming/CREDITS
-share/doc/ming/Makefile
-share/doc/ming/README
-share/doc/ming/TODO
-share/doc/ming/index.html
-share/doc/ming/php-action.html
-share/doc/ming/php-button.html
-share/doc/ming/php-movie.html
-share/doc/ming/php-shape.html
-share/doc/ming/php-text.html
-share/doc/ming/phpref.html
-share/doc/ming/examples/action.html
-share/doc/ming/examples/action.php
-share/doc/ming/examples/alpha.dbl
-share/doc/ming/examples/alphafill.html
-share/doc/ming/examples/alphafill.jpg
-share/doc/ming/examples/alphafill.msk
-share/doc/ming/examples/alphafill.php
-share/doc/ming/examples/animation.html
-share/doc/ming/examples/animation.php
-share/doc/ming/examples/button.html
-share/doc/ming/examples/button.php
-share/doc/ming/examples/drag.html
-share/doc/ming/examples/drag.php
-share/doc/ming/examples/index.html
-share/doc/ming/examples/jpegfill.html
-share/doc/ming/examples/jpegfill.php
-share/doc/ming/examples/keypress.html
-share/doc/ming/examples/keypress.php
-share/doc/ming/examples/morph.html
-share/doc/ming/examples/morph.php
-share/doc/ming/examples/mousetrack.html
-share/doc/ming/examples/mousetrack.php
-share/doc/ming/examples/newbutton.html
-share/doc/ming/examples/newbutton.php
-share/doc/ming/examples/png.dbl
-share/doc/ming/examples/png.html
-share/doc/ming/examples/png.php
-share/doc/ming/examples/pngalpha.html
-share/doc/ming/examples/pngalpha.php
-share/doc/ming/examples/shape.html
-share/doc/ming/examples/shape.php
-share/doc/ming/examples/showswf.php
-share/doc/ming/examples/sprite.html
-share/doc/ming/examples/sprite.php
-share/doc/ming/examples/streammp3.html
-share/doc/ming/examples/streammp3.php
-share/doc/ming/examples/text.html
-share/doc/ming/examples/text.php
-share/doc/ming/images/curve.gif
-@dirrm share/doc/ming/examples
-@dirrm share/doc/ming/images
-@dirrm share/doc/ming
-share/examples/ming
+lib/libming.so.1
diff --git a/graphics/py-ming/Makefile b/graphics/py-ming/Makefile
index a64fecc659b2..b2ef03f0ea53 100644
--- a/graphics/py-ming/Makefile
+++ b/graphics/py-ming/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ming
-PORTVERSION= 0.0.2e
-PORTREVISION= 1
+PORTVERSION= 0.0.3a
CATEGORIES= graphics python
MASTER_SITES= http://www.opaque.net/ming/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +15,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= knu@FreeBSD.org
BUILD_DEPENDS= ${SWIG}:${PORTSDIR}/devel/SWIG-devel
-LIB_DEPENDS= ming.0:${PORTSDIR}/graphics/ming
+LIB_DEPENDS= ming.1:${PORTSDIR}/graphics/ming
USE_PYTHON= yes
@@ -29,6 +28,9 @@ SWIG= swig1.3
EXAMPLES= shape.py test.py
+post-extract:
+ ${LN} -sf ../ming.i ${WRKSRC}/
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/examples/${PYTHON_VERSION}/ming
diff --git a/graphics/py-ming/files/patch-Makefile b/graphics/py-ming/files/patch-Makefile
index 189718208c3e..7da12fdc4941 100644
--- a/graphics/py-ming/files/patch-Makefile
+++ b/graphics/py-ming/files/patch-Makefile
@@ -1,11 +1,11 @@
---- Makefile.orig Fri Oct 13 15:26:29 2000
-+++ Makefile Tue Oct 17 17:43:54 2000
+--- Makefile.orig Wed Oct 25 07:02:37 2000
++++ Makefile Wed Oct 25 13:11:16 2000
@@ -1,11 +1,10 @@
all:
-- swig -python ming.i
+- swig -I.. -python ming.i
- gcc -I .. -I /usr/include/python1.5/ -fpic -c ming_wrap.c
- gcc -L .. -shared -o mingcmodule.so ming_wrap.o -lming
-+ ${SWIG} -python ming.i
++ ${SWIG} -I.. -python ming.i
+ ${CC} ${CFLAGS} -I${LOCALBASE}/include/ming -I${LOCALBASE}/include/${PYTHON_VERSION} -fpic -c ming_wrap.c
+ ${CC} -shared -o mingcmodule.so ming_wrap.o -L${LOCALBASE}/lib -lming
diff --git a/graphics/ruby-ming/Makefile b/graphics/ruby-ming/Makefile
index 81c228db7ef2..e6ec4632e06d 100644
--- a/graphics/ruby-ming/Makefile
+++ b/graphics/ruby-ming/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ming
-PORTVERSION= 0.0.2e
-PORTREVISION= 1
+PORTVERSION= 0.0.3a
CATEGORIES= graphics ruby
MASTER_SITES= http://www.opaque.net/ming/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -16,7 +15,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= knu@FreeBSD.org
BUILD_DEPENDS= swig1.3:${PORTSDIR}/devel/SWIG-devel
-LIB_DEPENDS= ming.0:${PORTSDIR}/graphics/ming
+LIB_DEPENDS= ming.1:${PORTSDIR}/graphics/ming
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
@@ -33,7 +32,7 @@ SWIG= swig1.3
EXAMPLES= shape.rb test.rb
post-extract:
- ${LN} -sf ${WRKSRC}/../py_ext/*.i ${WRKSRC}/
+ ${LN} -sf ../ming.i ${WRKSRC}/
post-install:
${INSTALL_DATA} ${WRKSRC}/ming.rb ${RUBY_SITELIBDIR}/
diff --git a/graphics/ruby-ming/files/patch-depend b/graphics/ruby-ming/files/patch-depend
index a16f374050bf..2cddb2e4a07c 100644
--- a/graphics/ruby-ming/files/patch-depend
+++ b/graphics/ruby-ming/files/patch-depend
@@ -1,17 +1,13 @@
---- depend.orig Fri Oct 13 15:26:31 2000
-+++ depend Tue Oct 17 17:46:26 2000
-@@ -1,4 +1,4 @@
--SWIGINC= ../py_ext
-+SWIGINC= .
+--- depend.orig Wed Oct 25 07:02:39 2000
++++ depend Wed Oct 25 13:23:57 2000
+@@ -4,8 +4,8 @@
- OBJS+= ming_wrap.o
-
-@@ -7,7 +7,7 @@
ming_wrap.o: ming_wrap.c
- ming_wrap.c: ${SWIGINC}/blocklist.i ${SWIGINC}/blocktypes.i ${SWIGINC}/ming.i ${SWIGINC}/swf.i
-- swig -I${SWIGINC} -ruby ${SWIGINC}/ming.i
-+ ${SWIG} -I${SWIGINC} -ruby ${SWIGINC}/ming.i
+-ming_wrap.c: ../ming.i
+- swig -I.. -ruby ming.i
++ming_wrap.c: ming.i
++ ${SWIG} -ruby ming.i
clean: clean_local