aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-01-09 12:40:05 +0000
committerSteve Wills <swills@FreeBSD.org>2019-01-09 12:40:05 +0000
commit4d052662daef4a4dd811f11cbdca01779f36e7cc (patch)
tree8becce0fc01c80cb0e2eafd6d00200a8584a9f5d /graphics
parent25e87da2c19c0febdcde08d21b46a7d024f3160f (diff)
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cloudcompare/Makefile7
-rw-r--r--graphics/cloudcompare/distinfo6
-rw-r--r--graphics/cloudcompare/files/patch-cmake_CMakeExternalLibs.cmake (renamed from graphics/cloudcompare/files/patch-CMakeExternalLibs.cmake)8
-rw-r--r--graphics/cloudcompare/files/patch-common_ccPluginManager.cpp11
-rw-r--r--graphics/cloudcompare/files/patch-plugins_core_qFacets_CMakeLists.txt (renamed from graphics/cloudcompare/files/patch-plugins_qFacets_CMakeLists.txt)8
-rw-r--r--graphics/cloudcompare/files/patch-plugins_core_qPCL_PclUtils_filters_MLSSmoothingUpsampling.cpp (renamed from graphics/cloudcompare/files/patch-plugins_qPCL_PclUtils_filters_MLSSmoothingUpsampling.cpp)6
-rw-r--r--graphics/cloudcompare/files/patch-plugins_core_qRANSAC__SD_RANSAC__SD__orig_GfxTL_FlatCopyVector.h (renamed from graphics/cloudcompare/files/patch-plugins_qRANSAC__SD_RANSAC__SD__orig_GfxTL_FlatCopyVector.h)4
-rw-r--r--graphics/cloudcompare/files/patch-plugins_core_qRANSAC__SD_RANSAC__SD__orig_GfxTL_KdTree.h11
-rw-r--r--graphics/cloudcompare/files/patch-plugins_core_qRANSAC__SD_RANSAC__SD__orig_MiscLib_AlignedAllocator.h (renamed from graphics/cloudcompare/files/patch-plugins_qRANSAC__SD_RANSAC__SD__orig_MiscLib_AlignedAllocator.h)4
-rw-r--r--graphics/cloudcompare/files/patch-plugins_qRANSAC__SD_RANSAC__SD__orig_GfxTL_KdTree.h11
-rw-r--r--graphics/cloudcompare/pkg-plist51
11 files changed, 68 insertions, 59 deletions
diff --git a/graphics/cloudcompare/Makefile b/graphics/cloudcompare/Makefile
index 7c423dd38b6a..0551abc08d6d 100644
--- a/graphics/cloudcompare/Makefile
+++ b/graphics/cloudcompare/Makefile
@@ -2,9 +2,7 @@
PORTNAME= cloudcompare
DISTVERSIONPREFIX= v
-DISTVERSION= 2.9.1-288
-DISTVERSIONSUFFIX= -gb4d51361
-PORTREVISION= 7
+DISTVERSION= 2.10
CATEGORIES= graphics
MAINTAINER= neel@neelc.org
@@ -19,8 +17,7 @@ USES= cmake localbase:ldflags qt:5
USE_GITHUB= yes
GH_ACCOUNT= CloudCompare
GH_PROJECT= ${GH_ACCOUNT}
-GH_TAGNAME= 5d41227deb30c445ccbaa2d789a4363b57948a5d
-USE_QT= concurrent core gui opengl printsupport widgets buildtools_build qmake_build
+USE_QT= concurrent core gui opengl printsupport widgets buildtools_build qmake_build svg linguisttools
USE_LDCONFIG= yes
OPTIONS_DEFINE= DXFLIB GAMEPAD GDAL PDAL SHAPELIB PLUGINS
diff --git a/graphics/cloudcompare/distinfo b/graphics/cloudcompare/distinfo
index a8667ed58df1..56f0151886ed 100644
--- a/graphics/cloudcompare/distinfo
+++ b/graphics/cloudcompare/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1523597948
-SHA256 (CloudCompare-CloudCompare-v2.9.1-288-gb4d51361-5d41227deb30c445ccbaa2d789a4363b57948a5d_GH0.tar.gz) = 17a473be2706a0146b0652c59ed170c0496eea67e62d5555b5fec67828ef8f13
-SIZE (CloudCompare-CloudCompare-v2.9.1-288-gb4d51361-5d41227deb30c445ccbaa2d789a4363b57948a5d_GH0.tar.gz) = 35032942
+TIMESTAMP = 1546885922
+SHA256 (CloudCompare-CloudCompare-v2.10_GH0.tar.gz) = 835047603e3fd260f90c97bb813a9273d5f3a78a47b4b446dd65cbf04a37cf19
+SIZE (CloudCompare-CloudCompare-v2.10_GH0.tar.gz) = 35307711
diff --git a/graphics/cloudcompare/files/patch-CMakeExternalLibs.cmake b/graphics/cloudcompare/files/patch-cmake_CMakeExternalLibs.cmake
index 24463f12c302..f1e9c7bd085f 100644
--- a/graphics/cloudcompare/files/patch-CMakeExternalLibs.cmake
+++ b/graphics/cloudcompare/files/patch-cmake_CMakeExternalLibs.cmake
@@ -1,11 +1,11 @@
---- CMakeExternalLibs.cmake.orig 2018-03-16 21:26:02 UTC
-+++ CMakeExternalLibs.cmake
-@@ -66,7 +66,7 @@ endif()
+--- cmake/CMakeExternalLibs.cmake.orig 2019-01-07 13:42:34.210570000 -0500
++++ cmake/CMakeExternalLibs.cmake 2019-01-07 13:45:18.201885000 -0500
+@@ -67,7 +67,7 @@
# ------------------------------------------------------------------------------
# OpenMP
# ------------------------------------------------------------------------------
-find_package(OpenMP QUIET)
-+#find_package(OpenMP QUIET) # Broken on FreeBSD: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=223678
++find_package(OpenMP QUIET) # Broken on FreeBSD: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=223678
if (OPENMP_FOUND)
message("OpenMP found")
set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${OpenMP_C_FLAGS}")
diff --git a/graphics/cloudcompare/files/patch-common_ccPluginManager.cpp b/graphics/cloudcompare/files/patch-common_ccPluginManager.cpp
new file mode 100644
index 000000000000..79135abcf91b
--- /dev/null
+++ b/graphics/cloudcompare/files/patch-common_ccPluginManager.cpp
@@ -0,0 +1,11 @@
+--- common/ccPluginManager.cpp.orig 2019-01-06 17:02:13.000000000 -0500
++++ common/ccPluginManager.cpp 2019-01-07 14:12:33.433157000 -0500
+@@ -177,7 +177,7 @@
+ "*.dylib"
+ #elif defined(Q_OS_WIN)
+ "*.dll"
+-#elif defined(Q_OS_LINUX)
++#elif defined(Q_OS_LINUX) || defined(Q_OS_FREEBSD)
+ "*.so"
+ #else
+ #error Need to specify the dynamic library extension for this OS.
diff --git a/graphics/cloudcompare/files/patch-plugins_qFacets_CMakeLists.txt b/graphics/cloudcompare/files/patch-plugins_core_qFacets_CMakeLists.txt
index 395bdcab5c43..18e8eab113ab 100644
--- a/graphics/cloudcompare/files/patch-plugins_qFacets_CMakeLists.txt
+++ b/graphics/cloudcompare/files/patch-plugins_core_qFacets_CMakeLists.txt
@@ -1,6 +1,6 @@
---- plugins/qFacets/CMakeLists.txt.orig 2018-03-16 21:26:02 UTC
-+++ plugins/qFacets/CMakeLists.txt
-@@ -4,7 +4,7 @@ option( INSTALL_QFACETS_PLUGIN "Check to
+--- ./plugins/core/qFacets/CMakeLists.txt.orig 2019-01-07 13:50:00.290346000 -0500
++++ ./plugins/core/qFacets/CMakeLists.txt 2019-01-07 13:50:27.770300000 -0500
+@@ -4,7 +4,7 @@
# CloudCompare 'FACETS' plugin
if (INSTALL_QFACETS_PLUGIN)
@@ -9,7 +9,7 @@
message( SEND_ERROR "ShapeLib is required to compile this plugin (enable OPTION_USE_SHAPE_LIB)" )
endif()
-@@ -27,7 +27,7 @@ if (INSTALL_QFACETS_PLUGIN)
+@@ -31,7 +31,7 @@
target_link_libraries( ${PROJECT_NAME} QCC_IO_LIB )
#add shapelib support
diff --git a/graphics/cloudcompare/files/patch-plugins_qPCL_PclUtils_filters_MLSSmoothingUpsampling.cpp b/graphics/cloudcompare/files/patch-plugins_core_qPCL_PclUtils_filters_MLSSmoothingUpsampling.cpp
index d85bc250391e..d38696ab37d7 100644
--- a/graphics/cloudcompare/files/patch-plugins_qPCL_PclUtils_filters_MLSSmoothingUpsampling.cpp
+++ b/graphics/cloudcompare/files/patch-plugins_core_qPCL_PclUtils_filters_MLSSmoothingUpsampling.cpp
@@ -1,6 +1,6 @@
---- plugins/qPCL/PclUtils/filters/MLSSmoothingUpsampling.cpp.orig 2018-04-14 06:09:41 UTC
-+++ plugins/qPCL/PclUtils/filters/MLSSmoothingUpsampling.cpp
-@@ -51,7 +51,7 @@ int smooth_mls(const typename pcl::Point
+--- ./plugins/core/qPCL/PclUtils/filters/MLSSmoothingUpsampling.cpp.orig 2019-01-06 17:02:13.000000000 -0500
++++ ./plugins/core/qPCL/PclUtils/filters/MLSSmoothingUpsampling.cpp 2019-01-07 13:52:41.029660000 -0500
+@@ -51,7 +51,7 @@
{
typename pcl::search::KdTree<PointInT>::Ptr tree (new pcl::search::KdTree<PointInT>);
diff --git a/graphics/cloudcompare/files/patch-plugins_qRANSAC__SD_RANSAC__SD__orig_GfxTL_FlatCopyVector.h b/graphics/cloudcompare/files/patch-plugins_core_qRANSAC__SD_RANSAC__SD__orig_GfxTL_FlatCopyVector.h
index a5e6c544e43d..c338c090551a 100644
--- a/graphics/cloudcompare/files/patch-plugins_qRANSAC__SD_RANSAC__SD__orig_GfxTL_FlatCopyVector.h
+++ b/graphics/cloudcompare/files/patch-plugins_core_qRANSAC__SD_RANSAC__SD__orig_GfxTL_FlatCopyVector.h
@@ -1,5 +1,5 @@
---- plugins/qRANSAC_SD/RANSAC_SD_orig/GfxTL/FlatCopyVector.h.orig 2018-04-14 01:45:59 UTC
-+++ plugins/qRANSAC_SD/RANSAC_SD_orig/GfxTL/FlatCopyVector.h
+--- ./plugins/core/qRANSAC_SD/RANSAC_SD_orig/GfxTL/FlatCopyVector.h.orig 2019-01-07 13:54:30.016129000 -0500
++++ ./plugins/core/qRANSAC_SD/RANSAC_SD_orig/GfxTL/FlatCopyVector.h 2019-01-07 13:55:05.855728000 -0500
@@ -1,6 +1,6 @@
#ifndef GfxTL__FLATCOPYVECTOR_HEADER__
#define GfxTL__FLATCOPYVECTOR_HEADER__
diff --git a/graphics/cloudcompare/files/patch-plugins_core_qRANSAC__SD_RANSAC__SD__orig_GfxTL_KdTree.h b/graphics/cloudcompare/files/patch-plugins_core_qRANSAC__SD_RANSAC__SD__orig_GfxTL_KdTree.h
new file mode 100644
index 000000000000..c75de39e1422
--- /dev/null
+++ b/graphics/cloudcompare/files/patch-plugins_core_qRANSAC__SD_RANSAC__SD__orig_GfxTL_KdTree.h
@@ -0,0 +1,11 @@
+--- ./plugins/core/qRANSAC_SD/RANSAC_SD_orig/GfxTL/KdTree.h.orig 2019-01-07 13:56:42.017699000 -0500
++++ ./plugins/core/qRANSAC_SD/RANSAC_SD_orig/GfxTL/KdTree.h 2019-01-07 13:57:21.280897000 -0500
+@@ -14,7 +14,7 @@
+ #include <algorithm>
+ #include <memory>
+ #include <deque>
+-#ifndef __APPLE__
++#if !defined(__APPLE__) && !defined(__FreeBSD__)
+ #include <malloc.h>
+ #else
+ #include <stdlib.h>
diff --git a/graphics/cloudcompare/files/patch-plugins_qRANSAC__SD_RANSAC__SD__orig_MiscLib_AlignedAllocator.h b/graphics/cloudcompare/files/patch-plugins_core_qRANSAC__SD_RANSAC__SD__orig_MiscLib_AlignedAllocator.h
index a211b839e2da..cae8976abeac 100644
--- a/graphics/cloudcompare/files/patch-plugins_qRANSAC__SD_RANSAC__SD__orig_MiscLib_AlignedAllocator.h
+++ b/graphics/cloudcompare/files/patch-plugins_core_qRANSAC__SD_RANSAC__SD__orig_MiscLib_AlignedAllocator.h
@@ -1,5 +1,5 @@
---- plugins/qRANSAC_SD/RANSAC_SD_orig/MiscLib/AlignedAllocator.h.orig 2018-04-14 01:44:24 UTC
-+++ plugins/qRANSAC_SD/RANSAC_SD_orig/MiscLib/AlignedAllocator.h
+--- ./plugins/core/qRANSAC_SD/RANSAC_SD_orig/MiscLib/AlignedAllocator.h.orig 2019-01-07 13:59:17.670295000 -0500
++++ ./plugins/core/qRANSAC_SD/RANSAC_SD_orig/MiscLib/AlignedAllocator.h 2019-01-07 13:59:38.242600000 -0500
@@ -1,7 +1,7 @@
#ifndef MiscLib__ALIGNEDALLOCATOR_HEADER__
#define MiscLib__ALIGNEDALLOCATOR_HEADER__
diff --git a/graphics/cloudcompare/files/patch-plugins_qRANSAC__SD_RANSAC__SD__orig_GfxTL_KdTree.h b/graphics/cloudcompare/files/patch-plugins_qRANSAC__SD_RANSAC__SD__orig_GfxTL_KdTree.h
deleted file mode 100644
index 180d844df4da..000000000000
--- a/graphics/cloudcompare/files/patch-plugins_qRANSAC__SD_RANSAC__SD__orig_GfxTL_KdTree.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/qRANSAC_SD/RANSAC_SD_orig/GfxTL/KdTree.h.orig 2018-04-14 01:47:30 UTC
-+++ plugins/qRANSAC_SD/RANSAC_SD_orig/GfxTL/KdTree.h
-@@ -14,7 +14,7 @@
- #include <algorithm>
- #include <memory>
- #include <deque>
--#ifndef __APPLE__
-+#if !defined(__APPLE__) && !defined(__FreeBSD__)
- #include <malloc.h>
- #else
- #include <stdlib.h>
diff --git a/graphics/cloudcompare/pkg-plist b/graphics/cloudcompare/pkg-plist
index 34f38a8459d7..455fa8fa8168 100644
--- a/graphics/cloudcompare/pkg-plist
+++ b/graphics/cloudcompare/pkg-plist
@@ -3,35 +3,36 @@ bin/ccViewer
lib/cloudcompare/libCC_CORE_LIB.so
lib/cloudcompare/libQCC_DB_LIB.so
lib/cloudcompare/libQCC_IO_LIB.so
-%%PLUGINS%%lib/cloudcompare/plugins/libQANIMATION_PLUGIN.so
-%%PLUGINS%%lib/cloudcompare/plugins/libQBLUR_PLUGIN.so
-%%PLUGINS%%lib/cloudcompare/plugins/libQBROOM_PLUGIN.so
-%%PLUGINS%%lib/cloudcompare/plugins/libQCOMPASS_PLUGIN.so
-%%PLUGINS%%lib/cloudcompare/plugins/libQCSF_PLUGIN.so
-%%PLUGINS%%lib/cloudcompare/plugins/libQCSV_MATRIX_IO_PLUGIN.so
-%%PLUGINS%%lib/cloudcompare/plugins/libQDUMMY_PLUGIN.so
-%%PLUGINS%%lib/cloudcompare/plugins/libQEDL_PLUGIN.so
-%%PLUGINS%%lib/cloudcompare/plugins/libQFACETS_PLUGIN_DLL.so
-%%PLUGINS%%lib/cloudcompare/plugins/libQHPR_PLUGIN.so
-%%PLUGINS%%lib/cloudcompare/plugins/libQM3C2_PLUGIN_DLL.so
-%%PLUGINS%%lib/cloudcompare/plugins/libQPCV_PLUGIN.so
-%%PLUGINS%%lib/cloudcompare/plugins/libQPHOTOSCAN_IO_PLUGIN.so
-%%PLUGINS%%lib/cloudcompare/plugins/libQRANSAC_SD_PLUGIN.so
-%%PLUGINS%%lib/cloudcompare/plugins/libQSRA_PLUGIN.so
-%%PLUGINS%%lib/cloudcompare/plugins/libQSSAO_PLUGIN.so
+lib/cloudcompare/plugins/libQANIMATION_PLUGIN.so
+lib/cloudcompare/plugins/libQBROOM_PLUGIN.so
+lib/cloudcompare/plugins/libQCOMPASS_PLUGIN.so
+lib/cloudcompare/plugins/libQCSF_PLUGIN.so
+lib/cloudcompare/plugins/libQCSV_MATRIX_IO_PLUGIN.so
+lib/cloudcompare/plugins/libQEDL_PLUGIN.so
+lib/cloudcompare/plugins/libQFACETS_PLUGIN_DLL.so
+lib/cloudcompare/plugins/libQHPR_PLUGIN.so
+lib/cloudcompare/plugins/libQM3C2_PLUGIN_DLL.so
+lib/cloudcompare/plugins/libQPCV_PLUGIN.so
+lib/cloudcompare/plugins/libQPHOTOSCAN_IO_PLUGIN.so
+lib/cloudcompare/plugins/libQRANSAC_SD_PLUGIN.so
+lib/cloudcompare/plugins/libQSRA_PLUGIN.so
+lib/cloudcompare/plugins/libQSSAO_PLUGIN.so
share/applications/ccViewer.desktop
share/applications/cloudcompare.desktop
%%DATADIR%%/CHANGELOG.md
%%DATADIR%%/global_shift_list_template.txt
%%DATADIR%%/license.txt
-%%PLUGINS%%%%DATADIR%%/shaders/Bilateral/bilateral.frag
-%%PLUGINS%%%%DATADIR%%/shaders/Bilateral/bilateral.vert
-%%PLUGINS%%%%DATADIR%%/shaders/ColorRamp/color_ramp.frag
-%%PLUGINS%%%%DATADIR%%/shaders/EDL/edl_mix.frag
-%%PLUGINS%%%%DATADIR%%/shaders/EDL/edl_mix.vert
-%%PLUGINS%%%%DATADIR%%/shaders/EDL/edl_shade.frag
-%%PLUGINS%%%%DATADIR%%/shaders/EDL/edl_shade.vert
-%%PLUGINS%%%%DATADIR%%/shaders/SSAO/ssao.frag
-%%PLUGINS%%%%DATADIR%%/shaders/SSAO/ssao.vert
+%%DATADIR%%/shaders/Bilateral/bilateral.frag
+%%DATADIR%%/shaders/Bilateral/bilateral.vert
+%%DATADIR%%/shaders/ColorRamp/color_ramp.frag
+%%DATADIR%%/shaders/EDL/edl_mix.frag
+%%DATADIR%%/shaders/EDL/edl_mix.vert
+%%DATADIR%%/shaders/EDL/edl_shade.frag
+%%DATADIR%%/shaders/EDL/edl_shade.vert
+%%DATADIR%%/shaders/SSAO/ssao.frag
+%%DATADIR%%/shaders/SSAO/ssao.vert
+%%DATADIR%%/translations/CloudCompare_fr.qm
+%%DATADIR%%/translations/CloudCompare_pt.qm
+%%DATADIR%%/translations/CloudCompare_ru.qm
share/pixmaps/ccViewer.png
share/pixmaps/cloudcompare.png