aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2004-07-23 19:10:32 +0000
committerEric Anholt <anholt@FreeBSD.org>2004-07-23 19:10:32 +0000
commit4eb209da7d941e66e0cb065aead6bda76c9e97f3 (patch)
treec9cf2fdcee3885499960b9c706dacac0a0080f8e /graphics
parentb188150955302fdc3c1402eb0688a84d1f2cf451 (diff)
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/diacanvas2/Makefile2
-rw-r--r--graphics/glide3/Makefile1
-rw-r--r--graphics/ivtools/Makefile9
-rw-r--r--graphics/linux_glx/Makefile2
-rw-r--r--graphics/mesagl/Makefile2
-rw-r--r--graphics/pixmap/Makefile10
-rw-r--r--graphics/sng/Makefile2
-rw-r--r--graphics/utah-glx/Makefile2
-rw-r--r--graphics/vcg/Makefile2
-rw-r--r--graphics/xpm/Makefile2
10 files changed, 14 insertions, 20 deletions
diff --git a/graphics/diacanvas2/Makefile b/graphics/diacanvas2/Makefile
index df83818d92a5..1e6a899cd129 100644
--- a/graphics/diacanvas2/Makefile
+++ b/graphics/diacanvas2/Makefile
@@ -26,7 +26,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
INSTALLS_SHLIB= yes
.if !defined(DISPLAY)
-BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
+BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
CONFIGURE_ENV+= DISPLAY=localhost:1001
.endif
diff --git a/graphics/glide3/Makefile b/graphics/glide3/Makefile
index 2b865ddd9d3b..aec048d6f1a2 100644
--- a/graphics/glide3/Makefile
+++ b/graphics/glide3/Makefile
@@ -25,7 +25,6 @@ COMMENT= Library to support 3dfx Voodoo3/4/5/Banshee with the DRI
USE_BZIP2= yes
WRKSRC= ${WRKDIR}/Glide3
USE_X_PREFIX= yes
-XFREE86_VERSION= 4
INSTALLS_SHLIB= yes
USE_INC_LIBTOOL_VER= 13
USE_AUTOMAKE_VER= 14
diff --git a/graphics/ivtools/Makefile b/graphics/ivtools/Makefile
index 678423597502..2cba4f8b9bf9 100644
--- a/graphics/ivtools/Makefile
+++ b/graphics/ivtools/Makefile
@@ -16,9 +16,12 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Drawing editors derived from idraw
+BUILD_DEPENDS= imake:${X_IMAKE_PORT}
+
USE_XLIB= yes
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
+INSTALLS_SHLIB= yes
MANCOMPRESSED= no
MAN1= idraw.1 iclass.1 drawtool.1 comterp.1 comdraw.1 flipbook.1 graphdraw.1
@@ -29,10 +32,4 @@ MAN1= idraw.1 iclass.1 drawtool.1 comterp.1 comdraw.1 flipbook.1 graphdraw.1
BROKEN= "fails to configure on ${ARCH}"
.endif
-.if ${XFREE86_VERSION} == 3
-BUILD_DEPENDS= imake:${PORTSDIR}/devel/imake
-.else
-BUILD_DEPENDS= imake:${PORTSDIR}/devel/imake-4
-.endif
-
.include <bsd.port.post.mk>
diff --git a/graphics/linux_glx/Makefile b/graphics/linux_glx/Makefile
index e7873206e1b8..97eed90295ee 100644
--- a/graphics/linux_glx/Makefile
+++ b/graphics/linux_glx/Makefile
@@ -30,7 +30,7 @@ STRIP=
.include <bsd.port.pre.mk>
-.if ${XFREE86_VERSION} > 3
+.if ${X_WINDOW_SYSTEM:L} != xfree86-3
IGNORE= "Requires XFree86 3.3.* - will not work with XFree86 4.*"
.endif
diff --git a/graphics/mesagl/Makefile b/graphics/mesagl/Makefile
index daf009313a78..0f7d4a2a2338 100644
--- a/graphics/mesagl/Makefile
+++ b/graphics/mesagl/Makefile
@@ -39,7 +39,7 @@ MAKE_ENV+= SUB_GL="${SUB_GL}" \
.include <bsd.port.pre.mk>
-.if ${XFREE86_VERSION} != 3
+.if ${X_WINDOW_SYSTEM:L} != xfree86-3
IGNORE= is unnecessary because libGL and libGLU come with XFree86 4.0 and higher
.endif
diff --git a/graphics/pixmap/Makefile b/graphics/pixmap/Makefile
index 46f778d76338..8edf7f1395be 100644
--- a/graphics/pixmap/Makefile
+++ b/graphics/pixmap/Makefile
@@ -15,14 +15,12 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= jmz@FreeBSD.org
COMMENT= A pixmap editor based on XPM library
+# requires rgb.txt
+BUILD_DEPENDS= xrdb:${X_CLIENTS_PORT}
+
WRKSRC= ${WRKDIR}/pixmap
USE_IMAKE= yes
USE_XPM= yes
MAN1= pixmap.1
-.include <bsd.port.pre.mk>
-.if ${XFREE86_VERSION} == 4 # requires rgb.txt
-BUILD_DEPENDS= xrdb:${PORTSDIR}/x11/XFree86-4-clients
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/sng/Makefile b/graphics/sng/Makefile
index 7a401e8c95c0..dccd701131bd 100644
--- a/graphics/sng/Makefile
+++ b/graphics/sng/Makefile
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= compiler/decompiler for Scriptable Network Graphics
-BUILD_DEPENDS= ${X11BASE}/lib/X11/rgb.txt:${PORTSDIR}/x11/XFree86-4-clients
+BUILD_DEPENDS= ${X11BASE}/lib/X11/rgb.txt:${X_CLIENTS_PORT}
RUN_DEPENDS= ${BUILD_DEPENDS}
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
diff --git a/graphics/utah-glx/Makefile b/graphics/utah-glx/Makefile
index 1c1400ff4e54..7357e9f6a096 100644
--- a/graphics/utah-glx/Makefile
+++ b/graphics/utah-glx/Makefile
@@ -54,7 +54,7 @@ ALL_TARGET= depend all
.include <bsd.port.pre.mk>
-.if ${XFREE86_VERSION} > 3
+.if ${X_WINDOW_SYSTEM:L} != xfree86-3
IGNORE= "Requires XFree86 3.3.* - will not work with XFree86 4.*"
.endif
diff --git a/graphics/vcg/Makefile b/graphics/vcg/Makefile
index 26f7f479b642..4f6cf1d99e58 100644
--- a/graphics/vcg/Makefile
+++ b/graphics/vcg/Makefile
@@ -15,7 +15,7 @@ EXTRACT_SUFX= .r3.17.tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A Visualization Tool for compiler graphs
-BUILD_DEPENDS= imake:${PORTSDIR}/devel/imake-4
+BUILD_DEPENDS= imake:${X_IMAKE_PORT}
USE_X_PREFIX= yes
MANL= pbmrot90.l pbmshift.l pbm2hp.l vcgdemomaker.l vcg.l xvcg.l
diff --git a/graphics/xpm/Makefile b/graphics/xpm/Makefile
index 315acbd1bb86..60801ce4ca97 100644
--- a/graphics/xpm/Makefile
+++ b/graphics/xpm/Makefile
@@ -25,7 +25,7 @@ MAN1= cxpm.1 sxpm.1
.include <bsd.port.pre.mk>
-.if ${XFREE86_VERSION} > 3
+.if ${X_WINDOW_SYSTEM:L} != xfree86-3
IGNORE= is included in XFree86 >3.x
.endif