aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2008-05-07 13:06:11 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2008-05-07 13:06:11 +0000
commit58376196173c6ed47ac3e6e985e20c77de54ce29 (patch)
tree6bd86c69cd6699ef1fd05880c196835a02eef36f /graphics
parent1c83a169bc6a81f6f49a2bdbfd8d64079236c5be (diff)
downloadports-58376196173c6ed47ac3e6e985e20c77de54ce29.tar.gz
ports-58376196173c6ed47ac3e6e985e20c77de54ce29.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libraw/Makefile37
1 files changed, 35 insertions, 2 deletions
diff --git a/graphics/libraw/Makefile b/graphics/libraw/Makefile
index 82698adf8d10..bacf4ae50a96 100644
--- a/graphics/libraw/Makefile
+++ b/graphics/libraw/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libraw
PORTVERSION= 0.5.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://www.libraw.su/data/
DISTNAME= LibRaw-${PORTVERSION}
@@ -23,6 +23,29 @@ MAKE_ENV+= CXX="${CXX}" CC="${CC}" CFLAGS="${CFLAGS}" \
USE_LDCONFIG= yes
+PORTDOCS= API-C-eng.html API-C-rus.html API-CXX-eng.html API-CXX-rus.html \
+ API-datastruct-eng.html API-datastruct-rus.html API-notes-eng.html \
+ API-notes-rus.html API-overview-eng.html API-overview-rus.html \
+ Install-LibRaw-eng.html Install-LibRaw-rus.html Samples-LibRaw-eng.html \
+ Samples-LibRaw-rus.html Why-LibRaw-eng.html Why-LibRaw-rus.html \
+ index-eng.html index-rus.html index.html
+
+PORTEXAMPLES= dcraw_emu.cpp dcraw_half.c half_mt.c identify.cpp simple_dcraw.cpp
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+.if defined(WITH_OPTIMIZED_CFLAGS)
+CFLAGS+= -O4
+.else
+pre-everything::
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "The following options are available:"
+ @${ECHO_CMD} " WITH_OPTIMIZED_CFLAGS - build port with optimization support"
+ @${ECHO_CMD} ""
+.endif
+.endif
+
do-install:
@${MKDIR} ${PREFIX}/include/libraw
@@ -36,4 +59,14 @@ do-install:
@ cd ${PREFIX}/lib ; ${LN} -sf ${f}.so.0 ${f}.so
.endfor
-.include <bsd.port.mk>
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/doc/,} ${DOCSDIR}
+.endif
+
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S,^,${WRKSRC}/samples/,} ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.post.mk>