aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2006-09-22 06:27:42 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2006-09-22 06:27:42 +0000
commit709432950faccf4211fddefd63019e3ead60f7ae (patch)
tree4145a28c7df57be63e528005ec39ba01966d440c /graphics
parent05b379d9fbb436c926bbc0553b8ff2c47006820a (diff)
downloadports-709432950faccf4211fddefd63019e3ead60f7ae.tar.gz
ports-709432950faccf4211fddefd63019e3ead60f7ae.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/php5-imlib2/Makefile32
-rw-r--r--graphics/php5-imlib2/distinfo3
-rw-r--r--graphics/php5-imlib2/files/patch-imlib2.c43
-rw-r--r--graphics/php5-imlib2/pkg-descr5
5 files changed, 84 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 15ef3690ae0c..42e3c7df0511 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -492,6 +492,7 @@
SUBDIR += php4-ming
SUBDIR += php5-exif
SUBDIR += php5-gd
+ SUBDIR += php5-imlib2
SUBDIR += php5-ming
SUBDIR += phplot
SUBDIR += phpsview
diff --git a/graphics/php5-imlib2/Makefile b/graphics/php5-imlib2/Makefile
new file mode 100644
index 000000000000..b7ed2e504b79
--- /dev/null
+++ b/graphics/php5-imlib2/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: php5-imlib2
+# Date created: 18 September 2006
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= imlib2
+PORTVERSION= 0.1.00
+CATEGORIES= graphics
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= php${PHP_VER}-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= The imlib2 shared extension for php
+
+LIB_DEPENDS= Imlib2:${PORTSDIR}/graphics/imlib2
+
+USE_PHP= yes
+USE_PHPEXT= yes
+DEFAULT_PHP_VER?=5
+
+# libImlib2 may or may not depend on X, however,
+# imlib2 extension doesn't need X related functions in libImlib2
+CFLAGS+= -DX_DISPLAY_MISSING
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/-ldl//' ${WRKSRC}/config.m4
+ @${REINPLACE_CMD} -e '/Xlib.h/d' ${WRKSRC}/php_imlib2.h
+
+.include <bsd.port.mk>
diff --git a/graphics/php5-imlib2/distinfo b/graphics/php5-imlib2/distinfo
new file mode 100644
index 000000000000..6807346fb4b4
--- /dev/null
+++ b/graphics/php5-imlib2/distinfo
@@ -0,0 +1,3 @@
+MD5 (imlib2-0.1.00.tgz) = 8bc2d64a7f8897e914f1e1b1f8e7b554
+SHA256 (imlib2-0.1.00.tgz) = 4506ac1bdefdb5d0eb1f4e16080010463ffcc48c4fec4119717f769858dc6cd2
+SIZE (imlib2-0.1.00.tgz) = 15536
diff --git a/graphics/php5-imlib2/files/patch-imlib2.c b/graphics/php5-imlib2/files/patch-imlib2.c
new file mode 100644
index 000000000000..150b40bd035c
--- /dev/null
+++ b/graphics/php5-imlib2/files/patch-imlib2.c
@@ -0,0 +1,43 @@
+--- imlib2.c.orig Wed Sep 20 10:05:27 2006
++++ imlib2.c Wed Sep 20 10:06:15 2006
+@@ -643,8 +643,8 @@
+ zval **img, **gamma;
+ Imlib_Image im;
+ Imlib_Color_Modifier cm;
+- IMLIB2_LS_FETCH();
+ double ng;
++ IMLIB2_LS_FETCH();
+
+ if (ZEND_NUM_ARGS() != 2 | zend_get_parameters_ex(2, &img, &gamma) == FAILURE) {
+ WRONG_PARAM_COUNT;
+@@ -675,8 +675,8 @@
+ zval **img, **contrast;
+ Imlib_Image im;
+ Imlib_Color_Modifier cm;
+- IMLIB2_LS_FETCH();
+ double nc;
++ IMLIB2_LS_FETCH();
+
+ if (ZEND_NUM_ARGS() != 2 | zend_get_parameters_ex(2, &img, &contrast) == FAILURE) {
+ WRONG_PARAM_COUNT;
+@@ -707,8 +707,8 @@
+ zval **img, **bv;
+ Imlib_Image im;
+ Imlib_Color_Modifier cm;
+- IMLIB2_LS_FETCH();
+ double nbv;
++ IMLIB2_LS_FETCH();
+
+ if (ZEND_NUM_ARGS() != 2 | zend_get_parameters_ex(2, &img, &bv) == FAILURE) {
+ WRONG_PARAM_COUNT;
+@@ -760,9 +760,9 @@
+ {
+ zval **img, **angle;
+ double rot_angle, rads, pi;
+- pi = 3.141592653;
+ Imlib_Image src_img, dst_img;
+ IMLIB2_LS_FETCH();
++ pi = 3.141592653;
+
+ if((ZEND_NUM_ARGS() != 2) || zend_get_parameters_ex(2, &img, &angle) == FAILURE) {
+ WRONG_PARAM_COUNT;
diff --git a/graphics/php5-imlib2/pkg-descr b/graphics/php5-imlib2/pkg-descr
new file mode 100644
index 000000000000..15a355ad2c7f
--- /dev/null
+++ b/graphics/php5-imlib2/pkg-descr
@@ -0,0 +1,5 @@
+This extension provides an image manipulation interface using libImlib2.
+Imlib2 is a very fast image manipulation library, but without the support
+for as many image formats as other libraries such as imagemagick.
+
+WWW: http://pecl.php.net/package/imlib2