aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
commita1993564e04f29ecbaa05be740547c8677d423cd (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /graphics
parent868fb29f23bfae4d55ab923ea34259adf63b4886 (diff)
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Notes
Notes: svn path=/head/; revision=463917
Diffstat (limited to 'graphics')
-rw-r--r--graphics/pear-Horde_Image/Makefile2
-rw-r--r--graphics/pear-Image_Barcode/Makefile2
-rw-r--r--graphics/pear-Image_Canvas/Makefile2
-rw-r--r--graphics/pear-Image_Graph/Makefile4
-rw-r--r--graphics/pecl-qrencode/Makefile4
-rw-r--r--graphics/pecl-qrencode/pkg-descr2
-rw-r--r--graphics/php-facedetect/Makefile2
-rw-r--r--graphics/php-geos/Makefile6
-rw-r--r--graphics/php-libpuzzle/Makefile2
-rw-r--r--graphics/php-magickwand/Makefile2
-rw-r--r--graphics/php5-ffmpeg/Makefile2
11 files changed, 14 insertions, 16 deletions
diff --git a/graphics/pear-Horde_Image/Makefile b/graphics/pear-Horde_Image/Makefile
index dbc8e2132622..2b193cd9a84b 100644
--- a/graphics/pear-Horde_Image/Makefile
+++ b/graphics/pear-Horde_Image/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Horde_Image
PORTVERSION= 2.5.2
CATEGORIES= graphics www pear
-PKGNAMEPREFIX= pear-
+PKGNAMEPREFIX= ${PEAR_PKGNAMEPREFIX}
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde Image API
diff --git a/graphics/pear-Image_Barcode/Makefile b/graphics/pear-Image_Barcode/Makefile
index 52493eb2645a..1a58aaf4cb24 100644
--- a/graphics/pear-Image_Barcode/Makefile
+++ b/graphics/pear-Image_Barcode/Makefile
@@ -14,6 +14,6 @@ USES= pear php
OPTIONS_DEFINE= PEAR_PHP_COMPAT
PEAR_PHP_COMPAT_DESC= PEAR::PHP_Compat support
-PEAR_PHP_COMPAT_RUN_DEPENDS= ${PEARDIR}/PHP/Compat.php:devel/pear-PHP_Compat
+PEAR_PHP_COMPAT_RUN_DEPENDS= ${PEARDIR}/PHP/Compat.php:devel/pear-PHP_Compat@${PHP_FLAVOR}
.include <bsd.port.mk>
diff --git a/graphics/pear-Image_Canvas/Makefile b/graphics/pear-Image_Canvas/Makefile
index cbbcc425e8ed..3f8f3e77a65e 100644
--- a/graphics/pear-Image_Canvas/Makefile
+++ b/graphics/pear-Image_Canvas/Makefile
@@ -9,7 +9,7 @@ CATEGORIES= graphics www pear
MAINTAINER= numisemis@yahoo.com
COMMENT= OO PEAR common interface to image drawing
-RUN_DEPENDS= ${PEARDIR}/Image/Color.php:graphics/pear-Image_Color
+RUN_DEPENDS= ${PEARDIR}/Image/Color.php:graphics/pear-Image_Color@${PHP_FLAVOR}
USE_PHP= gd
USES= dos2unix pear php
diff --git a/graphics/pear-Image_Graph/Makefile b/graphics/pear-Image_Graph/Makefile
index 2a1fdfb9171a..2669f2747fab 100644
--- a/graphics/pear-Image_Graph/Makefile
+++ b/graphics/pear-Image_Graph/Makefile
@@ -8,8 +8,8 @@ CATEGORIES= graphics www pear
MAINTAINER= joneum@FreeBSD.org
COMMENT= OO PEAR graph rendering package
-RUN_DEPENDS= ${PEARDIR}/Log.php:sysutils/pear-Log \
- ${PEARDIR}/Image/Canvas.php:graphics/pear-Image_Canvas
+RUN_DEPENDS= ${PEARDIR}/Log.php:sysutils/pear-Log@${PHP_FLAVOR} \
+ ${PEARDIR}/Image/Canvas.php:graphics/pear-Image_Canvas@${PHP_FLAVOR}
USES= dos2unix pear
DOS2UNIX_REGEX= .*php$$
diff --git a/graphics/pecl-qrencode/Makefile b/graphics/pecl-qrencode/Makefile
index b5f16197360d..34326111c3b4 100644
--- a/graphics/pecl-qrencode/Makefile
+++ b/graphics/pecl-qrencode/Makefile
@@ -6,8 +6,6 @@ PORTVERSION= 0.6
DISTVERSIONPREFIX= v
PORTREVISION= 1
CATEGORIES= graphics pear
-PKGNAMEPREFIX= pecl-
-DIST_SUBDIR= PECL
MAINTAINER= vanilla@FreeBSD.org
COMMENT= PECL extension for generate qrcode
@@ -17,7 +15,7 @@ LICENSE= BSD2CLAUSE
LIB_DEPENDS= libqrencode.so:graphics/libqrencode \
libpng.so:graphics/png
-USES= php:ext
+USES= php:pecl
USE_GITHUB= yes
GH_ACCOUNT= vanillahsu
GH_PROJECT= pecl-qrencode
diff --git a/graphics/pecl-qrencode/pkg-descr b/graphics/pecl-qrencode/pkg-descr
index f9e5600e948b..4495d9e75689 100644
--- a/graphics/pecl-qrencode/pkg-descr
+++ b/graphics/pecl-qrencode/pkg-descr
@@ -1,3 +1,3 @@
A PECL extension for generate qrcode.
-WWW: https://github.com/vanillahsu/pecl-qrencode
+WWW: https://github.com/vanillahsu/pecl-qrencode@${PHP_FLAVOR}
diff --git a/graphics/php-facedetect/Makefile b/graphics/php-facedetect/Makefile
index 650bc3428149..7ddc9505e62d 100644
--- a/graphics/php-facedetect/Makefile
+++ b/graphics/php-facedetect/Makefile
@@ -5,7 +5,7 @@ PORTNAME= facedetect
PORTVERSION= 1.1
PORTREVISION= 6
CATEGORIES= graphics
-PKGNAMEPREFIX= php-
+PKGNAMEPREFIX= ${PHP_PKGNAMEPREFIX}
MAINTAINER= mm@FreeBSD.org
COMMENT= Face detection extension for PHP using OpenCV library
diff --git a/graphics/php-geos/Makefile b/graphics/php-geos/Makefile
index cd3a85bdf4de..4741161b251a 100644
--- a/graphics/php-geos/Makefile
+++ b/graphics/php-geos/Makefile
@@ -6,9 +6,9 @@ PORTVERSION= 1.0.0
CATEGORIES= graphics
MASTER_SITES= https://git.osgeo.org/gogs/geos/php-geos/archive/ \
LOCAL/sunpoet/${PKGNAMEPREFIX}${PORTNAME}
-PKGNAMEPREFIX= php-
+PKGNAMEPREFIX= ${PHP_PKGNAMEPREFIX}
DISTNAME= ${DISTVERSION}
-DIST_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
+DIST_SUBDIR= php-${PORTNAME}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= PHP bindings for GEOS
@@ -24,6 +24,6 @@ LIB_DEPENDS= libgeos_c.so:graphics/geos
LDFLAGS+= -L${PREFIX}/lib
USES= php:ext
-WRKSRC= ${WRKDIR}/${PKGNAMEPREFIX}${PORTNAME}
+WRKSRC= ${WRKDIR}/php-${PORTNAME}
.include <bsd.port.mk>
diff --git a/graphics/php-libpuzzle/Makefile b/graphics/php-libpuzzle/Makefile
index ebba77f8bbf2..711bb183be57 100644
--- a/graphics/php-libpuzzle/Makefile
+++ b/graphics/php-libpuzzle/Makefile
@@ -7,7 +7,7 @@ PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://download.pureftpd.org/pub/pure-ftpd/misc/libpuzzle/release/ \
ftp://ftp.pureftpd.org/pub/pure-ftpd/misc/libpuzzle/releases/
-PKGNAMEPREFIX= php-
+PKGNAMEPREFIX= ${PHP_PKGNAMEPREFIX}
MAINTAINER= cyberbotx@cyberbotx.com
COMMENT= PHP extension for Puzzle library to find similar pictures
diff --git a/graphics/php-magickwand/Makefile b/graphics/php-magickwand/Makefile
index 680614c632c4..a88268c75375 100644
--- a/graphics/php-magickwand/Makefile
+++ b/graphics/php-magickwand/Makefile
@@ -6,7 +6,7 @@ PORTVERSION= 1.0.9
PORTREVISION= 7
CATEGORIES= graphics
MASTER_SITES= http://www.magickwand.org/download/php/
-PKGNAMEPREFIX= php-
+PKGNAMEPREFIX= ${PHP_PKGNAMEPREFIX}
DISTNAME= MagickWandForPHP-${PORTVERSION}-2
MAINTAINER= ports@FreeBSD.org
diff --git a/graphics/php5-ffmpeg/Makefile b/graphics/php5-ffmpeg/Makefile
index 67c8e5f206fe..365b5c08ac1e 100644
--- a/graphics/php5-ffmpeg/Makefile
+++ b/graphics/php5-ffmpeg/Makefile
@@ -7,7 +7,7 @@ DISTVERSIONPREFIX= php-
PORTREVISION= 6
CATEGORIES= graphics
MASTER_SITES= LOCAL/sunpoet
-PKGNAMEPREFIX= php5-
+PKGNAMEPREFIX= ${PHP_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= FFmpeg shared extension for php