aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-06-26 11:01:21 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-06-26 11:01:21 +0000
commitdfa2d819b059c6eb3c35594d955d2b1eac533278 (patch)
tree2743f47610764da6247856832806431cf1bde6b5 /graphics
parent1218e6669a81bb650fc175061900c473add00be3 (diff)
downloadports-dfa2d819b059c6eb3c35594d955d2b1eac533278.tar.gz
ports-dfa2d819b059c6eb3c35594d955d2b1eac533278.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/geeqie/Makefile60
-rw-r--r--graphics/geeqie/distinfo3
-rw-r--r--graphics/geeqie/pkg-descr19
-rw-r--r--graphics/geeqie/pkg-plist4
5 files changed, 87 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 06cce83095ed..1ce1b57ee16a 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -191,6 +191,7 @@
SUBDIR += gdchart
SUBDIR += gdk-pixbuf
SUBDIR += gdtclft
+ SUBDIR += geeqie
SUBDIR += geist
SUBDIR += geoapi
SUBDIR += geomorph
diff --git a/graphics/geeqie/Makefile b/graphics/geeqie/Makefile
new file mode 100644
index 000000000000..603a485e9ff8
--- /dev/null
+++ b/graphics/geeqie/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: graphics/geeqie
+# Date created: 17 May 2008
+# Whom: Martin Tournoij <carpetsmoker@xs4all.nl>
+#
+# $Carpetsmoker: ports/graphics/geeqie/Makefile,v 1.2 2008/05/17 19:35:22 carpetsmoker Exp $
+# $FreeBSD$
+#
+
+PORTNAME= geeqie
+DISTVERSION= 1.0alpha1
+CATEGORIES= graphics
+MASTER_SITES= SF
+
+MAINTAINER= carpetsmoker@xs4all.nl
+COMMENT= Lightweight image viewer forked from GQview
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+USE_GNOME= gtk20
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --docdir="${DOCSDIR}" \
+ --htmldir="${DOCSDIR}/html" \
+ --with-htmldir="${DOCSDIR}/html" \
+ --with-readmedir="${DOCSDIR}"
+MAKE_ARGS+= top_builddir="${WRKSRC}"
+
+PORTDOCS= *
+
+MAN1= geeqie.1
+
+OPTIONS= EXIV2 "Enable EXIV2 for metadata editing" on \
+ LCMS "Enable LCMS for color adjusting" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_EXIV2)
+LIB_DEPENDS+= exiv2.3:${PORTSDIR}/graphics/exiv2
+CONFIGURE_ARGS+=--with-exiv2
+.else
+CONFIGURE_ARGS+=--without-exiv2
+.endif
+
+.if defined(WITH_LCMS)
+LIB_DEPENDS+= lcms.1:${PORTSDIR}/graphics/lcms
+CONFIGURE_ARGS+=--with-lcms
+.else
+CONFIGURE_ARGS+=--without-lcms
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's| -r %F||' \
+ ${WRKSRC}/geeqie.desktop
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-helpDATA||' \
+ ${WRKSRC}/doc/Makefile.in
+ @${REINPLACE_CMD} -e '/^install-data-am:/,/^[a-z]/ s|install-readmeDATA||' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/geeqie/distinfo b/graphics/geeqie/distinfo
new file mode 100644
index 000000000000..8d576b3fcfc8
--- /dev/null
+++ b/graphics/geeqie/distinfo
@@ -0,0 +1,3 @@
+MD5 (geeqie-1.0alpha1.tar.gz) = 8e4838018b597cb6df056959ccf1ba45
+SHA256 (geeqie-1.0alpha1.tar.gz) = 7df5b644e572ec0f8a489c31ccf01789d602c788cffa33bca5ecd236020ad199
+SIZE (geeqie-1.0alpha1.tar.gz) = 1970338
diff --git a/graphics/geeqie/pkg-descr b/graphics/geeqie/pkg-descr
new file mode 100644
index 000000000000..2a6a01305d43
--- /dev/null
+++ b/graphics/geeqie/pkg-descr
@@ -0,0 +1,19 @@
+Geeqie is a lightweight Gtk+ based image viewer for Unix operating systems.
+
+Main features
+ o EXIF, IPTC and XMP metadata browsing and editing.
+ o Interoperability, easy integration with other software.
+ o geeqie works on files and directories, there is no need to import images.
+ o Fast preview for many raw image formats.
+ o Tools for image comparison, sorting and managing photo collection.
+
+History
+ Geeqie has been forked from gqview project, because it was not possible to
+ contact gqview author and the only maintainer. Geeqie projects goal is to move
+ the development forward and also integrate the existing patches.
+
+Project Status
+ Geeqie is currently in alpha state. Everybody is encouraged to try the new
+ features, however for stable software look at the original project.
+
+WWW: http://geeqie.sourceforge.net/
diff --git a/graphics/geeqie/pkg-plist b/graphics/geeqie/pkg-plist
new file mode 100644
index 000000000000..fc15ca80bde4
--- /dev/null
+++ b/graphics/geeqie/pkg-plist
@@ -0,0 +1,4 @@
+bin/geeqie
+share/pixmaps/geeqie.png
+share/applications/geeqie.desktop
+@dirrmtry share/applications