aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2020-05-04 21:31:39 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2020-05-04 21:31:39 +0000
commiteff60e5ddbce15a254c860d4fef91197591e24a4 (patch)
tree3606f251be6090a257f7f4032b4c3e82530bdede /graphics
parenteeb0232a477853320129e42a04324af2686eca56 (diff)
downloadports-eff60e5ddbce15a254c860d4fef91197591e24a4.tar.gz
ports-eff60e5ddbce15a254c860d4fef91197591e24a4.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/R-cran-GDD/Makefile2
-rw-r--r--graphics/a2png/Makefile2
-rw-r--r--graphics/dataplot/Makefile1
-rw-r--r--graphics/fly/Makefile2
-rw-r--r--graphics/g2/Makefile2
-rw-r--r--graphics/gd/Makefile13
-rw-r--r--graphics/gd/distinfo6
-rw-r--r--graphics/gd/files/gdlib-config.in114
-rw-r--r--graphics/gd/files/patch-gd_gif_in.c34
-rw-r--r--graphics/gd/pkg-plist2
-rw-r--r--graphics/gdchart/Makefile2
-rw-r--r--graphics/gdtclft/Makefile2
-rw-r--r--graphics/grads/Makefile2
-rw-r--r--graphics/graphviz/Makefile2
-rw-r--r--graphics/libansilove/Makefile1
-rw-r--r--graphics/libgphoto2/Makefile1
-rw-r--r--graphics/libpuzzle/Makefile2
-rw-r--r--graphics/libsixel/Makefile1
-rw-r--r--graphics/lua-gd/Makefile2
-rw-r--r--graphics/mapserver/Makefile1
-rw-r--r--graphics/mscgen/Makefile2
-rw-r--r--graphics/p5-GD/Makefile1
-rw-r--r--graphics/phplot/Makefile2
-rw-r--r--graphics/png2html/Makefile2
-rw-r--r--graphics/pstoedit/Makefile2
-rw-r--r--graphics/raster3d/Makefile2
-rw-r--r--graphics/repng2jpeg/Makefile2
-rw-r--r--graphics/ruby-gd/Makefile2
-rw-r--r--graphics/rubygem-gd2/Makefile2
-rw-r--r--graphics/scr2png/Makefile2
-rw-r--r--graphics/zimg/Makefile2
31 files changed, 154 insertions, 61 deletions
diff --git a/graphics/R-cran-GDD/Makefile b/graphics/R-cran-GDD/Makefile
index bed66f5e19ef..c44790a4f433 100644
--- a/graphics/R-cran-GDD/Makefile
+++ b/graphics/R-cran-GDD/Makefile
@@ -3,7 +3,7 @@
PORTNAME= GDD
DISTVERSION= 0.1-13.1
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= graphics
DISTNAME= ${PORTNAME}_${DISTVERSION}
diff --git a/graphics/a2png/Makefile b/graphics/a2png/Makefile
index 66a302c392d9..ee3a0feefdbf 100644
--- a/graphics/a2png/Makefile
+++ b/graphics/a2png/Makefile
@@ -3,7 +3,7 @@
PORTNAME= a2png
PORTVERSION= 0.1.5
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= graphics
MASTER_SITES= SF
diff --git a/graphics/dataplot/Makefile b/graphics/dataplot/Makefile
index cea9557511f4..481ae6c91bec 100644
--- a/graphics/dataplot/Makefile
+++ b/graphics/dataplot/Makefile
@@ -3,6 +3,7 @@
PORTNAME= dataplot
DISTVERSION= 20200229
+PORTREVISION= 1
CATEGORIES= graphics
MAINTAINER= ports@FreeBSD.org
diff --git a/graphics/fly/Makefile b/graphics/fly/Makefile
index 26833a4a9714..4e61b0abb44f 100644
--- a/graphics/fly/Makefile
+++ b/graphics/fly/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fly
PORTVERSION= 2.0.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics
MASTER_SITES= http://fossies.org/unix/www/ \
http://martin.gleeson.com/fly/dist/
diff --git a/graphics/g2/Makefile b/graphics/g2/Makefile
index c7b195a5d213..eef0400b0a94 100644
--- a/graphics/g2/Makefile
+++ b/graphics/g2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= g2
PORTVERSION= 0.40
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= graphics
MASTER_SITES= SUNSITE/libs/graphics
diff --git a/graphics/gd/Makefile b/graphics/gd/Makefile
index ae4e83b91251..2624710d9dd5 100644
--- a/graphics/gd/Makefile
+++ b/graphics/gd/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= libgd
-PORTVERSION= 2.2.5
-PORTREVISION= 2
+PORTVERSION= 2.3.0
+PORTREVISION= 0
PORTEPOCH= 1
CATEGORIES+= graphics
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/gd-${PORTVERSION}/
@@ -19,10 +19,11 @@ CONFLICTS= bazaar-1.*
USES= tar:xz pkgconfig pathfix libtool:keepla shebangfix
SHEBANG_FILES= ${WRKSRC}/src/bdftogd
GNU_CONFIGURE= yes
+SUB_FILES= gdlib-config
USE_LDCONFIG= yes
TEST_TARGET= check
-OPTIONS_DEFINE= PNG JPEG WEBP TIFF FREETYPE FONTCONFIG XPM ICONV
+OPTIONS_DEFINE= PNG JPEG WEBP TIFF FREETYPE FONTCONFIG RAQM XPM ICONV
OPTIONS_DEFAULT=PNG JPEG WEBP TIFF FREETYPE FONTCONFIG ICONV
NO_OPTIONS_SORT=yes
OPTIONS_SUB= yes
@@ -44,6 +45,10 @@ FREETYPE_CPPFLAGS= -I${LOCALBASE}/include
FONTCONFIG_LIB_DEPENDS+= libfontconfig.so:x11-fonts/fontconfig
FONTCONFIG_CONFIGURE_OFF= --with-fontconfig=no
FONTCONFIG_CPPFLAGS= -I${LOCALBASE}/include
+RAQM_DESC= Raqm text layout support
+RAQM_LIB_DEPENDS= libraqm.so:print/libraqm
+RAQM_CONFIGURE_OFF= --with-raqm=no
+RAQM_CPPFLAGS= -I${LOCALBASE}/include
XPM_USES= xorg
XPM_USE= xorg=xpm,x11
XPM_CONFIGURE_ON= --with-x
@@ -104,5 +109,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/src/gdhelpers.h \
${STAGEDIR}${PREFIX}/include/
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgd.so.6*
+ ${INSTALL_SCRIPT} ${WRKDIR}/gdlib-config \
+ ${STAGEDIR}${PREFIX}/bin/
.include <bsd.port.mk>
diff --git a/graphics/gd/distinfo b/graphics/gd/distinfo
index 013798259f92..ab3602a7bd8a 100644
--- a/graphics/gd/distinfo
+++ b/graphics/gd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1531337629
-SHA256 (libgd-2.2.5.tar.xz) = 8c302ccbf467faec732f0741a859eef4ecae22fea2d2ab87467be940842bde51
-SIZE (libgd-2.2.5.tar.xz) = 2594092
+TIMESTAMP = 1587757003
+SHA256 (libgd-2.3.0.tar.xz) = ecd9155b9a417fb3f837f29e5966323796de247789163761dd72dbf83bfcac58
+SIZE (libgd-2.3.0.tar.xz) = 2539188
diff --git a/graphics/gd/files/gdlib-config.in b/graphics/gd/files/gdlib-config.in
new file mode 100644
index 000000000000..f2123096d62f
--- /dev/null
+++ b/graphics/gd/files/gdlib-config.in
@@ -0,0 +1,114 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Return information about the local GD library installation
+#
+# Modeled for ports:
+# audio/mp3plot
+# devel/cvsgraph
+# graphics/R-cran-GDD
+# graphics/a2png
+# graphics/gdtclft
+# graphics/lua-gd
+# graphics/mscgen
+# graphics/p5-GD
+# math/gnuplot
+# net-p2p/amule
+# net-p2p/mldonkey
+# science/octopus
+
+echo "gdlib-config: warning: this script is deprecated;" \
+ "please use the pkg-config file instead." >&2
+sleep 10
+
+# installation directories
+prefix=%%PREFIX%%
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include
+bindir=${exec_prefix}/bin
+
+usage()
+{
+ cat <<EOF
+Print information on GD library's version, configuration, and use.
+Usage: gdlib-config [options]
+Options:
+ --libdir # directory where GD library is installed
+ --includedir # directory where GD library headers are installed
+ --version # complete GD library version string
+ --majorversion # GD library major version number
+ --minorversion # GD library minor version number
+ --revision # GD library revision version number
+ --ldflags # options required for linking against GD library
+ --libs # libs required for linking against GD library
+ --cflags # options required for compiling GD library apps
+ --includes # same as --cflags
+ --features # lists features compiled into gd, separated by spaces.
+ # Currently (as of 2.2.5) the optional features
+ # are GD_PNG, GD_JPEG, GD_XPM, GD_FREETYPE, and
+ # GD_FONTCONFIG. When these features are reported by
+ # --features, it is safe to include calls to the
+ # related functions in your code.
+ --all # print a summary of all GD library configure options
+EOF
+ exit $1
+}
+
+if test $# -eq 0; then
+ usage 1 1>&2
+fi
+
+while test $# -gt 0; do
+ case "$1" in
+ -*=*) optarg=`echo "$1" | sed 's/[-_a-zA-Z0-9]*=//'` ;;
+ *) optarg= ;;
+ esac
+
+ case $1 in
+ --libdir)
+ echo "${libdir}"
+ ;;
+ --includedir)
+ echo "${includedir}"
+ ;;
+ --version)
+ echo "%%PORTVERSION%%"
+ ;;
+ --majorversion)
+ echo %%MAJORVERSION%%
+ ;;
+ --minorversion)
+ echo 2
+ ;;
+ --revision)
+ echo 5
+ ;;
+ --ldflags)
+ echo " -L${prefix}/lib -fstack-protector-strong "
+ ;;
+ --libs)
+ echo "-lgd"
+ ;;
+ --cflags|--includes)
+ echo "-I${includedir}"
+ ;;
+ --features)
+ echo GD_GIF GD_GIFANIM GD_OPENPOLYGON GD_ZLIB GD_PNG GD_FREETYPE GD_FONTCONFIG GD_JPEG GD_TIFF GD_WEBP
+ ;;
+ --all)
+ echo "GD library 2.2.5"
+ echo "includedir: ${includedir}"
+ echo "cflags: -I${includedir}"
+ echo "ldflags: -L${prefix}/lib -fstack-protector-strong "
+ echo "libs: -lgd"
+ echo "libdir: $libdir"
+ echo "features: GD_GIF GD_GIFANIM GD_OPENPOLYGON GD_ZLIB GD_PNG GD_FREETYPE GD_FONTCONFIG GD_JPEG GD_TIFF GD_WEBP"
+ ;;
+ *)
+ usage 1 1>&2
+ ;;
+ esac
+ shift
+done
diff --git a/graphics/gd/files/patch-gd_gif_in.c b/graphics/gd/files/patch-gd_gif_in.c
deleted file mode 100644
index a034136a8611..000000000000
--- a/graphics/gd/files/patch-gd_gif_in.c
+++ /dev/null
@@ -1,34 +0,0 @@
-See:
-
- https://bugs.php.net/bug.php?id=75571
-
---- src/gd_gif_in.c 2017-08-30 07:05:54.000000000 -0400
-+++ src/gd_gif_in.c 2018-07-11 15:39:11.746181000 -0400
-@@ -336,9 +336,4 @@
- }
-
-- if(!im->colorsTotal) {
-- gdImageDestroy(im);
-- return 0;
-- }
--
- /* Check for open colors at the end, so
- * we can reduce colorsTotal and ultimately
-@@ -352,4 +347,9 @@
- }
-
-+ if(!im->colorsTotal) {
-+ gdImageDestroy(im);
-+ return 0;
-+ }
-+
- return im;
- }
-@@ -447,6 +447,5 @@
- GetCode_(gdIOCtx *fd, CODE_STATIC_DATA *scd, int code_size, int flag, int *ZeroDataBlockP)
- {
-- int i, j, ret;
-- unsigned char count;
-+ int i, j, ret, count;
-
- if(flag) {
diff --git a/graphics/gd/pkg-plist b/graphics/gd/pkg-plist
index e3fe1b216cdb..4fd4f245b8b0 100644
--- a/graphics/gd/pkg-plist
+++ b/graphics/gd/pkg-plist
@@ -29,5 +29,5 @@ lib/libgd.a
lib/libgd.la
lib/libgd.so
lib/libgd.so.6
-lib/libgd.so.6.0.5
+lib/libgd.so.6.0.8
libdata/pkgconfig/gdlib.pc
diff --git a/graphics/gdchart/Makefile b/graphics/gdchart/Makefile
index c8bca3e55b64..5d4389cfbb4b 100644
--- a/graphics/gdchart/Makefile
+++ b/graphics/gdchart/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gdchart
PORTVERSION= 0.11.5
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= graphics
MASTER_SITES= http://www.fred.net/brv/chart/ \
ftp://ftp.nuug.no/pub/anders/distfiles/
diff --git a/graphics/gdtclft/Makefile b/graphics/gdtclft/Makefile
index e9bd3e827bfe..5f77820b7cf1 100644
--- a/graphics/gdtclft/Makefile
+++ b/graphics/gdtclft/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Gdtclft
PORTVERSION= 2.2.5
-PORTREVISION= 17
+PORTREVISION= 18
CATEGORIES= graphics tcl
MASTER_SITES= https://BSDforge.com/projects/source/graphics/gdtclft/
DISTNAME= ${PORTNAME}${PORTVERSION}
diff --git a/graphics/grads/Makefile b/graphics/grads/Makefile
index d55925eb38ae..d45580667df1 100644
--- a/graphics/grads/Makefile
+++ b/graphics/grads/Makefile
@@ -3,7 +3,7 @@
PORTNAME= grads
PORTVERSION= 1.9b4
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= graphics science math
MASTER_SITES= ftp://grads.iges.org/grads/1.9/:src \
ftp://cola.gmu.edu/grads/1.9/:src \
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index 015839cb35ff..a3253164226f 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -3,7 +3,7 @@
PORTNAME= graphviz
PORTVERSION= 2.44.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics tk
MASTER_SITES= https://www2.graphviz.org/Packages/stable/portable_source/
diff --git a/graphics/libansilove/Makefile b/graphics/libansilove/Makefile
index 47a932ac8e6c..59d78a1143e7 100644
--- a/graphics/libansilove/Makefile
+++ b/graphics/libansilove/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libansilove
PORTVERSION= 1.2.2
+PORTREVISION= 1
CATEGORIES= graphics
MAINTAINER= amdmi3@FreeBSD.org
diff --git a/graphics/libgphoto2/Makefile b/graphics/libgphoto2/Makefile
index a4eca6169d18..99792884729c 100644
--- a/graphics/libgphoto2/Makefile
+++ b/graphics/libgphoto2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libgphoto2
PORTVERSION= 2.5.23
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/gphoto/libgphoto/${PORTVERSION}
diff --git a/graphics/libpuzzle/Makefile b/graphics/libpuzzle/Makefile
index 201a85ccefc1..fe1b55aa875f 100644
--- a/graphics/libpuzzle/Makefile
+++ b/graphics/libpuzzle/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libpuzzle
PORTVERSION= 0.11
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.pureftpd.org/pub/pure-ftpd/misc/libpuzzle/releases/
diff --git a/graphics/libsixel/Makefile b/graphics/libsixel/Makefile
index 7c33025d6f25..910eb854cc61 100644
--- a/graphics/libsixel/Makefile
+++ b/graphics/libsixel/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libsixel
PORTVERSION= 1.8.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= https://github.com/saitoha/libsixel/releases/download/v${PORTVERSION}/
diff --git a/graphics/lua-gd/Makefile b/graphics/lua-gd/Makefile
index 6836827fb6da..8a72d590cdb2 100644
--- a/graphics/lua-gd/Makefile
+++ b/graphics/lua-gd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lua-gd
PORTVERSION= 2.0.33r2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= http://files.luaforge.net/releases/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}forLua5.1/
diff --git a/graphics/mapserver/Makefile b/graphics/mapserver/Makefile
index eb670c607ab2..910d22fa00b7 100644
--- a/graphics/mapserver/Makefile
+++ b/graphics/mapserver/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mapserver
PORTVERSION= 7.4.4
+PORTREVISION= 1
CATEGORIES= graphics www geography
MASTER_SITES= https://download.osgeo.org/mapserver/
diff --git a/graphics/mscgen/Makefile b/graphics/mscgen/Makefile
index 614f4bc60bac..eb4984185145 100644
--- a/graphics/mscgen/Makefile
+++ b/graphics/mscgen/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mscgen
PORTVERSION= 0.20
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics
MASTER_SITES= http://www.mcternan.me.uk/mscgen/software/ \
http://romain.blogreen.org/distfiles/
diff --git a/graphics/p5-GD/Makefile b/graphics/p5-GD/Makefile
index ca632bc2ca59..ea7c054b8922 100644
--- a/graphics/p5-GD/Makefile
+++ b/graphics/p5-GD/Makefile
@@ -2,6 +2,7 @@
PORTNAME= GD
PORTVERSION= 2.71
+PORTREVISION= 1
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/graphics/phplot/Makefile b/graphics/phplot/Makefile
index c29faa4afc72..dbd184725fdf 100644
--- a/graphics/phplot/Makefile
+++ b/graphics/phplot/Makefile
@@ -3,7 +3,7 @@
PORTNAME= phplot
PORTVERSION= 6.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics www
MASTER_SITES= SF \
SF/${PORTNAME}/Manual/20130511:source2
diff --git a/graphics/png2html/Makefile b/graphics/png2html/Makefile
index f2eb7f606932..7fd73087bdb7 100644
--- a/graphics/png2html/Makefile
+++ b/graphics/png2html/Makefile
@@ -3,7 +3,7 @@
PORTNAME= png2html
PORTVERSION= 1.1
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= graphics
MASTER_SITES= http://www.engr.mun.ca/~holden/
diff --git a/graphics/pstoedit/Makefile b/graphics/pstoedit/Makefile
index 2621037767cd..88f3bca9fe80 100644
--- a/graphics/pstoedit/Makefile
+++ b/graphics/pstoedit/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pstoedit
PORTVERSION= 3.70
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= graphics print
MASTER_SITES= SF
diff --git a/graphics/raster3d/Makefile b/graphics/raster3d/Makefile
index 1023d3caa3fc..e66de7e7befe 100644
--- a/graphics/raster3d/Makefile
+++ b/graphics/raster3d/Makefile
@@ -3,7 +3,7 @@
PORTNAME= raster3d
DISTVERSION= 3.0.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics biology
MASTER_SITES= http://skuld.bmsc.washington.edu/${PORTNAME}/
DISTNAME= Raster3D_${DISTVERSION:R}-${DISTVERSION:E}
diff --git a/graphics/repng2jpeg/Makefile b/graphics/repng2jpeg/Makefile
index 95cfdbc411c5..5f9d571bd124 100644
--- a/graphics/repng2jpeg/Makefile
+++ b/graphics/repng2jpeg/Makefile
@@ -3,7 +3,7 @@
PORTNAME= repng2jpeg
PORTVERSION= 1.0.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= https://BSDforge.com/projects/source/graphics/repng2jpeg/
diff --git a/graphics/ruby-gd/Makefile b/graphics/ruby-gd/Makefile
index c55ae9fb52f0..a50260273aea 100644
--- a/graphics/ruby-gd/Makefile
+++ b/graphics/ruby-gd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gd
PORTVERSION= 0.8.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= graphics ruby
MASTER_SITES= ftp://ftp.jp.vim.org/pub/distfiles/ruby/ \
http://www.mmnt.net/db/0/8/ftp.jp.vim.org/pub/distfiles/ruby/
diff --git a/graphics/rubygem-gd2/Makefile b/graphics/rubygem-gd2/Makefile
index 469aa9ae9cc8..eb566dcadede 100644
--- a/graphics/rubygem-gd2/Makefile
+++ b/graphics/rubygem-gd2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gd2
PORTVERSION= 1.1.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics rubygems
MASTER_SITES= RG
diff --git a/graphics/scr2png/Makefile b/graphics/scr2png/Makefile
index 804cc9b16d29..39b66e88e6ab 100644
--- a/graphics/scr2png/Makefile
+++ b/graphics/scr2png/Makefile
@@ -3,7 +3,7 @@
PORTNAME= scr2png
PORTVERSION= 1.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= graphics
MASTER_SITES= LOCAL/nik
diff --git a/graphics/zimg/Makefile b/graphics/zimg/Makefile
index 8b51bef3ed2d..b8a6c5b68df0 100644
--- a/graphics/zimg/Makefile
+++ b/graphics/zimg/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zimg
PORTVERSION= 5.0.0
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}