aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-12-23 14:00:18 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-12-23 14:00:18 +0000
commit2834288846a017896ae631f044c73a073e02378f (patch)
tree234d6aa1e488ae1fe319f06e8ead3b3e089407a7 /graphics
parentef3d6c957055b551b63542e6e6fd53de8569904f (diff)
downloadports-2834288846a017896ae631f044c73a073e02378f.tar.gz
ports-2834288846a017896ae631f044c73a073e02378f.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ycomp/Makefile35
-rw-r--r--graphics/ycomp/distinfo3
-rw-r--r--graphics/ycomp/files/ycomp.sh.in9
-rw-r--r--graphics/ycomp/pkg-descr17
-rw-r--r--graphics/ycomp/pkg-plist8
5 files changed, 72 insertions, 0 deletions
diff --git a/graphics/ycomp/Makefile b/graphics/ycomp/Makefile
new file mode 100644
index 000000000000..396fa3e48b39
--- /dev/null
+++ b/graphics/ycomp/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: ycomp
+# Date created: 23 Dec 2008
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= ycomp
+PORTVERSION= 1.3.10
+CATEGORIES= graphics java
+MASTER_SITES= http://www.info.uni-karlsruhe.de/software/
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Visualization system for Program Dependency Graphs in VCG format
+
+RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
+
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+USE_BZIP2= yes
+NO_BUILD= yes
+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}-${PORTVERSION}
+DATAFILES= antlr.jar batik.jar graphmlObf.jar yComp.jar yObf.jar \
+ ysvgObf.jar
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+SUB_FILES= ycomp.sh
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DATAFILES} ${DATADIR}/
+ ${INSTALL_SCRIPT} ${WRKDIR}/ycomp.sh ${PREFIX}/bin/ycomp
+
+.include <bsd.port.mk>
diff --git a/graphics/ycomp/distinfo b/graphics/ycomp/distinfo
new file mode 100644
index 000000000000..c14388174053
--- /dev/null
+++ b/graphics/ycomp/distinfo
@@ -0,0 +1,3 @@
+MD5 (ycomp-1.3.10.tar.bz2) = 975bf3ce68db1e901ffb180aa165470e
+SHA256 (ycomp-1.3.10.tar.bz2) = 2ceccee781ade3a45bd8cec73d7168c4f9538da31ad4a870fefe32aff420f926
+SIZE (ycomp-1.3.10.tar.bz2) = 5456013
diff --git a/graphics/ycomp/files/ycomp.sh.in b/graphics/ycomp/files/ycomp.sh.in
new file mode 100644
index 000000000000..09787a208800
--- /dev/null
+++ b/graphics/ycomp/files/ycomp.sh.in
@@ -0,0 +1,9 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+YCOMP_HOME="%%DATADIR%%"
+export YCOMP_HOME
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" -jar "$YCOMP_HOME/yComp.jar" "${@}"
+
+# eof
diff --git a/graphics/ycomp/pkg-descr b/graphics/ycomp/pkg-descr
new file mode 100644
index 000000000000..d4b48de76ca0
--- /dev/null
+++ b/graphics/ycomp/pkg-descr
@@ -0,0 +1,17 @@
+Program Highlights
+ * Read, layout and print of graphs in the .VCG, .GML and .YGF format
+ * Layout support for program dependency graphs yielding
+ high performance graph layout
+ * Easy to use GUI
+ * NEW! PGF / TikZ format export to use in LaTeX documents
+ * For version 1.3.1 we have implemented numerous improvements to the layout,
+ useability and performance
+ * System requirements: Java 1.5 aka J2SE 5.0
+
+Licence:
+This software is based on the yFiles library.
+yWorks GmbH granted an academic license for #yFiles" to IPD Goos: An academic
+license restricts the use of the software (yComp) to non-commercial purposes
+(research, teaching, projects, courses and application development).
+
+WWW: http://www.info.uni-karlsruhe.de/software.php/id=6&lang=en
diff --git a/graphics/ycomp/pkg-plist b/graphics/ycomp/pkg-plist
new file mode 100644
index 000000000000..85e16d4b8f3d
--- /dev/null
+++ b/graphics/ycomp/pkg-plist
@@ -0,0 +1,8 @@
+bin/ycomp
+%%DATADIR%%/antlr.jar
+%%DATADIR%%/batik.jar
+%%DATADIR%%/graphmlObf.jar
+%%DATADIR%%/yComp.jar
+%%DATADIR%%/yObf.jar
+%%DATADIR%%/ysvgObf.jar
+@dirrm %%DATADIR%%