aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-02-08 10:27:24 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-02-08 10:27:24 +0000
commit2ea36c10d8d290571bae8de8b3806bd022bf9bba (patch)
tree91bd6b13522ddd086aebce298f26a99db369683b /graphics
parent588ef344e7729605403bfe99164d877b86adcaf1 (diff)
downloadports-2ea36c10d8d290571bae8de8b3806bd022bf9bba.tar.gz
ports-2ea36c10d8d290571bae8de8b3806bd022bf9bba.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/meshviewer/Makefile28
-rw-r--r--graphics/meshviewer/distinfo1
-rw-r--r--graphics/meshviewer/files/patch-Makefile25
-rw-r--r--graphics/meshviewer/files/patch-mesh.cc11
-rw-r--r--graphics/meshviewer/pkg-comment1
-rw-r--r--graphics/meshviewer/pkg-descr17
-rw-r--r--graphics/meshviewer/pkg-plist1
8 files changed, 85 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 5339fac53bc7..772ccf2c6bf1 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -218,6 +218,7 @@
SUBDIR += linux_mesa3
SUBDIR += lodju
SUBDIR += maverik
+ SUBDIR += meshviewer
SUBDIR += metapixel
SUBDIR += mgp-gallery
SUBDIR += ming
diff --git a/graphics/meshviewer/Makefile b/graphics/meshviewer/Makefile
new file mode 100644
index 000000000000..41432922b822
--- /dev/null
+++ b/graphics/meshviewer/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: meshviewer
+# Date created: Jun 10, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+
+PORTNAME= meshviewer
+PORTVERSION= 0.1.2
+CATEGORIES= graphics
+MASTER_SITES= http://www.dai.ed.ac.uk/homes/helmutc/mesh_viewer/
+DISTNAME= mview-src-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+
+USE_MESA= yes
+USE_QT_VER= 3
+USE_GMAKE= yes
+MAKE_ENV= MOC="${MOC}" QTDIR="${X11BASE}" \
+ CPPFLAGS="${QTCPPFLAGS} ${PTHREAD_CFLAGS}" \
+ LIBS="${QTCFGLIBS} ${PTHREAD_LIBS}"
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mview ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/meshviewer/distinfo b/graphics/meshviewer/distinfo
new file mode 100644
index 000000000000..17df1321f8ff
--- /dev/null
+++ b/graphics/meshviewer/distinfo
@@ -0,0 +1 @@
+MD5 (mview-src-0.1.2.tar.gz) = 5882dbc62ad297614afa9ca1b45a6527
diff --git a/graphics/meshviewer/files/patch-Makefile b/graphics/meshviewer/files/patch-Makefile
new file mode 100644
index 000000000000..778fc34cb832
--- /dev/null
+++ b/graphics/meshviewer/files/patch-Makefile
@@ -0,0 +1,25 @@
+--- Makefile.orig Thu Feb 6 15:30:42 2003
++++ Makefile Sat Feb 8 18:22:36 2003
+@@ -1,18 +1,18 @@
+
+ CC=g++
+-MOC=$(QTDIR)/bin/moc
++#MOC=$(QTDIR)/bin/moc
+ #MOC=/usr/lib/qt3/bin/moc
+ EXE=mview
+
+-CPPFLAGS = $(INCPATH) -O2
++CPPFLAGS+= $(INCPATH) -O2
+ # supposedly compiler options for faster code
+ #CPPFLAGS = $(INCPATH) -O3 -fexceptions --fast-math -felide-constructors -fexpensive-optimizations -fdelayed-branch -fschedule-insns
+
+ INCPATH = -I. -Itexture -Imesh -Imathvector -I$(QTDIR)/include -I/usr/lib/qt3/include
+ LIBPATH = -L$(QTDIR)/lib -L/usr/local/lib -L/usr/X11R6/lib -L/usr/lib/qt3/lib
+
+-LIBS_QT = -lGL -lGLU -lqt-mt -ljpeg
+-LIBS_GLUT = -lGL -lGLU -lglut -ljpeg
++LIBS_QT = ${LIBS} -lGL -lGLU -lqt-mt -ljpeg
++LIBS_GLUT = ${LIBS} -lGL -lGLU -lglut -ljpeg
+
+ QT = qt/main.o \
+ qt/mview.o \
diff --git a/graphics/meshviewer/files/patch-mesh.cc b/graphics/meshviewer/files/patch-mesh.cc
new file mode 100644
index 000000000000..0ac41d6aa2f2
--- /dev/null
+++ b/graphics/meshviewer/files/patch-mesh.cc
@@ -0,0 +1,11 @@
+--- mesh/mesh.cc.orig Sat Feb 8 18:14:00 2003
++++ mesh/mesh.cc Sat Feb 8 18:14:11 2003
+@@ -9,7 +9,7 @@
+ #include <set>
+
+ // for MAXFLOAT
+-#include <values.h>
++#include <limits.h>
+
+ #include "mesh.h"
+
diff --git a/graphics/meshviewer/pkg-comment b/graphics/meshviewer/pkg-comment
new file mode 100644
index 000000000000..5fe57fb26b63
--- /dev/null
+++ b/graphics/meshviewer/pkg-comment
@@ -0,0 +1 @@
+Mesh Viewer
diff --git a/graphics/meshviewer/pkg-descr b/graphics/meshviewer/pkg-descr
new file mode 100644
index 000000000000..3498d0ed5071
--- /dev/null
+++ b/graphics/meshviewer/pkg-descr
@@ -0,0 +1,17 @@
+The Mesh Viewer is an easy to use lightweight application to display
+triangular meshes from a variety of file formats. It uses the OpenGL API
+to render the models. The program was born under the need for quickly
+displaying reconstructed triangulated meshes. The Mesh Viewer based on
+an idea and an early elementary implementation from Craig Robertson. The
+current version was developed by Helmut Cantzler. Triangular meshes can
+be displayed texture mapped (optional with bilinear filtering), solid or
+as a skeleton (full or just the front lines). The surface normals of the
+triangles can be displayed optionally.
+
+Features (from a different data file) like edges and points can be
+displayed into the mesh. Loaded models can be rotated, translated and
+scaled (all done with the mouse). The model is lighted by multiple light
+sources. Viewpoints can be saved. Screenshots of the model can be taken (as
+BMP, JPEG, PNG and so on).
+
+WWW: http://www.dai.ed.ac.uk/~helmutc/mesh_viewer/
diff --git a/graphics/meshviewer/pkg-plist b/graphics/meshviewer/pkg-plist
new file mode 100644
index 000000000000..953ae8558be1
--- /dev/null
+++ b/graphics/meshviewer/pkg-plist
@@ -0,0 +1 @@
+bin/mview