aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2012-02-14 22:08:59 +0000
committerKoop Mast <kwm@FreeBSD.org>2012-02-14 22:08:59 +0000
commitdc2cf4584f4d95498710c6d8a583ddb3905131a6 (patch)
tree936c64dc937edf1ad130e2a422582fb6b9995231 /graphics
parent5e0d7a740618f4433bf2d32917a4b47c263d0bd6 (diff)
downloadports-dc2cf4584f4d95498710c6d8a583ddb3905131a6.tar.gz
ports-dc2cf4584f4d95498710c6d8a583ddb3905131a6.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gimp-app/Makefile5
-rw-r--r--graphics/gimp-app/distinfo4
-rw-r--r--graphics/gimp-app/files/patch-plugins_common_file-pdf.c128
-rw-r--r--graphics/gimp-app/pkg-plist19
-rw-r--r--graphics/gimp/Makefile2
5 files changed, 17 insertions, 141 deletions
diff --git a/graphics/gimp-app/Makefile b/graphics/gimp-app/Makefile
index 3b2e16ed6d7b..591b8c58d6d9 100644
--- a/graphics/gimp-app/Makefile
+++ b/graphics/gimp-app/Makefile
@@ -7,8 +7,8 @@
#
PORTNAME= gimp-app
-DISTVERSION= 2.6.11
-PORTREVISION?= 5
+DISTVERSION= 2.6.12
+PORTREVISION?= 0
PORTEPOCH?= 1
CATEGORIES?= graphics gnome
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
@@ -47,6 +47,7 @@ INSTALLS_ICONS= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
CONFIGURE_ARGS?=--with-html-dir=${PREFIX}/share/doc/gimp \
--disable-gtk-doc \
+ --without-linux-input \
--without-print \
--disable-python \
--with-desktop-dir=${PREFIX}/share \
diff --git a/graphics/gimp-app/distinfo b/graphics/gimp-app/distinfo
index 54a230f77ba3..3ce59ed6edab 100644
--- a/graphics/gimp-app/distinfo
+++ b/graphics/gimp-app/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gimp-2.6.11.tar.bz2) = 9b6d08d0803b3912ea596d1b77b9c21ee13778c23388a225c004b8c1587cb0a1
-SIZE (gimp-2.6.11.tar.bz2) = 16473561
+SHA256 (gimp-2.6.12.tar.bz2) = d553c9f1c07f59fa7b7ce9cc5f84ce59bf4e9dfb5b6ee4bd8718b74b947aec62
+SIZE (gimp-2.6.12.tar.bz2) = 16745411
diff --git a/graphics/gimp-app/files/patch-plugins_common_file-pdf.c b/graphics/gimp-app/files/patch-plugins_common_file-pdf.c
deleted file mode 100644
index 72017ebea56a..000000000000
--- a/graphics/gimp-app/files/patch-plugins_common_file-pdf.c
+++ /dev/null
@@ -1,128 +0,0 @@
---- plug-ins/common/file-pdf.c.orig 2010-07-02 22:51:56.000000000 +0000
-+++ plug-ins/common/file-pdf.c 2011-10-23 19:29:37.000000000 +0000
-@@ -566,6 +566,84 @@ layer_from_pixbuf (gint32 image,
- return layer;
- }
-
-+static void
-+copy_cairo_surface_to_pixbuf (cairo_surface_t *surface,
-+ GdkPixbuf *pixbuf)
-+{
-+ int cairo_width, cairo_height, cairo_rowstride;
-+ unsigned char *pixbuf_data, *dst, *cairo_data;
-+ int pixbuf_rowstride, pixbuf_n_channels;
-+ unsigned int *src;
-+ int x, y;
-+
-+ cairo_width = cairo_image_surface_get_width (surface);
-+ cairo_height = cairo_image_surface_get_height (surface);
-+ cairo_rowstride = cairo_image_surface_get_stride (surface);
-+ cairo_data = cairo_image_surface_get_data (surface);
-+
-+ pixbuf_data = gdk_pixbuf_get_pixels (pixbuf);
-+ pixbuf_rowstride = gdk_pixbuf_get_rowstride (pixbuf);
-+ pixbuf_n_channels = gdk_pixbuf_get_n_channels (pixbuf);
-+
-+ if (cairo_width > gdk_pixbuf_get_width (pixbuf))
-+ cairo_width = gdk_pixbuf_get_width (pixbuf);
-+ if (cairo_height > gdk_pixbuf_get_height (pixbuf))
-+ cairo_height = gdk_pixbuf_get_height (pixbuf);
-+
-+ for (y = 0; y < cairo_height; y++)
-+ {
-+ src = (unsigned int *) (cairo_data + y * cairo_rowstride);
-+ dst = pixbuf_data + y * pixbuf_rowstride;
-+
-+ for (x = 0; x < cairo_width; x++)
-+ {
-+ dst[0] = (*src >> 16) & 0xff;
-+ dst[1] = (*src >> 8) & 0xff;
-+ dst[2] = (*src >> 0) & 0xff;
-+
-+ if (pixbuf_n_channels == 4)
-+ dst[3] = (*src >> 24) & 0xff;
-+
-+ dst += pixbuf_n_channels;
-+ src++;
-+ }
-+ }
-+}
-+
-+static GdkPixbuf *
-+render_page_to_pixbuf (PopplerPage *page,
-+ int width,
-+ int height,
-+ double scale)
-+{
-+ GdkPixbuf *pixbuf;
-+ cairo_surface_t *surface;
-+ cairo_t *cr;
-+
-+ pixbuf = gdk_pixbuf_new (GDK_COLORSPACE_RGB, FALSE, 8, width, height);
-+ surface = cairo_image_surface_create (CAIRO_FORMAT_ARGB32, width, height);
-+ cr = cairo_create (surface);
-+
-+ cairo_save (cr);
-+ cairo_translate (cr, 0.0, 0.0);
-+
-+ if (scale != 1.0)
-+ cairo_scale (cr, scale, scale);
-+
-+ poppler_page_render (page, cr);
-+ cairo_restore (cr);
-+
-+ cairo_set_operator (cr, CAIRO_OPERATOR_DEST_OVER);
-+ cairo_set_source_rgb (cr, 1.0, 1.0, 1.0);
-+ cairo_paint (cr);
-+
-+ cairo_destroy (cr);
-+ copy_cairo_surface_to_pixbuf (surface, pixbuf);
-+ cairo_surface_destroy (surface);
-+
-+ return pixbuf;
-+}
-+
- static gint32
- load_image (PopplerDocument *doc,
- const gchar *filename,
-@@ -597,7 +675,7 @@ load_image (PopplerDocument *doc,
- gdouble page_width;
- gdouble page_height;
-
-- GdkPixbuf *buf;
-+ GdkPixbuf *pixbuf;
- gint width;
- gint height;
-
-@@ -627,15 +705,13 @@ load_image (PopplerDocument *doc,
- gimp_image_set_resolution (image_ID, resolution, resolution);
- }
-
-- buf = gdk_pixbuf_new (GDK_COLORSPACE_RGB, FALSE, 8, width, height);
-+ pixbuf = render_page_to_pixbuf (page, width, height, scale);
-
-- poppler_page_render_to_pixbuf (page, 0, 0, width, height, scale, 0, buf);
--
-- layer_from_pixbuf (image_ID, page_label, i, buf,
-+ layer_from_pixbuf (image_ID, page_label, i, pixbuf,
- doc_progress, 1.0 / pages->n_pages);
-
- g_free (page_label);
-- g_object_unref (buf);
-+ g_object_unref (pixbuf);
-
- doc_progress = (double) (i + 1) / pages->n_pages;
- gimp_progress_update (doc_progress);
-@@ -712,11 +788,7 @@ get_thumbnail (PopplerDocument *doc,
- width *= scale;
- height *= scale;
-
-- pixbuf = gdk_pixbuf_new (GDK_COLORSPACE_RGB, FALSE, 8,
-- width, height);
--
-- poppler_page_render_to_pixbuf (page,
-- 0, 0, width, height, scale, 0, pixbuf);
-+ pixbuf = render_page_to_pixbuf (page, width, height, scale);
- }
-
- g_object_unref (page);
diff --git a/graphics/gimp-app/pkg-plist b/graphics/gimp-app/pkg-plist
index 2211aa3798c4..1781acaf93f7 100644
--- a/graphics/gimp-app/pkg-plist
+++ b/graphics/gimp-app/pkg-plist
@@ -544,7 +544,6 @@ share/doc/gimp/libgimp/libgimp-index-new-in-2-4.html
share/doc/gimp/libgimp/libgimp-index-new-in-2-6.html
share/doc/gimp/libgimp/libgimp-index.html
share/doc/gimp/libgimp/libgimp-selectors.html
-share/doc/gimp/libgimp/libgimp.devhelp
share/doc/gimp/libgimp/libgimp.devhelp2
share/doc/gimp/libgimp/libgimp.html
share/doc/gimp/libgimp/libgimpui-hierarchy.html
@@ -577,7 +576,6 @@ share/doc/gimp/libgimpbase/libgimpbase-index-new-in-2-2.html
share/doc/gimp/libgimpbase/libgimpbase-index-new-in-2-4.html
share/doc/gimp/libgimpbase/libgimpbase-index-new-in-2-6.html
share/doc/gimp/libgimpbase/libgimpbase-index.html
-share/doc/gimp/libgimpbase/libgimpbase.devhelp
share/doc/gimp/libgimpbase/libgimpbase.devhelp2
share/doc/gimp/libgimpbase/libgimpbase.html
share/doc/gimp/libgimpbase/right.png
@@ -599,7 +597,6 @@ share/doc/gimp/libgimpcolor/libgimpcolor-index-new-in-2-2.html
share/doc/gimp/libgimpcolor/libgimpcolor-index-new-in-2-4.html
share/doc/gimp/libgimpcolor/libgimpcolor-index-new-in-2-6.html
share/doc/gimp/libgimpcolor/libgimpcolor-index.html
-share/doc/gimp/libgimpcolor/libgimpcolor.devhelp
share/doc/gimp/libgimpcolor/libgimpcolor.devhelp2
share/doc/gimp/libgimpcolor/libgimpcolor.html
share/doc/gimp/libgimpcolor/right.png
@@ -624,7 +621,6 @@ share/doc/gimp/libgimpconfig/libgimpconfig-index-deprecated.html
share/doc/gimp/libgimpconfig/libgimpconfig-index-new-in-2-4.html
share/doc/gimp/libgimpconfig/libgimpconfig-index-new-in-2-6.html
share/doc/gimp/libgimpconfig/libgimpconfig-index.html
-share/doc/gimp/libgimpconfig/libgimpconfig.devhelp
share/doc/gimp/libgimpconfig/libgimpconfig.devhelp2
share/doc/gimp/libgimpconfig/libgimpconfig.html
share/doc/gimp/libgimpconfig/right.png
@@ -643,7 +639,6 @@ share/doc/gimp/libgimpmath/libgimpmath-index-new-in-2-2.html
share/doc/gimp/libgimpmath/libgimpmath-index-new-in-2-4.html
share/doc/gimp/libgimpmath/libgimpmath-index-new-in-2-6.html
share/doc/gimp/libgimpmath/libgimpmath-index.html
-share/doc/gimp/libgimpmath/libgimpmath.devhelp
share/doc/gimp/libgimpmath/libgimpmath.devhelp2
share/doc/gimp/libgimpmath/libgimpmath.html
share/doc/gimp/libgimpmath/right.png
@@ -660,7 +655,6 @@ share/doc/gimp/libgimpmodule/libgimpmodule-index-new-in-2-2.html
share/doc/gimp/libgimpmodule/libgimpmodule-index-new-in-2-4.html
share/doc/gimp/libgimpmodule/libgimpmodule-index-new-in-2-6.html
share/doc/gimp/libgimpmodule/libgimpmodule-index.html
-share/doc/gimp/libgimpmodule/libgimpmodule.devhelp
share/doc/gimp/libgimpmodule/libgimpmodule.devhelp2
share/doc/gimp/libgimpmodule/libgimpmodule.html
share/doc/gimp/libgimpmodule/right.png
@@ -679,7 +673,6 @@ share/doc/gimp/libgimpthumb/libgimpthumb-index-new-in-2-2.html
share/doc/gimp/libgimpthumb/libgimpthumb-index-new-in-2-4.html
share/doc/gimp/libgimpthumb/libgimpthumb-index-new-in-2-6.html
share/doc/gimp/libgimpthumb/libgimpthumb-index.html
-share/doc/gimp/libgimpthumb/libgimpthumb.devhelp
share/doc/gimp/libgimpthumb/libgimpthumb.devhelp2
share/doc/gimp/libgimpthumb/libgimpthumb.html
share/doc/gimp/libgimpthumb/right.png
@@ -779,7 +772,6 @@ share/doc/gimp/libgimpwidgets/libgimpwidgets-index-new-in-2-6.html
share/doc/gimp/libgimpwidgets/libgimpwidgets-index.html
share/doc/gimp/libgimpwidgets/libgimpwidgets-utils.html
share/doc/gimp/libgimpwidgets/libgimpwidgets-widgets.html
-share/doc/gimp/libgimpwidgets/libgimpwidgets.devhelp
share/doc/gimp/libgimpwidgets/libgimpwidgets.devhelp2
share/doc/gimp/libgimpwidgets/right.png
share/doc/gimp/libgimpwidgets/stock-anchor-16.png
@@ -1742,6 +1734,7 @@ share/locale/el/LC_MESSAGES/gimp20-libgimp.mo
share/locale/el/LC_MESSAGES/gimp20-python.mo
share/locale/el/LC_MESSAGES/gimp20-script-fu.mo
share/locale/el/LC_MESSAGES/gimp20-std-plug-ins.mo
+share/locale/el/LC_MESSAGES/gimp20-tips.mo
share/locale/el/LC_MESSAGES/gimp20.mo
share/locale/en_CA/LC_MESSAGES/gimp20-libgimp.mo
share/locale/en_CA/LC_MESSAGES/gimp20-python.mo
@@ -1758,6 +1751,7 @@ share/locale/en_GB/LC_MESSAGES/gimp20.mo
share/locale/eo/LC_MESSAGES/gimp20-libgimp.mo
share/locale/eo/LC_MESSAGES/gimp20-python.mo
share/locale/eo/LC_MESSAGES/gimp20-script-fu.mo
+share/locale/eo/LC_MESSAGES/gimp20-std-plug-ins.mo
share/locale/eo/LC_MESSAGES/gimp20-tips.mo
share/locale/eo/LC_MESSAGES/gimp20.mo
share/locale/es/LC_MESSAGES/gimp20-libgimp.mo
@@ -1854,6 +1848,8 @@ share/locale/ja/LC_MESSAGES/gimp20-std-plug-ins.mo
share/locale/ja/LC_MESSAGES/gimp20-tips.mo
share/locale/ja/LC_MESSAGES/gimp20.mo
share/locale/ka/LC_MESSAGES/gimp20.mo
+share/locale/kk/LC_MESSAGES/gimp20-libgimp.mo
+share/locale/kk/LC_MESSAGES/gimp20.mo
share/locale/km/LC_MESSAGES/gimp20-libgimp.mo
share/locale/km/LC_MESSAGES/gimp20-python.mo
share/locale/km/LC_MESSAGES/gimp20-script-fu.mo
@@ -1875,6 +1871,10 @@ share/locale/lt/LC_MESSAGES/gimp20-std-plug-ins.mo
share/locale/lt/LC_MESSAGES/gimp20-tips.mo
share/locale/lt/LC_MESSAGES/gimp20.mo
share/locale/lv/LC_MESSAGES/gimp20-libgimp.mo
+share/locale/lv/LC_MESSAGES/gimp20-python.mo
+share/locale/lv/LC_MESSAGES/gimp20-script-fu.mo
+share/locale/lv/LC_MESSAGES/gimp20-std-plug-ins.mo
+share/locale/lv/LC_MESSAGES/gimp20-tips.mo
share/locale/lv/LC_MESSAGES/gimp20.mo
share/locale/mk/LC_MESSAGES/gimp20-libgimp.mo
share/locale/mk/LC_MESSAGES/gimp20-python.mo
@@ -2013,6 +2013,7 @@ share/locale/tr/LC_MESSAGES/gimp20-libgimp.mo
share/locale/tr/LC_MESSAGES/gimp20-python.mo
share/locale/tr/LC_MESSAGES/gimp20-script-fu.mo
share/locale/tr/LC_MESSAGES/gimp20-std-plug-ins.mo
+share/locale/tr/LC_MESSAGES/gimp20-tips.mo
share/locale/tr/LC_MESSAGES/gimp20.mo
share/locale/tt/LC_MESSAGES/gimp20.mo
share/locale/uk/LC_MESSAGES/gimp20-libgimp.mo
@@ -2078,6 +2079,8 @@ share/locale/zh_TW/LC_MESSAGES/gimp20.mo
@dirrmtry share/locale/mr
@dirrmtry share/locale/km/LC_MESSAGES
@dirrmtry share/locale/km
+@dirrmtry share/locale/kk/LC_MESSAGES
+@dirrmtry share/locale/kk
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
@dirrmtry share/locale/ca@valencia/LC_MESSAGES
diff --git a/graphics/gimp/Makefile b/graphics/gimp/Makefile
index 179989283c37..199b636d3d09 100644
--- a/graphics/gimp/Makefile
+++ b/graphics/gimp/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= gimp
-DISTVERSION?= 2.6.11
+DISTVERSION?= 2.6.12
PORTREVISION?= 0
PORTEPOCH?= 2
CATEGORIES= graphics gnome