aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-06-16 08:43:57 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-06-16 08:43:57 +0000
commited15371ac8214781248103fbf2cd8b100f9c5e5b (patch)
treef50e520aa1c5a521742a730ab142f9d14bbc4818 /graphics
parentdca1ed5e28fa3236f572bc3193c3ea181dab887c (diff)
downloadports-ed15371ac8214781248103fbf2cd8b100f9c5e5b.tar.gz
ports-ed15371ac8214781248103fbf2cd8b100f9c5e5b.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/lcdtest/Makefile38
-rw-r--r--graphics/lcdtest/distinfo3
-rw-r--r--graphics/lcdtest/pkg-descr7
4 files changed, 49 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 123857bb07e8..d4cd552beaed 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -322,6 +322,7 @@
SUBDIR += kuickshow
SUBDIR += l2p
SUBDIR += landscape
+ SUBDIR += lcdtest
SUBDIR += lcms
SUBDIR += leafpak
SUBDIR += lfview
diff --git a/graphics/lcdtest/Makefile b/graphics/lcdtest/Makefile
new file mode 100644
index 000000000000..3d9a037d953e
--- /dev/null
+++ b/graphics/lcdtest/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: lcdtest
+# Date created: 23 Mar 2007
+# Whom: Eric P. Scott <eps+pbug0703@ana.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lcdtest
+PORTVERSION= 1.04
+CATEGORIES= graphics
+MASTER_SITES= http://www.brouhaha.com/~eric/software/lcdtest/download/ \
+ CENKES
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= LCD monitor test pattern generator
+
+BUILD_DEPENDS= pngtopnm:${PORTSDIR}/graphics/netpbm
+
+USE_GMAKE= yes
+USE_SDL= sdl image
+CFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+MAKE_ENV= LDFLAGS="${LDFLAGS}"
+MAKE_ARGS= -o SDL/SDL.h -o SDL/SDL_image.h
+PLIST_FILES= bin/lcdtest
+PORTDOCS= README
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^CFLAGS =/s|=|+=|' ${WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/lcdtest ${PREFIX}/bin/
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}/
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/lcdtest/distinfo b/graphics/lcdtest/distinfo
new file mode 100644
index 000000000000..7a00c1c62970
--- /dev/null
+++ b/graphics/lcdtest/distinfo
@@ -0,0 +1,3 @@
+MD5 (lcdtest-1.04.tar.gz) = 7a5a34206438b628b8e5aea3da2ed84a
+SHA256 (lcdtest-1.04.tar.gz) = 265327fb4a6e8b816966f858bfa882bae30bf44ab186b7bb1dc7da6b41b680f8
+SIZE (lcdtest-1.04.tar.gz) = 27018
diff --git a/graphics/lcdtest/pkg-descr b/graphics/lcdtest/pkg-descr
new file mode 100644
index 000000000000..2a8504798f97
--- /dev/null
+++ b/graphics/lcdtest/pkg-descr
@@ -0,0 +1,7 @@
+lcdtest is a utility to display LCD monitor test patterns. It may be
+useful for adjusting the pixel clock frequency and phase on LCD
+monitors when using analog inputs, and for finding pixels that are
+stuck on or off.
+
+WWW: http://www.brouhaha.com/~eric/software/lcdtest/
+Author: Eric Smith <eric@brouhaha.com>