aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-22 18:05:04 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-22 18:05:04 +0000
commitf45d0a8198e01f9de3159f120af98857c70773c1 (patch)
tree5ccc149311d24585961d9a2cf90f90b5de162a2d /graphics
parenta14ce15e349663b36e082c2a46c21adc66d82376 (diff)
downloadports-f45d0a8198e01f9de3159f120af98857c70773c1.tar.gz
ports-f45d0a8198e01f9de3159f120af98857c70773c1.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cairomm/Makefile2
-rw-r--r--graphics/gimp-manual-html/Makefile2
-rw-r--r--graphics/libdrm/Makefile2
-rw-r--r--graphics/p5-Image-Imlib2/Makefile2
-rw-r--r--graphics/py-gchartwrapper/Makefile2
-rw-r--r--graphics/py-webcolors/Makefile2
-rw-r--r--graphics/yukon/Makefile2
7 files changed, 7 insertions, 7 deletions
diff --git a/graphics/cairomm/Makefile b/graphics/cairomm/Makefile
index a75bec5a8b06..6598dc4ec0ae 100644
--- a/graphics/cairomm/Makefile
+++ b/graphics/cairomm/Makefile
@@ -23,12 +23,12 @@ USE_GNOME= gnomehack ltverhack
CONFIGURE_ENV= AUTOMAKE="${TRUE}" AUTOCONF="${TRUE}" DOXYGEN="${TRUE}"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+NO_STAGE= yes
.if defined(NOPORTDOCS)
CONFIGURE_ARGS+= --disable-documentation
.else
-NO_STAGE= yes
post-configure:
@${TOUCH} -f ${WRKSRC}/docs/reference/html/index.html
.endif
diff --git a/graphics/gimp-manual-html/Makefile b/graphics/gimp-manual-html/Makefile
index 1b1851691611..c640b951d3fc 100644
--- a/graphics/gimp-manual-html/Makefile
+++ b/graphics/gimp-manual-html/Makefile
@@ -12,11 +12,11 @@ PKGNAMESUFFIX= -${DOCFORMAT}
MAINTAINER= ports@FreeBSD.org
COMMENT= The user manual for the GNU Image Manipulation Program (GIMP)
+NO_STAGE= yes
.if !defined(DOCFORMAT)
DOCFORMAT=HTML
.else
.if ${DOCFORMAT} != "HTML" && ${DOCFORMAT} != "PDF"
-NO_STAGE= yes
.BEGIN:
@${ECHO_MSG} "ERROR: invalid value for DOCFORMAT: \"${DOCFORMAT}\""
@${ECHO_MSG} "Possible values are: HTML, PDF."
diff --git a/graphics/libdrm/Makefile b/graphics/libdrm/Makefile
index 28843b4e4f89..5b51bc62d067 100644
--- a/graphics/libdrm/Makefile
+++ b/graphics/libdrm/Makefile
@@ -17,6 +17,7 @@ USES= pkgconfig
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+NO_STAGE= yes
.if defined(WITH_NEW_XORG)
@@ -31,7 +32,6 @@ KMS_DESC= Enable KMS support
OPTIONS_DEFAULT+= MANPAGES
.endif
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MKMS}
diff --git a/graphics/p5-Image-Imlib2/Makefile b/graphics/p5-Image-Imlib2/Makefile
index 7a7188057f59..d39b72c7933e 100644
--- a/graphics/p5-Image-Imlib2/Makefile
+++ b/graphics/p5-Image-Imlib2/Makefile
@@ -16,6 +16,7 @@ BUILD_DEPENDS+= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
USES= perl5
USE_PERL5= modbuild
USE_EFL= imlib2
+NO_STAGE= yes
MAN3= Image::Imlib2.3
@@ -23,7 +24,6 @@ MAN3= Image::Imlib2.3
PORTDOCS= CHANGES
EXAMPLES= examples/benchmark.pl examples/benchmark.txt examples/maeda.pl
-NO_STAGE= yes
post-install:
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
diff --git a/graphics/py-gchartwrapper/Makefile b/graphics/py-gchartwrapper/Makefile
index 05d838f85231..b02ef9b099b2 100644
--- a/graphics/py-gchartwrapper/Makefile
+++ b/graphics/py-gchartwrapper/Makefile
@@ -21,6 +21,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}imaging>=1.1.6_2:${PORTSDIR}/graphics/py-ima
USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_ZIP= yes
+NO_STAGE= yes
EXAMPLESDIR= ${PREFIX}/share/examples/${PYTHON_PKGNAMEPREFIX}${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/${PYTHON_PKGNAMEPREFIX}${PORTNAME}
@@ -28,7 +29,6 @@ DOCSDIR= ${PREFIX}/share/doc/${PYTHON_PKGNAMEPREFIX}${PORTNAME}
PROJECTHOST= google-chartwrapper
.if !defined(NOPORTDOCS)
-NO_STAGE= yes
post-extract:
@cd ${WRKDIR} && ${RM} -R doc/.svn && ${RM} -R demo/.svn
.endif
diff --git a/graphics/py-webcolors/Makefile b/graphics/py-webcolors/Makefile
index b4a0e1536a0f..6bc7e9442d22 100644
--- a/graphics/py-webcolors/Makefile
+++ b/graphics/py-webcolors/Makefile
@@ -12,12 +12,12 @@ COMMENT= Library working with the sRGB color space as used in the HTML and CSS
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+NO_STAGE= yes
DOCSDIR= ${PREFIX}/share/doc/${UNIQUENAME}
PORTDOCS= README
.if !defined(NOPORTDOCS)
-NO_STAGE= yes
post-install:
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${INSTALL_WRKSRC}/${PORTDOCS} ${DOCSDIR}
diff --git a/graphics/yukon/Makefile b/graphics/yukon/Makefile
index 9ee15b64f1f5..96ca94800519 100644
--- a/graphics/yukon/Makefile
+++ b/graphics/yukon/Makefile
@@ -22,6 +22,7 @@ USE_GMAKE= yes
USE_XORG= x11 xv
USE_GL= yes
USE_LDCONFIG= ${PREFIX}/lib/yukon
+NO_STAGE= yes
# NOTE: These should be bumped if the underlying GL or Xorg ports change.
@@ -39,7 +40,6 @@ FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
SVN_REV= 158 # svn tip at epoch 2009120801
SVNROOT_URI= https://devel.neopsis.com/svn/yukon
-NO_STAGE= yes
do-fetch:
${MKDIR} ${WRKDIR}
svn export -r ${SVN_REV} ${SVNROOT_URI}/trunk ${WRKSRC}