aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-02-16 15:20:48 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-02-19 00:44:23 +0000
commit04d616ca7227fdd260d6cd77639a3281ba21736c (patch)
tree690d3395be13a08b926e01946efff2aef005e0aa /graphics
parentb8e43c5956401535e7ff16a6701c11f0a04bd0e4 (diff)
downloadports-04d616ca7227fdd260d6cd77639a3281ba21736c.tar.gz
ports-04d616ca7227fdd260d6cd77639a3281ba21736c.zip
graphics/mesa-devel: update to 21.4.b.579
Changes: https://gitlab.freedesktop.org/mesa/mesa/-/compare/b995a8eba4f...01d1bf62283 (cherry picked from commit 48f54fbff0d358c598780b107a3aabc1482b895f)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/mesa-devel/Makefile4
-rw-r--r--graphics/mesa-devel/distinfo6
-rw-r--r--graphics/mesa-devel/files/patch-no-inotify44
3 files changed, 49 insertions, 5 deletions
diff --git a/graphics/mesa-devel/Makefile b/graphics/mesa-devel/Makefile
index 128d53c08868..74c50b4e343b 100644
--- a/graphics/mesa-devel/Makefile
+++ b/graphics/mesa-devel/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mesa
-DISTVERSION= 22.0-branchpoint-436
-DISTVERSIONSUFFIX= -gb995a8eba4f
+DISTVERSION= 22.0-branchpoint-579
+DISTVERSIONSUFFIX= -g01d1bf62283
CATEGORIES= graphics
PKGNAMESUFFIX= -devel
diff --git a/graphics/mesa-devel/distinfo b/graphics/mesa-devel/distinfo
index 5bea5385c77a..7b17cd2c96d1 100644
--- a/graphics/mesa-devel/distinfo
+++ b/graphics/mesa-devel/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1644876397
-SHA256 (mesa3d-mesa-22.0-branchpoint-436-gb995a8eba4f_GH0.tar.gz) = 68c1be58c3e3244291e3c7f57ed080ee077b742e7267901b1568b16721b1fa03
-SIZE (mesa3d-mesa-22.0-branchpoint-436-gb995a8eba4f_GH0.tar.gz) = 23572417
+TIMESTAMP = 1645228113
+SHA256 (mesa3d-mesa-22.0-branchpoint-579-g01d1bf62283_GH0.tar.gz) = f64bab8095faf9f32bfa9e1e519dada89e33648ff3f121e0b71008734dd81b35
+SIZE (mesa3d-mesa-22.0-branchpoint-579-g01d1bf62283_GH0.tar.gz) = 23588143
SHA256 (700efacda59c.patch) = f034cfbe09edff0baba67e46e7e3812fdef73ff3cf3e579050c024c95234c8d5
SIZE (700efacda59c.patch) = 981
SHA256 (50433886a3e3.patch) = 15af265e9dbb5dec7514062cfa549d1c1053f567395d9d133611c2a5138da470
diff --git a/graphics/mesa-devel/files/patch-no-inotify b/graphics/mesa-devel/files/patch-no-inotify
new file mode 100644
index 000000000000..0cc54a4db514
--- /dev/null
+++ b/graphics/mesa-devel/files/patch-no-inotify
@@ -0,0 +1,44 @@
+Regressed by https://gitlab.freedesktop.org/mesa/mesa/-/commit/c50557d9612a
+
+../src/amd/vulkan/radv_device.c:39:10: fatal error: 'sys/inotify.h' file not found
+#include <sys/inotify.h>
+ ^~~~~~~~~~~~~~~
+
+--- src/amd/vulkan/radv_device.c.orig 2022-02-18 15:04:48 UTC
++++ src/amd/vulkan/radv_device.c
+@@ -35,7 +35,7 @@
+ #include <sys/sysmacros.h>
+ #endif
+
+-#ifndef _WIN32
++#ifdef __linux__
+ #include <sys/inotify.h>
+ #endif
+
+@@ -2974,7 +2974,7 @@ radv_parse_force_vrs_config_file(const char *config_fi
+ return force_vrs;
+ }
+
+-#ifndef _WIN32
++#ifdef __linux__
+
+ #define BUF_LEN ((10 * (sizeof(struct inotify_event) + NAME_MAX + 1)))
+
+@@ -3020,7 +3020,7 @@ radv_notifier_thread_run(void *data)
+ static int
+ radv_device_init_notifier(struct radv_device *device)
+ {
+-#ifdef _WIN32
++#ifndef __linux__
+ return true;
+ #else
+ struct radv_notifier *notifier = &device->notifier;
+@@ -3053,7 +3053,7 @@ fail_watch:
+ static void
+ radv_device_finish_notifier(struct radv_device *device)
+ {
+-#ifndef _WIN32
++#ifdef __linux__
+ struct radv_notifier *notifier = &device->notifier;
+
+ if (!notifier->thread)