aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-02-06 02:05:51 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-02-06 02:26:08 +0000
commitda8ba36617a30b491c6497b46a97969c3f2c772d (patch)
treee0fbfb2c5c3ea111a268435fcea0beb7f8a83d8f /graphics
parent697a048b769c200c0c2652679a5153d05f3a2601 (diff)
downloadports-da8ba36617a30b491c6497b46a97969c3f2c772d.tar.gz
ports-da8ba36617a30b491c6497b46a97969c3f2c772d.zip
graphics/vulkan-loader: respect PREFIX more
$ VK_LOADER_DEBUG=layer vkcube-xcb [...] LAYER: /etc/xdg/vulkan/implicit_layer.d [...] (cherry picked from commit 8287c8a0c70e663b233f3c091504b542196c07f7)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/vulkan-loader/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/graphics/vulkan-loader/Makefile b/graphics/vulkan-loader/Makefile
index 080429ba5343..f6b9f23c9614 100644
--- a/graphics/vulkan-loader/Makefile
+++ b/graphics/vulkan-loader/Makefile
@@ -36,9 +36,12 @@ XLIB_CMAKE_BOOL= BUILD_WSI_XLIB_SUPPORT
post-patch:
# Extract (snapshot) version from the port
+# Respect PREFIX when XDG_CONFIG_DIRS and XDG_DATA_DIRS are unset
@${REINPLACE_CMD} -e '/find_.*Git/d' \
-e '/BRANCH/s/--unknown--/main/' \
-e '/TAG/s/--unknown--/${DISTVERSIONFULL}/' \
+ -e '/FALLBACK/s,/etc,${PREFIX}&,' \
+ -e 's,/usr/local,${PREFIX},' \
${WRKSRC}/CMakeLists.txt
# https://bugs.llvm.org/show_bug.cgi?id=47348
@if [ "${CHOSEN_COMPILER_TYPE}-${ARCH}-${_OSRELEASE:C/.*-//}" = "clang-i386-CURRENT" ]; then \