aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-09-07 17:14:41 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-09-07 17:14:41 +0000
commit12b47f0d2d09db18dd7fa7ff45f2679b71b81e1b (patch)
tree004baee0422dcc573a7c7193bcc78ec8d806ce38 /graphics
parentcb479c4102bb78a03118b85be1fdea06aec15e07 (diff)
downloadports-12b47f0d2d09db18dd7fa7ff45f2679b71b81e1b.tar.gz
ports-12b47f0d2d09db18dd7fa7ff45f2679b71b81e1b.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/freeimage/Makefile1
-rw-r--r--graphics/freeimage/files/patch-Source_FreeImage_PluginPSD.cpp7
2 files changed, 7 insertions, 1 deletions
diff --git a/graphics/freeimage/Makefile b/graphics/freeimage/Makefile
index 968b2a7b0b3e..3024d0d3dbb2 100644
--- a/graphics/freeimage/Makefile
+++ b/graphics/freeimage/Makefile
@@ -3,6 +3,7 @@
PORTNAME= freeimage
PORTVERSION= 3.18.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/Source%20Distribution/${PORTVERSION}
DISTNAME= FreeImage${PORTVERSION:S/.//g}
diff --git a/graphics/freeimage/files/patch-Source_FreeImage_PluginPSD.cpp b/graphics/freeimage/files/patch-Source_FreeImage_PluginPSD.cpp
index d4440b6d2cd4..306e8fce5cf0 100644
--- a/graphics/freeimage/files/patch-Source_FreeImage_PluginPSD.cpp
+++ b/graphics/freeimage/files/patch-Source_FreeImage_PluginPSD.cpp
@@ -1,3 +1,8 @@
+Source/FreeImage/PluginPSD.cpp:130:10: error: cannot initialize return object of type
+ 'BOOL' (aka 'int') with an rvalue of type 'nullptr_t'
+ return NULL;
+ ^~~~
+
--- Source/FreeImage/PluginPSD.cpp.orig 2018-09-04 20:32:27 UTC
+++ Source/FreeImage/PluginPSD.cpp
@@ -127,7 +127,7 @@ Load(FreeImageIO *io, fi_handle handle, int page, int
@@ -5,7 +10,7 @@
Save(FreeImageIO *io, FIBITMAP *dib, fi_handle handle, int page, int flags, void *data) {
if(!handle) {
- return NULL;
-+ //return NULL;
++ return FALSE;
}
try {
psdParser parser;