aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-09-30 02:04:37 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-09-30 02:04:37 +0000
commit2f6d6d9c2a1571d853b9e755b17188c04b8e949c (patch)
tree1764e0c07a39aac2ed927a19020c6cba1d18b65d /graphics
parentd162675dfd9c9300951312297701010d933e3881 (diff)
downloadports-2f6d6d9c2a1571d853b9e755b17188c04b8e949c.tar.gz
ports-2f6d6d9c2a1571d853b9e755b17188c04b8e949c.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/osg/Makefile2
-rw-r--r--graphics/osg/files/patch-shift-key-fix23
2 files changed, 24 insertions, 1 deletions
diff --git a/graphics/osg/Makefile b/graphics/osg/Makefile
index a39880415a7b..a94aa1ddda41 100644
--- a/graphics/osg/Makefile
+++ b/graphics/osg/Makefile
@@ -3,7 +3,7 @@
PORTNAME= osg
PORTVERSION= 3.2.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= http://trac.openscenegraph.org/downloads/developer_releases/ \
http://mirror.amdmi3.ru/distfiles/
diff --git a/graphics/osg/files/patch-shift-key-fix b/graphics/osg/files/patch-shift-key-fix
new file mode 100644
index 000000000000..87d9003ae693
--- /dev/null
+++ b/graphics/osg/files/patch-shift-key-fix
@@ -0,0 +1,23 @@
+# Shift key not released if group switch is something other than Control-Shift:
+# https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1218650.html
+
+--- src/osgGA/EventQueue.cpp.orig
++++ src/osgGA/EventQueue.cpp
+@@ -337,7 +337,7 @@ void EventQueue::mouseButtonRelease(floa
+
+ void EventQueue::keyPress(int key, double time, int unmodifiedKey)
+ {
+- switch(key)
++ switch(unmodifiedKey)
+ {
+ case(GUIEventAdapter::KEY_Shift_L): _accumulateEventState->setModKeyMask(GUIEventAdapter::MODKEY_LEFT_SHIFT | _accumulateEventState->getModKeyMask()); break;
+ case(GUIEventAdapter::KEY_Shift_R): _accumulateEventState->setModKeyMask(GUIEventAdapter::MODKEY_RIGHT_SHIFT | _accumulateEventState->getModKeyMask()); break;
+@@ -381,7 +381,7 @@ void EventQueue::keyPress(int key, doubl
+
+ void EventQueue::keyRelease(int key, double time, int unmodifiedKey)
+ {
+- switch(key)
++ switch(unmodifiedKey)
+ {
+ case(GUIEventAdapter::KEY_Shift_L): _accumulateEventState->setModKeyMask(~GUIEventAdapter::MODKEY_LEFT_SHIFT & _accumulateEventState->getModKeyMask()); break;
+ case(GUIEventAdapter::KEY_Shift_R): _accumulateEventState->setModKeyMask(~GUIEventAdapter::MODKEY_RIGHT_SHIFT & _accumulateEventState->getModKeyMask()); break;