aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-10-02 19:56:04 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-10-02 19:56:04 +0000
commit7773f2ccbef4985f2c64a445925fdba294bb308f (patch)
tree92dad6e28cb212fb9b30d59b4e3a08adb54b57f6 /graphics
parentcf5abe6907ed0bdf8734a3bef0b342fbf4542958 (diff)
downloadports-7773f2ccbef4985f2c64a445925fdba294bb308f.tar.gz
ports-7773f2ccbef4985f2c64a445925fdba294bb308f.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/osg-devel/Makefile11
-rw-r--r--graphics/osg-devel/distinfo4
-rw-r--r--graphics/osg-devel/files/patch-CMakeModules_FindFreeType.cmake44
-rw-r--r--graphics/osg-devel/files/patch-src-osgPlugins-freetype-FreeTypeFont.cpp14
-rw-r--r--graphics/osg-devel/pkg-plist24
5 files changed, 31 insertions, 66 deletions
diff --git a/graphics/osg-devel/Makefile b/graphics/osg-devel/Makefile
index 01d600e6cdd6..d9b590d295d9 100644
--- a/graphics/osg-devel/Makefile
+++ b/graphics/osg-devel/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= osg
-PORTVERSION= 3.3.0
-PORTREVISION= 3
+PORTVERSION= 3.3.2
CATEGORIES= graphics
MASTER_SITES= http://trac.openscenegraph.org/downloads/developer_releases/ \
http://mirror.amdmi3.ru/distfiles/
@@ -30,9 +29,9 @@ USE_XORG= x11
USE_LDCONFIG= yes
PLIST_SUB= OSG_VERSION=${PORTVERSION} \
- OSG_SHLIBVER=110 \
- OPENTHREADS_VERSION=${PORTVERSION} \
- OPENTHREADS_SHLIBVER=14
+ OSG_SHLIBVER=112 \
+ OPENTHREADS_VERSION=3.3.0 \
+ OPENTHREADS_SHLIBVER=20
PORTSCOUT= limitw:1,odd
@@ -73,7 +72,7 @@ XRANDR_CMAKE_OFF= -DOSGVIEWER_USE_XRANDR:BOOL=OFF
QT4_USE= QT4=corelib,gui,opengl,qmake_build,moc_build,uic_build,rcc_build
QT4_CMAKE_ON= -DOSG_USE_QT=ON
QT4_CMAKE_OFF= -DOSG_USE_QT=OFF
-LUA_USES= lua:51
+LUA_USES= lua:52
V8_LIB_DEPENDS= libv8.so:${PORTSDIR}/lang/v8
PYTHON_USE= PYTHON=2
diff --git a/graphics/osg-devel/distinfo b/graphics/osg-devel/distinfo
index 1495ca2315ca..58ccececb61c 100644
--- a/graphics/osg-devel/distinfo
+++ b/graphics/osg-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (OpenSceneGraph-3.3.0.zip) = 55224da955d58705d1cf9ec46a4129f29e8f37e69f4e9430c28f978594e1a5c6
-SIZE (OpenSceneGraph-3.3.0.zip) = 7627299
+SHA256 (OpenSceneGraph-3.3.2.zip) = 759676cdccd0b88e60dc1f86ee143c7598a817506fce9a6d8a388998f4230099
+SIZE (OpenSceneGraph-3.3.2.zip) = 8089660
diff --git a/graphics/osg-devel/files/patch-CMakeModules_FindFreeType.cmake b/graphics/osg-devel/files/patch-CMakeModules_FindFreeType.cmake
deleted file mode 100644
index 135d24e12ff3..000000000000
--- a/graphics/osg-devel/files/patch-CMakeModules_FindFreeType.cmake
+++ /dev/null
@@ -1,44 +0,0 @@
---- CMakeModules/FindFreeType.cmake.orig 2013-12-24 19:18:24.000000000 +0100
-+++ CMakeModules/FindFreeType.cmake 2013-12-24 19:19:27.000000000 +0100
-@@ -24,18 +24,18 @@
- # wants explicit full paths and this trickery doesn't work too well.
- # I'm going to attempt to cut out the middleman and hope
- # everything still works.
--FIND_PATH(FREETYPE_INCLUDE_DIR_ft2build ft2build.h
-+FIND_PATH(FREETYPE_INCLUDE_DIR_ft2build freetype2/ft2build.h
- PATHS
- $ENV{FREETYPE_DIR}
- NO_DEFAULT_PATH
- PATH_SUFFIXES include
- )
--FIND_PATH(FREETYPE_INCLUDE_DIR_ft2build ft2build.h
-+FIND_PATH(FREETYPE_INCLUDE_DIR_ft2build freetype2/ft2build.h
- PATHS ${CMAKE_PREFIX_PATH} # Unofficial: We are proposing this.
- NO_DEFAULT_PATH
- PATH_SUFFIXES include
- )
--FIND_PATH(FREETYPE_INCLUDE_DIR_ft2build ft2build.h
-+FIND_PATH(FREETYPE_INCLUDE_DIR_ft2build freetype2/ft2build.h
- PATHS
- /usr/local
- /usr
-@@ -51,16 +51,16 @@
- PATH_SUFFIXES include
- )
-
--FIND_PATH(FREETYPE_INCLUDE_DIR_freetype2 freetype/config/ftheader.h
-+FIND_PATH(FREETYPE_INCLUDE_DIR_freetype2 config/ftheader.h
- $ENV{FREETYPE_DIR}/include/freetype2
- NO_DEFAULT_PATH
- )
--FIND_PATH(FREETYPE_INCLUDE_DIR_freetype2 freetype/config/ftheader.h
-+FIND_PATH(FREETYPE_INCLUDE_DIR_freetype2 config/ftheader.h
- PATHS ${CMAKE_PREFIX_PATH} # Unofficial: We are proposing this.
- NO_DEFAULT_PATH
- PATH_SUFFIXES include/freetype2
- )
--FIND_PATH(FREETYPE_INCLUDE_DIR_freetype2 freetype/config/ftheader.h
-+FIND_PATH(FREETYPE_INCLUDE_DIR_freetype2 config/ftheader.h
- /usr/local/include/freetype2
- /usr/include/freetype2
- /usr/local/X11R6/include/freetype2
diff --git a/graphics/osg-devel/files/patch-src-osgPlugins-freetype-FreeTypeFont.cpp b/graphics/osg-devel/files/patch-src-osgPlugins-freetype-FreeTypeFont.cpp
deleted file mode 100644
index eaae7ca841dc..000000000000
--- a/graphics/osg-devel/files/patch-src-osgPlugins-freetype-FreeTypeFont.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/osgPlugins/freetype/FreeTypeFont.cpp.orig 2013-12-24 19:29:26.000000000 +0100
-+++ src/osgPlugins/freetype/FreeTypeFont.cpp 2013-12-24 19:30:24.000000000 +0100
-@@ -14,8 +14,9 @@
- #include "FreeTypeFont.h"
- #include "FreeTypeLibrary.h"
-
--#include <freetype/ftoutln.h>
--#include <freetype/ftbbox.h>
-+#include <ft2build.h>
-+#include FT_OUTLINE_H
-+#include FT_BBOX_H
-
- #include <osg/Notify>
- #include <osg/io_utils>
diff --git a/graphics/osg-devel/pkg-plist b/graphics/osg-devel/pkg-plist
index 8bc5aa218754..347b83a741d9 100644
--- a/graphics/osg-devel/pkg-plist
+++ b/graphics/osg-devel/pkg-plist
@@ -11,6 +11,26 @@ include/OpenThreads/Condition
include/OpenThreads/Config
include/OpenThreads/Exports
include/OpenThreads/Mutex
+include/osg/Callback
+include/osgGA/Event
+include/osgGA/EventHandler
+include/osgGA/Widget
+include/osgPresentation/PresentationInterface
+include/osgUI/AlignmentSettings
+include/osgUI/ColorPalette
+include/osgUI/ComboBox
+include/osgUI/Dialog
+include/osgUI/Export
+include/osgUI/FrameSettings
+include/osgUI/Label
+include/osgUI/LineEdit
+include/osgUI/Popup
+include/osgUI/PushButton
+include/osgUI/Style
+include/osgUI/TextSettings
+include/osgUI/Widget
+include/osgVolume/MultipassTechnique
+include/osgVolume/VolumeScene
include/OpenThreads/ReadWriteMutex
include/OpenThreads/ReentrantMutex
include/OpenThreads/ScopedLock
@@ -716,6 +736,7 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgshadow.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgsim.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgterrain.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgtext.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgui.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgviewer.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgvolume.so
%%SDL%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_sdl.so
@@ -735,6 +756,9 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_vtf.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_x.so
%%XINE%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_xine.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_zip.so
+lib/libosgUI.so
+lib/libosgUI.so.%%OSG_VERSION%%
+lib/libosgUI.so.%%OSG_SHLIBVER%%
libdata/pkgconfig/openscenegraph-osg.pc
libdata/pkgconfig/openscenegraph-osgAnimation.pc
libdata/pkgconfig/openscenegraph-osgDB.pc