aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2018-12-16 16:49:17 +0000
committerRene Ladan <rene@FreeBSD.org>2018-12-16 16:49:17 +0000
commit7cbe341ae63754f2ad63dd52f20d9d1b9b312aa5 (patch)
tree892baa84cc0c67b08795b6576e985d83e5a8f6d1 /graphics
parent278e6c95a6bbd77f475d8bd167ba51814bb09fc0 (diff)
downloadports-7cbe341ae63754f2ad63dd52f20d9d1b9b312aa5.tar.gz
ports-7cbe341ae63754f2ad63dd52f20d9d1b9b312aa5.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/fracplanet/Makefile5
-rw-r--r--graphics/photivo/Makefile5
2 files changed, 4 insertions, 6 deletions
diff --git a/graphics/fracplanet/Makefile b/graphics/fracplanet/Makefile
index 3ebfffdcf522..88b41b8b5bd7 100644
--- a/graphics/fracplanet/Makefile
+++ b/graphics/fracplanet/Makefile
@@ -22,14 +22,13 @@ FLAVORS= qt5 qt4
FLAVOR?= ${FLAVORS:[1]}
qt5_PKGNAMESUFFIX= -${FLAVOR}
-qt4_DEPRECATED= Qt4 has been EOL since december 2015
-qt4_EXPIRATION_DATE= 2019-03-15
-
USES= compiler:c++11-lang gl qmake:outsource
USE_GL= gl glu
QMAKE_ARGS= VERSION_NUMBER=${PORTVERSION}
.if ${FLAVOR} == qt4
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE=2019-03-15
USES+= qt:4
USE_QT= corelib gui moc_build opengl
.else
diff --git a/graphics/photivo/Makefile b/graphics/photivo/Makefile
index bce5c215fb78..44f4e50c6077 100644
--- a/graphics/photivo/Makefile
+++ b/graphics/photivo/Makefile
@@ -35,10 +35,9 @@ qt4_CONFLICTS_INSTALL= ${PORTNAME}
qt4_PKGNAMESUFFIX= -qt4
qt5_CONFLICTS_INSTALL= ${PORTNAME}-qt4
-qt4_DEPRECATED= Qt4 has been EOL since december 2015
-qt4_EXPIRATION_DATE= 2019-03-15
-
.if ${FLAVOR:U} == qt4
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE=2019-03-15
USES+= qt:4
USE_QT= qmake_build moc_build rcc_build uic_build corelib gui network
CMAKE_ON= FORCE_QT4