aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2010-10-05 19:57:56 +0000
committerAde Lovett <ade@FreeBSD.org>2010-10-05 19:57:56 +0000
commit7e80cde3289d108a73c54656f4fde354dd2fb09e (patch)
treeb85b705571d426ca1d0ff74b6af8f029081a6a39 /graphics
parent6abe3f75658b0457864b49c9fdaf298b79f2c447 (diff)
downloadports-7e80cde3289d108a73c54656f4fde354dd2fb09e.tar.gz
ports-7e80cde3289d108a73c54656f4fde354dd2fb09e.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/agg/Makefile2
-rw-r--r--graphics/cal3d-devel/Makefile2
-rw-r--r--graphics/cal3d/Makefile6
-rw-r--r--graphics/cal3d/files/patch-aclocal.m412
-rw-r--r--graphics/devil/Makefile2
-rw-r--r--graphics/divxcalc/Makefile2
-rw-r--r--graphics/enblend/Makefile2
-rw-r--r--graphics/gnash-devel/Makefile2
-rw-r--r--graphics/gsnapshot/Makefile2
-rw-r--r--graphics/guilib/Makefile2
-rw-r--r--graphics/iulib/Makefile2
-rw-r--r--graphics/kbarcode/Makefile2
-rw-r--r--graphics/leptonica/Makefile2
-rw-r--r--graphics/leptonlib/Makefile2
-rw-r--r--graphics/libjpeg-turbo/Makefile2
-rw-r--r--graphics/libpano12/Makefile4
-rw-r--r--graphics/libpano13/Makefile4
-rw-r--r--graphics/ocaml-images/Makefile2
-rw-r--r--graphics/ocropus/Makefile2
19 files changed, 36 insertions, 20 deletions
diff --git a/graphics/agg/Makefile b/graphics/agg/Makefile
index 57c9fe7b35af..ba2ab7cc0fcb 100644
--- a/graphics/agg/Makefile
+++ b/graphics/agg/Makefile
@@ -24,7 +24,7 @@ USE_GNOME= pkgconfig gnomehack
USE_GMAKE= yes
USE_LDCONFIG= yes
ACLOCAL_ARGS+= -I ${LOCALBASE}/share/aclocal
-USE_AUTOTOOLS= autoconf:267:env automake:19:env libtool:22:env
+USE_AUTOTOOLS= autoconf:267:env automake:111:env libtool:22:env
MAKE_ENV= C="${CC}" AGGCXXFLAGS="${CXXFLAGS}"
CXXFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib -I../include -L./
diff --git a/graphics/cal3d-devel/Makefile b/graphics/cal3d-devel/Makefile
index b13e156bd0c3..fcc3122d5b72 100644
--- a/graphics/cal3d-devel/Makefile
+++ b/graphics/cal3d-devel/Makefile
@@ -22,7 +22,7 @@ CONFLICTS= cal3d-[0-9]*
USE_BZIP2= yes
USE_GNOME= pkgconfig
USE_LDCONFIG= yes
-USE_AUTOTOOLS= automake:19 autoheader:267 libtool:22
+USE_AUTOTOOLS= automake:111 autoheader:267 libtool:22
AUTOMAKE_ARGS= --add-missing
MAN1= cal3d_converter.1
diff --git a/graphics/cal3d/Makefile b/graphics/cal3d/Makefile
index 04eb1e7757d5..572d2be2cd46 100644
--- a/graphics/cal3d/Makefile
+++ b/graphics/cal3d/Makefile
@@ -19,7 +19,7 @@ CONFLICTS= cal3d-devel-[0-9]*
USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= automake:19 autoheader:267 libtool:22
+USE_AUTOTOOLS= automake:111 autoheader:267 libtool:22
USE_LDCONFIG= yes
MAN1= cal3d_converter.1
@@ -34,4 +34,8 @@ post-patch:
${WRKSRC}/src/cal3d/streamsource.h
@${REINPLACE_CMD} -e '/^all_libraries/d' ${WRKSRC}/src/cal3d/Makefile.am
+post-configure:
+ @${FIND} ${WRKSRC} -name Makefile -print | \
+ ${XARGS} ${REINPLACE_CMD} -e 's|MKDIR_P|mkdir_p|g'
+
.include <bsd.port.mk>
diff --git a/graphics/cal3d/files/patch-aclocal.m4 b/graphics/cal3d/files/patch-aclocal.m4
new file mode 100644
index 000000000000..d3ff6efe4588
--- /dev/null
+++ b/graphics/cal3d/files/patch-aclocal.m4
@@ -0,0 +1,12 @@
+--- aclocal.m4.orig 2006-06-29 11:04:20.000000000 -0500
++++ aclocal.m4 2010-09-28 19:09:08.000000000 -0500
+@@ -6392,3 +6392,3 @@
+ # generated from the m4 files accompanying Automake X.Y.
+-AC_DEFUN([AM_AUTOMAKE_VERSION], [am__api_version="1.9"])
++AC_DEFUN([AM_AUTOMAKE_VERSION], [am__api_version="1.11"])
+
+@@ -6399,3 +6399,3 @@
+ AC_DEFUN([AM_SET_CURRENT_AUTOMAKE_VERSION],
+- [AM_AUTOMAKE_VERSION([1.9.6])])
++ [AM_AUTOMAKE_VERSION([1.11.1])])
+
diff --git a/graphics/devil/Makefile b/graphics/devil/Makefile
index 9e8b5bfbe079..01462148c053 100644
--- a/graphics/devil/Makefile
+++ b/graphics/devil/Makefile
@@ -30,7 +30,7 @@ OPTIONS= JPEG "Enable JPEG support" on \
WRKSRC= ${WRKDIR}/${DISTNAME:L}
USE_GNOME= pkgconfig
-USE_AUTOTOOLS= aclocal:110 autoheader:267 automake:110 autoconf:267 libtool:22
+USE_AUTOTOOLS= aclocal:111 autoheader:267 automake:111 autoconf:267 libtool:22
ACLOCAL_ARGS= -I m4 -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= --add-missing --copy --force-missing
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/graphics/divxcalc/Makefile b/graphics/divxcalc/Makefile
index 510bc200fddc..98da689a7192 100644
--- a/graphics/divxcalc/Makefile
+++ b/graphics/divxcalc/Makefile
@@ -19,7 +19,7 @@ USE_XORG= x11 ice xext
USE_BZIP2= yes
USE_QT_VER= 3
USE_GMAKE= yes
-USE_AUTOTOOLS= automake:19:env autoconf:267:env
+USE_AUTOTOOLS= automake:111:env autoconf:267:env
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/graphics/enblend/Makefile b/graphics/enblend/Makefile
index 5fe689c01e29..6c53d8cde9c9 100644
--- a/graphics/enblend/Makefile
+++ b/graphics/enblend/Makefile
@@ -25,7 +25,7 @@ RUN_DEPENDS= OpenEXR>=1.0:${PORTSDIR}/graphics/OpenEXR
USE_BZIP2= yes
-USE_AUTOTOOLS= automake:110:env autoconf:267:env
+USE_AUTOTOOLS= automake:111:env autoconf:267:env
# GCC 4.2 has some problems, see
# http://groups.google.com/group/hugin-ptx/browse_thread/thread/725b1581c9889e37/50abe3387d61541a#50abe3387d61541a
diff --git a/graphics/gnash-devel/Makefile b/graphics/gnash-devel/Makefile
index ecf45d6ae80e..1b7d4943513e 100644
--- a/graphics/gnash-devel/Makefile
+++ b/graphics/gnash-devel/Makefile
@@ -34,7 +34,7 @@ USE_GCC= 4.2+ # triggers compiler error on gcc 3.4
WANT_GSTREAMER= yes
USE_GNOME= pkgconfig libxml2
USE_XORG= x11 xau xdmcp xext xi xinerama ice sm
-USE_AUTOTOOLS= libltdl:22 libtool:22:env autoconf:267:env automake:110:env
+USE_AUTOTOOLS= libltdl:22 libtool:22:env autoconf:267:env automake:111:env
MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --with-boost-incl="${LOCALBASE}/include" \
diff --git a/graphics/gsnapshot/Makefile b/graphics/gsnapshot/Makefile
index 21a8a64ece7a..ce1f4ee4ad0f 100644
--- a/graphics/gsnapshot/Makefile
+++ b/graphics/gsnapshot/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= SF/gould/${PORTNAME}/release%20${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A gtk+ based screen capture
-USE_AUTOTOOLS= aclocal:110 autoheader:267 automake:110 autoconf:267 libtool:22
+USE_AUTOTOOLS= aclocal:111 autoheader:267 automake:111 autoconf:267 libtool:22
USE_GNOME= pkgconfig gtk20 libwnck libxml2
USE_XORG= x11 xmu
diff --git a/graphics/guilib/Makefile b/graphics/guilib/Makefile
index d9adf8ca1716..25f09974f167 100644
--- a/graphics/guilib/Makefile
+++ b/graphics/guilib/Makefile
@@ -19,7 +19,7 @@ USE_SDL= sdl
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_AUTOTOOLS= aclocal:19:env
+USE_AUTOTOOLS= aclocal:111:env
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
diff --git a/graphics/iulib/Makefile b/graphics/iulib/Makefile
index 2f2933237653..5dd5bc6fdf4d 100644
--- a/graphics/iulib/Makefile
+++ b/graphics/iulib/Makefile
@@ -24,7 +24,7 @@ OPTIONS= SDL "Enable SDL for graphical debugging" off \
MAKE_JOBS_SAFE= yes
USE_PYTHON_BUILD= yes
-USE_AUTOTOOLS= libtool:22 aclocal:110 automake:110 autoconf:267
+USE_AUTOTOOLS= libtool:22 aclocal:111 automake:111 autoconf:267
ACLOCAL_ARGS= --acdir=${ACLOCAL_DIR} -I${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= --add-missing
USE_LDCONFIG= yes
diff --git a/graphics/kbarcode/Makefile b/graphics/kbarcode/Makefile
index c3dcd2b125ad..d3460c1169e8 100644
--- a/graphics/kbarcode/Makefile
+++ b/graphics/kbarcode/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
USE_KDELIBS_VER= 3
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= automake:19:env autoconf:267:env libtool:22:env
+USE_AUTOTOOLS= automake:111:env autoconf:267:env libtool:22:env
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
diff --git a/graphics/leptonica/Makefile b/graphics/leptonica/Makefile
index 4d0ff39e81c1..2a27e50e600b 100644
--- a/graphics/leptonica/Makefile
+++ b/graphics/leptonica/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
PROJECTHOST= leptonica
MAKE_JOBS_SAFE= yes
-USE_AUTOTOOLS= libtool:22 aclocal:110 automake:110 autoconf:267
+USE_AUTOTOOLS= libtool:22 aclocal:111 automake:111 autoconf:267
ACLOCAL_ARGS= --acdir=${ACLOCAL_DIR} -I${LOCALBASE}/share/aclocal
USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
diff --git a/graphics/leptonlib/Makefile b/graphics/leptonlib/Makefile
index 4d0ff39e81c1..2a27e50e600b 100644
--- a/graphics/leptonlib/Makefile
+++ b/graphics/leptonlib/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
PROJECTHOST= leptonica
MAKE_JOBS_SAFE= yes
-USE_AUTOTOOLS= libtool:22 aclocal:110 automake:110 autoconf:267
+USE_AUTOTOOLS= libtool:22 aclocal:111 automake:111 autoconf:267
ACLOCAL_ARGS= --acdir=${ACLOCAL_DIR} -I${LOCALBASE}/share/aclocal
USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
diff --git a/graphics/libjpeg-turbo/Makefile b/graphics/libjpeg-turbo/Makefile
index faba9a0c1e2e..9c8ae4499ffc 100644
--- a/graphics/libjpeg-turbo/Makefile
+++ b/graphics/libjpeg-turbo/Makefile
@@ -21,7 +21,7 @@ BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
CONFLICTS= jpeg-[0-9]*
ONLY_FOR_ARCHS= amd64 i386
-USE_AUTOTOOLS= autoconf:267 autoheader:267 aclocal:110 automake:110 libtool:22
+USE_AUTOTOOLS= autoconf:267 autoheader:267 aclocal:111 automake:111 libtool:22
ACLOCAL_ARGS= -I.
USE_LDCONFIG= yes
diff --git a/graphics/libpano12/Makefile b/graphics/libpano12/Makefile
index d65603d6044b..7a7fc8877066 100644
--- a/graphics/libpano12/Makefile
+++ b/graphics/libpano12/Makefile
@@ -23,8 +23,8 @@ LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
USE_GNOME= gtk20 glib20 pango atk
-USE_AUTOTOOLS= autoconf:267:env autoheader:267:env aclocal:19:env \
- automake:19:env libtool:22:env
+USE_AUTOTOOLS= autoconf:267:env autoheader:267:env aclocal:111:env \
+ automake:111:env libtool:22:env
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/gtk-2.0 \
-I${LOCALBASE}/include/glib-2.0 \
diff --git a/graphics/libpano13/Makefile b/graphics/libpano13/Makefile
index 5e206facf8a6..a16e0b64c1e7 100644
--- a/graphics/libpano13/Makefile
+++ b/graphics/libpano13/Makefile
@@ -20,8 +20,8 @@ LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
USE_GNOME= gtk20 glib20 pango atk
-USE_AUTOTOOLS= autoconf:267:env autoheader:267:env aclocal:110:env \
- automake:110:env libtool:22:env
+USE_AUTOTOOLS= autoconf:267:env autoheader:267:env aclocal:111:env \
+ automake:111:env libtool:22:env
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/gtk-2.0 \
-I${LOCALBASE}/include/glib-2.0 \
diff --git a/graphics/ocaml-images/Makefile b/graphics/ocaml-images/Makefile
index 37ce71fd46e3..ba6794acae1b 100644
--- a/graphics/ocaml-images/Makefile
+++ b/graphics/ocaml-images/Makefile
@@ -22,7 +22,7 @@ COMMENT= Objective Caml image processing library
BUILD_DEPENDS= ${LOCALBASE}/share/aclocal/ocaml.m4:${PORTSDIR}/lang/ocaml-autoconf
-USE_AUTOTOOLS= aclocal:110 autoheader:267 automake:110 autoconf:267
+USE_AUTOTOOLS= aclocal:111 autoheader:267 automake:111 autoconf:267
ACLOCAL_ARGS= -I . -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= --add-missing
USE_OCAML= yes
diff --git a/graphics/ocropus/Makefile b/graphics/ocropus/Makefile
index 1f4c5585570a..f2782ef955c1 100644
--- a/graphics/ocropus/Makefile
+++ b/graphics/ocropus/Makefile
@@ -27,7 +27,7 @@ OPTIONS= SDL "Enable SDL for graphical debugging" off \
MAKE_JOBS_UNSAFE= yes
USE_PYTHON_BUILD= yes
-USE_AUTOTOOLS= aclocal:110 automake:110 autoconf:267
+USE_AUTOTOOLS= aclocal:111 automake:111 autoconf:267
USE_GMAKE= yes
CONFIGURE_ARGS= --without-fst --without-tesseract --with-iulib=${LOCALBASE}
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib