aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-01-20 16:30:09 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-01-20 16:30:09 +0000
commitb7eeb1b30d83e557cf2a24b7952efbea026c2779 (patch)
tree1b6cdba0063a7653636c9b822f9b7e586ca8a359 /graphics
parent77e590c67f5a83837d71c343ff30bbc332704534 (diff)
downloadports-b7eeb1b30d83e557cf2a24b7952efbea026c2779.tar.gz
ports-b7eeb1b30d83e557cf2a24b7952efbea026c2779.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ImageMagick/Makefile20
-rw-r--r--graphics/eps2png/Makefile8
-rw-r--r--graphics/epstool/Makefile8
-rw-r--r--graphics/ipe/Makefile10
-rw-r--r--graphics/ocaml-images/Makefile12
-rw-r--r--graphics/peps/Makefile9
-rw-r--r--graphics/pstoedit/Makefile8
-rw-r--r--graphics/pstoepsi/Makefile9
-rw-r--r--graphics/py-chart/Makefile8
-rw-r--r--graphics/sam2p/Makefile7
10 files changed, 16 insertions, 83 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 479e0c7e35f7..c7902f2ba36d 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -155,7 +155,7 @@ CONFIGURE_ARGS+= --without-lcms
.if !defined(WITHOUT_IMAGEMAGICK_TTF)
BUILD_DEPENDS+= freetype-config:${PORTSDIR}/print/freetype2 # XXX
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
-NEED_GS= yes
+USE_GHOSTSCRIPT= yes
.else
CONFIGURE_ARGS+= --without-ttf
.endif
@@ -188,7 +188,7 @@ CONFIGURE_ARGS+= --without-dps
# PDF (Adobe Portable Document Format) support
.if !defined(WITHOUT_IMAGEMAGICK_PDF)
CONFIGURE_ARGS+= --with-gslib
-NEED_GS= yes
+USE_GHOSTSCRIPT= yes
.else
CONFIGURE_ARGS+= --without-gslib
.endif
@@ -211,22 +211,6 @@ CONFIGURE_ARGS+= --without-mpeg2
.endif
.endif
-.if defined(NEED_GS)
-.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
-GSPORT?= print/ghostscript-afpl
-.else
-GSPORT?= print/ghostscript-gnu
-.endif
-
-.if defined(WITHOUT_X11)
-BUILD_DEPENDS+= gs:${PORTSDIR}/${GSPORT}-nox11
-RUN_DEPENDS+= gs:${PORTSDIR}/${GSPORT}-nox11
-.else
-BUILD_DEPENDS+= gs:${PORTSDIR}/${GSPORT}
-RUN_DEPENDS+= gs:${PORTSDIR}/${GSPORT}
-.endif
-.endif
-
.if defined(NOPORTDOCS)
INSTALL_TARGET= install
.else
diff --git a/graphics/eps2png/Makefile b/graphics/eps2png/Makefile
index b8fad6d096d1..93c3b968cc77 100644
--- a/graphics/eps2png/Makefile
+++ b/graphics/eps2png/Makefile
@@ -15,13 +15,7 @@ MASTER_SITE_SUBDIR= ../../authors/Johan_Vromans
MAINTAINER= nik@freebsd.org
COMMENT= Converts EPS images to PNG
-.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
-GSPORT?= print/ghostscript-afpl
-.else
-GSPORT?= print/ghostscript-gnu
-.endif
-
-RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT}
+USE_GHOSTSCRIPT_RUN= yes
PERL_CONFIGURE= yes
diff --git a/graphics/epstool/Makefile b/graphics/epstool/Makefile
index 9b5f72fcd42e..c966c17cdc02 100644
--- a/graphics/epstool/Makefile
+++ b/graphics/epstool/Makefile
@@ -13,13 +13,7 @@ MASTER_SITES= ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/ghostgum/
MAINTAINER= ports@FreeBSD.org
COMMENT= Create or extract preview bitmaps in EPS files
-.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
-GSPORT?= print/ghostscript-afpl
-.else
-GSPORT?= print/ghostscript-gnu
-.endif
-
-RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT}
+USE_GHOSTSCRIPT_RUN= yes
USE_REINPLACE= yes
USE_GMAKE= yes
diff --git a/graphics/ipe/Makefile b/graphics/ipe/Makefile
index 5643f98eaf21..2bc2ba50bc56 100644
--- a/graphics/ipe/Makefile
+++ b/graphics/ipe/Makefile
@@ -15,15 +15,9 @@ EXTRACT_SUFX= -src.tar.gz
MAINTAINER= bremner@unb.ca
COMMENT= Extensible drawing editor
-RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT} \
- latex:${PORTSDIR}/print/teTeX
-
-.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
-GSPORT?= print/ghostscript-afpl
-.else
-GSPORT?= print/ghostscript-gnu
-.endif
+USE_GHOSTSCRIPT_RUN= yes
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
WRKSRC= ${WRKDIR}/${DISTNAME}/src
USE_QT_VER= 3
MAKE_ENV+= QTDIR=${QTDIR}
diff --git a/graphics/ocaml-images/Makefile b/graphics/ocaml-images/Makefile
index 840e16de274c..0cb8a2e75710 100644
--- a/graphics/ocaml-images/Makefile
+++ b/graphics/ocaml-images/Makefile
@@ -18,18 +18,12 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Objective Caml image processing library
-.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
-GSPORT?= print/ghostscript-afpl
-.else
-GSPORT?= print/ghostscript-gnu
-.endif
+USE_GHOSTSCRIPT= yes
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
- lablgtk:${PORTSDIR}/x11-toolkits/ocaml-lablgtk \
- gs:${PORTSDIR}/${GSPORT}
+ lablgtk:${PORTSDIR}/x11-toolkits/ocaml-lablgtk
RUN_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
- lablgtk:${PORTSDIR}/x11-toolkits/ocaml-lablgtk \
- gs:${PORTSDIR}/${GSPORT}
+ lablgtk:${PORTSDIR}/x11-toolkits/ocaml-lablgtk
LIB_DEPENDS= ungif:${PORTSDIR}/graphics/libungif \
png:${PORTSDIR}/graphics/png \
jpeg:${PORTSDIR}/graphics/jpeg \
diff --git a/graphics/peps/Makefile b/graphics/peps/Makefile
index e944bdccd93b..8673245f49bd 100644
--- a/graphics/peps/Makefile
+++ b/graphics/peps/Makefile
@@ -15,14 +15,9 @@ MASTER_SITE_SUBDIR= petef
MAINTAINER= petef@FreeBSD.org
COMMENT= Converts EPS images to anti-aliased PGM bitmaps
-.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
-GSPORT?= print/ghostscript-afpl
-.else
-GSPORT?= print/ghostscript-gnu
-.endif
+USE_GHOSTSCRIPT_RUN= yes
-RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT} \
- pnmtopng:${PORTSDIR}/graphics/netpbm
+RUN_DEPENDS= pnmtopng:${PORTSDIR}/graphics/netpbm
USE_REINPLACE= yes
diff --git a/graphics/pstoedit/Makefile b/graphics/pstoedit/Makefile
index e55620250df4..5ba056e22e53 100644
--- a/graphics/pstoedit/Makefile
+++ b/graphics/pstoedit/Makefile
@@ -14,17 +14,11 @@ MASTER_SITES= http://home.t-online.de/home/helga.glunz/wglunz/pstoedit/
MAINTAINER= ports@FreeBSD.org
COMMENT= Convert PostScript to other vector graphic formats
-.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
-GSPORT?= print/ghostscript-afpl
-.else
-GSPORT?= print/ghostscript-gnu
-.endif
+USE_GHOSTSCRIPT= yes
-BUILD_DEPENDS= gs:${PORTSDIR}/${GSPORT}
LIB_DEPENDS= Magick++.6:${PORTSDIR}/graphics/ImageMagick \
ming.3:${PORTSDIR}/graphics/ming \
plotter.4:${PORTSDIR}/graphics/plotutils
-RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT}
USE_GNOME= gnometarget pkgconfig
USE_LIBTOOL= yes
diff --git a/graphics/pstoepsi/Makefile b/graphics/pstoepsi/Makefile
index f09367980c3c..058a4cba88a2 100644
--- a/graphics/pstoepsi/Makefile
+++ b/graphics/pstoepsi/Makefile
@@ -16,14 +16,9 @@ EXTRACT_ONLY= #empty
MAINTAINER= mita@FreeBSD.org
COMMENT= Wiliam Chia-Wei Cheng's yet another PS to EPSI converter
-.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
-GSPORT?= print/ghostscript-afpl
-.else
-GSPORT?= print/ghostscript-gnu
-.endif
+USE_GHOSTSCRIPT_RUN= yes
-RUN_DEPENDS= pbmtoepsi:${PORTSDIR}/graphics/netpbm \
- gs:${PORTSDIR}/${GSPORT}
+RUN_DEPENDS= pbmtoepsi:${PORTSDIR}/graphics/netpbm
NO_WRKSUBDIR= yes
diff --git a/graphics/py-chart/Makefile b/graphics/py-chart/Makefile
index a02ef19d0005..1f9448ef2cb1 100644
--- a/graphics/py-chart/Makefile
+++ b/graphics/py-chart/Makefile
@@ -16,13 +16,7 @@ DISTNAME= PyChart-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Create high quality Encapsulated Postscript, PDF, or PNG charts
-.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
-GSPORT?= print/ghostscript-afpl
-.else
-GSPORT?= print/ghostscript-gnu
-.endif
-
-RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT}
+USE_GHOSTSCRIPT_RUN= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
diff --git a/graphics/sam2p/Makefile b/graphics/sam2p/Makefile
index 875108888e4c..819f235d2a74 100644
--- a/graphics/sam2p/Makefile
+++ b/graphics/sam2p/Makefile
@@ -15,15 +15,10 @@ MASTER_SITES= http://www.inf.bme.hu/~pts/
MAINTAINER= ports@FreeBSD.org
COMMENT= Converts raster (bitmap) image formats into PS or PDF files
-.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
-GSPORT?= print/ghostscript-afpl
-.else
-GSPORT?= print/ghostscript-gnu
-.endif
+USE_GHOSTSCRIPT_RUN= yes
BUILD_DEPENDS= tif22pnm:${PORTSDIR}/graphics/tif22pnm \
tifftopnm:${PORTSDIR}/graphics/netpbm \
- gs:${PORTSDIR}/${GSPORT} \
zip:${PORTSDIR}/archivers/zip \
bash:${PORTSDIR}/shells/bash2
LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg