aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-12 19:24:03 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-12 19:24:03 +0000
commitcad64609b277e9ccbcfcf5b89c0a8a4be82089b9 (patch)
tree0c668450e3aca1a8cda385b3eacf2b368732e615 /graphics
parentadbd24370fb330ed3cd7d3e052e8a1fd80992809 (diff)
downloadports-cad64609b277e9ccbcfcf5b89c0a8a4be82089b9.tar.gz
ports-cad64609b277e9ccbcfcf5b89c0a8a4be82089b9.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/py-graph-core/Makefile4
-rw-r--r--graphics/py-graph-core/distinfo6
-rw-r--r--graphics/py-graph-core/files/patch-setup.py22
-rw-r--r--graphics/py-graph-core/pkg-plist91
-rw-r--r--graphics/py-graph-dot/Makefile4
-rw-r--r--graphics/py-graph-dot/distinfo6
-rw-r--r--graphics/py-graph-dot/files/patch-setup.py22
-rw-r--r--graphics/py-graph-dot/pkg-plist91
-rw-r--r--graphics/py-graph/Makefile4
-rw-r--r--graphics/py-graph/distinfo6
-rw-r--r--graphics/py-graph/files/patch-setup.py22
-rw-r--r--graphics/py-graph/pkg-plist91
12 files changed, 183 insertions, 186 deletions
diff --git a/graphics/py-graph-core/Makefile b/graphics/py-graph-core/Makefile
index b7c4021af06d..d0b7373d166c 100644
--- a/graphics/py-graph-core/Makefile
+++ b/graphics/py-graph-core/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= graph
-PORTVERSION= 1.3.1
+PORTVERSION= 1.4.2
CATEGORIES= graphics python
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -20,7 +20,7 @@ RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
PROJECTHOST= python-graph
USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USE_PYDISTUTILS= easy_install
PYDISTUTILS_PKGNAME= python-graph
WRKSRC= ${WRKDIR}/${PYDISTUTILS_PKGNAME}
diff --git a/graphics/py-graph-core/distinfo b/graphics/py-graph-core/distinfo
index 368263f12eb4..81185dd5b242 100644
--- a/graphics/py-graph-core/distinfo
+++ b/graphics/py-graph-core/distinfo
@@ -1,3 +1,3 @@
-MD5 (python-graph-1.3.1.tar.bz2) = 6f679f7cbe5104188faae360371f744f
-SHA256 (python-graph-1.3.1.tar.bz2) = 969f0cba956321576586d74375cad5af38d2bf23acd5d8b5628252e44c316df8
-SIZE (python-graph-1.3.1.tar.bz2) = 45372
+MD5 (python-graph-1.4.2.tar.bz2) = 142807b1d3865c915bee8b5346790e7b
+SHA256 (python-graph-1.4.2.tar.bz2) = 91225ee818272debc17af7df4b0f4acb638fc772b796397689464a26c8bf0ee6
+SIZE (python-graph-1.4.2.tar.bz2) = 49957
diff --git a/graphics/py-graph-core/files/patch-setup.py b/graphics/py-graph-core/files/patch-setup.py
index f537e9b349f5..c6d20f03fc30 100644
--- a/graphics/py-graph-core/files/patch-setup.py
+++ b/graphics/py-graph-core/files/patch-setup.py
@@ -1,15 +1,13 @@
---- setup.py.orig 2008-10-28 21:22:57.000000000 +0800
-+++ setup.py 2008-10-28 21:23:17.000000000 +0800
-@@ -18,9 +18,9 @@
+--- setup.py.orig 2009-02-23 22:14:56.000000000 +0800
++++ setup.py 2009-02-23 22:14:38.000000000 +0800
+@@ -37,8 +37,8 @@
name = appname,
version = appversion,
- packages = ['graph'],
-- data_files = [(docfolder, ['README','Changelog','COPYING']),
-- (docfolder + docs, docfiles),
-- ],
-+# data_files = [(docfolder, ['README','Changelog','COPYING']),
-+# (docfolder + docs, docfiles),
-+# ],
-
- # metadata
+ packages = ['graph', 'graph.algorithms', 'graph.algorithms.filters', 'graph.algorithms.heuristics', 'graph.classes'],
+- data_files = [(docsdir,docsfiles),
+- (datadir,datafiles)],
++# data_files = [(docsdir,docsfiles),
++# (datadir,datafiles)],
author = "Pedro Matiello",
+ author_email = "pmatiello@gmail.com",
+ description = "A library for working with graphs in Python",
diff --git a/graphics/py-graph-core/pkg-plist b/graphics/py-graph-core/pkg-plist
index 2c4202db59db..fb780887ac1a 100644
--- a/graphics/py-graph-core/pkg-plist
+++ b/graphics/py-graph-core/pkg-plist
@@ -1,59 +1,60 @@
-%%PYTHON_SITELIBDIR%%/graph/__init__.py
-%%PYTHON_SITELIBDIR%%/graph/__init__.pyc
-%%PYTHON_SITELIBDIR%%/graph/__init__.pyo
-%%PYTHON_SITELIBDIR%%/graph/accessibility.py
-%%PYTHON_SITELIBDIR%%/graph/accessibility.pyc
-%%PYTHON_SITELIBDIR%%/graph/accessibility.pyo
-%%PYTHON_SITELIBDIR%%/graph/generators.py
-%%PYTHON_SITELIBDIR%%/graph/generators.pyc
-%%PYTHON_SITELIBDIR%%/graph/generators.pyo
-%%PYTHON_SITELIBDIR%%/graph/minmax.py
-%%PYTHON_SITELIBDIR%%/graph/minmax.pyc
-%%PYTHON_SITELIBDIR%%/graph/minmax.pyo
-%%PYTHON_SITELIBDIR%%/graph/readwrite.py
-%%PYTHON_SITELIBDIR%%/graph/readwrite.pyc
-%%PYTHON_SITELIBDIR%%/graph/readwrite.pyo
-%%PYTHON_SITELIBDIR%%/graph/searching.py
-%%PYTHON_SITELIBDIR%%/graph/searching.pyc
-%%PYTHON_SITELIBDIR%%/graph/searching.pyo
-%%PYTHON_SITELIBDIR%%/graph/sorting.py
-%%PYTHON_SITELIBDIR%%/graph/sorting.pyc
-%%PYTHON_SITELIBDIR%%/graph/sorting.pyo
-%%PYTHON_SITELIBDIR%%/graph/traversal.py
-%%PYTHON_SITELIBDIR%%/graph/traversal.pyc
-%%PYTHON_SITELIBDIR%%/graph/traversal.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
@dirrm %%PYTHON_SITELIBDIR%%/graph
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/Changelog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/draw.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/drawhyper.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ex1.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.tls
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graph.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lts2graph.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/read.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/write.py
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/Changelog
+%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/api-objects.txt
%%PORTDOCS%%%%DOCSDIR%%/class-tree.html
%%PORTDOCS%%%%DOCSDIR%%/crarr.png
%%PORTDOCS%%%%DOCSDIR%%/epydoc.css
%%PORTDOCS%%%%DOCSDIR%%/epydoc.js
%%PORTDOCS%%%%DOCSDIR%%/graph-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.accessibility-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.digraph-class.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.generators-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.graph-class.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.hypergraph-class.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.minmax-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.readwrite-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.searching-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.sorting-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.traversal-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.accessibility-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.cycles-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.exceptions-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.exceptions.python_graph_exception-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.exceptions.unreachable-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Find-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Find.find-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Null-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Null.null-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Radius-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Radius.radius-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.generators-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.heuristics-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.heuristics.Chow-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.heuristics.Chow.chow-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.heuristics.Euclidean-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.heuristics.Euclidean.euclidean-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.minmax-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.readwrite-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.searching-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.sorting-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.traversal-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.utils-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.utils.HeapItem-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.utils.priority_queue-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.classes-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Digraph-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Digraph.digraph-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Graph-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Graph.graph-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Hypergraph-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Hypergraph.hypergraph-class.html
%%PORTDOCS%%%%DOCSDIR%%/help.html
%%PORTDOCS%%%%DOCSDIR%%/identifier-index.html
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/module-tree.html
%%PORTDOCS%%%%DOCSDIR%%/redirect.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/draw.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/drawhyper.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ex1.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.tls
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graph.xml
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lts2graph.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/read.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/write.py
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
diff --git a/graphics/py-graph-dot/Makefile b/graphics/py-graph-dot/Makefile
index b7c4021af06d..d0b7373d166c 100644
--- a/graphics/py-graph-dot/Makefile
+++ b/graphics/py-graph-dot/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= graph
-PORTVERSION= 1.3.1
+PORTVERSION= 1.4.2
CATEGORIES= graphics python
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -20,7 +20,7 @@ RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
PROJECTHOST= python-graph
USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USE_PYDISTUTILS= easy_install
PYDISTUTILS_PKGNAME= python-graph
WRKSRC= ${WRKDIR}/${PYDISTUTILS_PKGNAME}
diff --git a/graphics/py-graph-dot/distinfo b/graphics/py-graph-dot/distinfo
index 368263f12eb4..81185dd5b242 100644
--- a/graphics/py-graph-dot/distinfo
+++ b/graphics/py-graph-dot/distinfo
@@ -1,3 +1,3 @@
-MD5 (python-graph-1.3.1.tar.bz2) = 6f679f7cbe5104188faae360371f744f
-SHA256 (python-graph-1.3.1.tar.bz2) = 969f0cba956321576586d74375cad5af38d2bf23acd5d8b5628252e44c316df8
-SIZE (python-graph-1.3.1.tar.bz2) = 45372
+MD5 (python-graph-1.4.2.tar.bz2) = 142807b1d3865c915bee8b5346790e7b
+SHA256 (python-graph-1.4.2.tar.bz2) = 91225ee818272debc17af7df4b0f4acb638fc772b796397689464a26c8bf0ee6
+SIZE (python-graph-1.4.2.tar.bz2) = 49957
diff --git a/graphics/py-graph-dot/files/patch-setup.py b/graphics/py-graph-dot/files/patch-setup.py
index f537e9b349f5..c6d20f03fc30 100644
--- a/graphics/py-graph-dot/files/patch-setup.py
+++ b/graphics/py-graph-dot/files/patch-setup.py
@@ -1,15 +1,13 @@
---- setup.py.orig 2008-10-28 21:22:57.000000000 +0800
-+++ setup.py 2008-10-28 21:23:17.000000000 +0800
-@@ -18,9 +18,9 @@
+--- setup.py.orig 2009-02-23 22:14:56.000000000 +0800
++++ setup.py 2009-02-23 22:14:38.000000000 +0800
+@@ -37,8 +37,8 @@
name = appname,
version = appversion,
- packages = ['graph'],
-- data_files = [(docfolder, ['README','Changelog','COPYING']),
-- (docfolder + docs, docfiles),
-- ],
-+# data_files = [(docfolder, ['README','Changelog','COPYING']),
-+# (docfolder + docs, docfiles),
-+# ],
-
- # metadata
+ packages = ['graph', 'graph.algorithms', 'graph.algorithms.filters', 'graph.algorithms.heuristics', 'graph.classes'],
+- data_files = [(docsdir,docsfiles),
+- (datadir,datafiles)],
++# data_files = [(docsdir,docsfiles),
++# (datadir,datafiles)],
author = "Pedro Matiello",
+ author_email = "pmatiello@gmail.com",
+ description = "A library for working with graphs in Python",
diff --git a/graphics/py-graph-dot/pkg-plist b/graphics/py-graph-dot/pkg-plist
index 2c4202db59db..fb780887ac1a 100644
--- a/graphics/py-graph-dot/pkg-plist
+++ b/graphics/py-graph-dot/pkg-plist
@@ -1,59 +1,60 @@
-%%PYTHON_SITELIBDIR%%/graph/__init__.py
-%%PYTHON_SITELIBDIR%%/graph/__init__.pyc
-%%PYTHON_SITELIBDIR%%/graph/__init__.pyo
-%%PYTHON_SITELIBDIR%%/graph/accessibility.py
-%%PYTHON_SITELIBDIR%%/graph/accessibility.pyc
-%%PYTHON_SITELIBDIR%%/graph/accessibility.pyo
-%%PYTHON_SITELIBDIR%%/graph/generators.py
-%%PYTHON_SITELIBDIR%%/graph/generators.pyc
-%%PYTHON_SITELIBDIR%%/graph/generators.pyo
-%%PYTHON_SITELIBDIR%%/graph/minmax.py
-%%PYTHON_SITELIBDIR%%/graph/minmax.pyc
-%%PYTHON_SITELIBDIR%%/graph/minmax.pyo
-%%PYTHON_SITELIBDIR%%/graph/readwrite.py
-%%PYTHON_SITELIBDIR%%/graph/readwrite.pyc
-%%PYTHON_SITELIBDIR%%/graph/readwrite.pyo
-%%PYTHON_SITELIBDIR%%/graph/searching.py
-%%PYTHON_SITELIBDIR%%/graph/searching.pyc
-%%PYTHON_SITELIBDIR%%/graph/searching.pyo
-%%PYTHON_SITELIBDIR%%/graph/sorting.py
-%%PYTHON_SITELIBDIR%%/graph/sorting.pyc
-%%PYTHON_SITELIBDIR%%/graph/sorting.pyo
-%%PYTHON_SITELIBDIR%%/graph/traversal.py
-%%PYTHON_SITELIBDIR%%/graph/traversal.pyc
-%%PYTHON_SITELIBDIR%%/graph/traversal.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
@dirrm %%PYTHON_SITELIBDIR%%/graph
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/Changelog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/draw.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/drawhyper.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ex1.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.tls
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graph.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lts2graph.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/read.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/write.py
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/Changelog
+%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/api-objects.txt
%%PORTDOCS%%%%DOCSDIR%%/class-tree.html
%%PORTDOCS%%%%DOCSDIR%%/crarr.png
%%PORTDOCS%%%%DOCSDIR%%/epydoc.css
%%PORTDOCS%%%%DOCSDIR%%/epydoc.js
%%PORTDOCS%%%%DOCSDIR%%/graph-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.accessibility-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.digraph-class.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.generators-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.graph-class.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.hypergraph-class.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.minmax-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.readwrite-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.searching-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.sorting-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.traversal-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.accessibility-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.cycles-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.exceptions-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.exceptions.python_graph_exception-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.exceptions.unreachable-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Find-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Find.find-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Null-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Null.null-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Radius-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Radius.radius-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.generators-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.heuristics-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.heuristics.Chow-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.heuristics.Chow.chow-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.heuristics.Euclidean-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.heuristics.Euclidean.euclidean-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.minmax-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.readwrite-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.searching-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.sorting-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.traversal-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.utils-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.utils.HeapItem-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.utils.priority_queue-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.classes-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Digraph-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Digraph.digraph-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Graph-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Graph.graph-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Hypergraph-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Hypergraph.hypergraph-class.html
%%PORTDOCS%%%%DOCSDIR%%/help.html
%%PORTDOCS%%%%DOCSDIR%%/identifier-index.html
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/module-tree.html
%%PORTDOCS%%%%DOCSDIR%%/redirect.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/draw.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/drawhyper.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ex1.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.tls
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graph.xml
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lts2graph.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/read.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/write.py
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
diff --git a/graphics/py-graph/Makefile b/graphics/py-graph/Makefile
index b7c4021af06d..d0b7373d166c 100644
--- a/graphics/py-graph/Makefile
+++ b/graphics/py-graph/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= graph
-PORTVERSION= 1.3.1
+PORTVERSION= 1.4.2
CATEGORIES= graphics python
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -20,7 +20,7 @@ RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
PROJECTHOST= python-graph
USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USE_PYDISTUTILS= easy_install
PYDISTUTILS_PKGNAME= python-graph
WRKSRC= ${WRKDIR}/${PYDISTUTILS_PKGNAME}
diff --git a/graphics/py-graph/distinfo b/graphics/py-graph/distinfo
index 368263f12eb4..81185dd5b242 100644
--- a/graphics/py-graph/distinfo
+++ b/graphics/py-graph/distinfo
@@ -1,3 +1,3 @@
-MD5 (python-graph-1.3.1.tar.bz2) = 6f679f7cbe5104188faae360371f744f
-SHA256 (python-graph-1.3.1.tar.bz2) = 969f0cba956321576586d74375cad5af38d2bf23acd5d8b5628252e44c316df8
-SIZE (python-graph-1.3.1.tar.bz2) = 45372
+MD5 (python-graph-1.4.2.tar.bz2) = 142807b1d3865c915bee8b5346790e7b
+SHA256 (python-graph-1.4.2.tar.bz2) = 91225ee818272debc17af7df4b0f4acb638fc772b796397689464a26c8bf0ee6
+SIZE (python-graph-1.4.2.tar.bz2) = 49957
diff --git a/graphics/py-graph/files/patch-setup.py b/graphics/py-graph/files/patch-setup.py
index f537e9b349f5..c6d20f03fc30 100644
--- a/graphics/py-graph/files/patch-setup.py
+++ b/graphics/py-graph/files/patch-setup.py
@@ -1,15 +1,13 @@
---- setup.py.orig 2008-10-28 21:22:57.000000000 +0800
-+++ setup.py 2008-10-28 21:23:17.000000000 +0800
-@@ -18,9 +18,9 @@
+--- setup.py.orig 2009-02-23 22:14:56.000000000 +0800
++++ setup.py 2009-02-23 22:14:38.000000000 +0800
+@@ -37,8 +37,8 @@
name = appname,
version = appversion,
- packages = ['graph'],
-- data_files = [(docfolder, ['README','Changelog','COPYING']),
-- (docfolder + docs, docfiles),
-- ],
-+# data_files = [(docfolder, ['README','Changelog','COPYING']),
-+# (docfolder + docs, docfiles),
-+# ],
-
- # metadata
+ packages = ['graph', 'graph.algorithms', 'graph.algorithms.filters', 'graph.algorithms.heuristics', 'graph.classes'],
+- data_files = [(docsdir,docsfiles),
+- (datadir,datafiles)],
++# data_files = [(docsdir,docsfiles),
++# (datadir,datafiles)],
author = "Pedro Matiello",
+ author_email = "pmatiello@gmail.com",
+ description = "A library for working with graphs in Python",
diff --git a/graphics/py-graph/pkg-plist b/graphics/py-graph/pkg-plist
index 2c4202db59db..fb780887ac1a 100644
--- a/graphics/py-graph/pkg-plist
+++ b/graphics/py-graph/pkg-plist
@@ -1,59 +1,60 @@
-%%PYTHON_SITELIBDIR%%/graph/__init__.py
-%%PYTHON_SITELIBDIR%%/graph/__init__.pyc
-%%PYTHON_SITELIBDIR%%/graph/__init__.pyo
-%%PYTHON_SITELIBDIR%%/graph/accessibility.py
-%%PYTHON_SITELIBDIR%%/graph/accessibility.pyc
-%%PYTHON_SITELIBDIR%%/graph/accessibility.pyo
-%%PYTHON_SITELIBDIR%%/graph/generators.py
-%%PYTHON_SITELIBDIR%%/graph/generators.pyc
-%%PYTHON_SITELIBDIR%%/graph/generators.pyo
-%%PYTHON_SITELIBDIR%%/graph/minmax.py
-%%PYTHON_SITELIBDIR%%/graph/minmax.pyc
-%%PYTHON_SITELIBDIR%%/graph/minmax.pyo
-%%PYTHON_SITELIBDIR%%/graph/readwrite.py
-%%PYTHON_SITELIBDIR%%/graph/readwrite.pyc
-%%PYTHON_SITELIBDIR%%/graph/readwrite.pyo
-%%PYTHON_SITELIBDIR%%/graph/searching.py
-%%PYTHON_SITELIBDIR%%/graph/searching.pyc
-%%PYTHON_SITELIBDIR%%/graph/searching.pyo
-%%PYTHON_SITELIBDIR%%/graph/sorting.py
-%%PYTHON_SITELIBDIR%%/graph/sorting.pyc
-%%PYTHON_SITELIBDIR%%/graph/sorting.pyo
-%%PYTHON_SITELIBDIR%%/graph/traversal.py
-%%PYTHON_SITELIBDIR%%/graph/traversal.pyc
-%%PYTHON_SITELIBDIR%%/graph/traversal.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
@dirrm %%PYTHON_SITELIBDIR%%/graph
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/Changelog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/draw.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/drawhyper.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ex1.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.tls
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graph.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lts2graph.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/read.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/write.py
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/Changelog
+%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/api-objects.txt
%%PORTDOCS%%%%DOCSDIR%%/class-tree.html
%%PORTDOCS%%%%DOCSDIR%%/crarr.png
%%PORTDOCS%%%%DOCSDIR%%/epydoc.css
%%PORTDOCS%%%%DOCSDIR%%/epydoc.js
%%PORTDOCS%%%%DOCSDIR%%/graph-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.accessibility-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.digraph-class.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.generators-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.graph-class.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.hypergraph-class.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.minmax-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.readwrite-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.searching-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.sorting-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.traversal-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.accessibility-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.cycles-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.exceptions-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.exceptions.python_graph_exception-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.exceptions.unreachable-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Find-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Find.find-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Null-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Null.null-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Radius-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Radius.radius-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.generators-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.heuristics-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.heuristics.Chow-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.heuristics.Chow.chow-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.heuristics.Euclidean-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.heuristics.Euclidean.euclidean-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.minmax-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.readwrite-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.searching-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.sorting-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.traversal-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.utils-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.utils.HeapItem-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.utils.priority_queue-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.classes-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Digraph-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Digraph.digraph-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Graph-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Graph.graph-class.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Hypergraph-module.html
+%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Hypergraph.hypergraph-class.html
%%PORTDOCS%%%%DOCSDIR%%/help.html
%%PORTDOCS%%%%DOCSDIR%%/identifier-index.html
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/module-tree.html
%%PORTDOCS%%%%DOCSDIR%%/redirect.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/draw.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/drawhyper.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ex1.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.tls
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graph.xml
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lts2graph.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/read.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/write.py
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%