aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2009-03-16 21:01:00 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2009-03-16 21:01:00 +0000
commitddbfe7933c1fc8e654735968d98c6276a22b0b87 (patch)
treef153362e23ab4f8bb7228a2fb2e1969a8e90c83d /graphics
parentabc1288808a2c83ce85490714ebeacea3c89cbfe (diff)
downloadports-ddbfe7933c1fc8e654735968d98c6276a22b0b87.tar.gz
ports-ddbfe7933c1fc8e654735968d98c6276a22b0b87.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/feh/Makefile2
-rw-r--r--graphics/feh/files/patch-src-winwidget.c33
2 files changed, 34 insertions, 1 deletions
diff --git a/graphics/feh/Makefile b/graphics/feh/Makefile
index 3e435eaa3c3b..b2d1d33053df 100644
--- a/graphics/feh/Makefile
+++ b/graphics/feh/Makefile
@@ -7,7 +7,7 @@
PORTNAME= feh
PORTVERSION= 1.3.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= http://linuxbrit.co.uk/downloads/
diff --git a/graphics/feh/files/patch-src-winwidget.c b/graphics/feh/files/patch-src-winwidget.c
new file mode 100644
index 000000000000..cbc57f07ee12
--- /dev/null
+++ b/graphics/feh/files/patch-src-winwidget.c
@@ -0,0 +1,33 @@
+--- src/winwidget.c.orig 2005-07-14 13:59:03.000000000 +0200
++++ src/winwidget.c 2009-03-11 21:46:33.000000000 +0100
+@@ -158,6 +158,7 @@
+ int h)
+ {
+ XSetWindowAttributes attr;
++ XEvent ev;
+ XClassHint *xch;
+ MWMHints mwmhints;
+ Atom prop = None;
+@@ -256,6 +257,22 @@
+ XChangeProperty(disp, ret->win, prop, prop, 32, PropModeReplace,
+ (unsigned char *) &mwmhints, PROP_MWM_HINTS_ELEMENTS);
+ }
++ if (ret->full_screen) {
++ Atom prop_fs = XInternAtom(disp, "_NET_WM_STATE_FULLSCREEN", False);
++ Atom prop_state = XInternAtom(disp, "_NET_WM_STATE", False);
++
++ memset(&ev, 0, sizeof(ev));
++ ev.xclient.type = ClientMessage;
++ ev.xclient.message_type = prop_state;
++ ev.xclient.display = disp;
++ ev.xclient.window = ret->win;
++ ev.xclient.format = 32;
++ ev.xclient.data.l[0] = (ret->full_screen ? 1 : 0);
++ ev.xclient.data.l[1] = prop_fs;
++
++ XChangeProperty(disp, ret->win, prop_state, XA_ATOM, 32,
++ PropModeReplace, &prop_fs, 1);
++ }
+
+ XSetWMProtocols(disp, ret->win, &wmDeleteWindow, 1);
+ winwidget_update_title(ret);