aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorBrian Somers <brian@FreeBSD.org>2001-04-04 10:36:00 +0000
committerBrian Somers <brian@FreeBSD.org>2001-04-04 10:36:00 +0000
commite766ee395d9413c8822e6afb4fdc40e80239819a (patch)
treeca34a086852e61d15801a5387479072526bff125 /graphics
parent4ee38fcfd889a32944d3b977e423e1b60ce95eda (diff)
downloadports-e766ee395d9413c8822e6afb4fdc40e80239819a.tar.gz
ports-e766ee395d9413c8822e6afb4fdc40e80239819a.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/xsane/Makefile37
-rw-r--r--graphics/xsane/distinfo2
-rw-r--r--graphics/xsane/files/patch-ad11
-rw-r--r--graphics/xsane/pkg-descr2
-rw-r--r--graphics/xsane/pkg-message8
-rw-r--r--graphics/xsane/pkg-plist88
6 files changed, 81 insertions, 67 deletions
diff --git a/graphics/xsane/Makefile b/graphics/xsane/Makefile
index 7118098e09dc..5c858e8f0702 100644
--- a/graphics/xsane/Makefile
+++ b/graphics/xsane/Makefile
@@ -6,31 +6,48 @@
#
PORTNAME= xsane
-PORTVERSION= 0.70
+PORTVERSION= 0.73
CATEGORIES= graphics
-MASTER_SITES= http://www.wolfsburg.de/~rauch/sane/ \
+MASTER_SITES= http://www.xsane.org/download/ \
http://gd.tuwien.ac.at/hci/sane/xsane/ \
- ftp://ftp.mostang.com/pub/sane/xsane/ \
+ ftp://ftp.mostang.com/pub/sane/xsane/
MAINTAINER= domi@saargate.de
-LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext \
- sane.1:${PORTSDIR}/graphics/sane-backends \
- jpeg.9:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.4:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
- png.4:${PORTSDIR}/graphics/png
+ sane.1:${PORTSDIR}/graphics/sane-backends
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GTK= yes
-USE_AUTOCONF= yes
-CONFIGURE_ARGS= --enable-intl-patch
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl"
MAN1= xsane.1
+.if defined(WITH_GIMP)
+LIB_DEPENDS+= gimp:${PORTSDIR}/graphics/gimp1
+CONFIGURE_ARGS+= --enable-gimp
+.else
+CONFIGURE_ARGS+= --disable-gimp
+.endif
+
+pre-everything:
+.if !defined(WITH_GIMP)
+ @${ECHO_MSG} "*** Note: XSane can be built with a standalone"
+ @${ECHO_MSG} "*** X scanner interface as well as a GIMP plug-in."
+ @${ECHO_MSG} "*** If you wish to do this, hit Ctrl-C now and use"
+ @${ECHO_MSG} "*** \"WITH_GIMP=yes\""
+.endif
+
+pre-patch:
+ @find ${WRKSRC} -name 'Makefile.in' | xargs ${PERL} -pi -e \
+ 's|\$$\(sbindir\)||g'
+
post-install:
- @${CAT} ${PKGMESSAGE}
+ @${SED} 's:/usr/X11R6:${PREFIX}:' ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/graphics/xsane/distinfo b/graphics/xsane/distinfo
index 1c250f62d605..a8fb2220f494 100644
--- a/graphics/xsane/distinfo
+++ b/graphics/xsane/distinfo
@@ -1 +1 @@
-MD5 (xsane-0.70.tar.gz) = 6578cbbb70aa9950f9905b9631d76310
+MD5 (xsane-0.73.tar.gz) = 3d368b536af110e8b75ae4f8fb9e5346
diff --git a/graphics/xsane/files/patch-ad b/graphics/xsane/files/patch-ad
deleted file mode 100644
index 7efb19f26d0f..000000000000
--- a/graphics/xsane/files/patch-ad
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in.orig Sat Jan 6 17:24:43 2001
-+++ src/Makefile.in Sun Jan 14 23:11:28 2001
-@@ -57,7 +57,7 @@
- all: $(PROGRAMS)
-
- install: $(PROGRAMS)
-- $(MKINSTALLDIRS) $(bindir) $(sbindir) $(datadir) $(sanedatadir) $(sanedatadir)/xsane
-+ $(MKINSTALLDIRS) $(bindir) $(datadir) $(sanedatadir) $(sanedatadir)/xsane
- @for program in $(BINPROGS); do \
- $(INSTALL_PROGRAM) $${program} $(bindir)/$${program}; \
- done
diff --git a/graphics/xsane/pkg-descr b/graphics/xsane/pkg-descr
index cca798f25f75..dab8b879ae0b 100644
--- a/graphics/xsane/pkg-descr
+++ b/graphics/xsane/pkg-descr
@@ -1,4 +1,4 @@
XSANE is a gtk based X11 frontend for SANE (Scanner Access Now Easy). It
works either standalone or as a GIMP plugin.
-WWW: http://www.wolfsburg.de/~rauch/sane/sane-xsane.html
+WWW: http://www.xsane.org/
diff --git a/graphics/xsane/pkg-message b/graphics/xsane/pkg-message
index 44d1ae461265..5cd73ec4404a 100644
--- a/graphics/xsane/pkg-message
+++ b/graphics/xsane/pkg-message
@@ -1,11 +1,11 @@
Congratulations, XSane is now installed.
-If you have GIMP installed, you can use XSane as a GIMP plug-in.
-To do this, as root, type:
+If you built it with GIMP packages/ports installed, you can use
+XSane as a GIMP plug-in. To do this, type:
-ln -sf /usr/X11R6/bin/xsane /usr/X11R6/libexec/gimp/1.1/plug-ins/xsane
+ln -sf /usr/X11R6/bin/xsane ~/.gimp-1.2/plug-ins/xsane
Then run the GIMP, and a new "XSane" menu item should appear in the
-"Xtns" menu. Use this to access your scanner.
+"File->Acquire" menu. Use this to access your scanner.
Have fun!
diff --git a/graphics/xsane/pkg-plist b/graphics/xsane/pkg-plist
index bd0d533dcb7a..a6f79066089d 100644
--- a/graphics/xsane/pkg-plist
+++ b/graphics/xsane/pkg-plist
@@ -3,72 +3,80 @@ share/locale/cs/LC_MESSAGES/xsane.mo
share/locale/de/LC_MESSAGES/xsane.mo
share/locale/fr/LC_MESSAGES/xsane.mo
share/locale/it/LC_MESSAGES/xsane.mo
+share/locale/ja/LC_MESSAGES/xsane.mo
+share/locale/sl/LC_MESSAGES/xsane.mo
share/locale/sv/LC_MESSAGES/xsane.mo
share/locale/tr/LC_MESSAGES/xsane.mo
-share/sane/autoenhance.jpg
-share/sane/brightness.jpg
-share/sane/contrast.jpg
-share/sane/default.jpg
-share/sane/gamma.jpg
-share/sane/negative.jpg
-share/sane/restore.jpg
-share/sane/rgb-default.jpg
share/sane/sane-backends-doc.html
-share/sane/sane-logo.jpg
-share/sane/sane-logo2.jpg
share/sane/sane-pnm-doc.html
-share/sane/sane-pnm16-doc.html
share/sane/sane-problems-doc.html
share/sane/sane-scantips-doc.html
share/sane/sane-xsane-advanced-doc.html
-share/sane/sane-xsane-advanced.jpg
+share/sane/sane-xsane-color-correction-doc.html
share/sane/sane-xsane-copy-doc.html
-share/sane/sane-xsane-copy.jpg
share/sane/sane-xsane-doc.html
-share/sane/sane-xsane-enhancement-doc.html
+share/sane/sane-xsane-empty-doc.html
share/sane/sane-xsane-fax-doc.html
-share/sane/sane-xsane-fax-project.jpg
-share/sane/sane-xsane-fax.jpg
share/sane/sane-xsane-gimp-doc.html
-share/sane/sane-xsane-gimp.jpg
share/sane/sane-xsane-histogram-doc.html
-share/sane/sane-xsane-histogram.jpg
share/sane/sane-xsane-main-doc.html
-share/sane/sane-xsane-output-formats-doc.html
-share/sane/sane-xsane-pipette-black.jpg
-share/sane/sane-xsane-pipette-gray.jpg
-share/sane/sane-xsane-pipette-white.jpg
share/sane/sane-xsane-preview-doc.html
-share/sane/sane-xsane-preview.jpg
share/sane/sane-xsane-scan-doc.html
share/sane/sane-xsane-setup-copy-doc.html
-share/sane/sane-xsane-setup-copy.jpg
-share/sane/sane-xsane-setup-device-doc.html
-share/sane/sane-xsane-setup-device.jpg
share/sane/sane-xsane-setup-display-doc.html
-share/sane/sane-xsane-setup-display.jpg
+share/sane/sane-xsane-setup-enhancement-doc.html
share/sane/sane-xsane-setup-fax-doc.html
-share/sane/sane-xsane-setup-fax.jpg
share/sane/sane-xsane-setup-save-doc.html
-share/sane/sane-xsane-setup-save.jpg
share/sane/sane-xsane-standard-doc.html
-share/sane/sane-xsane-standard.jpg
-share/sane/sane-xsane-visible-area.jpg
-share/sane/sane-xsane-zoom-in.jpg
-share/sane/sane-xsane-zoom-not.jpg
-share/sane/sane-xsane-zoom-out.jpg
-share/sane/sane-xsane-zoom-undo.jpg
-share/sane/sane-xsane.jpg
-share/sane/store.jpg
-share/sane/threshold.jpg
-share/sane/xsane-logo.jpg
-share/sane/xsane-logo2.jpg
share/sane/xsane/sane-epson-logo.xpm
+share/sane/xsane/sane-hp-logo.xpm
share/sane/xsane/sane-umax-logo.xpm
share/sane/xsane/sane-xsane-logo.xpm
+share/sane/xsane/umax-logo.xpm
share/sane/xsane/xsane-calibration.pnm
+share/sane/xsane/xsane-license.txt
share/sane/xsane/xsane-logo.xpm
share/sane/xsane/xsane-startimage.pnm
share/sane/xsane/xsane-style.rc
+share/sane/xsane-advanced.jpg
+share/sane/xsane-autoenhance.jpg
+share/sane/xsane-autoselect.jpg
+share/sane/xsane-brightness.jpg
+share/sane/xsane-colormode.jpg
+share/sane/xsane-contrast.jpg
+share/sane/xsane-copy.jpg
+share/sane/xsane-default.jpg
+share/sane/xsane-disk.jpg
+share/sane/xsane-fax-project.jpg
+share/sane/xsane-fax.jpg
+share/sane/xsane-gamma.jpg
+share/sane/xsane-gimp.jpg
+share/sane/xsane-histogram.jpg
+share/sane/xsane-logo2.jpg
+share/sane/xsane-negative.jpg
+share/sane/xsane-pipette-black.jpg
+share/sane/xsane-pipette-gray.jpg
+share/sane/xsane-pipette-white.jpg
+share/sane/xsane-preview.jpg
+share/sane/xsane-printer.jpg
+share/sane/xsane-resolution.jpg
+share/sane/xsane-restore.jpg
+share/sane/xsane-rgb-default.jpg
+share/sane/xsane-scansource.jpg
+share/sane/xsane-setup-copy.jpg
+share/sane/xsane-setup-display.jpg
+share/sane/xsane-setup-enhancement.jpg
+share/sane/xsane-setup-fax.jpg
+share/sane/xsane-setup-save.jpg
+share/sane/xsane-standard.jpg
+share/sane/xsane-store.jpg
+share/sane/xsane-threshold.jpg
+share/sane/xsane-visible-area.jpg
+share/sane/xsane-zoom-in.jpg
+share/sane/xsane-zoom-not.jpg
+share/sane/xsane-zoom-out.jpg
+share/sane/xsane-zoom-undo.jpg
+share/sane/xsane-zoom.jpg
+share/sane/xsane.jpg
@dirrm share/sane/xsane
@dirrm share/sane