aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-07-13 23:36:40 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-07-13 23:36:40 +0000
commit3fee91136667f7b3cca62afbc9d9f01d03a2ec89 (patch)
treecaf481fc0fb12e9f5b4f7e105ea42f01f77c286a /graphics
parente6ffa1f425ea668e859fae97edfd25a239614331 (diff)
downloadports-3fee91136667f7b3cca62afbc9d9f01d03a2ec89.tar.gz
ports-3fee91136667f7b3cca62afbc9d9f01d03a2ec89.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/prison/Makefile4
-rw-r--r--graphics/py-openexr/Makefile2
-rw-r--r--graphics/py-qt4-svg/Makefile2
-rw-r--r--graphics/py-soya3d/Makefile2
-rw-r--r--graphics/quat-gui/Makefile2
-rw-r--r--graphics/repng2jpeg/Makefile2
-rw-r--r--graphics/ruby-ming/Makefile2
-rw-r--r--graphics/rubygem-gd2/Makefile2
-rw-r--r--graphics/sane-epkowa/Makefile6
-rw-r--r--graphics/stamp/Makefile2
-rw-r--r--graphics/svg2pdf/Makefile2
-rw-r--r--graphics/svg2png/Makefile2
-rw-r--r--graphics/synfigstudio/Makefile4
-rw-r--r--graphics/uDrawGraph/Makefile2
-rw-r--r--graphics/xnview/Makefile2
15 files changed, 19 insertions, 19 deletions
diff --git a/graphics/prison/Makefile b/graphics/prison/Makefile
index 00eb8d0d7b53..7cd1b11702ce 100644
--- a/graphics/prison/Makefile
+++ b/graphics/prison/Makefile
@@ -12,8 +12,8 @@ MAINTAINER= fluffy@FreeBSD.org
COMMENT= Barcode library for KDE
-LIB_DEPENDS= dmtx.0:${PORTSDIR}/graphics/libdmtx \
- qrencode.3:${PORTSDIR}/graphics/libqrencode
+LIB_DEPENDS= libdmtx.so:${PORTSDIR}/graphics/libdmtx \
+ libqrencode.so:${PORTSDIR}/graphics/libqrencode
USE_QT4= corelib gui qmake_build moc_build rcc_build uic_build
USES= cmake
diff --git a/graphics/py-openexr/Makefile b/graphics/py-openexr/Makefile
index c483a45966f5..d8e6ffb75fa4 100644
--- a/graphics/py-openexr/Makefile
+++ b/graphics/py-openexr/Makefile
@@ -13,7 +13,7 @@ DISTNAME= OpenEXR-${PORTVERSION}
MAINTAINER= jamesb-bsd@excamera.com
COMMENT= Python module for ILM's OpenEXR image format and library
-LIB_DEPENDS= IlmImf:${PORTSDIR}/graphics/OpenEXR
+LIB_DEPENDS= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR
post-extract:
${REINPLACE_CMD} -e 's#/usr/local#${LOCALBASE}#g' ${WRKSRC}/setup.py
diff --git a/graphics/py-qt4-svg/Makefile b/graphics/py-qt4-svg/Makefile
index 23a4b7bb2429..053962f0207b 100644
--- a/graphics/py-qt4-svg/Makefile
+++ b/graphics/py-qt4-svg/Makefile
@@ -45,7 +45,7 @@ ARGS= -b ${PREFIX}/bin \
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= libqscintilla2.so:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
diff --git a/graphics/py-soya3d/Makefile b/graphics/py-soya3d/Makefile
index 247a28e502e1..9e894daa6b69 100644
--- a/graphics/py-soya3d/Makefile
+++ b/graphics/py-soya3d/Makefile
@@ -16,7 +16,7 @@ COMMENT= Very high level 3D engine for Python
BUILD_DEPENDS= ${LOCALBASE}/lib/libode.a:${PORTSDIR}/devel/ode \
${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging
-LIB_DEPENDS= cal3d.12:${PORTSDIR}/graphics/cal3d \
+LIB_DEPENDS= libcal3d.so:${PORTSDIR}/graphics/cal3d \
libfreetype.so:${PORTSDIR}/print/freetype2
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/editobj/editor.py:${PORTSDIR}/graphics/py-editobj \
${PYTHON_SITELIBDIR}/tofu/client.py:${PORTSDIR}/net/py-tofu \
diff --git a/graphics/quat-gui/Makefile b/graphics/quat-gui/Makefile
index 287b3da4ba0e..f91b02632757 100644
--- a/graphics/quat-gui/Makefile
+++ b/graphics/quat-gui/Makefile
@@ -14,7 +14,7 @@ COMMENT= Three-dimensional fractal creator (X11 GUI)
LICENSE= GPLv2 # (or later)
-LIB_DEPENDS= fltk:${PORTSDIR}/x11-toolkits/fltk
+LIB_DEPENDS= libfltk.so:${PORTSDIR}/x11-toolkits/fltk
OPTIONS_DEFINE= OPTIMIZED_CFLAGS DOCS
diff --git a/graphics/repng2jpeg/Makefile b/graphics/repng2jpeg/Makefile
index 23e66dca770a..d0cc675da387 100644
--- a/graphics/repng2jpeg/Makefile
+++ b/graphics/repng2jpeg/Makefile
@@ -13,7 +13,7 @@ COMMENT= Tool to recompress JPEG/PNG/GIF
BROKEN= Unfetchable
-LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lgd
diff --git a/graphics/ruby-ming/Makefile b/graphics/ruby-ming/Makefile
index e8ac9d702bc0..7ee986cb987d 100644
--- a/graphics/ruby-ming/Makefile
+++ b/graphics/ruby-ming/Makefile
@@ -14,7 +14,7 @@ DIST_SUBDIR= ruby
MAINTAINER= don@na.rim.or.jp
COMMENT= Yet another Ming module for Ruby
-LIB_DEPENDS?= ming.5:${PORTSDIR}/graphics/ming
+LIB_DEPENDS?= libming.so:${PORTSDIR}/graphics/ming
RUBY_MING_VERSION= 0.2.1
diff --git a/graphics/rubygem-gd2/Makefile b/graphics/rubygem-gd2/Makefile
index e22b75e3919c..2dd732b67c9b 100644
--- a/graphics/rubygem-gd2/Makefile
+++ b/graphics/rubygem-gd2/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby binding for Thomas Boutell's gd 2.x graphics library #'
-LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd
REINPLACE_ARGS= -i ""
diff --git a/graphics/sane-epkowa/Makefile b/graphics/sane-epkowa/Makefile
index 31525fd3d6b3..7b6d2e030bed 100644
--- a/graphics/sane-epkowa/Makefile
+++ b/graphics/sane-epkowa/Makefile
@@ -59,9 +59,9 @@ WRKSRC=${WRKDIR}/iscan-${PORTVERSION}
MAN5= sane-epkowa.5
# We use LIB_DEPENDS, but the dependency is also at build time
-LIB_DEPENDS+= ltdl:${PORTSDIR}/devel/libltdl
-LIB_DEPENDS+= getline:${PORTSDIR}/devel/libgetline
-LIB_DEPENDS+= sane.1:${PORTSDIR}/graphics/sane-backends
+LIB_DEPENDS+= libltdl.so:${PORTSDIR}/devel/libltdl
+LIB_DEPENDS+= libgetline.so:${PORTSDIR}/devel/libgetline
+LIB_DEPENDS+= libsane.so:${PORTSDIR}/graphics/sane-backends
#BUILD_DEPENDS+= ${LOCALBASE}/lib/libltdl.so:${PORTSDIR}/devel/libltdl
diff --git a/graphics/stamp/Makefile b/graphics/stamp/Makefile
index 92a78f108dcf..8bf11976e380 100644
--- a/graphics/stamp/Makefile
+++ b/graphics/stamp/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Adds a graphical, configurable timestamp to a grayscale image
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/graphics/svg2pdf/Makefile b/graphics/svg2pdf/Makefile
index 0dc9c4046ffc..a7775ef3942b 100644
--- a/graphics/svg2pdf/Makefile
+++ b/graphics/svg2pdf/Makefile
@@ -11,7 +11,7 @@ MASTER_SITES= http://cairographics.org/snapshots/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Render an SVG image to a PDF file (using cairo)
-LIB_DEPENDS= svg-cairo.1:${PORTSDIR}/graphics/libsvg-cairo
+LIB_DEPENDS= libsvg-cairo.so:${PORTSDIR}/graphics/libsvg-cairo
GNU_CONFIGURE= yes
USES= pkgconfig
diff --git a/graphics/svg2png/Makefile b/graphics/svg2png/Makefile
index b1f70f3912ee..396e9d3a29d8 100644
--- a/graphics/svg2png/Makefile
+++ b/graphics/svg2png/Makefile
@@ -11,7 +11,7 @@ MASTER_SITES= http://cairographics.org/snapshots/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Render an SVG image to a PNG image (using cairo)
-LIB_DEPENDS= svg-cairo.1:${PORTSDIR}/graphics/libsvg-cairo
+LIB_DEPENDS= libsvg-cairo.so:${PORTSDIR}/graphics/libsvg-cairo
GNU_CONFIGURE= yes
USES= pkgconfig
diff --git a/graphics/synfigstudio/Makefile b/graphics/synfigstudio/Makefile
index 21bc3e425a0d..7b3476982719 100644
--- a/graphics/synfigstudio/Makefile
+++ b/graphics/synfigstudio/Makefile
@@ -13,8 +13,8 @@ COMMENT= Vector-based 2D animation software package
BROKEN= Fails to compile
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/ETL.pc:${PORTSDIR}/devel/etl
-LIB_DEPENDS= synfig.0:${PORTSDIR}/devel/synfig \
- gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
+LIB_DEPENDS= libsynfig.so:${PORTSDIR}/devel/synfig \
+ libgtkmm-2.4.so:${PORTSDIR}/x11-toolkits/gtkmm24
USE_GNOME= gnomehack gtk20
USES= gettext gmake
diff --git a/graphics/uDrawGraph/Makefile b/graphics/uDrawGraph/Makefile
index a058853ac185..b04186c53855 100644
--- a/graphics/uDrawGraph/Makefile
+++ b/graphics/uDrawGraph/Makefile
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-${PKGNUM}-${OPSYS:tl}-${ARCH}
MAINTAINER= nivit@FreeBSD.org
COMMENT= Graph drawing/visualization system
-LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x
+LIB_DEPENDS= libc.so.4:${PORTSDIR}/misc/compat4x
NO_BUILD= yes
ONLY_FOR_ARCHS= i386
diff --git a/graphics/xnview/Makefile b/graphics/xnview/Makefile
index afe600e67680..99d3ab3f84bb 100644
--- a/graphics/xnview/Makefile
+++ b/graphics/xnview/Makefile
@@ -18,7 +18,7 @@ INSTALL_SLIB= yes
OPTIONS_DEFINE= DOCS
-LIB_DEPENDS+= c.5:${PORTSDIR}/misc/compat5x
+LIB_DEPENDS+= libc.so.5:${PORTSDIR}/misc/compat5x
DISTFILES+= NConvert-x86-unknown-FreeBSD6.x.tgz
WRKSRC_NC= ${WRKDIR}/NConvert