aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-01-21 05:57:50 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-01-21 05:57:50 +0000
commit66acb9cd06907030a13dd56c90708c4cf4861f92 (patch)
tree1b86710ecc3bb60c1a702a6e49a3b7540d0959a4 /graphics
parent24ebd4cbfc87f39b6d0e861ecc2b1ddf6ef5ac2e (diff)
downloadports-66acb9cd06907030a13dd56c90708c4cf4861f92.tar.gz
ports-66acb9cd06907030a13dd56c90708c4cf4861f92.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ming/Makefile33
-rw-r--r--graphics/ming/distinfo2
-rw-r--r--graphics/ming/files/Makefile16
-rw-r--r--graphics/ming/pkg-comment2
-rw-r--r--graphics/ming/pkg-descr4
-rw-r--r--graphics/ming/pkg-plist65
-rw-r--r--graphics/py-ming/Makefile19
-rw-r--r--graphics/py-ming/files/patch-Makefile35
-rw-r--r--graphics/py-ming/pkg-comment2
-rw-r--r--graphics/py-ming/pkg-descr2
-rw-r--r--graphics/py-ming/pkg-plist20
-rw-r--r--graphics/ruby-ming/Makefile6
-rw-r--r--graphics/ruby-ming/pkg-comment2
-rw-r--r--graphics/ruby-ming/pkg-descr2
14 files changed, 166 insertions, 44 deletions
diff --git a/graphics/ming/Makefile b/graphics/ming/Makefile
index d2b8b05798e4..d8aa33d5fe00 100644
--- a/graphics/ming/Makefile
+++ b/graphics/ming/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ming
-PORTVERSION= 0.0.3a
+PORTVERSION= 0.0.9b
CATEGORIES= graphics
MASTER_SITES= http://www.opaque.net/ming/
EXTRACT_SUFX= .tgz
@@ -18,11 +18,40 @@ MAKE_ARGS= NOPROFILE=true
DOCS= CHANGES \
CREDITS \
- Makefile \
README \
TODO
+post-extract:
+ ${MKDIR} ${WRKSRC}/c++
+ ${CP} ${WRKSRC}/../c++_ext/ming.h ${WRKSRC}/c++/
+
+post-patch:
+ ${PERL} -i -p \
+ -e 's:"\.\./\.\./c\+\+_ext/ming\.h":<c++/ming.h>:g;' \
+ -e 's:"\.\./\.\./ming\.h":<ming.h>:g;' \
+ ${WRKSRC}/../examples/c/* \
+ ${WRKSRC}/../examples/c++/* \
+ ${WRKSRC}/../examples/common/* \
+ ${WRKSRC}/c++/ming.h
+
pre-build:
${CP} ${FILESDIR}/Makefile ${WRKSRC}/
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ming
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/../${f} ${PREFIX}/share/doc/ming/
+.endfor
+ ${MKDIR} ${PREFIX}/share/examples/ming/common
+ ${INSTALL_DATA} ${WRKSRC}/../examples/common/* \
+ ${PREFIX}/share/examples/ming/common/
+ ${MKDIR} ${PREFIX}/share/examples/ming/c
+ ${INSTALL_DATA} ${WRKSRC}/../examples/c/*.c \
+ ${PREFIX}/share/examples/ming/c/
+ ${MKDIR} ${PREFIX}/share/examples/ming/c++
+ ${INSTALL_DATA} ${WRKSRC}/../examples/c++/*.cpp \
+ ${PREFIX}/share/examples/ming/c++/
+.endif
+
.include <bsd.port.mk>
diff --git a/graphics/ming/distinfo b/graphics/ming/distinfo
index 909f32315482..43e0762517f6 100644
--- a/graphics/ming/distinfo
+++ b/graphics/ming/distinfo
@@ -1 +1 @@
-MD5 (ming-0.0.3a.tgz) = befc531dae73efb4f8558278e38b1e48
+MD5 (ming-0.0.9b.tgz) = 4b3117322e0af30a19514240f1df9566
diff --git a/graphics/ming/files/Makefile b/graphics/ming/files/Makefile
index 130a2a2731b9..ab2b8c4cd8d1 100644
--- a/graphics/ming/files/Makefile
+++ b/graphics/ming/files/Makefile
@@ -1,16 +1,17 @@
# $FreeBSD$
LIB= ming
-SHLIB_MAJOR?= 1
+SHLIB_MAJOR?= 2
SHLIB_MINOR?= 0
CFLAGS+= -I${.CURDIR}/actioncompiler -I${.CURDIR}/blocks -I${LOCALBASE}/include
LDADD= -lm
SRCS= blocklist.c \
displaylist.c \
+ ming.c \
movie.c \
movieclip.c \
position.c \
- shape.c \
+ shape_util.c \
actioncompiler/compile.c \
actioncompiler/compileaction.c \
actioncompiler/compiler.tab.c \
@@ -43,6 +44,7 @@ SRCS= blocklist.c \
blocks/text.c \
blocks/textfield.c
INCS= blocklist.h \
+ blocktypes.h \
displaylist.h \
fill.h \
libming.h \
@@ -50,8 +52,7 @@ INCS= blocklist.h \
movie.h \
movieclip.h \
position.h \
- shape.h \
- blocks/swf.h
+ shape_util.h
NOMAN= YES
LIBDIR= ${LOCALBASE}/lib
@@ -77,7 +78,10 @@ beforeinstall: _includeinstall
_includeinstall: pre-_includeinstall
pre-_includeinstall:
- mkdir -p ${INCDIR}/blocks
+ mkdir -p ${DESTDIR}${INCDIR}/blocks ${DESTDIR}${INCDIR}/c++
beforeinstall:
- mv ${INCDIR}/swf.h ${INCDIR}/blocks/
+ ${INSTALL} -C -o ${INCOWN} -g ${INCGRP} -m ${INCMODE} \
+ ${.CURDIR}/blocks/swf.h ${INCDIR}/blocks/
+ ${INSTALL} -C -o ${INCOWN} -g ${INCGRP} -m ${INCMODE} \
+ ${.CURDIR}/c++/ming.h ${INCDIR}/c++/
diff --git a/graphics/ming/pkg-comment b/graphics/ming/pkg-comment
index 7859b7a4bcf8..721346f2c5b2 100644
--- a/graphics/ming/pkg-comment
+++ b/graphics/ming/pkg-comment
@@ -1 +1 @@
-LGPL Flash (TM) movie output library with PHP, Python and Ruby interfaces
+LGPL'ed Flash 4 movie output library with many languages support
diff --git a/graphics/ming/pkg-descr b/graphics/ming/pkg-descr
index 8ddd688d6fee..f7c87c6d550e 100644
--- a/graphics/ming/pkg-descr
+++ b/graphics/ming/pkg-descr
@@ -1,5 +1,5 @@
-Ming is an LGPL Flash (TM) movie (SWF) output library with PHP, Python
-and Ruby interfaces.
+Ming is an LGPL'ed Flash 4 (TM) movie (SWF) output library with PHP,
+Python, Ruby, Perl5, C and C++ interfaces.
Author: Opaque Industries <dave@opaque.net>
WWW: http://www.opaque.net/ming/
diff --git a/graphics/ming/pkg-plist b/graphics/ming/pkg-plist
index d2cffe3faf2f..0928a3fd1d5f 100644
--- a/graphics/ming/pkg-plist
+++ b/graphics/ming/pkg-plist
@@ -1,4 +1,5 @@
include/ming/blocklist.h
+include/ming/blocktypes.h
include/ming/displaylist.h
include/ming/fill.h
include/ming/libming.h
@@ -6,10 +7,70 @@ include/ming/ming.h
include/ming/movie.h
include/ming/movieclip.h
include/ming/position.h
-include/ming/shape.h
+include/ming/shape_util.h
include/ming/blocks/swf.h
+include/ming/c++/ming.h
@dirrm include/ming/blocks
+@dirrm include/ming/c++
@dirrm include/ming
lib/libming.a
lib/libming.so
-lib/libming.so.1
+lib/libming.so.2
+share/doc/ming/CHANGES
+share/doc/ming/CREDITS
+share/doc/ming/README
+share/doc/ming/TODO
+@dirrm share/doc/ming
+share/examples/ming/c/action.c
+share/examples/ming/c/alphafill.c
+share/examples/ming/c/animation.c
+share/examples/ming/c/bitmapxform.c
+share/examples/ming/c/button.c
+share/examples/ming/c/cxform.c
+share/examples/ming/c/drag.c
+share/examples/ming/c/glyph.c
+share/examples/ming/c/gradient.c
+share/examples/ming/c/gradientxform.c
+share/examples/ming/c/jpegfill.c
+share/examples/ming/c/keypress.c
+share/examples/ming/c/morph.c
+share/examples/ming/c/mousetrack.c
+share/examples/ming/c/newbutton.c
+share/examples/ming/c/png.c
+share/examples/ming/c/pngalpha.c
+share/examples/ming/c/shape.c
+share/examples/ming/c/sprite.c
+share/examples/ming/c/streammp3.c
+share/examples/ming/c/text.c
+@dirrm share/examples/ming/c
+share/examples/ming/c++/action.cpp
+share/examples/ming/c++/alphafill.cpp
+share/examples/ming/c++/animation.cpp
+share/examples/ming/c++/bitmapxform.cpp
+share/examples/ming/c++/button.cpp
+share/examples/ming/c++/cxform.cpp
+share/examples/ming/c++/drag.cpp
+share/examples/ming/c++/glyph.cpp
+share/examples/ming/c++/gradient.cpp
+share/examples/ming/c++/gradientxform.cpp
+share/examples/ming/c++/jpegfill.cpp
+share/examples/ming/c++/keypress.cpp
+share/examples/ming/c++/morph.cpp
+share/examples/ming/c++/mousetrack.cpp
+share/examples/ming/c++/newbutton.cpp
+share/examples/ming/c++/png.cpp
+share/examples/ming/c++/pngalpha.cpp
+share/examples/ming/c++/shape.cpp
+share/examples/ming/c++/sprite.cpp
+share/examples/ming/c++/streammp3.cpp
+share/examples/ming/c++/text.cpp
+@dirrm share/examples/ming/c++
+share/examples/ming/common/alpha.dbl
+share/examples/ming/common/alphafill.jpg
+share/examples/ming/common/alphafill.msk
+share/examples/ming/common/backyard.jpg
+share/examples/ming/common/distortobass.mp3
+share/examples/ming/common/png.dbl
+share/examples/ming/common/test.fdb
+@dirrm share/examples/ming/common
+@dirrm share/examples/ming
diff --git a/graphics/py-ming/Makefile b/graphics/py-ming/Makefile
index 5713bd1ae03e..3457cb4ba2bb 100644
--- a/graphics/py-ming/Makefile
+++ b/graphics/py-ming/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ming
-PORTVERSION= 0.0.3a
-PORTREVISION= 1
+PORTVERSION= 0.0.9b
CATEGORIES= graphics python
MASTER_SITES= http://www.opaque.net/ming/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,23 +14,25 @@ EXTRACT_SUFX= .tgz
MAINTAINER= knu@FreeBSD.org
-BUILD_DEPENDS= ${SWIG}:${PORTSDIR}/devel/SWIG-devel
-LIB_DEPENDS= ming.1:${PORTSDIR}/graphics/ming
+LIB_DEPENDS= ming.2:${PORTSDIR}/graphics/ming
USE_PYTHON= yes
-MD5_FILE= ${PORTSDIR}/graphics/ming/distinfo
+MD5_FILE= ${.CURDIR}/../ming/distinfo
WRKSRC= ${WRKDIR}/${DISTNAME}/py_ext
-MAKE_ARGS= PYTHON_VERSION="${PYTHON_VERSION}" SWIG="${SWIG}"
+MAKE_ARGS= PYTHON_VERSION="${PYTHON_VERSION}"
-SWIG= swig1.3
-
-EXAMPLES= shape.py test.py
+EXAMPLES= shape.py test.py ../examples/python/*.py
post-extract:
${LN} -sf ../ming.i ${WRKSRC}/
+post-patch:
+ ${PERL} -i -p \
+ -e 's:\.\./common:../../ming/common:g;' \
+ ${WRKSRC}/../examples/python/*
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/examples/${PYTHON_VERSION}/ming
diff --git a/graphics/py-ming/files/patch-Makefile b/graphics/py-ming/files/patch-Makefile
index 7da12fdc4941..bfb35330acab 100644
--- a/graphics/py-ming/files/patch-Makefile
+++ b/graphics/py-ming/files/patch-Makefile
@@ -1,18 +1,25 @@
---- Makefile.orig Wed Oct 25 07:02:37 2000
-+++ Makefile Wed Oct 25 13:11:16 2000
-@@ -1,11 +1,10 @@
+--- Makefile.orig Fri Jan 5 08:05:13 2001
++++ Makefile Sat Jan 20 05:05:03 2001
+@@ -1,12 +1,12 @@
+ #PYINCDIR = /usr/local/include/python2.0
+ #PYLIBDIR = /usr/local/lib/python2.0
+
+-PYINCDIR = /usr/include/python1.5
+-PYLIBDIR = /usr/lib/python1.5
++PYINCDIR = ${LOCALBASE}/include/${PYTHON_VERSION}
++PYLIBDIR = ${LOCALBASE}/lib/${PYTHON_VERSION}
+
all:
-- swig -I.. -python ming.i
-- gcc -I .. -I /usr/include/python1.5/ -fpic -c ming_wrap.c
-- gcc -L .. -shared -o mingcmodule.so ming_wrap.o -lming
-+ ${SWIG} -I.. -python ming.i
-+ ${CC} ${CFLAGS} -I${LOCALBASE}/include/ming -I${LOCALBASE}/include/${PYTHON_VERSION} -fpic -c ming_wrap.c
-+ ${CC} -shared -o mingcmodule.so ming_wrap.o -L${LOCALBASE}/lib -lming
+- gcc -g -Wall -I .. -I ${PYINCDIR} -fpic -c ming_wrap.c
+- gcc -g -Wall -L .. -shared -o mingcmodule.so ming_wrap.o -lming
++ ${CC} ${CFLAGS} -g -Wall -I .. -I ${PYINCDIR} -fpic -c ming_wrap.c
++ ${CC} -g -Wall -L .. -shared -o mingcmodule.so ming_wrap.o -L${LOCALBASE}/lib -lming
- clean:
- rm -f mingcmodule.so core *~ *.o ming_wrap*
+ swig:
+ swig -I.. -python ming.i
+@@ -15,4 +15,4 @@
+ rm -f mingcmodule.so core *~ *.o
install:
-- cp mingcmodule.so ming.py /usr/lib/python1.5/site-packages
-- chmod 755 /usr/lib/python1.5/site-packages/mingcmodule.so
-+ ${BSD_INSTALL_DATA} mingcmodule.so ming.py ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages
+- cp mingcmodule.so ming.py ${PYLIBDIR}/site-packages
++ ${BSD_INSTALL_DATA} mingcmodule.so ming.py ${PYLIBDIR}/site-packages
diff --git a/graphics/py-ming/pkg-comment b/graphics/py-ming/pkg-comment
index 838d8b217b0e..abc75d69028c 100644
--- a/graphics/py-ming/pkg-comment
+++ b/graphics/py-ming/pkg-comment
@@ -1 +1 @@
-Python module for the Ming library which allows you to create Flash (TM) movies
+Python module for the Ming library which allows you to create Flash 4 movies
diff --git a/graphics/py-ming/pkg-descr b/graphics/py-ming/pkg-descr
index 6c66e42bfd19..396ebd5a5df6 100644
--- a/graphics/py-ming/pkg-descr
+++ b/graphics/py-ming/pkg-descr
@@ -1,5 +1,5 @@
This is a Python module for the Ming.
-Ming allows you to create Flash (TM) movies.
+Ming allows you to create Flash 4 (TM) movies.
Author: Roberto Raggi <roberto@elecomsolutions.com> (author)
Fiore Basile <fiore@elecomsolutions.com> (contact)
diff --git a/graphics/py-ming/pkg-plist b/graphics/py-ming/pkg-plist
index a54644e14f6f..e28db7b3dd58 100644
--- a/graphics/py-ming/pkg-plist
+++ b/graphics/py-ming/pkg-plist
@@ -1,6 +1,26 @@
lib/%%PYTHON_VERSION%%/site-packages/mingcmodule.so
lib/%%PYTHON_VERSION%%/site-packages/ming.py
+share/examples/%%PYTHON_VERSION%%/ming/action.py
+share/examples/%%PYTHON_VERSION%%/ming/alphafill.py
+share/examples/%%PYTHON_VERSION%%/ming/animation.py
+share/examples/%%PYTHON_VERSION%%/ming/bitmapxform.py
+share/examples/%%PYTHON_VERSION%%/ming/button.py
+share/examples/%%PYTHON_VERSION%%/ming/cxform.py
+share/examples/%%PYTHON_VERSION%%/ming/drag.py
+share/examples/%%PYTHON_VERSION%%/ming/glyph.py
+share/examples/%%PYTHON_VERSION%%/ming/gradient.py
+share/examples/%%PYTHON_VERSION%%/ming/gradientxform.py
+share/examples/%%PYTHON_VERSION%%/ming/jpegfill.py
+share/examples/%%PYTHON_VERSION%%/ming/keypress.py
+share/examples/%%PYTHON_VERSION%%/ming/morph.py
+share/examples/%%PYTHON_VERSION%%/ming/mousetrack.py
+share/examples/%%PYTHON_VERSION%%/ming/newbutton.py
+share/examples/%%PYTHON_VERSION%%/ming/png.py
+share/examples/%%PYTHON_VERSION%%/ming/pngalpha.py
share/examples/%%PYTHON_VERSION%%/ming/shape.py
+share/examples/%%PYTHON_VERSION%%/ming/sprite.py
+share/examples/%%PYTHON_VERSION%%/ming/streammp3.py
share/examples/%%PYTHON_VERSION%%/ming/test.py
+share/examples/%%PYTHON_VERSION%%/ming/text.py
@dirrm share/examples/%%PYTHON_VERSION%%/ming
@unexec rmdir %D/share/examples/%%PYTHON_VERSION%% 2>/dev/null || true
diff --git a/graphics/ruby-ming/Makefile b/graphics/ruby-ming/Makefile
index e6ec4632e06d..f74857b0b9a4 100644
--- a/graphics/ruby-ming/Makefile
+++ b/graphics/ruby-ming/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ming
-PORTVERSION= 0.0.3a
+PORTVERSION= 0.0.9b
CATEGORIES= graphics ruby
MASTER_SITES= http://www.opaque.net/ming/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -15,12 +15,12 @@ EXTRACT_SUFX= .tgz
MAINTAINER= knu@FreeBSD.org
BUILD_DEPENDS= swig1.3:${PORTSDIR}/devel/SWIG-devel
-LIB_DEPENDS= ming.1:${PORTSDIR}/graphics/ming
+LIB_DEPENDS= ming.2:${PORTSDIR}/graphics/ming
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-MD5_FILE= ${PORTSDIR}/graphics/ming/distinfo
+MD5_FILE= ${.CURDIR}/../ming/distinfo
WRKSRC= ${WRKDIR}/${DISTNAME}/rb_ext
CONFIGURE_ARGS= --with-ming-include="${LOCALBASE}/include/ming"
diff --git a/graphics/ruby-ming/pkg-comment b/graphics/ruby-ming/pkg-comment
index f562bd6b0fd4..c7a49891c69a 100644
--- a/graphics/ruby-ming/pkg-comment
+++ b/graphics/ruby-ming/pkg-comment
@@ -1 +1 @@
-Ruby module for the Ming library which allows you to create Flash (TM) movies
+Ruby module for the Ming library which allows you to create Flash 4 movies
diff --git a/graphics/ruby-ming/pkg-descr b/graphics/ruby-ming/pkg-descr
index d4e542f5df44..9dcab4bf1e86 100644
--- a/graphics/ruby-ming/pkg-descr
+++ b/graphics/ruby-ming/pkg-descr
@@ -1,4 +1,4 @@
This is a Ruby module for the Ming library based on Python module.
-Ming allows you to create Flash (TM) movies.
+Ming allows you to create Flash 4 (TM) movies.
Author: Kazuki Sakamoto <sakamoto@splhack.org>