aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2001-04-16 12:45:23 +0000
committerPeter Pentchev <roam@FreeBSD.org>2001-04-16 12:45:23 +0000
commit680a234ce5a8d955995c9a17c7a46396dcf2fcc9 (patch)
treed82a79b04c6d9aa5fbd970f3dc69ce082d31aab6 /graphics
parentf6cb2453c0ac198edd5773d3a0c677fb4ec6f539 (diff)
downloadports-680a234ce5a8d955995c9a17c7a46396dcf2fcc9.tar.gz
ports-680a234ce5a8d955995c9a17c7a46396dcf2fcc9.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/aero/Makefile12
-rw-r--r--graphics/aero/files/patch-aa60
-rw-r--r--graphics/aero/pkg-descr25
3 files changed, 62 insertions, 35 deletions
diff --git a/graphics/aero/Makefile b/graphics/aero/Makefile
index 40e3a41bf529..987a649e0ba5 100644
--- a/graphics/aero/Makefile
+++ b/graphics/aero/Makefile
@@ -1,14 +1,15 @@
-# New ports collection makefile for: aero
-# Date created: Mon Aug 28 13:35:31 CDT 1995
-# Whom: erich@rrnet.com
+# New ports collection makefile for: aero
+# Date created: Mon Aug 28 13:35:31 CDT 1995
+# Whom: erich@rrnet.com
#
# $FreeBSD$
#
PORTNAME= aero
PORTVERSION= 1.7.0
+PORTREVISION= 1
CATEGORIES= graphics
-MASTER_SITES= ftp://ftp.ee.uwa.edu.au/users/braunl/aero/
+MASTER_SITES= http://www.ee.uwa.edu.au/~braunl/aero/ftp/
DISTNAME= ${PORTNAME}_${PORTVERSION}_src
MAINTAINER= ports@FreeBSD.org
@@ -16,9 +17,10 @@ MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= ${X11BASE}/lib/libfwf.a:${PORTSDIR}/x11-toolkits/FWF
RUN_DEPENDS= povray:${PORTSDIR}/graphics/povray
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+
USE_X_PREFIX= yes
USE_XPM= yes
-WRKSRC= ${WRKDIR}/aero/src
MAKEFILE= Makefile.linux
.include <bsd.port.mk>
diff --git a/graphics/aero/files/patch-aa b/graphics/aero/files/patch-aa
index 59feaae5bab6..21cd7c0513b0 100644
--- a/graphics/aero/files/patch-aa
+++ b/graphics/aero/files/patch-aa
@@ -1,5 +1,5 @@
---- Makefile.linux.orig Fri Aug 30 19:19:25 1996
-+++ Makefile.linux Thu Apr 16 20:30:53 1998
+--- Makefile.linux.orig Sat Aug 31 02:19:25 1996
++++ Makefile.linux Sat Feb 24 11:29:47 2001
@@ -34,8 +34,8 @@
# Set path where you want to install xaero and it's application-default
# resource file.
@@ -11,7 +11,7 @@
###########################################################################
-@@ -43,17 +43,17 @@
+@@ -43,19 +43,19 @@
# of X11 in parallel on their systems, e.g. X11R5 and X11R6. So here
# you can choose the one you want.
@@ -22,17 +22,21 @@
+XINCLUDE = ${PREFIX}/include
+XLIB = ${PREFIX}/lib
+FWFINCLUDE = $(XINCLUDE)
-+FWFLIB = $(XLIB)
++FWFLIB = $(XLIB)
###########################################################################
# Compiler and Linker definitions.
- CC = gcc
+-CC = gcc
-COPTS = -ansi -Wall $(OPTIMIZE)
-+COPTS = -ansi -Wall $(OPTIMIZE)
++CC ?= gcc
++COPTS = -ansi $(OPTIMIZE)
DEBUG =
- OPTIMIZE = -O2 -DNODEBUG
+-OPTIMIZE = -O2 -DNODEBUG
++OPTIMIZE = -DNODEBUG
+
+ LD = ld
@@ -63,16 +63,16 @@
#libraries if needed; use -L and -l syntax, e.g.
@@ -54,6 +58,15 @@
###########################################################################
+@@ -101,7 +101,7 @@
+ ###########################################################################
+ # compiler-options
+
+-CFLAGS = $(COPTS) $(DEBUG) -I$(XINCLUDE) -I$(FWFINCLUDE)
++CFLAGS += $(COPTS) $(DEBUG) -I$(XINCLUDE) -I$(FWFINCLUDE)
+
+
+ ###########################################################################
@@ -134,7 +134,7 @@
# The default rule for compiling .o files from .c files
@@ -63,27 +76,30 @@
###########################################################################
-@@ -158,7 +158,23 @@
+@@ -157,8 +157,24 @@
+ # to compile this application type 'make all'. For infos type 'make help'.
copyFilesToDestination::
- $(CP) xaero $(XAEROBIN)
-+ strip $(XAEROBIN)/xaero
+- $(CP) xaero $(XAEROBIN)
+- $(CP) ../app-defaults/XAero $(XAEROAPPL)
++ ${BSD_INSTALL_PROGRAM} xaero $(XAEROBIN)
+ [ -d $(XAEROAPPL) ] || mkdir -p $(XAEROAPPL)
+ [ -d ${PREFIX}/lib/X11/xaero ] || mkdir -p ${PREFIX}/lib/X11/xaero
- $(CP) ../app-defaults/XAero $(XAEROAPPL)
-+ $(CP) ../scripts/povsubst $(XAEROBIN)
-+ $(CP) ../scripts/rayclear $(XAEROBIN)
-+ $(CP) ../scripts/raystart $(XAEROBIN)
-+ $(CP) ../scripts/raystat $(XAEROBIN)
-+ sed 's:__XAERO_LIB_PATH__:${PREFIX}/lib/X11/xaero:' ../scripts/raymany > $(XAEROBIN)/raymany
++ ${BSD_INSTALL_DATA} ../app-defaults/XAero $(XAEROAPPL)
++ ${BSD_INSTALL_SCRIPT} ../scripts/povsubst $(XAEROBIN)
++ ${BSD_INSTALL_SCRIPT} ../scripts/rayclear $(XAEROBIN)
++ ${BSD_INSTALL_SCRIPT} ../scripts/raystart $(XAEROBIN)
++ ${BSD_INSTALL_SCRIPT} ../scripts/raystat $(XAEROBIN)
+ chmod +x $(XAEROBIN)/raymany
-+ $(CP) ../povray-include/FILELIST.povray-include ${PREFIX}/lib/X11/xaero
-+ $(CP) ../povray-include/aeromat2.inc ${PREFIX}/lib/X11/xaero
-+ $(CP) ../povray-include/aerop1materials.inc ${PREFIX}/lib/X11/xaero
-+ $(CP) ../povray-include/aeropov1.inc ${PREFIX}/lib/X11/xaero
-+ $(CP) ../povray-include/aeropov2.inc ${PREFIX}/lib/X11/xaero
++ sed 's:__XAERO_LIB_PATH__:${PREFIX}/lib/X11/xaero:' ../scripts/raymany > ../scripts/raymany.in
++ ${BSD_INSTALL_SCRIPT} ../scripts/raymany.in $(XAEROBIN)/raymany
++ ${BSD_INSTALL_DATA} ../povray-include/FILELIST.povray-include ${PREFIX}/lib/X11/xaero
++ ${BSD_INSTALL_DATA} ../povray-include/aeromat2.inc ${PREFIX}/lib/X11/xaero
++ ${BSD_INSTALL_DATA} ../povray-include/aerop1materials.inc ${PREFIX}/lib/X11/xaero
++ ${BSD_INSTALL_DATA} ../povray-include/aeropov1.inc ${PREFIX}/lib/X11/xaero
++ ${BSD_INSTALL_DATA} ../povray-include/aeropov2.inc ${PREFIX}/lib/X11/xaero
+ mkdir -p ${PREFIX}/lib/X11/xaero/examples
-+ $(CP) ../examples/* ${PREFIX}/lib/X11/xaero/examples
++ ${BSD_INSTALL_DATA} ../examples/* ${PREFIX}/lib/X11/xaero/examples
all:: xaero
strip xaero
diff --git a/graphics/aero/pkg-descr b/graphics/aero/pkg-descr
index 23ee44914643..79044c913d2b 100644
--- a/graphics/aero/pkg-descr
+++ b/graphics/aero/pkg-descr
@@ -1,9 +1,18 @@
-+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
-++ XAERO README ++
-+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+AERO is a simulation program based on rigid body systems. With the
+built-in 3D editor you can create a virtual scene consisting of
+spheres, boxes (cuboids), cylinders and plains. These objects may be
+connected with links like spring, damper, rod and joint.
-To render the written raytracer files, POVRAY1.0 or newer should be
-used. The included script files for automatic generation of readable
-picture files out of the raytracer files need the "tgatoppm" command
-out of the PBM+ distribution. A special text file called
-README.raytracer explains how to use AERO's raytracing feature.
+Now the simulation can be started and all objects obey to the laws of
+physics. That means gravitation, air resistance, friction and all
+additonal user defined forces are taken into account and set the scene
+into motion. You can watch this sequence similar to watching a video
+tape: play the scene or step back to memory positions and replay or
+you can "wind" back to the beginning or forward to the end of the
+scene.
+
+In addition AERO is capable of creating scene files for the raytracing
+program POV-Ray out of these sequences. This means you can create
+fully rendered animation sequences, e.g. MPEG videos.
+
+WWW: http://www.aero-simulation.de/