aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2014-04-07 23:57:00 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2014-04-07 23:57:00 +0000
commitaec9c758e14011b06b4903213172fc5983218020 (patch)
tree8f3c0e7cc9229f6c095667330afb1879e24d6f16 /graphics
parent69d281f306674f9348138c73e73e2078c4b2373b (diff)
downloadports-aec9c758e14011b06b4903213172fc5983218020.tar.gz
ports-aec9c758e14011b06b4903213172fc5983218020.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/gimp-wavelet-sharpen-plugin/Makefile67
-rw-r--r--graphics/gimp-wavelet-sharpen-plugin/distinfo2
-rw-r--r--graphics/gimp-wavelet-sharpen-plugin/pkg-descr16
-rw-r--r--graphics/gimp-wavelet-sharpen-plugin/pkg-plist20
5 files changed, 106 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index aa7a240c8070..d0d99baf6aff 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -278,6 +278,7 @@
SUBDIR += gimp-save-for-web
SUBDIR += gimp-wavelet-decompose-plugin
SUBDIR += gimp-wavelet-denoise-plugin
+ SUBDIR += gimp-wavelet-sharpen-plugin
SUBDIR += gimpfx-foundry
SUBDIR += giram
SUBDIR += gkrellkam2
diff --git a/graphics/gimp-wavelet-sharpen-plugin/Makefile b/graphics/gimp-wavelet-sharpen-plugin/Makefile
new file mode 100644
index 000000000000..4aa2964145c5
--- /dev/null
+++ b/graphics/gimp-wavelet-sharpen-plugin/Makefile
@@ -0,0 +1,67 @@
+# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= wavelet-sharpen
+PORTVERSION= 0.1.2
+CATEGORIES= graphics
+MASTER_SITES= http://registry.gimp.org/files/
+PKGNAMEPREFIX= gimp-
+PKGNAMESUFFIX= -plugin
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= GIMP plugin to sharpen by increasing contrast in high frequency space
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gimp-2.0.pc:${PORTSDIR}/graphics/gimp-app
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gimp-2.0.pc:${PORTSDIR}/graphics/gimp-app
+
+OPTIONS_DEFINE= NLS OPTIMIZED_CFLAGS
+OPTIONS_DEFAULT= OPTIMIZED_CFLAGS
+OPTIONS_SUB= yes
+
+USES= gettext gmake
+
+PLIST_SUB= GIMP_PLUGIN_DIR=${GIMP_PLUGIN_DIR}
+GIMP_PLUGIN_DIR= libexec/gimp/2.2/plug-ins
+
+# l10n languages
+LANGUAGES= de et it pl ru
+
+.include <bsd.port.options.mk>
+
+# optimized CFLAGS
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
+CFLAGS+= -O3
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|gimptool-2.0|${LOCALBASE}/bin/gimptool-2.0|' \
+ ${WRKSRC}/src/Makefile
+#
+## l10n
+# disable l10n if appropriate
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -E \
+ -e 's|(^all:.*)po |\1|' \
+ ${WRKSRC}/Makefile
+.endif
+
+do-install:
+# plugin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${GIMP_PLUGIN_DIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/${GIMP_PLUGIN_DIR}
+#
+## l10n
+#
+.if ${PORT_OPTIONS:MNLS}
+.for language in ${LANGUAGES}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/locale/${language}/LC_MESSAGES/
+ ${INSTALL_DATA} ${WRKSRC}/po/${language}.mo \
+ ${STAGEDIR}${PREFIX}/share/locale/${language}/LC_MESSAGES/gimp20-${PORTNAME}-plug-in.mo
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/gimp-wavelet-sharpen-plugin/distinfo b/graphics/gimp-wavelet-sharpen-plugin/distinfo
new file mode 100644
index 000000000000..9bc4a550ec27
--- /dev/null
+++ b/graphics/gimp-wavelet-sharpen-plugin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (wavelet-sharpen-0.1.2.tar.gz) = 1cf7ee72bc4cdb721ecc3edf995904f508f2b2295006a5762c2f8878cc0c146f
+SIZE (wavelet-sharpen-0.1.2.tar.gz) = 18145
diff --git a/graphics/gimp-wavelet-sharpen-plugin/pkg-descr b/graphics/gimp-wavelet-sharpen-plugin/pkg-descr
new file mode 100644
index 000000000000..95c9ca05d49c
--- /dev/null
+++ b/graphics/gimp-wavelet-sharpen-plugin/pkg-descr
@@ -0,0 +1,16 @@
+The wavelet decomposition of an image results in multiple images
+with different frequency content. When amplifying the high frequency
+parts the recomposed image appears to be sharper than the original
+one. That way the frequency which should be amplified most can also
+be selected and a given unsharpness in the original image can be
+taken into account.
+
+The wavelet sharpen plugin enhances apparent sharpness of an image
+by increasing contrast in high frequency space. The amount of
+unsharpness of the original image can be taken into account by
+adjusting the sharpening radius. As an option you can choose to
+sharpen the luminance (YCbCr) channel of the image only.
+
+The plugin can be found under "Filters > Enhance > Wavelet sharpen"
+
+WWW: http://registry.gimp.org/node/9836
diff --git a/graphics/gimp-wavelet-sharpen-plugin/pkg-plist b/graphics/gimp-wavelet-sharpen-plugin/pkg-plist
new file mode 100644
index 000000000000..99d28c60078d
--- /dev/null
+++ b/graphics/gimp-wavelet-sharpen-plugin/pkg-plist
@@ -0,0 +1,20 @@
+%%GIMP_PLUGIN_DIR%%/wavelet-sharpen
+%%NLS%%share/locale/de/LC_MESSAGES/gimp20-wavelet-sharpen-plug-in.mo
+%%NLS%%share/locale/et/LC_MESSAGES/gimp20-wavelet-sharpen-plug-in.mo
+%%NLS%%share/locale/it/LC_MESSAGES/gimp20-wavelet-sharpen-plug-in.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/gimp20-wavelet-sharpen-plug-in.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/gimp20-wavelet-sharpen-plug-in.mo
+@dirrmtry %%GIMP_PLUGIN_DIR%%
+@dirrmtry libexec/gimp/2.2
+@dirrmtry libexec/gimp
+%%NLS%%@dirrmtry share/locale/de/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/de
+%%NLS%%@dirrmtry share/locale/et/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/et
+%%NLS%%@dirrmtry share/locale/it/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/it
+%%NLS%%@dirrmtry share/locale/pl/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/pl
+%%NLS%%@dirrmtry share/locale/ru/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ru
+%%NLS%%@dirrmtry share/locale