aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /graphics
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
downloadports-7887c684adab042fed1bfcba2e91589ecd17c4a8.tar.gz
ports-7887c684adab042fed1bfcba2e91589ecd17c4a8.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/clutter/Makefile22
-rw-r--r--graphics/clutter/pkg-descr2
-rw-r--r--graphics/colord/Makefile64
-rw-r--r--graphics/colord/distinfo2
-rw-r--r--graphics/colord/files/patch-Makefile.in11
-rw-r--r--graphics/colord/files/patch-client_Makefile.in13
-rw-r--r--graphics/colord/pkg-descr4
-rw-r--r--graphics/colord/pkg-plist119
-rw-r--r--graphics/dia/Makefile4
-rw-r--r--graphics/epdfview/Makefile4
-rw-r--r--graphics/gdk-pixbuf2/Makefile50
-rw-r--r--graphics/gdk-pixbuf2/distinfo4
-rw-r--r--graphics/gdk-pixbuf2/files/patch-gdk-pixbuf_io-xbm.c44
-rw-r--r--graphics/gdk-pixbuf2/pkg-plist14
-rw-r--r--graphics/glitz/Makefile8
-rw-r--r--graphics/gtk-update-icon-cache/Makefile36
-rw-r--r--graphics/gtk-update-icon-cache/distinfo4
-rw-r--r--graphics/lensfun/Makefile1
-rw-r--r--graphics/libart_lgpl/Makefile8
-rw-r--r--graphics/libchamplain/Makefile8
-rw-r--r--graphics/libsvg-cairo/Makefile14
-rw-r--r--graphics/shotwell/Makefile2
23 files changed, 295 insertions, 144 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 419bdb2ee363..d5bef0eb5b8e 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -94,6 +94,7 @@
SUBDIR += clutter
SUBDIR += clutter-box2d
SUBDIR += clutter-gtk
+ SUBDIR += colord
SUBDIR += comical
SUBDIR += comix
SUBDIR += commons-utilities
diff --git a/graphics/clutter/Makefile b/graphics/clutter/Makefile
index 8681562a5ff5..05b2660dad90 100644
--- a/graphics/clutter/Makefile
+++ b/graphics/clutter/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: clutter
-# Date created: 2008-12-25
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
+# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/graphics/clutter/Makefile,v 1.34 2010/09/24 16:35:42 kwm Exp $
-#
PORTNAME= clutter
PORTVERSION= 1.4.0
@@ -16,15 +12,16 @@ MASTER_SITES= GNOME \
MAINTAINER= gnome@FreeBSD.org
COMMENT= OpenGL based interactive canvas library
-LIB_DEPENDS= json-glib-1.0.0:${PORTSDIR}/devel/json-glib
+LIB_DEPENDS= json-glib-1.0:${PORTSDIR}/devel/json-glib
LICENSE= LGPL21
-LICENSE_FILE= ${WRKSRC}/COPYING
+
USE_GMAKE= yes
USE_GETTEXT= yes
USE_BZIP2= yes
USE_AUTOTOOLS= libtool
-USE_GNOME= pkgconfig gdkpixbuf2 gnomehack ltverhack gnomeprefix atk pango
+USE_GNOME= gdkpixbuf2 gnomehack ltverhack gnomeprefix atk pango
+USE_PKGCONFIG= build
USE_GL= gl
USE_XORG= glproto x11 xfixes xdamage xcomposite xi
USE_LDCONFIG= yes
@@ -33,4 +30,13 @@ CONFIGURE_ARGS= --with-x --enable-conformance=no
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+post-patch:
+ @${REINPLACE_CMD} -e 's|G_CONST_RETURN|const|g' \
+ ${WRKSRC}/clutter/cally/*.c \
+ ${WRKSRC}/clutter/*.[ch] \
+ ${WRKSRC}/clutter/glx/*.c \
+ ${WRKSRC}/clutter/x11/*.h \
+ ${WRKSRC}/clutter/cogl/cogl/*.h \
+ ${WRKSRC}/clutter/json/*.c
+
.include <bsd.port.mk>
diff --git a/graphics/clutter/pkg-descr b/graphics/clutter/pkg-descr
index 593f4afbc1db..347482b0cf49 100644
--- a/graphics/clutter/pkg-descr
+++ b/graphics/clutter/pkg-descr
@@ -1,4 +1,4 @@
Clutter it an open source software library for creating fast, visually
rich and animated graphical user interfaces.
-WWW: http://clutter-project.org/
+WWW: https://live.gnome.org/Clutter
diff --git a/graphics/colord/Makefile b/graphics/colord/Makefile
new file mode 100644
index 000000000000..7fc3ff6e89c2
--- /dev/null
+++ b/graphics/colord/Makefile
@@ -0,0 +1,64 @@
+# Created by: Koop Mast <kwm@FreeBSD.org>
+# $FreeBSD$
+# $MCom: ports/graphics/colord/Makefile,v 1.10 2012/12/17 23:50:40 kwm Exp $
+
+PORTNAME= colord
+PORTVERSION= 0.1.20
+PORTREVISION= 1
+CATEGORIES= graphics
+MASTER_SITES= http://www.freedesktop.org/software/colord/releases/
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= Manage color profiles to accurately color input/output devices
+
+BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection \
+ vala-vapigen>=0.13.0:${PORTSDIR}/lang/vala-vapigen
+LIB_DEPENDS= polkit-gobject-1:${PORTSDIR}/sysutils/polkit \
+ dbus-1:${PORTSDIR}/devel/dbus \
+ lcms2:${PORTSDIR}/graphics/lcms2
+
+USE_XZ= yes
+USE_GNOME= gnomehier gnomehack glib20 intlhack
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_SQLITE= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+MAKE_JOBS_UNSAFE=yes
+CONFIGURE_ARGS= --disable-gudev --enable-gtk-doc-html=no --disable-gtk
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= USB_CFLAGS="-I/usr/include" \
+ USB_LIBS="-L/usr/lib -lusb"
+
+OPTIONS_DEFINE= SANE MANPAGES
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSANE}
+CONFIGURE_ARGS+=--disable-sane
+.else
+CONFGIURE_ARGS+=--enable-sane=yes
+LIB_DEPENDS+= sane.1:${PORTSDIR}/graphics/sane-backends
+.endif
+
+.if ${PORT_OPTIONS:MMANPAGES}
+BUILD_DEPENDS+= docbook2html:${PORTSDIR}/textproc/docbook-utils \
+ ${LOCALBASE}/share/sgml/docbook/4.1/dtd/catalog:${PORTSDIR}/textproc/docbook-410
+MAN1= cd-create-profile.1 cd-fix-profile.1 colormgr.1
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-Wclobbered||g' \
+ -e 's|-Wempty-body||g' \
+ -e 's|-Wignored-qualifiers||g' \
+ -e 's|-Wtype-limits||g' \
+ -e 's|-Wmissing-parameter-type||g' \
+ -e 's|LIBS="-lusb-1.0|LIBS="-lusb|g' \
+ ${WRKSRC}/configure
+.if empty(PORT_OPTIONS:MMANPAGES}
+ @${REINPLACE_CMD} -e "s|2MAN_TRUE=$$|2MAN_TRUE='#'|g ; \
+ s|2MAN_FALSE='#'|2MAN_FALSE=|g" ${WRKSRC}/configure
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/colord/distinfo b/graphics/colord/distinfo
new file mode 100644
index 000000000000..2db4de59d601
--- /dev/null
+++ b/graphics/colord/distinfo
@@ -0,0 +1,2 @@
+SHA256 (colord-0.1.20.tar.xz) = 45d6e7e73c9eab9f3f3c0eec8d008fd96c147333aeb4a77a2c2695657e48ae58
+SIZE (colord-0.1.20.tar.xz) = 551408
diff --git a/graphics/colord/files/patch-Makefile.in b/graphics/colord/files/patch-Makefile.in
new file mode 100644
index 000000000000..8adde68742b5
--- /dev/null
+++ b/graphics/colord/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2012-05-15 23:46:55.000000000 +0200
++++ Makefile.in 2012-05-15 23:47:27.000000000 +0200
+@@ -329,7 +329,7 @@
+ # this needs libcolord and libcolord-gtk
+
+ # this needs client/cd-create-profile
+-SUBDIRS = etc policy man libcolord rules po $(am__append_1) client \
++SUBDIRS = etc policy man libcolord po $(am__append_1) client \
+ contrib doc examples src data
+ DISTCHECK_CONFIGURE_FLAGS = \
+ --enable-introspection \
diff --git a/graphics/colord/files/patch-client_Makefile.in b/graphics/colord/files/patch-client_Makefile.in
new file mode 100644
index 000000000000..4c832e9f1f11
--- /dev/null
+++ b/graphics/colord/files/patch-client_Makefile.in
@@ -0,0 +1,13 @@
+--- client/Makefile.in.orig 2012-05-16 20:35:37.000000000 +0200
++++ client/Makefile.in 2012-05-16 20:35:57.000000000 +0200
+@@ -36,8 +36,8 @@
+ POST_UNINSTALL = :
+ build_triplet = @build@
+ host_triplet = @host@
+-bin_PROGRAMS = colormgr$(EXEEXT) cd-create-profile$(EXEEXT) \
+- cd-fix-profile$(EXEEXT)
++@HAVE_GTK_TRUE@bin_PROGRAMS = colormgr$(EXEEXT) cd-create-profile$(EXEEXT) \
++@HAVE_GTK_TRUE@ cd-fix-profile$(EXEEXT)
+ @HAVE_GTK_TRUE@noinst_PROGRAMS = colord-convert$(EXEEXT)
+ subdir = client
+ DIST_COMMON = $(dist_bashcompletion_DATA) $(srcdir)/Makefile.am \
diff --git a/graphics/colord/pkg-descr b/graphics/colord/pkg-descr
new file mode 100644
index 000000000000..8d30a2bf0883
--- /dev/null
+++ b/graphics/colord/pkg-descr
@@ -0,0 +1,4 @@
+colord is a system service that makes it easy to manage, install and generate
+color profiles to accurately color manage input and output devices.
+
+WWW: http://www.freedesktop.org/software/colord
diff --git a/graphics/colord/pkg-plist b/graphics/colord/pkg-plist
new file mode 100644
index 000000000000..d48f60969fca
--- /dev/null
+++ b/graphics/colord/pkg-plist
@@ -0,0 +1,119 @@
+etc/bash_completion.d/colormgr-completion.bash
+etc/colord.conf
+etc/dbus-1/system.d/org.freedesktop.ColorManager.conf
+etc/dbus-1/system.d/org.freedesktop.colord-sane.conf
+include/colord-1/colord.h
+include/colord-1/colord-private.h
+include/colord-1/colord/cd-client-sync.h
+include/colord-1/colord/cd-client.h
+include/colord-1/colord/cd-color.h
+include/colord-1/colord/cd-device-sync.h
+include/colord-1/colord/cd-device.h
+include/colord-1/colord/cd-enum.h
+include/colord-1/colord/cd-it8.h
+include/colord-1/colord/cd-it8-utils.h
+include/colord-1/colord/cd-math.h
+include/colord-1/colord/cd-profile-sync.h
+include/colord-1/colord/cd-profile.h
+include/colord-1/colord/cd-sensor-sync.h
+include/colord-1/colord/cd-sensor.h
+include/colord-1/colord/cd-version.h
+lib/colord-sensors/libcolord_sensor_dummy.a
+lib/colord-sensors/libcolord_sensor_dummy.la
+lib/colord-sensors/libcolord_sensor_dummy.so
+lib/girepository-1.0/Colord-1.0.typelib
+lib/libcolord.a
+lib/libcolord.la
+lib/libcolord.so
+lib/libcolord.so.1
+libdata/pkgconfig/colord.pc
+libexec/colord
+share/color/icc/colord/crayons.icc
+share/color/icc/colord/x11-colors.icc
+share/dbus-1/interfaces/org.freedesktop.ColorManager.Device.xml
+share/dbus-1/interfaces/org.freedesktop.ColorManager.Profile.xml
+share/dbus-1/interfaces/org.freedesktop.ColorManager.Sensor.xml
+share/dbus-1/interfaces/org.freedesktop.ColorManager.xml
+share/dbus-1/interfaces/org.freedesktop.colord.sane.xml
+share/dbus-1/system-services/org.freedesktop.ColorManager.service
+share/dbus-1/system-services/org.freedesktop.colord-sane.service
+share/gir-1.0/Colord-1.0.gir
+share/locale/as/LC_MESSAGES/colord.mo
+share/locale/bg/LC_MESSAGES/colord.mo
+share/locale/bg_BG/LC_MESSAGES/colord.mo
+share/locale/bn_IN/LC_MESSAGES/colord.mo
+share/locale/ca/LC_MESSAGES/colord.mo
+share/locale/cs/LC_MESSAGES/colord.mo
+share/locale/da/LC_MESSAGES/colord.mo
+share/locale/de/LC_MESSAGES/colord.mo
+share/locale/el/LC_MESSAGES/colord.mo
+share/locale/en_GB/LC_MESSAGES/colord.mo
+share/locale/eo/LC_MESSAGES/colord.mo
+share/locale/es/LC_MESSAGES/colord.mo
+share/locale/eu/LC_MESSAGES/colord.mo
+share/locale/fi/LC_MESSAGES/colord.mo
+share/locale/fr/LC_MESSAGES/colord.mo
+share/locale/ga/LC_MESSAGES/colord.mo
+share/locale/gl/LC_MESSAGES/colord.mo
+share/locale/gu/LC_MESSAGES/colord.mo
+share/locale/he/LC_MESSAGES/colord.mo
+share/locale/hi/LC_MESSAGES/colord.mo
+share/locale/hu/LC_MESSAGES/colord.mo
+share/locale/id/LC_MESSAGES/colord.mo
+share/locale/it/LC_MESSAGES/colord.mo
+share/locale/it_IT/LC_MESSAGES/colord.mo
+share/locale/ja/LC_MESSAGES/colord.mo
+share/locale/kk/LC_MESSAGES/colord.mo
+share/locale/kn/LC_MESSAGES/colord.mo
+share/locale/ko/LC_MESSAGES/colord.mo
+share/locale/lt/LC_MESSAGES/colord.mo
+share/locale/lv/LC_MESSAGES/colord.mo
+share/locale/ml/LC_MESSAGES/colord.mo
+share/locale/mr/LC_MESSAGES/colord.mo
+share/locale/ms/LC_MESSAGES/colord.mo
+share/locale/nb/LC_MESSAGES/colord.mo
+share/locale/nl/LC_MESSAGES/colord.mo
+share/locale/or/LC_MESSAGES/colord.mo
+share/locale/pa/LC_MESSAGES/colord.mo
+share/locale/pl/LC_MESSAGES/colord.mo
+share/locale/pt/LC_MESSAGES/colord.mo
+share/locale/pt_BR/LC_MESSAGES/colord.mo
+share/locale/ro/LC_MESSAGES/colord.mo
+share/locale/ru/LC_MESSAGES/colord.mo
+share/locale/sk/LC_MESSAGES/colord.mo
+share/locale/sl/LC_MESSAGES/colord.mo
+share/locale/sr/LC_MESSAGES/colord.mo
+share/locale/sr@latin/LC_MESSAGES/colord.mo
+share/locale/sv/LC_MESSAGES/colord.mo
+share/locale/ta/LC_MESSAGES/colord.mo
+share/locale/te/LC_MESSAGES/colord.mo
+share/locale/th/LC_MESSAGES/colord.mo
+share/locale/tr/LC_MESSAGES/colord.mo
+share/locale/uk/LC_MESSAGES/colord.mo
+share/locale/zh_CN/LC_MESSAGES/colord.mo
+share/locale/zh_TW/LC_MESSAGES/colord.mo
+share/polkit-1/actions/org.freedesktop.color.policy
+share/vala/vapi/colord.vapi
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/kk/LC_MESSAGES
+@dirrmtry share/locale/kk
+@dirrmtry share/locale/it_IT/LC_MESSAGES
+@dirrmtry share/locale/it_IT
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/bg_BG/LC_MESSAGES
+@dirrmtry share/locale/bg_BG
+@dirrmtry share/locale/as/LC_MESSAGES
+@dirrmtry share/locale/as
+@dirrm share/color/icc/colord
+@dirrm share/color/icc
+@dirrm share/color
+@dirrm lib/colord-sensors
+@dirrm include/colord-1/colord
+@dirrm include/colord-1
+@dirrmtry etc/bash_completion.d
diff --git a/graphics/dia/Makefile b/graphics/dia/Makefile
index c0dfb727ef80..b5b2b6824c21 100644
--- a/graphics/dia/Makefile
+++ b/graphics/dia/Makefile
@@ -71,6 +71,10 @@ PLIST_SUB+= GNOME="@comment "
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/lib/intl.c
+ @${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
+ ${WRKSRC}/objects/custom/shape_typeinfo.c \
+ ${WRKSRC}/tests/test-objects.c \
+ ${WRKSRC}/tests/test-boundingbox.c
.if defined(NOPORTDOCS)
@${FIND} ${WRKSRC}/doc -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|$$(examples)||g ; s|$$(mkinstalldirs) $$(sysdoc)/examples||g ; \
diff --git a/graphics/epdfview/Makefile b/graphics/epdfview/Makefile
index b5acfb7dfce2..4efbce1e1ab5 100644
--- a/graphics/epdfview/Makefile
+++ b/graphics/epdfview/Makefile
@@ -53,6 +53,10 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
+ ${WRKSRC}/src/gtk/StockIcons.h
+
post-install:
${REINPLACE_CMD} -e 's,Icon.*,Icon=${DATADIR}/pixmaps/icon_epdfview-48.png,' ${WRKSRC}/data/${PORTNAME}.desktop
${MKDIR} ${PREFIX}/share/applications
diff --git a/graphics/gdk-pixbuf2/Makefile b/graphics/gdk-pixbuf2/Makefile
index 73a127b0a42b..e855f934d806 100644
--- a/graphics/gdk-pixbuf2/Makefile
+++ b/graphics/gdk-pixbuf2/Makefile
@@ -1,17 +1,12 @@
-# New ports collection makefile for: gdk-pixbuf
-# Date created: 5th October 1999
-# Whom: Ade Lovett <ade@lovett.com>
-#
+# Created by: Ade Lovett <ade@lovett.com>
# $FreeBSD$
-# $MCom: ports/graphics/gdk-pixbuf2/Makefile,v 1.15 2011/06/27 21:10:23 kwm Exp $
+# $MCom: ports/graphics/gdk-pixbuf2/Makefile,v 1.28 2012/12/10 12:09:15 kwm Exp $
-PORTNAME?= gdk-pixbuf
-PORTVERSION= 2.23.5
-PORTREVISION= 3
-CATEGORIES?= graphics
+PORTNAME= gdk-pixbuf
+PORTVERSION= 2.26.5
+CATEGORIES= graphics
MASTER_SITES= GNOME
-MASTER_SITE_SUBDIR= sources/gdk-pixbuf/${PORTVERSION:R}
-DISTNAME= gdk-pixbuf-${PORTVERSION}
+PKGNAMESUFFIX= 2
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -21,49 +16,49 @@ BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
LATEST_LINK= gdk-pixbuf2
USE_XZ= yes
+USE_GETTEXT= yes
USE_GMAKE= yes
USE_XORG= xt xi x11
USE_AUTOTOOLS= libtool
USE_GNOME+= gnomehack glib20 ltverhack
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ARGS= --enable-introspection=yes
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --enable-introspection=yes --with-x11
MAN1= gdk-pixbuf-csource.1 gdk-pixbuf-query-loaders.1
-OPTIONS= JP2 "JPEG2000 support" ON \
- JPEG "JPEG support" ON \
- PNG "PNG support" ON \
- TIFF "TIFF support" ON
+OPTIONS_DEFINE= JASPER JPEG PNG TIFF NLS
+OPTIONS_DEFAULT=JASPER JPEG PNG TIFF NLS
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:M_NLS}
+USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if !defined(WITHOUT_JP2)
-LIB_DEPENDS+= jasper.4:${PORTSDIR}/graphics/jasper
+.if ${PORT_OPTIONS:MJASPER}
+LIB_DEPENDS+= jasper:${PORTSDIR}/graphics/jasper
CONFIGURE_ARGS+=--with-libjasper
PLIST_SUB+= JP2=""
.else
PLIST_SUB+= JP2="@comment "
.endif
-.if !defined(WITHOUT_JPEG)
-LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
+.if ${PORT_OPTIONS:MJPEG}
+LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg
PLIST_SUB+= JPEG=""
.else
CONFIGURE_ARGS+=--without-libjpeg
PLIST_SUB+= JPEG="@comment "
.endif
-.if !defined(WITHOUT_PNG)
+.if ${PORT_OPTIONS:MPNG}
LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
PLIST_SUB+= PNG=""
.else
@@ -71,18 +66,15 @@ CONFIGURE_ARGS+=--without-libpng
PLIST_SUB+= PNG="@comment "
.endif
-.if !defined(WITHOUT_TIFF)
-LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
+.if ${PORT_OPTIONS:MTIFF}
+LIB_DEPENDS+= tiff:${PORTSDIR}/graphics/tiff
PLIST_SUB+= TIFF=""
.else
CONFIGURE_ARGS+=--without-libtiff
PLIST_SUB+= TIFF="@comment "
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|" == "|" = "|g' ${WRKSRC}/configure
-
post-install:
- @cd ${WRKSRC}/docs/reference/gdk-pixbuf && gmake install-man1
+ @cd ${WRKSRC}/docs/reference/gdk-pixbuf && ${GMAKE} install-man1
.include <bsd.port.mk>
diff --git a/graphics/gdk-pixbuf2/distinfo b/graphics/gdk-pixbuf2/distinfo
index a63a71c51324..b694e8216b8e 100644
--- a/graphics/gdk-pixbuf2/distinfo
+++ b/graphics/gdk-pixbuf2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome2/gdk-pixbuf-2.23.5.tar.xz) = 7a6c3550426f38f6b0eeeb49295654d9e706ce8f1786a4d0932f9d2c0d0bc500
-SIZE (gnome2/gdk-pixbuf-2.23.5.tar.xz) = 1171372
+SHA256 (gnome2/gdk-pixbuf-2.26.5.tar.xz) = 77696fd163bca95a130a1883dbd78d0ae4d782de2fc85a9a38556d13681f5c84
+SIZE (gnome2/gdk-pixbuf-2.26.5.tar.xz) = 1181336
diff --git a/graphics/gdk-pixbuf2/files/patch-gdk-pixbuf_io-xbm.c b/graphics/gdk-pixbuf2/files/patch-gdk-pixbuf_io-xbm.c
deleted file mode 100644
index e2e0805a355c..000000000000
--- a/graphics/gdk-pixbuf2/files/patch-gdk-pixbuf_io-xbm.c
+++ /dev/null
@@ -1,44 +0,0 @@
-From 4f0f465f991cd454d03189497f923eb40c170c22 Mon Sep 17 00:00:00 2001
-From: Matthias Clasen <mclasen@redhat.com>
-Date: Sat, 14 Apr 2012 18:21:09 +0000
-Subject: Avoid an integer overflow in the xbm loader
-
-At the same time, reject some silly input, such as negative
-width or height.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=672811
----
-diff --git a/gdk-pixbuf/io-xbm.c b/gdk-pixbuf/io-xbm.c
-index 46653b9..4f3e1e8 100644
---- gdk-pixbuf/io-xbm.c
-+++ gdk-pixbuf/io-xbm.c
-@@ -183,10 +183,16 @@ read_bitmap_file_data (FILE *fstream,
- type++;
- }
-
-- if (!strcmp ("width", type))
-+ if (!strcmp ("width", type)) {
-+ if (value <= 0)
-+ RETURN (FALSE);
- ww = (unsigned int) value;
-- if (!strcmp ("height", type))
-+ }
-+ if (!strcmp ("height", type)) {
-+ if (value <= 0)
-+ RETURN (FALSE);
- hh = (unsigned int) value;
-+ }
- if (!strcmp ("hot", type)) {
- if (type-- == name_and_type
- || type-- == name_and_type)
-@@ -231,6 +237,8 @@ read_bitmap_file_data (FILE *fstream,
- bytes_per_line = (ww+7)/8 + padding;
-
- size = bytes_per_line * hh;
-+ if (size / bytes_per_line != hh) /* overflow */
-+ RETURN (FALSE);
- bits = g_malloc (size);
-
- if (version10p) {
---
-cgit v0.9.0.2
diff --git a/graphics/gdk-pixbuf2/pkg-plist b/graphics/gdk-pixbuf2/pkg-plist
index b5f7a82a9998..f746a52fad9a 100644
--- a/graphics/gdk-pixbuf2/pkg-plist
+++ b/graphics/gdk-pixbuf2/pkg-plist
@@ -1,4 +1,5 @@
bin/gdk-pixbuf-csource
+bin/gdk-pixbuf-pixdata
bin/gdk-pixbuf-query-loaders
include/gdk-pixbuf-2.0/gdk-pixbuf-xlib/gdk-pixbuf-xlib.h
include/gdk-pixbuf-2.0/gdk-pixbuf-xlib/gdk-pixbuf-xlibrgb.h
@@ -98,9 +99,9 @@ share/gir-1.0/GdkPixbuf-2.0.gir
%%NLS%%share/locale/de/LC_MESSAGES/gdk-pixbuf.mo
%%NLS%%share/locale/dz/LC_MESSAGES/gdk-pixbuf.mo
%%NLS%%share/locale/el/LC_MESSAGES/gdk-pixbuf.mo
+%%NLS%%share/locale/en@shaw/LC_MESSAGES/gdk-pixbuf.mo
%%NLS%%share/locale/en_CA/LC_MESSAGES/gdk-pixbuf.mo
%%NLS%%share/locale/en_GB/LC_MESSAGES/gdk-pixbuf.mo
-%%NLS%%share/locale/en@shaw/LC_MESSAGES/gdk-pixbuf.mo
%%NLS%%share/locale/eo/LC_MESSAGES/gdk-pixbuf.mo
%%NLS%%share/locale/es/LC_MESSAGES/gdk-pixbuf.mo
%%NLS%%share/locale/et/LC_MESSAGES/gdk-pixbuf.mo
@@ -123,6 +124,7 @@ share/gir-1.0/GdkPixbuf-2.0.gir
%%NLS%%share/locale/it/LC_MESSAGES/gdk-pixbuf.mo
%%NLS%%share/locale/ja/LC_MESSAGES/gdk-pixbuf.mo
%%NLS%%share/locale/ka/LC_MESSAGES/gdk-pixbuf.mo
+%%NLS%%share/locale/km/LC_MESSAGES/gdk-pixbuf.mo
%%NLS%%share/locale/kn/LC_MESSAGES/gdk-pixbuf.mo
%%NLS%%share/locale/ko/LC_MESSAGES/gdk-pixbuf.mo
%%NLS%%share/locale/ku/LC_MESSAGES/gdk-pixbuf.mo
@@ -178,7 +180,7 @@ share/gir-1.0/GdkPixbuf-2.0.gir
%%NLS%%share/locale/zh_HK/LC_MESSAGES/gdk-pixbuf.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/gdk-pixbuf.mo
@exec %D/bin/gdk-pixbuf-query-loaders > /dev/null 2>&1 && %D/bin/gdk-pixbuf-query-loaders > %D/lib/gdk-pixbuf-2.0/%%GTK2_VERSION%%/loaders.cache 2>/dev/null || /usr/bin/true
-@unexec rm %D/lib/gdk-pixbuf-2.0/%%GTK2_VERSION%%/loaders.cache
+@unexec rm %D/lib/gdk-pixbuf-2.0/%%GTK2_VERSION%%/loaders.cache 2>&1 >/dev/null || true
%%NLS%%@dirrmtry share/locale/zh_HK/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/zh_HK
%%NLS%%@dirrmtry share/locale/yi/LC_MESSAGES
@@ -217,6 +219,8 @@ share/gir-1.0/GdkPixbuf-2.0.gir
%%NLS%%@dirrmtry share/locale/mai
%%NLS%%@dirrmtry share/locale/ku/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ku
+%%NLS%%@dirrmtry share/locale/km/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/km
%%NLS%%@dirrmtry share/locale/io/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/io
%%NLS%%@dirrmtry share/locale/ia/LC_MESSAGES
@@ -241,11 +245,9 @@ share/gir-1.0/GdkPixbuf-2.0.gir
%%NLS%%@dirrmtry share/locale/as
%%NLS%%@dirrmtry share/locale/ang/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ang
-@dirrmtry share/gir-1.0
-@dirrm lib/gdk-pixbuf-2.0/%%GTK2_VERSION%%/loaders/
+@dirrm lib/gdk-pixbuf-2.0/%%GTK2_VERSION%%/loaders
@dirrm lib/gdk-pixbuf-2.0/%%GTK2_VERSION%%
@dirrm lib/gdk-pixbuf-2.0
-@dirrmtry lib/girepository-1.0
-@dirrm include/gdk-pixbuf-2.0/gdk-pixbuf
@dirrm include/gdk-pixbuf-2.0/gdk-pixbuf-xlib
+@dirrm include/gdk-pixbuf-2.0/gdk-pixbuf
@dirrm include/gdk-pixbuf-2.0
diff --git a/graphics/glitz/Makefile b/graphics/glitz/Makefile
index 29895d3e281a..01b89a45b3af 100644
--- a/graphics/glitz/Makefile
+++ b/graphics/glitz/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: glitz
-# Date created: 2004-10-06
-# Whom: Michael Johnson <ahze@ahze.net>
-#
+# Created by: Michael Johnson <ahze@ahze.net>
# $FreeBSD$
# $MCom: ports/graphics/glitz/Makefile,v 1.8 2006/09/10 00:51:10 mezz Exp $
-#
PORTNAME= glitz
PORTVERSION= 0.5.6
@@ -17,7 +13,7 @@ COMMENT= OpenGL image compositing library
USE_GL= yes
USE_XORG= xt
-USE_GNOME= pkgconfig gnomehack
+USE_GNOME= gnomehack
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/graphics/gtk-update-icon-cache/Makefile b/graphics/gtk-update-icon-cache/Makefile
index f581765f6628..3254f198b5b5 100644
--- a/graphics/gtk-update-icon-cache/Makefile
+++ b/graphics/gtk-update-icon-cache/Makefile
@@ -1,37 +1,26 @@
-# New ports collection makefile for: gtk-update-icon-cache
-# Date Created: 4 Mar 2011
-# Whom: Koop Mast <kwm@FreeBSD.org>
-#
+# Created by: Koop Mast <kwm@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/graphics/gtk-update-icon-cache/Makefile,v 1.6 2011/06/16 17:36:39 kwm Exp $
-#
+# $MCom: ports/graphics/gtk-update-icon-cache/Makefile,v 1.18 2013/03/04 17:44:37 kwm Exp $
PORTNAME= gtk-update-icon-cache
-PORTVERSION= 2.24.6
-PORTREVISION?= 1
+PORTVERSION= 2.24.17
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/,} \
- ftp://ftp.gtk.org/pub/gtk/%SUBDIR%/ \
- ftp://ftp.gimp.org/pub/%SUBDIR%/ \
- ftp://ftp.cs.umn.edu/pub/gimp/%SUBDIR%/ \
- http://www.ameth.org/gimp/%SUBDIR%/ \
- ftp://ftp.mirror.ac.uk/sites/ftp.gimp.org/pub/%SUBDIR%/ \
- ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,graphics/gimp/%SUBDIR%,}
-MASTER_SITE_SUBDIR= gtk/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+MASTER_SITES= GNOME
+MASTER_SITE_SUBDIR= sources/gtk+/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DISTNAME= gtk+-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= gtk-update-icon-cache utility from the Gtk+ toolkit
+COMMENT= Gtk-update-icon-cache utility from the Gtk+ toolkit
LICENSE= LGPL20
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_XZ= yes
BUILD_DEPENDS+= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
RUN_DEPENDS+= ${LOCALBASE}/share/mime/magic:${PORTSDIR}/misc/shared-mime-info \
${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
+USE_XZ= yes
USE_GMAKE= yes
USE_PERL5_BUILD=yes
MAKE_JOBS_UNSAFE= yes
@@ -43,8 +32,7 @@ USE_XORG= xext xrender x11 xinerama xi xrandr xcursor xfixes xdamage \
xcomposite
PATCHDIR= ${.CURDIR}/../../x11-toolkits/gtk20/files
CONFIGURE_ARGS= --enable-static --with-xinput=yes
-CPPFLAGS+= -I${LOCALBASE}/include/freetype2 \
- -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/gtk-update-icon-cache
@@ -53,10 +41,10 @@ MAN1= gtk-update-icon-cache.1
.include <bsd.port.pre.mk>
pre-configure:
- @if [ ! -f ${LOCALBASE}/libdata/pkgconfig/cairo-xlib.pc ]; then \
- ${ECHO_CMD} "${PKGNAME}: Needs cairo built with X11 support."; \
- ${FALSE}; \
- fi
+.if !exists(${LOCALBASE}/libdata/pkgconfig/cairo-xlib.pc)
+ @${ECHO_CMD} "${PKGNAME}: Needs cairo with X11 support enabled."
+ @${FALSE}
+.endif
do-build:
@cd ${WRKSRC}/gtk && ${GMAKE} gtk-update-icon-cache
diff --git a/graphics/gtk-update-icon-cache/distinfo b/graphics/gtk-update-icon-cache/distinfo
index 164f01198946..e95c6ae937b6 100644
--- a/graphics/gtk-update-icon-cache/distinfo
+++ b/graphics/gtk-update-icon-cache/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome2/gtk+-2.24.6.tar.xz) = 8a026b545dc1fa0c1a69b395232ad7c8ee8fa260be5f7d9a2f2ffcd799efefca
-SIZE (gnome2/gtk+-2.24.6.tar.xz) = 13173032
+SHA256 (gnome2/gtk+-2.24.17.tar.xz) = e947b2b460156d98e8e38930b82458e1d613a71eb26e927f966f7081a640f415
+SIZE (gnome2/gtk+-2.24.17.tar.xz) = 13288028
diff --git a/graphics/lensfun/Makefile b/graphics/lensfun/Makefile
index 1c9fcd84801a..61c09f1737a5 100644
--- a/graphics/lensfun/Makefile
+++ b/graphics/lensfun/Makefile
@@ -16,6 +16,7 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= glib20
+USE_PKGCONFIG= build
USE_LDCONFIG= yes
USE_PYTHON_BUILD= yes
diff --git a/graphics/libart_lgpl/Makefile b/graphics/libart_lgpl/Makefile
index ea7ec5274474..d2015e406f7e 100644
--- a/graphics/libart_lgpl/Makefile
+++ b/graphics/libart_lgpl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libart_lgpl2
-# Date created: 8 July 2001
-# Whom: Hye-Shik Chang <perky@python.or.kr>
-#
+# Created by: Hye-Shik Chang <perky@python.or.kr>
# $FreeBSD$
-#
PORTNAME= libart_lgpl
PORTVERSION= 2.3.21
@@ -19,7 +15,7 @@ COMMENT= Library for high-performance 2D graphics
USE_AUTOTOOLS= libtool
USE_BZIP2= yes
USE_LDCONFIG= yes
-USE_GNOME= gnomehack pkgconfig
+USE_GNOME= gnomehack
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/graphics/libchamplain/Makefile b/graphics/libchamplain/Makefile
index b6c6cfe97a09..b10df0cfb240 100644
--- a/graphics/libchamplain/Makefile
+++ b/graphics/libchamplain/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: libchamplain
-# Date Created: 04 Aug 2009
-# Whom: Koop Mast <kwm@FreeBSD.org>
-#
+# Created by: Koop Mast <kwm@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/graphics/libchamplain/Makefile,v 1.23 2010/09/27 18:17:23 kwm Exp $
-#
PORTNAME= libchamplain
PORTVERSION= 0.8.1
@@ -22,7 +18,7 @@ LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3 \
RUN_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
USE_BZIP2= yes
-USE_GNOME= gnomeprefix pkgconfig gtk20 gnomehack ltverhack:1
+USE_GNOME= gnomeprefix gtk20 gnomehack ltverhack:1
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/graphics/libsvg-cairo/Makefile b/graphics/libsvg-cairo/Makefile
index e2b4858b00df..1d43046ffecc 100644
--- a/graphics/libsvg-cairo/Makefile
+++ b/graphics/libsvg-cairo/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: libsvg-cairo
-# Date created: 2004-10-06
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/graphics/libsvg-cairo/Makefile,v 1.5 2005/08/09 04:49:38 ahze Exp $
-#
PORTNAME= libsvg-cairo
PORTVERSION= 0.1.6
@@ -15,13 +11,13 @@ MASTER_SITES= http://cairographics.org/snapshots/
MAINTAINER= gnome@FreeBSD.org
COMMENT= SVG rendering library
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- svg.1:${PORTSDIR}/graphics/libsvg \
- cairo.2:${PORTSDIR}/graphics/cairo
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
+ svg:${PORTSDIR}/graphics/libsvg \
+ cairo:${PORTSDIR}/graphics/cairo
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
-USE_GNOME= pkgconfig gnomehack
+USE_GNOME= gnomehack
USE_LDCONFIG= yes
PLIST_FILES= include/svg-cairo.h \
lib/libsvg-cairo.a \
diff --git a/graphics/shotwell/Makefile b/graphics/shotwell/Makefile
index 76a5ce4d232a..ddd63acfa0f7 100644
--- a/graphics/shotwell/Makefile
+++ b/graphics/shotwell/Makefile
@@ -15,7 +15,7 @@ LICENSE= LGPL21
BUILD_DEPENDS= vala>=0.12.0:${PORTSDIR}/lang/vala
LIB_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3 \
dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
- gee:${PORTSDIR}/devel/libgee \
+ gee:${PORTSDIR}/devel/libgee06 \
json-glib-1.0:${PORTSDIR}/devel/json-glib \
soup-2.4:${PORTSDIR}/devel/libsoup \
gexiv2:${PORTSDIR}/graphics/gexiv2 \