aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorJoseph S. Atkinson <jsa@FreeBSD.org>2011-04-23 02:34:05 +0000
committerJoseph S. Atkinson <jsa@FreeBSD.org>2011-04-23 02:34:05 +0000
commitaa90b51026b558a211a55522430903856ddf3aca (patch)
tree44a653f94b2f0a5addd9078f891c0a467867df73 /graphics
parentb0852c055902cb3545257b2de1875774e664c9ce (diff)
downloadports-aa90b51026b558a211a55522430903856ddf3aca.tar.gz
ports-aa90b51026b558a211a55522430903856ddf3aca.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libprojectm/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/graphics/libprojectm/Makefile b/graphics/libprojectm/Makefile
index 0b00bb15c8f0..936f5aebd6cd 100644
--- a/graphics/libprojectm/Makefile
+++ b/graphics/libprojectm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libprojectM
PORTVERSION= 2.0.1
+PORTREVISION= 1
CATEGORIES= graphics audio
MASTER_SITES= SF/${PORTNAME:L:S/lib//}/${PORTVERSION}/
DISTNAME= ${PORTNAME:S/lib//}-${DISTVERSION}-Source
@@ -27,11 +28,15 @@ USE_LDCONFIG= yes
post-patch:
# Install config.inp.sample instead of overwriting user's file.
# Needs to be specific enough not to rename config.inp.in too!
+# Also correct pkgconfig destination dir -- fiddly
@${REINPLACE_CMD} -e 's/config.inp\([\" ]\)/config.inp.sample\1/' \
- -e 's#/pkgconfig#data/pkgconfig#' \
+ -e 's#\(/lib\)[^}]*}\(/pkgconfig\)#\1data\2#' \
${WRKSRC}/CMakeLists.txt
@${REINPLACE_CMD} -e 's#/usr/X11R6#${LOCALBASE}#' \
${WRKSRC}/cmake/FindFreetype2.cmake
+# Fix empty libdir in pkgconfig file to stop vlc complaining
+ @${REINPLACE_CMD} -e 's#^\(libdir=\).*#\1${PREFIX}/lib#' \
+ ${WRKSRC}/${PORTNAME}.pc.in
post-install:
@if [ ! -f ${PREFIX}/share/projectM/config.inp ]; then \