aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2011-07-21 05:03:02 +0000
committerMark Linimon <linimon@FreeBSD.org>2011-07-21 05:03:02 +0000
commit06e66777937202f04d646d24d24f524b13d79478 (patch)
tree85a44213b1929b12051c17091ea4ad53f819456b /graphics
parent63d4112e2e682002806fc4c52da2481ae7f045e7 (diff)
Now that the Java 1.3 and Java 1.4 ports are deprecated and will expire soon,
remove support for them from bsd.java.mk. As Jikes is not available in Java 1.5 or higher, remove it from bsd.java.mk too (suggested by hq@) and from the ports which used it (only occurences were USE_JIKES=no). Support for the Blackdown VM is also removed, as it is not available in Java 1.5 and higher. Also remove the mapping from Java 1.1-1.4 to Java 1.5+ in bsd.java.mk to detect old, broken ports; therefore bump the minimal value of JAVA_VERSION to 1.5. While here, replace static values of JAVA_VERSION in files/*.in by %%JAVA_VERSION%% . PR: ports/158969 Submitted by: rene Tested on: pointyhat-west -exp
Notes
Notes: svn path=/head/; revision=278068
Diffstat (limited to 'graphics')
-rw-r--r--graphics/aoi/Makefile2
-rw-r--r--graphics/barbecue/Makefile2
-rw-r--r--graphics/batik/Makefile1
-rw-r--r--graphics/cairo-java/Makefile2
-rw-r--r--graphics/cosmoplayer/Makefile2
-rw-r--r--graphics/jave6/Makefile2
-rw-r--r--graphics/jdraw/Makefile4
-rw-r--r--graphics/jdraw/files/jdraw.in6
-rw-r--r--graphics/jogl/Makefile2
-rw-r--r--graphics/jpatch/Makefile2
-rw-r--r--graphics/jpatch/files/jpatch.sh.in2
-rw-r--r--graphics/jumpgis-postgis/Makefile2
-rw-r--r--graphics/jumpgis/Makefile2
-rw-r--r--graphics/libpano12/Makefile2
-rw-r--r--graphics/libpano13/Makefile2
-rw-r--r--graphics/mapyrus/Makefile2
-rw-r--r--graphics/opendx/Makefile2
-rw-r--r--graphics/tintfu/Makefile2
-rw-r--r--graphics/tintfu/files/tintfu.sh.in2
19 files changed, 18 insertions, 25 deletions
diff --git a/graphics/aoi/Makefile b/graphics/aoi/Makefile
index 2344d3cb845d..07d80f4f89f7 100644
--- a/graphics/aoi/Makefile
+++ b/graphics/aoi/Makefile
@@ -18,7 +18,7 @@ COMMENT= An open source Java written 3D modelling and rendering studio
RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
USE_ZIP= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/ArtOfIllusion${PORTVERSION:S/.//g}
diff --git a/graphics/barbecue/Makefile b/graphics/barbecue/Makefile
index 64b58cf337a8..14a4d6cc0ed6 100644
--- a/graphics/barbecue/Makefile
+++ b/graphics/barbecue/Makefile
@@ -17,7 +17,7 @@ COMMENT= A Java barcode generator
RUN_DEPENDS= ${JAVALIBDIR}/jdom.jar:${PORTSDIR}/java/jdom
USE_JAVA= yes
-JAVA_VERSION= 1.3+
+JAVA_VERSION= 1.5+
NO_BUILD= yes
JARFILES= ${PORTNAME}-${PORTVERSION}.jar
diff --git a/graphics/batik/Makefile b/graphics/batik/Makefile
index 6c998eed5f75..33562d44eb9f 100644
--- a/graphics/batik/Makefile
+++ b/graphics/batik/Makefile
@@ -19,7 +19,6 @@ COMMENT= SVG Toolkit
USE_ZIP= yes
USE_JAVA= 1.5+
USE_ANT= yes
-USE_JIKES= no
ALL_TARGET= jars all-jar
# Prevent out of memory error during build
MAKE_ENV+= "ANT_OPTS=-Xmx512m"
diff --git a/graphics/cairo-java/Makefile b/graphics/cairo-java/Makefile
index 096e92e9752b..eedd5d08e77e 100644
--- a/graphics/cairo-java/Makefile
+++ b/graphics/cairo-java/Makefile
@@ -24,7 +24,7 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_JAVA= yes
-JAVA_VERSION= 1.2+
+JAVA_VERSION= 1.5+
JAVA_OS= native
USE_GNOME= gnomehack gnometarget
CONFIGURE_ARGS= --without-gcj-compile --with-jardir=${JAVAJARDIR}
diff --git a/graphics/cosmoplayer/Makefile b/graphics/cosmoplayer/Makefile
index af66a9ed8e67..0d30add9763c 100644
--- a/graphics/cosmoplayer/Makefile
+++ b/graphics/cosmoplayer/Makefile
@@ -21,7 +21,7 @@ COMMENT= Java classes to support VRML
RUN_DEPENDS= ${JAVALIBDIR}/java40.jar:${PORTSDIR}/devel/netscape-java40
USE_JAVA= yes
-JAVA_VERSION= 1.3+
+JAVA_VERSION= 1.5+
NO_BUILD= yes
JARFILES= npcosmop211.jar LICENSE.npcosmop211.txt
diff --git a/graphics/jave6/Makefile b/graphics/jave6/Makefile
index fe195a8eec1b..3add132519e0 100644
--- a/graphics/jave6/Makefile
+++ b/graphics/jave6/Makefile
@@ -18,7 +18,7 @@ COMMENT= Java ASCII-Art-Generator
USE_JAVA= YES
USE_ZIP= YES
-JAVA_VERSION= 1.3+
+JAVA_VERSION= 1.5+
NO_BUILD= YES
DATADIR= ${JAVASHAREDIR}/${PORTNAME}
LNKTARGET= ${PREFIX}/bin/jave6
diff --git a/graphics/jdraw/Makefile b/graphics/jdraw/Makefile
index 2cd230b8ec56..ee7fd04ed8e1 100644
--- a/graphics/jdraw/Makefile
+++ b/graphics/jdraw/Makefile
@@ -37,10 +37,8 @@ do-install:
.if defined(WITH_PLASTIC3D)
PLASTIC3D= "-Dlf=\"com.jgoodies.looks.plastic.Plastic3DLookAndFeel\""
-JAVA_VERSION= 1.5+
RUN_DEPENDS+= ${JAVAJARDIR}/looks.jar:${PORTSDIR}/devel/looks
-.else
-JAVA_VERSION= 1.4+
.endif
+JAVA_VERSION= 1.5+
.include <bsd.port.post.mk>
diff --git a/graphics/jdraw/files/jdraw.in b/graphics/jdraw/files/jdraw.in
index d2de0aa702cf..fdf78202b420 100644
--- a/graphics/jdraw/files/jdraw.in
+++ b/graphics/jdraw/files/jdraw.in
@@ -5,11 +5,7 @@ if [ -z "${JAVA_VERSION}" ]; then
JAVA_VERSION="%%JAVA_VERSION%%"
fi
-if [ "${JAVA_VERSION}" \> "1.4" ]; then
- LOOK_AND_FEEL="%%PLASTIC3D%%"
- else
- LOOK_AND_FEEL=
-fi
+LOOK_AND_FEEL="%%PLASTIC3D%%"
exec "%%LOCALBASE%%/bin/java" -cp "%%JAVAJARDIR%%" ${LOOK_AND_FEEL} -jar "%%JDRAWJAR%%" "$@"
diff --git a/graphics/jogl/Makefile b/graphics/jogl/Makefile
index a89492168253..a9b6a5ff144a 100644
--- a/graphics/jogl/Makefile
+++ b/graphics/jogl/Makefile
@@ -46,7 +46,7 @@ USE_ZIP= yes
USE_ANT= yes
USE_LDCONFIG= yes
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
BUILD_WRKSRC= ${WRKSRC}/jogl/make
diff --git a/graphics/jpatch/Makefile b/graphics/jpatch/Makefile
index 5b4b415a8ec5..3194f560b622 100644
--- a/graphics/jpatch/Makefile
+++ b/graphics/jpatch/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
USE_ZIP= yes
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}${DISTVERSION}
diff --git a/graphics/jpatch/files/jpatch.sh.in b/graphics/jpatch/files/jpatch.sh.in
index f06241d0a36a..9f6eda7db431 100644
--- a/graphics/jpatch/files/jpatch.sh.in
+++ b/graphics/jpatch/files/jpatch.sh.in
@@ -2,4 +2,4 @@
#
# $FreeBSD$
-JAVA_VERSION="1.4+" "%%LOCALBASE%%/bin/java" -jar "%%JAVAJARDIR%%/jpatch.jar" "$@"
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" -jar "%%JAVAJARDIR%%/jpatch.jar" "$@"
diff --git a/graphics/jumpgis-postgis/Makefile b/graphics/jumpgis-postgis/Makefile
index b2cd5891e5bf..713a63710229 100644
--- a/graphics/jumpgis-postgis/Makefile
+++ b/graphics/jumpgis-postgis/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= jumpgis:${PORTSDIR}/graphics/jumpgis
TARGET_DIR= ${PREFIX}/jumpgis
USE_JAVA= yes
-JAVA_VERSION= 1.3+
+JAVA_VERSION= 1.5+
USE_ZIP= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
diff --git a/graphics/jumpgis/Makefile b/graphics/jumpgis/Makefile
index 3026d3746797..79f63353a9eb 100644
--- a/graphics/jumpgis/Makefile
+++ b/graphics/jumpgis/Makefile
@@ -23,7 +23,7 @@ EXTRACT_AFTER_ARGS= -d ${WRKSRC}
TARGET_DIR= ${PREFIX}/${PORTNAME}
USE_JAVA= yes
-JAVA_VERSION= 1.3+
+JAVA_VERSION= 1.5+
USE_ZIP= yes
NO_BUILD= yes
WANT_GNOME= yes
diff --git a/graphics/libpano12/Makefile b/graphics/libpano12/Makefile
index 56a674be8e0a..fbf0a079ec70 100644
--- a/graphics/libpano12/Makefile
+++ b/graphics/libpano12/Makefile
@@ -38,7 +38,7 @@ USE_LDCONFIG= yes
.if !defined(WITHOUT_JAVA)
USE_JAVA= yes
-JAVA_VERSION= 1.3+
+JAVA_VERSION= 1.5+
JAVA_OS= native
CONFIGURE_ARGS+= --with-java=${JAVA_HOME}
.else
diff --git a/graphics/libpano13/Makefile b/graphics/libpano13/Makefile
index 1db84c326ada..3e36473e84cd 100644
--- a/graphics/libpano13/Makefile
+++ b/graphics/libpano13/Makefile
@@ -49,7 +49,7 @@ MAN1= \
.if !defined(WITHOUT_JAVA)
USE_JAVA= yes
-JAVA_VERSION= 1.3+
+JAVA_VERSION= 1.5+
JAVA_OS= native
CONFIGURE_ARGS+= --with-java=${JAVA_HOME}
PLIST_SUB= JAVA=""
diff --git a/graphics/mapyrus/Makefile b/graphics/mapyrus/Makefile
index 3d429b2609c1..41007d82a390 100644
--- a/graphics/mapyrus/Makefile
+++ b/graphics/mapyrus/Makefile
@@ -18,7 +18,7 @@ NO_BUILD= yes
NO_WRKSUBDIR= yes
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
USE_ZIP= yes
DATADIR= ${JAVASHAREDIR}/${PORTNAME}
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index d8f0cbdf0602..a4f4e9b6f231 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -52,7 +52,7 @@ CONFIGURE_ARGS+= --without-netcdf
.if defined(WITH_JAVA)
USE_JAVA= yes
-JAVA_VERSION= 1.3+
+JAVA_VERSION= 1.5+
BUILD_DEPENDS+= ${JAVALIBDIR}/npcosmop211.jar:${PORTSDIR}/graphics/cosmoplayer
RUN_DEPENDS+= ${JAVALIBDIR}/npcosmop211.jar:${PORTSDIR}/graphics/cosmoplayer
CONFIGURE_ARGS+= --with-cosmojar-path=${JAVALIBDIR}/npcosmop211.jar \
diff --git a/graphics/tintfu/Makefile b/graphics/tintfu/Makefile
index c31c0cf0c99b..a38a98ed207b 100644
--- a/graphics/tintfu/Makefile
+++ b/graphics/tintfu/Makefile
@@ -25,7 +25,7 @@ EXTRACT_BEFORE_ARGS= # empty
EXTRACT_AFTER_ARGS= .
NO_BUILD= yes
USE_JAVA= yes
-JAVA_VERSION= 1.3+
+JAVA_VERSION= 1.5+
PLIST_FILES= %%JAVAJARDIR%%/${DISTNAME}.jar \
bin/tintfu
diff --git a/graphics/tintfu/files/tintfu.sh.in b/graphics/tintfu/files/tintfu.sh.in
index 4a44d0645a0a..c766004fc83c 100644
--- a/graphics/tintfu/files/tintfu.sh.in
+++ b/graphics/tintfu/files/tintfu.sh.in
@@ -2,4 +2,4 @@
#
# $FreeBSD$
-JAVA_VERSION="1.3+" "%%LOCALBASE%%/bin/java" -jar "%%JAVAJARDIR%%/%%DISTNAME%%.jar"
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" -jar "%%JAVAJARDIR%%/%%DISTNAME%%.jar"