aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-11 06:06:44 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-11 06:06:44 +0000
commit974e7265886195006a966188f7f8d07231c9f8db (patch)
treeb7c0d35b8b4ed3b3671bcbb24cd8d0ffa4316a26 /graphics
parentfcd1f56dfa8bee154a0d51ba0c51868e6920dcc7 (diff)
downloadports-974e7265886195006a966188f7f8d07231c9f8db.tar.gz
ports-974e7265886195006a966188f7f8d07231c9f8db.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/p5-Image-Imgur/Makefile25
-rw-r--r--graphics/p5-Image-Imgur/distinfo3
-rw-r--r--graphics/p5-Image-Imgur/pkg-descr4
-rw-r--r--graphics/p5-Image-Imgur/pkg-plist6
5 files changed, 39 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index bc13e604274f..53fac95c2402 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -640,6 +640,7 @@
SUBDIR += p5-Image-Grab
SUBDIR += p5-Image-Heatmap
SUBDIR += p5-Image-IPTCInfo
+ SUBDIR += p5-Image-Imgur
SUBDIR += p5-Image-Imlib2
SUBDIR += p5-Image-Info
SUBDIR += p5-Image-Magick-Iterator
diff --git a/graphics/p5-Image-Imgur/Makefile b/graphics/p5-Image-Imgur/Makefile
new file mode 100644
index 000000000000..b258dc51c915
--- /dev/null
+++ b/graphics/p5-Image-Imgur/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Image-Imgur
+# Date created: 2010-10-27
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Image-Imgur
+PORTVERSION= 0.01
+CATEGORIES= graphics perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl extension for uploading images to http://imgur.com
+
+RUN_DEPENDS= p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Image::Imgur.3
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-Image-Imgur/distinfo b/graphics/p5-Image-Imgur/distinfo
new file mode 100644
index 000000000000..fdfd980edad9
--- /dev/null
+++ b/graphics/p5-Image-Imgur/distinfo
@@ -0,0 +1,3 @@
+MD5 (Image-Imgur-0.01.tgz) = 12639e5fe98a3349d75ca50d2e64dd4b
+SHA256 (Image-Imgur-0.01.tgz) = 924a6dc3ddcaa0ad70576b4808367ae948dfa8d7b5f766db123d4fabb7461fae
+SIZE (Image-Imgur-0.01.tgz) = 2856
diff --git a/graphics/p5-Image-Imgur/pkg-descr b/graphics/p5-Image-Imgur/pkg-descr
new file mode 100644
index 000000000000..a15f3eceda57
--- /dev/null
+++ b/graphics/p5-Image-Imgur/pkg-descr
@@ -0,0 +1,4 @@
+Image::Imgur intends to make programmatically possible to upload image
+files to the website http://imgur.com.
+
+WWW: http://search.cpan.org/dist/Image-Imgur/
diff --git a/graphics/p5-Image-Imgur/pkg-plist b/graphics/p5-Image-Imgur/pkg-plist
new file mode 100644
index 000000000000..f6dea589bf69
--- /dev/null
+++ b/graphics/p5-Image-Imgur/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Image/Imgur/.packlist
+%%SITE_PERL%%/Image/Imgur.pm
+@dirrmtry %%SITE_PERL%%/Image
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Image/Imgur
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Image