aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2022-04-29 04:52:18 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2022-04-30 08:03:20 +0000
commitca3f925d6eb53ff27e2a49775f6d33f52a587ae4 (patch)
tree8330d02f36a17f334c0d38f6741d0d042f6d6f38 /graphics
parentdc8bd44c128467d5b76d40478fa87da62d56d35d (diff)
downloadports-ca3f925d6eb53ff27e2a49775f6d33f52a587ae4.tar.gz
ports-ca3f925d6eb53ff27e2a49775f6d33f52a587ae4.zip
Diffstat (limited to 'graphics')
-rw-r--r--graphics/elementary-photos/Makefile3
-rw-r--r--graphics/entangle/Makefile4
-rw-r--r--graphics/evince/Makefile3
-rw-r--r--graphics/gnome-video-effects/Makefile4
-rw-r--r--graphics/gthumb/Makefile2
-rw-r--r--graphics/kmscube/Makefile4
-rw-r--r--graphics/opencv/Makefile2
-rw-r--r--graphics/osg/Makefile4
-rw-r--r--graphics/osg34/Makefile3
-rw-r--r--graphics/pdfpc/Makefile3
-rw-r--r--graphics/shotwell/Makefile5
11 files changed, 16 insertions, 21 deletions
diff --git a/graphics/elementary-photos/Makefile b/graphics/elementary-photos/Makefile
index baecdbc9b63f..89b3b4c7e08f 100644
--- a/graphics/elementary-photos/Makefile
+++ b/graphics/elementary-photos/Makefile
@@ -30,7 +30,7 @@ LIB_DEPENDS= libaccounts-glib.so:net-im/libaccounts-glib \
libwebp.so:graphics/webp \
libxml2.so:textproc/libxml2
-USES= compiler:c11 desktop-file-utils gettext gnome meson \
+USES= compiler:c11 desktop-file-utils gettext gnome gstreamer meson \
ninja pkgconfig sqlite xorg
USE_GITHUB= yes
GH_ACCOUNT= elementary
@@ -38,7 +38,6 @@ GH_PROJECT= photos
USE_GNOME= cairo gdkpixbuf2 gtk30 intltool
GLIB_SCHEMAS= io.elementary.photos-extras.gschema.xml \
io.elementary.photos.gschema.xml
-USE_GSTREAMER1= yes
USE_LDCONFIG= yes
USE_XORG= x11
MESON_BUILD_DIR= build
diff --git a/graphics/entangle/Makefile b/graphics/entangle/Makefile
index d09201921a2d..91db8eaac3a8 100644
--- a/graphics/entangle/Makefile
+++ b/graphics/entangle/Makefile
@@ -19,9 +19,9 @@ LIB_DEPENDS= libgphoto2.so:graphics/libgphoto2 \
libpeas-1.0.so:devel/libpeas
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}libpeas>0:devel/py-libpeas@${PY_FLAVOR}
-USES= compiler:c++11-lang gnome meson pkgconfig python tar:xz xorg
+USES= compiler:c++11-lang gnome gstreamer meson pkgconfig python tar:xz xorg
USE_GNOME= cairo gtk30 intltool introspection
-USE_GSTREAMER1= core
+USE_GSTREAMER= core
USE_XORG= xext
GLIB_SCHEMAS= org.entangle-photo.manager.gschema.xml
USE_LDCONFIG= yes
diff --git a/graphics/evince/Makefile b/graphics/evince/Makefile
index 2eecddf87a51..3e576bb76dc4 100644
--- a/graphics/evince/Makefile
+++ b/graphics/evince/Makefile
@@ -30,10 +30,9 @@ RUN_DEPENDS= adwaita-icon-theme>=0:x11-themes/adwaita-icon-theme \
PORTSCOUT= limitw:1,even
SLAVEPORT?= no
-USES= compiler:c++11-lib cpe desktop-file-utils gettext gnome libarchive \
+USES= compiler:c++11-lib cpe desktop-file-utils gettext gnome gstreamer libarchive \
localbase:ldflags meson pkgconfig tar:xz xorg
USE_GNOME= cairo gtk30
-USE_GSTREAMER1= yes
USE_LDCONFIG= yes
USE_XORG= ice
CPE_VENDOR= gnome
diff --git a/graphics/gnome-video-effects/Makefile b/graphics/gnome-video-effects/Makefile
index b32cdc0cc33f..5332494bffe9 100644
--- a/graphics/gnome-video-effects/Makefile
+++ b/graphics/gnome-video-effects/Makefile
@@ -11,8 +11,8 @@ COMMENT= Collection of Gstreamer effects
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gettext meson tar:xz
-USE_GSTREAMER1= good bad
+USES= gettext gstreamer meson tar:xz
+USE_GSTREAMER= good bad
NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/graphics/gthumb/Makefile b/graphics/gthumb/Makefile
index 3a054dce6730..e8be17b36b27 100644
--- a/graphics/gthumb/Makefile
+++ b/graphics/gthumb/Makefile
@@ -83,7 +83,7 @@ CLUTTER_LIB_DEPENDS= libclutter-gtk-1.0.so:graphics/clutter-gtk3
CLUTTER_MESON_TRUE= clutter
EXIV2_LIB_DEPENDS= libexiv2.so:graphics/exiv2
EXIV2_MESON_TRUE= exiv2
-GSTREAMER_USE= gstreamer1=yes
+GSTREAMER_USES= gstreamer
GSTREAMER_MESON_TRUE= gstreamer
RAW_DESC= Raw image support via libraw
RAW_LIB_DEPENDS= libraw.so:graphics/libraw
diff --git a/graphics/kmscube/Makefile b/graphics/kmscube/Makefile
index 00aa0bfab3fc..d37c4cfacac8 100644
--- a/graphics/kmscube/Makefile
+++ b/graphics/kmscube/Makefile
@@ -24,8 +24,8 @@ PLIST_FILES= bin/${PORTNAME} \
OPTIONS_DEFINE= GSTREAMER PNG
OPTIONS_DEFAULT=PNG
-GSTREAMER_USES= gnome
-GSTREAMER_USE= GNOME=glib20 GSTREAMER1=yes
+GSTREAMER_USES= gnome gstreamer
+GSTREAMER_USE= GNOME=glib20
GSTREAMER_MESON_ENABLED=gstreamer
PNG_LIB_DEPENDS= libpng.so:graphics/png
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index ad8d26e9aa0a..aa70fa383f78 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -161,7 +161,7 @@ FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
GSTREAMER_DESC= Add GSTREAMER Support
GSTREAMER_CMAKE_BOOL= WITH_GSTREAMER
-GSTREAMER_USE= GSTREAMER1=yes
+GSTREAMER_USES= gstreamer
V4L_DESC= Enable support for Video for Linux
V4L_CMAKE_BOOL= WITH_V4L WITH_LIBV4L
diff --git a/graphics/osg/Makefile b/graphics/osg/Makefile
index bea5562afc28..58068625a9f4 100644
--- a/graphics/osg/Makefile
+++ b/graphics/osg/Makefile
@@ -69,8 +69,8 @@ GDAL_VARS_OFF= FORCE_IGNORE+=GDAL
GIF_LIB_DEPENDS= libgif.so:graphics/giflib
GIF_VARS= FORCE_REQUIRE+=GIFLIB
GIF_VARS_OFF= FORCE_IGNORE+=GIFLIB
-GSTREAMER_USES= gnome
-GSTREAMER_USE= GNOME=glib20 GSTREAMER1=yes
+GSTREAMER_USES= gnome gstreamer
+GSTREAMER_USE= GNOME=glib20
GSTREAMER_VARS= FORCE_REQUIRE+="GStreamer GLIB"
GSTREAMER_VARS_OFF= FORCE_IGNORE+="GStreamer GLIB"
GTA_LIB_DEPENDS= libgta.so:devel/libgta
diff --git a/graphics/osg34/Makefile b/graphics/osg34/Makefile
index b4ef603c21af..8ee29af2e436 100644
--- a/graphics/osg34/Makefile
+++ b/graphics/osg34/Makefile
@@ -67,7 +67,8 @@ GDAL_VARS_OFF= FORCE_IGNORE+=GDAL
GIF_LIB_DEPENDS= libgif.so:graphics/giflib
GIF_VARS= FORCE_REQUIRE+=GIFLIB
GIF_VARS_OFF= FORCE_IGNORE+=GIFLIB
-GSTREAMER_USE= GNOME=glib20 GSTREAMER1=yes
+GSTREAMER_USES= gstreamer
+GSTREAMER_USE= GNOME=glib20
GSTREAMER_VARS= FORCE_REQUIRE+=GStreamer
GSTREAMER_VARS_OFF= FORCE_IGNORE+=GStreamer
GTA_LIB_DEPENDS= libgta.so:devel/libgta
diff --git a/graphics/pdfpc/Makefile b/graphics/pdfpc/Makefile
index e426c0a696bb..597eda3fa791 100644
--- a/graphics/pdfpc/Makefile
+++ b/graphics/pdfpc/Makefile
@@ -18,9 +18,8 @@ LIB_DEPENDS= libgee-0.8.so:devel/libgee \
USE_GITHUB= yes
-USES= cmake compiler:c11 gnome pkgconfig
+USES= cmake compiler:c11 gnome gstreamer pkgconfig
USE_GNOME= gtk30
-USE_GSTREAMER1= yes
CMAKE_ARGS= -DMANDIR:STRING="man/"
diff --git a/graphics/shotwell/Makefile b/graphics/shotwell/Makefile
index 82afb27be2c3..ac8eea654f29 100644
--- a/graphics/shotwell/Makefile
+++ b/graphics/shotwell/Makefile
@@ -25,17 +25,14 @@ LIB_DEPENDS= libgio-2.0.so:devel/glib20 \
libexif.so:graphics/libexif \
libgphoto2.so:graphics/libgphoto2 \
libraw.so:graphics/libraw \
- libgstreamer-1.0.so:multimedia/gstreamer1 \
- libgstapp-1.0.so:multimedia/gstreamer1-plugins \
libgcr-ui-3.so:security/gcr \
libwebkit2gtk-4.0.so:www/webkit2-gtk3 \
libxml2.so:textproc/libxml2
-USES= compiler:c++11-lib cpe desktop-file-utils gettext gnome meson \
+USES= compiler:c++11-lib cpe desktop-file-utils gettext gnome gstreamer meson \
ninja pkgconfig python:3.4+,build shebangfix sqlite tar:xz xorg
CPE_VENDOR= gnome
USE_GNOME= cairo dconf gtk30
-USE_GSTREAMER1= yes
USE_LDCONFIG= yes
USE_XORG= x11