aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-04-28 21:31:31 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-04-28 21:31:31 +0000
commite32eeb8bc95dc3e00105c622d055c9177d928ba4 (patch)
tree481f44c83e85357eb12d2a9f0bc58d63e3d19194 /graphics
parentf307be961265f4a67aa94291e46d209e5022eebc (diff)
downloadports-e32eeb8bc95dc3e00105c622d055c9177d928ba4.tar.gz
ports-e32eeb8bc95dc3e00105c622d055c9177d928ba4.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Hermes/Makefile15
-rw-r--r--graphics/aoi/Makefile4
-rw-r--r--graphics/autoq3d/Makefile5
-rw-r--r--graphics/box/Makefile6
-rw-r--r--graphics/boxer/Makefile11
-rw-r--r--graphics/cbrpager/Makefile4
-rw-r--r--graphics/cbview/Makefile5
-rw-r--r--graphics/cbviewer/Makefile4
-rw-r--r--graphics/eos-movrec/Makefile4
-rw-r--r--graphics/eos-movrec/pkg-plist2
-rw-r--r--graphics/evolvotron/Makefile9
-rw-r--r--graphics/fracplanet/Makefile16
-rw-r--r--graphics/gnofract4d/Makefile3
-rw-r--r--graphics/icon-slicer/Makefile11
-rw-r--r--graphics/lcdtest/Makefile10
-rw-r--r--graphics/multican/Makefile7
-rw-r--r--graphics/photopc/Makefile5
-rw-r--r--graphics/pngcheck/Makefile4
-rw-r--r--graphics/pngwriter/Makefile4
-rw-r--r--graphics/pstoedit/Makefile5
-rw-r--r--graphics/skencil/Makefile12
21 files changed, 75 insertions, 71 deletions
diff --git a/graphics/Hermes/Makefile b/graphics/Hermes/Makefile
index dced1e01dc57..116b94eefe39 100644
--- a/graphics/Hermes/Makefile
+++ b/graphics/Hermes/Makefile
@@ -3,28 +3,26 @@
PORTNAME= Hermes
PORTVERSION= 1.3.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.su.se/pub/lunar/source-archive/ \
GENTOO
MASTER_SITE_SUBDIR= distfiles
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Fast pixel formats conversion library
-USE_BZIP2= yes
-USES= gmake
+USES= gmake tar:bzip2
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
-CFLAGS+= -w
USE_LDCONFIG= yes
PORTDOCS= *
DOCSRCDIR1= ${WRKSRC}
-DOC_FILES1= AUTHORS ChangeLog FAQ README TODO TODO.conversion
+DOC_FILES1= AUTHORS ChangeLog FAQ README
DOCSRCDIR2= ${WRKSRC}/docs/api
DOCSDIR2= ${DOCSDIR}/docs/api
@@ -43,9 +41,10 @@ IGNORE= is broken on sparc64: interchanges red and blue colour channels in imag
.endif
post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lib${PORTNAME}.so.1
+
@${MKDIR} ${STAGEDIR}${DOCSDIR3}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR2}
${INSTALL_DATA} ${DOC_FILES3:S|^|${DOCSRCDIR3}/|} ${STAGEDIR}${DOCSDIR3}
diff --git a/graphics/aoi/Makefile b/graphics/aoi/Makefile
index a2d3116d0670..7bbd722a5259 100644
--- a/graphics/aoi/Makefile
+++ b/graphics/aoi/Makefile
@@ -3,14 +3,14 @@
PORTNAME= aoi
PORTVERSION= 3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics java
MASTER_SITES= SF/${PORTNAME}/ArtOfIllusion/${PORTVERSION} \
SF/${PORTNAME}/ArtOfIllusion-manual/${PORTVERSION}:docs
DISTFILES= ${PORTNAME}${PORTVERSION:S/.//g}${EXTRACT_SUFX}
DIST_SUBDIR= ${PORTNAME}
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Open source Java written 3D modelling and rendering studio
LICENSE= GPLv2
diff --git a/graphics/autoq3d/Makefile b/graphics/autoq3d/Makefile
index 9db54dc4507a..c7469d381941 100644
--- a/graphics/autoq3d/Makefile
+++ b/graphics/autoq3d/Makefile
@@ -3,12 +3,12 @@
PORTNAME= autoq3d
PORTVERSION= 1.40
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/AutoQ3D%20${PORTVERSION}
DISTNAME= AutoQ3DCommunity${PORTVERSION:C/\./-/}qt4source
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Qt 4 quick 3D model editor
LICENSE= GPLv2 GPLv3
@@ -21,7 +21,6 @@ USE_GL= glu
USE_QT4= corelib gui opengl moc_build
PORTDOCS= 3DQformat.txt ChangeLog.txt
-
OPTIONS_DEFINE= DOCS
DESKTOP_ENTRIES="AutoQ3D" "" "${PORTNAME}" \
diff --git a/graphics/box/Makefile b/graphics/box/Makefile
index c8896df8736a..efd77138ef1d 100644
--- a/graphics/box/Makefile
+++ b/graphics/box/Makefile
@@ -3,11 +3,12 @@
PORTNAME= box
PORTVERSION= 0.4.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}c/Box%20-%20the%20compiler/${DISTNAME}/
DIST_SUBDIR= box
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Compiler for box, the figure description language
LICENSE= GPLv2 LGPL3
@@ -21,8 +22,9 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-cairo
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE=yes
+MAKE_ENV= INSTALL_STRIP_FLAG=${STRIP}
-PORTDOCS= AUTHORS ChangeLog README STYLE TODO
+PORTDOCS= AUTHORS ChangeLog README STYLE
PORTEXAMPLES= *
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/graphics/boxer/Makefile b/graphics/boxer/Makefile
index 23ef0949d53e..25e218ebea52 100644
--- a/graphics/boxer/Makefile
+++ b/graphics/boxer/Makefile
@@ -3,7 +3,7 @@
PORTNAME= boxer
PORTVERSION= 0.4.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF/boxc/${PORTNAME:C/^b/B/}%20-%20the%20Box%20GUI/${DISTNAME}/ \
SF/nemysisfreebsdp/${CATEGORIES}/:icons
@@ -12,7 +12,7 @@ DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
DIST_SUBDIR= box
EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= GUI for Box the figure description language
LICENSE= GPLv3
@@ -25,15 +25,14 @@ USE_PYDISTUTILS=yes
PYDISTUTILS_AUTOPLIST= yes
USE_LDCONFIG= yes
+PLIST_FILES= share/pixmaps/${PORTNAME}.png
+
PORTDOCS= ChangeLog
+OPTIONS_DEFINE= DOCS
DESKTOP_ENTRIES="Boxer" "" "${PORTNAME}" \
"${PORTNAME}" "Application;Graphics;" ""
-OPTIONS_DEFINE= DOCS
-
-PLIST_FILES= share/pixmaps/${PORTNAME}.png
-
post-install:
${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/
diff --git a/graphics/cbrpager/Makefile b/graphics/cbrpager/Makefile
index 13a40a855aa3..5e1b1926d9a6 100644
--- a/graphics/cbrpager/Makefile
+++ b/graphics/cbrpager/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cbrpager
PORTVERSION= 0.9.22
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION} \
SF/nemysisfreebsdp/${CATEGORIES}/:icons
@@ -11,7 +11,7 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
${PORTNAME}.png:icons
EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Viewer for cbr (comic book archive) files
LICENSE= GPLv3
diff --git a/graphics/cbview/Makefile b/graphics/cbview/Makefile
index 9ccd87dfa54c..b59e9fcd2a9f 100644
--- a/graphics/cbview/Makefile
+++ b/graphics/cbview/Makefile
@@ -3,11 +3,11 @@
PORTNAME= cbview
PORTVERSION= 0.06
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= graphics perl5
MASTER_SITES= http://www.sourcefiles.org/Toys/Humor/
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Viewer/converter for CBR/CBZ comic book archives
LICENSE= GPLv2
@@ -23,7 +23,6 @@ USES= perl5
PLIST_FILES= bin/${PORTNAME}
PORTDOCS= Changes README TODO
-
OPTIONS_DEFINE= DOCS
post-patch:
diff --git a/graphics/cbviewer/Makefile b/graphics/cbviewer/Makefile
index 3fd184bf333e..e958aa5b6d15 100644
--- a/graphics/cbviewer/Makefile
+++ b/graphics/cbviewer/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cbviewer
PORTVERSION= 0.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics java
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/CBViewer%200.8/ \
SF/nemysisfreebsdp/graphics/:icons
@@ -12,7 +12,7 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Comic book viewer for comic book archives in cbz, cbr, zip, rar
LICENSE= GPLv2
diff --git a/graphics/eos-movrec/Makefile b/graphics/eos-movrec/Makefile
index e89916f06af1..a59309243fe1 100644
--- a/graphics/eos-movrec/Makefile
+++ b/graphics/eos-movrec/Makefile
@@ -3,11 +3,11 @@
PORTNAME= eos-movrec
DISTVERSION= 0.3.2_beta
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION}/
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Capture short movies with Canon DSLR camera
LICENSE= GPLv2
diff --git a/graphics/eos-movrec/pkg-plist b/graphics/eos-movrec/pkg-plist
index f1264dd02365..ac64120584b5 100644
--- a/graphics/eos-movrec/pkg-plist
+++ b/graphics/eos-movrec/pkg-plist
@@ -7,5 +7,3 @@ share/icons/hicolor/512x512/apps/eos-movrec.png
share/pixmaps/eos-movrec.png
@dirrmtry share/icons/hicolor/512x512/apps
@dirrmtry share/icons/hicolor/512x512
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons
diff --git a/graphics/evolvotron/Makefile b/graphics/evolvotron/Makefile
index 8b87a2d4a48e..07036289fe85 100644
--- a/graphics/evolvotron/Makefile
+++ b/graphics/evolvotron/Makefile
@@ -6,11 +6,11 @@ PORTVERSION= 0.6.3
PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF \
- SF/nemysisfreebsdp/:icons
+ SF/nemysisfreebsdp/${CATEGORIES}/:icons
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
${PORTNAME}_icons${EXTRACT_SUFX}:icons
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Generative software that evolves images/textures/patterns
LICENSE= GPLv2
@@ -32,7 +32,7 @@ INSTALLS_ICONS= yes
ICON_SIZES= 32x32 48x48 64x64 72x72 96x96 128x128
DESKTOP_ENTRIES="Evolvotron" "Interactive image generator" "${PORTNAME}" \
- "${PORTNAME}" "Graphics;2DGraphics;" true
+ "${PORTNAME}" "Graphics;2DGraphics;" ""
OPTIONS_DEFINE= DOCS
@@ -71,7 +71,8 @@ do-install:
${STAGEDIR}${PREFIX}/share/pixmaps/
.for m in evolvotron.1 evolvotron_mutate.1 evolvotron_render.1
- cd ${WRKSRC}/man/man1 && ${INSTALL_MAN} ${m} ${STAGEDIR}${MAN1PREFIX}/man/man1/
+ cd ${WRKSRC}/man/man1 && ${INSTALL_MAN} ${m} \
+ ${STAGEDIR}${MAN1PREFIX}/man/man1/
.endfor
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/graphics/fracplanet/Makefile b/graphics/fracplanet/Makefile
index b741e03155cf..ab9b2ea35851 100644
--- a/graphics/fracplanet/Makefile
+++ b/graphics/fracplanet/Makefile
@@ -3,14 +3,14 @@
PORTNAME= fracplanet
PORTVERSION= 0.4.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics
MASTER_SITES= SF \
SF/nemysisfreebsdp/:icons
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
${PORTNAME}_icons.tar.gz:icons
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Interactive tool for creating random fractal planets and terrain
LICENSE= GPLv2
@@ -31,13 +31,13 @@ CONFIGURE_ARGS= -spec ${QMAKESPEC}
PORTDOCS= *
DOCSRCDIR1= ${WRKSRC}
-DOC_FILES1= BUGS NEWS README THANKS TODO ${PORTNAME}.css ${PORTNAME}.htm
+DOC_FILES1= BUGS NEWS README THANKS ${PORTNAME}.css ${PORTNAME}.htm
INSTALLS_ICONS= yes
ICON_SIZES= 32x32 48x48 64x64 72x72 96x96
-DESKTOP_ENTRIES="Fracplanet" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}" "Graphics;" false
+DESKTOP_ENTRIES="Fracplanet" "" "${PORTNAME}" \
+ "${PORTNAME}" "Graphics;" ""
OPTIONS_DEFINE= DOCS
OPTIONS_GROUP= DOXYGEN
@@ -61,12 +61,14 @@ post-patch:
.endfor
@${REINPLACE_CMD} -e 's|qmake-qt4|${QMAKE} ${QMAKE_ARGS}|' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|-lboost_program_options|-lboost_program_options -lGLU|' \
+ @${REINPLACE_CMD} -e \
+ 's|-lboost_program_options|-lboost_program_options -lGLU|' \
${WRKSRC}/fracplanet.pro
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/man/man1/fracplanet.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKSRC}/man/man1/${PORTNAME}.1 \
+ ${STAGEDIR}${MAN1PREFIX}/man/man1/
.for s in ${ICON_SIZES}
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/
diff --git a/graphics/gnofract4d/Makefile b/graphics/gnofract4d/Makefile
index 574a22a0baea..02ec73ebbe51 100644
--- a/graphics/gnofract4d/Makefile
+++ b/graphics/gnofract4d/Makefile
@@ -3,10 +3,11 @@
PORTNAME= gnofract4d
PORTVERSION= 3.14.1
+PORTREVISION= 1
CATEGORIES= graphics gnome
MASTER_SITES= SF
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Weird GNOME fractal generator
LICENSE= BSD3CLAUSE
diff --git a/graphics/icon-slicer/Makefile b/graphics/icon-slicer/Makefile
index d70081e8c1e2..8c2ae817f547 100644
--- a/graphics/icon-slicer/Makefile
+++ b/graphics/icon-slicer/Makefile
@@ -3,16 +3,16 @@
PORTNAME= icon-slicer
PORTVERSION= 0.3
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= graphics
MASTER_SITES= http://www.freedesktop.org/software/icon-slicer/releases/
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Utility for generating icon and cursor themes
LICENSE= GPLv2
-LIB_DEPENDS= popt:${PORTSDIR}/devel/popt
+LIB_DEPENDS= libpopt.so:${PORTSDIR}/devel/popt
USES= pkgconfig
USE_GNOME= gtk20
@@ -20,10 +20,9 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_FILES= bin/icon-slicer
-
-PORTDOCS= AUTHORS ChangeLog README TODO
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= AUTHORS ChangeLog README
OPTIONS_DEFINE= DOCS
post-patch:
diff --git a/graphics/lcdtest/Makefile b/graphics/lcdtest/Makefile
index 9b723d15f023..bcd676fe10df 100644
--- a/graphics/lcdtest/Makefile
+++ b/graphics/lcdtest/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lcdtest
PORTVERSION= 1.18
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics
MASTER_SITES= http://www.brouhaha.com/~eric/software/lcdtest/download/ \
SF/nemysisfreebsdp/${CATEGORIES}/:icons
@@ -11,12 +11,12 @@ DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
${PORTNAME}.png:icons
EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= LCD monitor test pattern generator
LICENSE= GPLv3
-RUN_DEPENDS= ${LOCALBASE}/lib/X11/fonts/Liberation/LiberationMono-Bold.ttf:${PORTSDIR}/x11-fonts/liberation-fonts-ttf
+RUN_DEPENDS= liberation-fonts-ttf>0:${PORTSDIR}/x11-fonts/liberation-fonts-ttf
USE_SDL= sdl image ttf
@@ -29,11 +29,11 @@ PLIST_FILES= bin/${PORTNAME} \
share/pixmaps/${PORTNAME}.png
PORTDOCS= README
-
OPTIONS_DEFINE= DOCS
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/share/fonts/liberation/|${LOCALBASE}/lib/X11/fonts/Liberation/|' \
+ @${REINPLACE_CMD} -e \
+ 's|/usr/share/fonts/liberation/|${LOCALBASE}/lib/X11/fonts/Liberation/|' \
${WRKSRC}/src/lcdtest.c
do-build:
diff --git a/graphics/multican/Makefile b/graphics/multican/Makefile
index f0898e32f02d..3b0fa7969ed9 100644
--- a/graphics/multican/Makefile
+++ b/graphics/multican/Makefile
@@ -3,11 +3,11 @@
PORTNAME= multican
DISTVERSION= 0.0.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Remote control utility for Canon DSLR cameras
LICENSE= GPLv2
@@ -18,8 +18,7 @@ USE_LDCONFIG= yes
PLIST_FILES= bin/multican lib/libmultican.so.0 lib/libmultican.so \
include/canonio.h include/usbio.h
-PORTDOCS= ChangeLog README TODO
-
+PORTDOCS= ChangeLog README
OPTIONS_DEFINE= DOCS
post-patch:
diff --git a/graphics/photopc/Makefile b/graphics/photopc/Makefile
index d8c157782c0e..811339312000 100644
--- a/graphics/photopc/Makefile
+++ b/graphics/photopc/Makefile
@@ -3,10 +3,11 @@
PORTNAME= photopc
PORTVERSION= 3.07
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Control cameras based on Sierra Imaging chipset and compatibles
GNU_CONFIGURE= yes
@@ -19,10 +20,10 @@ PLIST_FILES= bin/epinfo \
man/man1/photopc.1.gz
PORTDOCS= README protocol.htm usage.htm
-
OPTIONS_DEFINE= DOCS
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>
diff --git a/graphics/pngcheck/Makefile b/graphics/pngcheck/Makefile
index 03f89944bf5f..847be53f422a 100644
--- a/graphics/pngcheck/Makefile
+++ b/graphics/pngcheck/Makefile
@@ -3,11 +3,11 @@
PORTNAME= pngcheck
PORTVERSION= 2.3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF/png-mng/${PORTNAME}/${PORTVERSION}
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Checks the integrity of PNG images
LICENSE= MIT GPLv2
diff --git a/graphics/pngwriter/Makefile b/graphics/pngwriter/Makefile
index e7577ce84fdf..211dcb380d31 100644
--- a/graphics/pngwriter/Makefile
+++ b/graphics/pngwriter/Makefile
@@ -3,11 +3,11 @@
PORTNAME= pngwriter
PORTVERSION= 0.5.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= C++ library for creating PNG images
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
diff --git a/graphics/pstoedit/Makefile b/graphics/pstoedit/Makefile
index ba51529746c4..3b127f53a07c 100644
--- a/graphics/pstoedit/Makefile
+++ b/graphics/pstoedit/Makefile
@@ -3,11 +3,11 @@
PORTNAME= pstoedit
PORTVERSION= 3.62
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics print
MASTER_SITES= SF
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Convert PostScript to other vector graphic formats
LICENSE= GPLv2
@@ -27,6 +27,7 @@ USES= pathfix pkgconfig
USE_GHOSTSCRIPT= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
+MAKE_ENV= INSTALL_STRIP_FLAG=${STRIP}
CPPFLAGS+= -I${LOCALBASE}/include/ming -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/graphics/skencil/Makefile b/graphics/skencil/Makefile
index 543f7d2c3b39..c853f8abdc97 100644
--- a/graphics/skencil/Makefile
+++ b/graphics/skencil/Makefile
@@ -3,13 +3,13 @@
PORTNAME= skencil
PORTVERSION= 1.0.a784
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= GOOGLE_CODE
PROJECTHOST= sk1
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.a/alpha_rev/}
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Interactive drawing program
LICENSE= LGPL20
@@ -27,14 +27,12 @@ USE_XORG= x11 xext
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-
PYDISTUTILS_EGGINFO= ${PORTNAME}-${PORTVERSION:R}alpha-py${PYTHON_VER}.egg-info
CFLAGS+= -I${TK_INCLUDEDIR} -I${LOCALBASE}/include \
-L${LOCALBASE}/lib
PORTDOCS= README
-
OPTIONS_DEFINE= DOCS NLS
NLS_USES= gettext
@@ -56,6 +54,12 @@ post-patch:
.endif
post-install:
+.for l in streamfilter paxmodule pstokenize _sketchmodule intl skreadmodule \
+ _type1module paxtkinter
+ ${STRIP_CMD} \
+ ${STAGEDIR}${PYTHON}${PYTHON_SITELIBDIR}/skencil/Sketch/Modules/${l}.so
+.endfor
+
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}