aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2002-05-29 19:07:10 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2002-05-29 19:07:10 +0000
commitf3f589368558098afebdff077633620f5e628ab7 (patch)
tree480fbf7fde575e487818402bc6f4d15b3b6c37f6 /graphics
parent91ffe994fbc2fd0cb34b1916fbb48d6782a590be (diff)
USE_LINUX rather than explicitly listing the dependency.
Notes
Notes: svn path=/head/; revision=60264
Diffstat (limited to 'graphics')
-rw-r--r--graphics/linux-bmrt/Makefile4
-rw-r--r--graphics/linux_glide/Makefile11
-rw-r--r--graphics/netshow/Makefile7
3 files changed, 8 insertions, 14 deletions
diff --git a/graphics/linux-bmrt/Makefile b/graphics/linux-bmrt/Makefile
index ae9e4a3da4de..e6d15e2744fc 100644
--- a/graphics/linux-bmrt/Makefile
+++ b/graphics/linux-bmrt/Makefile
@@ -13,9 +13,9 @@ DISTNAME= BMRT${PORTVERSION}.linux-glibc2
MAINTAINER= rjoseph@mammalia.org
-RUN_DEPENDS= /compat/linux/usr/i486-linux-libc5/lib/libc.so.5:${PORTSDIR}/emulators/linux_base \
- /compat/linux/usr/X11R6/lib/libGL.so:${PORTSDIR}/graphics/linux_mesa3
+RUN_DEPENDS= /compat/linux/usr/X11R6/lib/libGL.so:${PORTSDIR}/graphics/linux_mesa3
+USE_LINUX= yes
WRKSRC= ${WRKDIR}/BMRT2.6
NO_BUILD= yes
ONLY_FOR_ARCHS= i386
diff --git a/graphics/linux_glide/Makefile b/graphics/linux_glide/Makefile
index cfb36d01f1eb..fd8439d75f7f 100644
--- a/graphics/linux_glide/Makefile
+++ b/graphics/linux_glide/Makefile
@@ -15,22 +15,17 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}_2_4
MAINTAINER= cracauer@cons.org
-RUN_DEPENDS= /compat/linux/usr/i486-linux-libc5/lib/libc.so.5:${PORTSDIR}/emulators/linux_base
-
ONLY_FOR_ARCHS= i386
-PREFIX= /compat/linux/usr
+USE_LINUX_PREFIX=yes
NO_MTREE= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/Glide2.4
-pre-install:
- @[ -d ${PREFIX} ] || ${MKDIR} ${PREFIX}
-
do-install:
@zcat ${WRKSRC}/dist.tar.gz | \
- (cd ${PREFIX}; tar fx - lib include bin/test00)
- ${MV} ${PREFIX}/bin/test00 ${PREFIX}/bin/test-glide
+ (cd ${PREFIX}/usr; tar fx - lib include bin/test00)
+ ${MV} ${PREFIX}/usr/bin/test00 ${PREFIX}/usr/bin/test-glide
post-install:
-/compat/linux/sbin/ldconfig
diff --git a/graphics/netshow/Makefile b/graphics/netshow/Makefile
index f363019013ca..a2676b19cbc5 100644
--- a/graphics/netshow/Makefile
+++ b/graphics/netshow/Makefile
@@ -14,15 +14,14 @@ EXTRACT_SUFX= .gz
MAINTAINER= dburr@FreeBSD.org
-RUN_DEPENDS= /compat/linux/usr/i486-linux-libc5/lib/libc.so.5:${PORTSDIR}/emulators/linux_base
-
-ONLY_FOR_ARCHS= i386
RESTRICTED= "Commercial software"
NO_CDROM= ${RESTRICTED}
NO_PACKAGE= ${RESTRICTED}
-NO_BUILD= yes
+ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+NO_BUILD= yes
USE_X_PREFIX= yes
pre-extract: