aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-03-24 16:25:36 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-03-24 16:25:36 +0000
commit5debe5bc20256c475f1c1a46c2df00253e6a029f (patch)
treec7ceced7eb505359395d9e8680951563a96b5ccb /graphics
parent0e00f5d4b2b79b6988fa540921fdd4d2f92cf04e (diff)
downloadports-5debe5bc20256c475f1c1a46c2df00253e6a029f.tar.gz
ports-5debe5bc20256c475f1c1a46c2df00253e6a029f.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/OpenEXR/Makefile6
-rw-r--r--graphics/OpenEXR/files/patch-IlmImfExamples::Makeilfe.in11
-rw-r--r--graphics/OpenEXR/pkg-plist10
3 files changed, 25 insertions, 2 deletions
diff --git a/graphics/OpenEXR/Makefile b/graphics/OpenEXR/Makefile
index 8b089188fd7a..f6668500a2f2 100644
--- a/graphics/OpenEXR/Makefile
+++ b/graphics/OpenEXR/Makefile
@@ -7,7 +7,7 @@
PORTNAME= OpenEXR
PORTVERSION= 1.0.5
-#PORTREVISION= 1
+PORTREVISION= 1
CATEGORIES= graphics devel
MASTER_SITES= http://savannah.nongnu.org/download/openexr/${PORTNAME}.pkg/${PORTVERSION}/
@@ -19,6 +19,8 @@ USE_LIBTOOL= YES
GNU_CONFIGURE= YES
INSTALLS_SHLIB= YES
+EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}-${PORTVERSION}
+
.include <bsd.port.pre.mk>
.if defined(USE_GCC) && ${USE_GCC} == 3.1+ && ${OSVERSION} < 500035
@@ -46,7 +48,7 @@ pre-everything::
@${ECHO_CMD} ===================================================
.endif
.else
-CONFIGURE_ARGS+=--with-fltk-config=/usr/bin/false --without-x
+CONFIGURE_ARGS+=--with-fltk-config=${FALSE} --without-x
PLIST_SUB+= WITH_FLTK="@comment "
.endif
diff --git a/graphics/OpenEXR/files/patch-IlmImfExamples::Makeilfe.in b/graphics/OpenEXR/files/patch-IlmImfExamples::Makeilfe.in
new file mode 100644
index 000000000000..4d8dc311f0ba
--- /dev/null
+++ b/graphics/OpenEXR/files/patch-IlmImfExamples::Makeilfe.in
@@ -0,0 +1,11 @@
+--- IlmImfExamples/Makefile.in.orig Sun Mar 23 20:08:09 2003
++++ IlmImfExamples/Makefile.in Tue Mar 25 01:06:30 2003
+@@ -109,7 +109,7 @@
+ rgbaInterfaceExamples.h generalInterfaceExamples.h
+
+
+-examplesdir = $(datadir)/doc/OpenEXR-@OPENEXR_VERSION@/examples
++examplesdir = $(datadir)/examples/OpenEXR-@OPENEXR_VERSION@
+ examples_DATA = $(imfexamples_SOURCES)
+
+ imfexamplesdir = $(examplesdir)
diff --git a/graphics/OpenEXR/pkg-plist b/graphics/OpenEXR/pkg-plist
index 022e4f0ddfd9..363757cb9e81 100644
--- a/graphics/OpenEXR/pkg-plist
+++ b/graphics/OpenEXR/pkg-plist
@@ -1,3 +1,4 @@
+bin/exrheader
%%WITH_FLTK%%bin/exrdisplay
lib/libHalf.a
lib/libHalf.la
@@ -83,5 +84,14 @@ include/OpenEXR/half.h
include/OpenEXR/halfFunction.h
include/OpenEXR/halfLimits.h
libdata/pkgconfig/OpenEXR.pc
+share/aclocal/openexr.m4
+%%EXAMPLESDIR%%/drawImage.cpp
+%%EXAMPLESDIR%%/drawImage.h
+%%EXAMPLESDIR%%/generalInterfaceExamples.cpp
+%%EXAMPLESDIR%%/generalInterfaceExamples.h
+%%EXAMPLESDIR%%/main.cpp
+%%EXAMPLESDIR%%/rgbaInterfaceExamples.cpp
+%%EXAMPLESDIR%%/rgbaInterfaceExamples.h
@unexec rmdir %D/libdata/pkgconfig 2>/dev/null || true
@dirrm include/OpenEXR
+@dirrm %%EXAMPLESDIR%%