aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorJohannes M Dieterich <jmd@FreeBSD.org>2018-09-30 19:19:44 +0000
committerJohannes M Dieterich <jmd@FreeBSD.org>2018-09-30 19:19:44 +0000
commit2bcb49de3e64e9086077c1ee4090b60ae7ff049d (patch)
tree1f22a4e3efb340a6be0881c1cd0ce7b54deff1c4 /graphics
parent0a6792f496f92799c2c6fce43c8152e4703d400d (diff)
downloadports-2bcb49de3e64e9086077c1ee4090b60ae7ff049d.tar.gz
ports-2bcb49de3e64e9086077c1ee4090b60ae7ff049d.zip
new port: graphics/drm-kmod
This metaport encompasses the recommndations of the FreeBSDDesktop team for DRM modules based on the FreeBSD version and architecture. Reviewed by: x11 (zeising), imp, rene Approved by: x11 (zeising) Differential Revision: https://reviews.freebsd.org/D16903
Notes
Notes: svn path=/head/; revision=480967
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/drm-kmod/Makefile43
-rw-r--r--graphics/drm-kmod/pkg-descr13
3 files changed, 57 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 064d29460857..cf780666ae23 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -153,6 +153,7 @@
SUBDIR += drawpile
SUBDIR += driconf
SUBDIR += drm-devel-kmod
+ SUBDIR += drm-kmod
SUBDIR += drm-legacy-kmod
SUBDIR += drm-next-kmod
SUBDIR += drm-stable-kmod
diff --git a/graphics/drm-kmod/Makefile b/graphics/drm-kmod/Makefile
new file mode 100644
index 000000000000..7bbd2a0a162a
--- /dev/null
+++ b/graphics/drm-kmod/Makefile
@@ -0,0 +1,43 @@
+# Created by: Johannes Dieterich <jmd@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= drm-kmod
+PORTVERSION= g20180930
+CATEGORIES= graphics
+
+MAINTAINER= jmd@FreeBSD.org
+COMMENT= Metaport of DRM modules for the linuxkpi-based KMS components
+
+USES= metaport
+
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} != FreeBSD
+IGNORE= not supported on anything but FreeBSD (missing linuxkpi functionality)
+.else
+.if ${ARCH} != "amd64"
+.if ${OSVERSION} >= 1200080
+RUN_DEPENDS= ${KMODDIR}/drm.ko:graphics/drm-legacy-kmod
+.elif ${OSVERSION} < 1200080
+IGNORE= legacy kmod not required on less than 12.0
+.endif
+.else
+.if ${OSVERSION} < 1101510
+IGNORE= not supported on 11.1 or older, no kernel support
+.elif ${OSVERSION} >= 1101510 && ${OSVERSION} < 1200000
+RUN_DEPENDS= ${KMODDIR}/drm.ko:graphics/drm-stable-kmod
+.elif ${OSVERSION} >= 1200000 && ${OSVERSION} < 1200045
+IGNORE= not supported on older 12, no kernel support
+.elif ${OSVERSION} >= 1200045 && ${OSVERSION} < 1200058
+RUN_DEPENDS= ${KMODDIR}/drm.ko:graphics/drm-stable-kmod
+.elif ${OSVERSION} >= 1200058 && ${OSVERSION} < 1300000
+RUN_DEPENDS= ${KMODDIR}/drm.ko:graphics/drm-next-kmod
+.elif ${OSVERSION} >= 1300000
+RUN_DEPENDS= ${KMODDIR}/drm.ko:graphics/drm-devel-kmod
+.else
+IGNORE= not supported for this configuration
+.endif
+.endif
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/drm-kmod/pkg-descr b/graphics/drm-kmod/pkg-descr
new file mode 100644
index 000000000000..a5464156a440
--- /dev/null
+++ b/graphics/drm-kmod/pkg-descr
@@ -0,0 +1,13 @@
+amdgpu, i915, and radeon DRM modules for the linuxkpi-based KMS components on
+amd64, i915 and radeonkms DRM modules from the former base DRM component on
+other architectures.
+Metaport for different versions of Linux DRM based on the FreeBSD version
+in use. This port encompasses the recommendations of the FreeBSDDesktop team
+of DRM versions for FreeBSD versions based on the last update to the LinuxKPI
+in that code base. In general, the most recent supported stable DRM for a give
+FreeBSD version will be installed. CURRENT receives the most recent development
+DRM.
+This port does not however hinder the expert user to make other decisions and
+continue to install DRM ports directly.
+
+WWW: https://github.com/FreeBSDDesktop/kms-drm