aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
commit074ea5282a00d556c73d86231bec5444990597dc (patch)
treeeec3d608e84e79f0187985e5a1e29cd4f04f13eb /graphics
parent522c152d1c7b0c92982e310110fa6d59f915ffeb (diff)
downloadports-074ea5282a00d556c73d86231bec5444990597dc.tar.gz
ports-074ea5282a00d556c73d86231bec5444990597dc.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cegui/files/patch-cegui__src__IconvStringTranscoder.cpp15
-rw-r--r--graphics/iccexamin/files/patch-icc_gl.cpp11
-rw-r--r--graphics/inventor/Makefile16
-rw-r--r--graphics/inventor/files/patch-SoText2.c++17
-rw-r--r--graphics/inventor/files/patch-SoText3.c++19
-rw-r--r--graphics/inventor/files/patch-TextWrapper.c++36
-rw-r--r--graphics/inventor/files/patch-ivcommondefs88
-rw-r--r--graphics/inventor/files/patch-machine.h21
-rw-r--r--graphics/inventor/files/pkg-message.in2
-rw-r--r--graphics/ipe/files/patch-ipelib__ipedoc.cpp23
-rw-r--r--graphics/sswf/Makefile14
-rw-r--r--graphics/sswf/files/patch-include_sswf_libsswf.h15
-rw-r--r--graphics/swfmill/Makefile1
13 files changed, 50 insertions, 228 deletions
diff --git a/graphics/cegui/files/patch-cegui__src__IconvStringTranscoder.cpp b/graphics/cegui/files/patch-cegui__src__IconvStringTranscoder.cpp
deleted file mode 100644
index 3b7653f095bf..000000000000
--- a/graphics/cegui/files/patch-cegui__src__IconvStringTranscoder.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
---- cegui/src/IconvStringTranscoder.cpp.orig 2014-03-12 06:50:07.000000000 +0100
-+++ cegui/src/IconvStringTranscoder.cpp 2014-03-12 06:51:56.000000000 +0100
-@@ -64,12 +64,7 @@
- size_t iconv(const char** inbuf, size_t* inbytesleft,
- char** outbuf, size_t* outbytesleft)
- {
--#ifdef CEGUI_ICONV_USES_CONST_INBUF
- return ::iconv(d_cd, inbuf, inbytesleft, outbuf, outbytesleft);
--#else
-- return ::iconv(d_cd, const_cast<char**>(inbuf), inbytesleft,
-- outbuf, outbytesleft);
--#endif
- }
-
- //------------------------------------------------------------------------//
diff --git a/graphics/iccexamin/files/patch-icc_gl.cpp b/graphics/iccexamin/files/patch-icc_gl.cpp
deleted file mode 100644
index 0a028fb1bea7..000000000000
--- a/graphics/iccexamin/files/patch-icc_gl.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- icc_gl.cpp.orig 2013-05-01 21:38:55.000000000 +0400
-+++ icc_gl.cpp 2013-05-01 21:39:28.000000000 +0400
-@@ -191,7 +191,7 @@ void drawText( FTFont * f, const char *
- ttmp = txt = strdup(in_txt);
-
- iconv_t cd = iconv_open( "WCHAR_T", oy_domain_codeset );
-- iconv( cd, &ttmp, &in_left, (char**)&wtmp, &out_left);
-+ iconv( cd, (const char**)&ttmp, &in_left, (char**)&wtmp, &out_left);
- iconv_close( cd );
-
- drawTEXT( f, wchar );
diff --git a/graphics/inventor/Makefile b/graphics/inventor/Makefile
index 3940065d43e3..0c029d486b5b 100644
--- a/graphics/inventor/Makefile
+++ b/graphics/inventor/Makefile
@@ -3,7 +3,7 @@
PORTNAME= inventor
PORTVERSION= 2.1.5.p10
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= graphics
MASTER_SITES= ftp://oss.sgi.com/projects/inventor/download/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/-/}
@@ -19,7 +19,7 @@ LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
CONFLICTS= Coin-[0-9]* SoXt-[0-9]*
-USE_XORG= x11 xi
+USE_XORG= x11 xext xi xp xt
USE_GL= glu glw
USES= iconv gmake motif
USE_LDCONFIG= yes
@@ -27,7 +27,12 @@ ONLY_FOR_ARCHS= i386 amd64
MAKE_JOBS_UNSAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKE_ARGS= CC="${CC}" CXX="${CXX}" LD="${CXX}" \
+ VCOPTS="${CFLAGS}" VCXXOPTS="${CXXFLAGS}" \
+ VLDOPTS="${LDFLAGS}" VLDDSOOPTS="${LDFLAGS}" \
+ IVPREFIX="${PREFIX}" X11DIR="${LOCALBASE}"
MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/lib:${WRKSRC}/libSoXt \
+ FREETYPE=1 \
INSTALL_STRIP=${STRIP} \
IVROOT=${STAGEDIR}
MAKEFILE= GNUmakefile
@@ -41,13 +46,12 @@ DEBUG_MAKE_ENV= LIBTYPE=debug
.include <bsd.port.options.mk>
.if !(${OPSYS} == FreeBSD && ${OSVERSION} < 900033)
-MAKE_ENV+= VLDOPTS=-Wl,--add-needed
+LDFLAGS+= -Wl,--add-needed
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|%%CC%%|${CC}|g ;\
- s|%%CXX%%|${CXX}|g ; \
- s|%%CXXFLAGS%%|${CXXFLAGS}|g' ${WRKSRC}/make/ivcommondefs
+ @${REINPLACE_CMD} 's|/usr\(/include/freetype2\)|${LOCALBASE}\1|' \
+ ${WRKSRC}/libFL/ang/GNUmakefile
@${REINPLACE_CMD} -e 's|%%ICONV_LIB%%|${ICONV_LIB}|' \
${WRKSRC}/lib/GNUmakefile
diff --git a/graphics/inventor/files/patch-SoText2.c++ b/graphics/inventor/files/patch-SoText2.c++
index bd890bf99a7d..4258bddfb534 100644
--- a/graphics/inventor/files/patch-SoText2.c++
+++ b/graphics/inventor/files/patch-SoText2.c++
@@ -1,23 +1,6 @@
*** lib/database/src/so/nodes/SoText2.c++.orig Tue Sep 25 00:45:41 2001
--- lib/database/src/so/nodes/SoText2.c++ Mon Dec 23 13:28:11 2002
***************
-*** 778,784 ****
- size_t outbytes = 2*inbytes+2;
- char* output = (char*)UCSStrings[i];
-
-! if ((iconv(conversionCode, &input, &inbytes, &output, &outbytes) == (size_t)-1)){
- #ifdef DEBUG
- SoDebugError::post("SoBitmapFontCache::convertToUCS",
- "Error converting text to UCS-2");
---- 778,784 ----
- size_t outbytes = 2*inbytes+2;
- char* output = (char*)UCSStrings[i];
-
-! if ((iconv(conversionCode, (const char **)&input, &inbytes, &output, &outbytes) == (size_t)-1)){
- #ifdef DEBUG
- SoDebugError::post("SoBitmapFontCache::convertToUCS",
- "Error converting text to UCS-2");
-***************
*** 1498,1503 ****
--- 1498,1504 ----
// And some font library stuff:
diff --git a/graphics/inventor/files/patch-SoText3.c++ b/graphics/inventor/files/patch-SoText3.c++
deleted file mode 100644
index e5be93d7a900..000000000000
--- a/graphics/inventor/files/patch-SoText3.c++
+++ /dev/null
@@ -1,19 +0,0 @@
-*** lib/database/src/so/nodes/SoText3.c++.orig Mon Dec 23 13:37:59 2002
---- lib/database/src/so/nodes/SoText3.c++ Mon Dec 23 13:38:15 2002
-***************
-*** 2291,2297 ****
- size_t outbytes = 2*inbytes+2;
- char* output = (char*)UCSStrings[i];
-
-! if ((iconv(conversionCode, &input, &inbytes, &output, &outbytes) == (size_t)-1)){
- #ifdef DEBUG
- SoDebugError::post("SoOutlineFontCache::convertToUCS",
- "Error converting text to UCS-2");
---- 2291,2297 ----
- size_t outbytes = 2*inbytes+2;
- char* output = (char*)UCSStrings[i];
-
-! if ((iconv(conversionCode, (const char **)&input, &inbytes, &output, &outbytes) == (size_t)-1)){
- #ifdef DEBUG
- SoDebugError::post("SoOutlineFontCache::convertToUCS",
- "Error converting text to UCS-2");
diff --git a/graphics/inventor/files/patch-TextWrapper.c++ b/graphics/inventor/files/patch-TextWrapper.c++
deleted file mode 100644
index 29a30fcebffe..000000000000
--- a/graphics/inventor/files/patch-TextWrapper.c++
+++ /dev/null
@@ -1,36 +0,0 @@
-*** apps/demos/textomatic/TextWrapper.c++.orig Thu Jan 2 15:29:27 2003
---- apps/demos/textomatic/TextWrapper.c++ Thu Jan 2 15:31:00 2003
-***************
-*** 77,83 ****
- char *output = outbuf;
- //
- if ( global_iconvCodeL2 == (iconv_t)-1 ||
-! iconv(global_iconvCodeL2,&input,&inbytesleft,&output,&outbytesleft) == (size_t)-1 )
- {
- fprintf( stderr, "textomatic: iconv error.\n" );
- (*(UCS2 *)outbuf)=0;
---- 77,83 ----
- char *output = outbuf;
- //
- if ( global_iconvCodeL2 == (iconv_t)-1 ||
-! iconv(global_iconvCodeL2,(const char **)&input,&inbytesleft,&output,&outbytesleft) == (size_t)-1 )
- {
- fprintf( stderr, "textomatic: iconv error.\n" );
- (*(UCS2 *)outbuf)=0;
-***************
-*** 229,235 ****
- char *output = outbuf;
- //
- if ( global_iconvCode28 == (iconv_t)-1 ||
-! iconv( global_iconvCode28,&input,&inbytesleft,&output,&outbytesleft ) == (size_t)-1 )
- {
- fprintf( stderr, "textomatic: iconv error.\n" );
- (*(UCS2 *)outbuf)=0;
---- 229,235 ----
- char *output = outbuf;
- //
- if ( global_iconvCode28 == (iconv_t)-1 ||
-! iconv( global_iconvCode28,(const char **)&input,&inbytesleft,&output,&outbytesleft ) == (size_t)-1 )
- {
- fprintf( stderr, "textomatic: iconv error.\n" );
- (*(UCS2 *)outbuf)=0;
diff --git a/graphics/inventor/files/patch-ivcommondefs b/graphics/inventor/files/patch-ivcommondefs
index c894661c958b..52404fcd9fdc 100644
--- a/graphics/inventor/files/patch-ivcommondefs
+++ b/graphics/inventor/files/patch-ivcommondefs
@@ -1,82 +1,30 @@
---- make/ivcommondefs.orig Sat Jul 12 07:40:54 2003
-+++ make/ivcommondefs Sun Aug 3 15:10:28 2003
-@@ -49,9 +49,9 @@
-
- ifeq ($(usingLinux), 1)
-
--CC = /usr/bin/gcc
--C++ = /usr/bin/g++
--LD = /usr/bin/g++
-+CC = %%CC%%
-+C++ = %%CXX%%
-+LD = %%CXX%%
-
- INSTALL = /usr/bin/install
-
-@@ -74,7 +74,7 @@
- LCXXOPTS += $(LINUXOPTS)
- LCOPTS += $(LINUXOPTS)
-
--X11DIR = /usr/X11R6
-+X11DIR = ${LOCALBASE}
- X11INCDIR = $(X11DIR)/include
- X11LIBDIR = $(X11DIR)/lib
-
-@@ -86,6 +86,10 @@
-
- endif
-
-+ifeq ($(usingFreeBSD), 1)
-+LCINCS += -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2
-+LCXXINCS += -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2
-+endif
-
-
- #
-@@ -131,9 +135,9 @@
+--- make/ivcommondefs.orig 2003-07-11 22:40:54 UTC
++++ make/ivcommondefs
+@@ -131,9 +131,9 @@ endif
# Determine optimization from LIBTYPE.
#
-OPTIMIZER = -O -DNDEBUG
-+OPTIMIZER = %%CXXFLAGS%% -DNDEBUG
++OPTIMIZER = -DNDEBUG
ifneq (, $(findstring debug, $(LIBTYPE)))
-OPTIMIZER = -g
-+OPTIMIZER = %%CXXFLAGS%% -g -DDEBUG
++OPTIMIZER = -DDEBUG
endif
-@@ -158,6 +162,10 @@
- # Font library directories.
+@@ -206,12 +206,6 @@ IVDEMODATADIR = $(IVDEMODIR)/data/Invent
+ # Locate installed Inventor libraries when linking applications.
#
-+ifeq ($(usingFreeBSD), 1)
-+FREETYPE=1
-+endif
-+
- FLDIR = $(IVDEPTH)/libFL/src
- FLLIB = -lFL
- ifdef FREETYPE
-@@ -183,7 +191,12 @@
- # Inventor install directories.
- #
-
-+ifeq ($(usingFreeBSD), 1)
-+IVPREFIX = ${PREFIX}
-+else
- IVPREFIX = /usr
-+endif
-+
- LCXXOPTS += -DIVPREFIX=\"$(IVPREFIX)\"
- LCOPTS += -DIVPREFIX=\"$(IVPREFIX)\"
-
-@@ -213,5 +226,10 @@
- else
- LLDDSOOPTS += -L$(IVLIBDIR)
- LLDOPTS += -L$(IVLIBDIR)
-+endif
-+
-+ifeq ($(usingFreeBSD), 1)
+-ifneq (, $(findstring debug, $(LIBTYPE)))
+-LLDDSOOPTS += -L$(IVDLIBDIR)
+-LLDOPTS += -L$(IVDLIBDIR)
+-CXXDSOOPTS += -L$(IVDLIBDIR)
+-else
+-LLDDSOOPTS += -L$(IVLIBDIR)
+-LLDOPTS += -L$(IVLIBDIR)
+-CXXDSOOPTS += -L$(IVLIBDIR)
+-endif
++LLDDSOOPTS += -L$(IVDEPTH)/lib -L$(IVDEPTH)/libSoXt
+LLDOPTS += -L$(IVDEPTH)/lib -L$(IVDEPTH)/libSoXt
-+LLDDSOOPTS += -L$(IVDEPTH)/lib -L$(IVDEPTH)/libSoXt -L$(LOCALBASE)/lib
- CXXDSOOPTS += -L$(IVLIBDIR)
- endif
++CXXDSOOPTS += -L$(IVDEPTH)/lib -L$(IVDEPTH)/libSoXt
diff --git a/graphics/inventor/files/patch-machine.h b/graphics/inventor/files/patch-machine.h
index a18f79e74d62..1279ab8c1380 100644
--- a/graphics/inventor/files/patch-machine.h
+++ b/graphics/inventor/files/patch-machine.h
@@ -9,26 +9,7 @@
#define MACHINE_WORD_FORMAT DGL_LITTLE_ENDIAN
#define MACHINE_FLOAT_FORMAT DGL_NON_IEEE
-@@ -152,6 +152,18 @@
-
-
- /*
-+ * Alpha under FreeBSD
-+ */
-+
-+#if __alpha__ && __FreeBSD__
-+
-+#define MACHINE_WORD_FORMAT DGL_LITTLE_ENDIAN
-+#define MACHINE_FLOAT_FORMAT DGL_NON_IEEE
-+
-+#endif /* __alpha__ && __FreeBSD__ */
-+
-+
-+/*
- * Apple Darwin (Mac OS X) machine dependent setup
- */
-
-@@ -321,7 +333,7 @@
+@@ -321,7 +321,7 @@
*/
#if MACHINE_FLOAT_FORMAT == DGL_NON_IEEE
diff --git a/graphics/inventor/files/pkg-message.in b/graphics/inventor/files/pkg-message.in
index c3dbe6ba69a7..0eb31adfcaf2 100644
--- a/graphics/inventor/files/pkg-message.in
+++ b/graphics/inventor/files/pkg-message.in
@@ -3,7 +3,7 @@
Please set the environment variable FL_FONT_PATH to the directory where your
TrueType fonts are installed. If you do not set this variable, Open Inventor(TM)
-will use %%PREFIX%%/lib/X11/fonts/TTF as default.
+will use %%PREFIX%%/share/fonts/TTF as default.
Open Inventor (TM) needs the following TrueType fonts:
diff --git a/graphics/ipe/files/patch-ipelib__ipedoc.cpp b/graphics/ipe/files/patch-ipelib__ipedoc.cpp
deleted file mode 100644
index a0317b4e924d..000000000000
--- a/graphics/ipe/files/patch-ipelib__ipedoc.cpp
+++ /dev/null
@@ -1,23 +0,0 @@
---- ipelib/ipedoc.cpp.orig 2013-03-15 13:37:02.000000000 +0000
-+++ ipelib/ipedoc.cpp
-@@ -41,6 +41,7 @@
- #include "ipelatex.h"
-
- #include <errno.h>
-+#include <sys/param.h>
-
- #ifdef IPE_USE_ICONV
- #include <iconv.h>
-@@ -850,7 +851,12 @@ int Document::runLatex(String &texLog)
- if (!file)
- return ErrWritingSource;
-
-+#if defined(__FreeBSD__) || \
-+ (defined(__DragonFly__) && __DragonFly_version > 300502)
-+ const char *inbuf = utf8.data();
-+#else
- char *inbuf = (char *) utf8.data();
-+#endif
- size_t inbytesleft = utf8.size();
-
- FileStream fstream(file);
diff --git a/graphics/sswf/Makefile b/graphics/sswf/Makefile
index 347d7e8ad630..ed7c8f8e3092 100644
--- a/graphics/sswf/Makefile
+++ b/graphics/sswf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sswf
PORTVERSION= 1.8.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -29,15 +29,15 @@ LIBS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= DEBUG
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
.if ! ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --disable-debug --disable-yydebug
.endif
-post-configure:
- @${REINPLACE_CMD} 's|ICONV_INPUT_CAST||' \
- ${WRKSRC}/src/lib/libsswf_tag_header.c++ \
- ${WRKSRC}/src/sswf/sswf_lexical.c++
+.if empty(ICONV_LIB)
+CONFIGURE_ARGS+=ac_cv_lib_iconv_libiconv_open=no \
+ ac_cv_lib_iconv_iconv_open=no
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/sswf/files/patch-include_sswf_libsswf.h b/graphics/sswf/files/patch-include_sswf_libsswf.h
index 5c590d72fe20..818cff7d228f 100644
--- a/graphics/sswf/files/patch-include_sswf_libsswf.h
+++ b/graphics/sswf/files/patch-include_sswf_libsswf.h
@@ -1,6 +1,6 @@
---- include/sswf/libsswf.h.orig Sat Aug 12 23:59:53 2006
-+++ include/sswf/libsswf.h Sun Aug 13 00:00:44 2006
-@@ -60,16 +60,6 @@
+--- include/sswf/libsswf.h.orig 2009-03-08 04:04:03 UTC
++++ include/sswf/libsswf.h
+@@ -68,16 +68,6 @@ SOFTWARE.
#include "sswf/libsswf-config.h"
@@ -17,3 +17,12 @@
#ifndef M_PI
#define M_PI 3.14159265358979323846
#endif
+@@ -88,7 +78,7 @@ typedef unsigned int wint_t;
+ #define rint(x) ((double) (long) floor(x + 0.5))
+ #endif
+
+-#ifdef _LIBICONV_H
++#if defined(_LIBICONV_H) && _LIBICONV_VERSION < 0x010B
+ #define ICONV_INPUT_CAST
+ #else
+ /* older versions of iconv() were broken in regard to the
diff --git a/graphics/swfmill/Makefile b/graphics/swfmill/Makefile
index 9158c2d8e1e1..12fde2cc1cdc 100644
--- a/graphics/swfmill/Makefile
+++ b/graphics/swfmill/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
USES= dos2unix iconv gmake pkgconfig libtool
USE_GNOME= libxml2 libxslt
GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
DOS2UNIX_FILES= src/swft/swft_import_ttf.cpp
PLIST_FILES= bin/swfmill