aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2004-12-31 18:24:10 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2004-12-31 18:24:10 +0000
commit64cf27c85d89298041b8c8dc2fd090181e6d10d8 (patch)
tree11668b893f94453b0262a155d53e6eac8dd4a6f5 /graphics
parent440d8863c8d496b982754e2a71867892213a902b (diff)
downloadports-64cf27c85d89298041b8c8dc2fd090181e6d10d8.tar.gz
ports-64cf27c85d89298041b8c8dc2fd090181e6d10d8.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/linux-ac3d/Makefile2
-rw-r--r--graphics/linux-bmrt/Makefile3
-rw-r--r--graphics/linux-f10-gdk-pixbuf/Makefile6
-rw-r--r--graphics/linux-f10-jpeg/Makefile4
-rw-r--r--graphics/linux-f10-libmng/Makefile2
-rw-r--r--graphics/linux-f10-png/Makefile3
-rw-r--r--graphics/linux-f10-png10/Makefile3
-rw-r--r--graphics/linux-f10-sdl_image/Makefile2
-rw-r--r--graphics/linux-f10-tiff/Makefile4
-rw-r--r--graphics/linux-f10-ungif/Makefile2
-rw-r--r--graphics/linux-f8-gdk-pixbuf/Makefile6
-rw-r--r--graphics/linux-f8-jpeg/Makefile4
-rw-r--r--graphics/linux-f8-libmng/Makefile2
-rw-r--r--graphics/linux-f8-png/Makefile3
-rw-r--r--graphics/linux-f8-png10/Makefile3
-rw-r--r--graphics/linux-f8-sdl_image/Makefile2
-rw-r--r--graphics/linux-f8-tiff/Makefile4
-rw-r--r--graphics/linux-f8-ungif/Makefile2
-rw-r--r--graphics/linux-gdk-pixbuf/Makefile6
-rw-r--r--graphics/linux-jpeg/Makefile4
-rw-r--r--graphics/linux-libmng/Makefile2
-rw-r--r--graphics/linux-panorama-tools/Makefile2
-rw-r--r--graphics/linux-png/Makefile3
-rw-r--r--graphics/linux-png10/Makefile3
-rw-r--r--graphics/linux-sdl_image/Makefile2
-rw-r--r--graphics/linux-tiff/Makefile4
-rw-r--r--graphics/linux-ungif/Makefile2
-rw-r--r--graphics/linux_dri/Makefile7
-rw-r--r--graphics/linux_glide/Makefile2
-rw-r--r--graphics/linux_glx/Makefile7
-rw-r--r--graphics/linux_mesa3/Makefile10
31 files changed, 73 insertions, 38 deletions
diff --git a/graphics/linux-ac3d/Makefile b/graphics/linux-ac3d/Makefile
index 75212e01a4b2..b8bcb2ad6a41 100644
--- a/graphics/linux-ac3d/Makefile
+++ b/graphics/linux-ac3d/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ac3d
PORTVERSION= 4.0f
+PORTREVISION= 1
CATEGORIES= graphics linux
MASTER_SITES= http://inivis.swmirror.com/
PKGNAMEPREFIX= linux-
@@ -19,6 +20,7 @@ COMMENT= Easy to use and powerful 3D graphics modeller (trial version)
.ifdef(INSTALL_DYNLINKED_VERSION)
LIB_DEPENDS= ${LINUXBASE}/usr/X11R6/libGLU.so.1:${PORTSDIR}/graphics/linux_mesa3
.endif
+RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
USE_LINUX= yes
NO_BUILD= yes
diff --git a/graphics/linux-bmrt/Makefile b/graphics/linux-bmrt/Makefile
index ec0b2545a495..6657e273c294 100644
--- a/graphics/linux-bmrt/Makefile
+++ b/graphics/linux-bmrt/Makefile
@@ -7,6 +7,7 @@
PORTNAME= linux-bmrt
PORTVERSION= 2.6beta
+PORTREVISION= 1
CATEGORIES= graphics linux
MASTER_SITES= #fetch manually
DISTNAME= BMRT${PORTVERSION}.linux-glibc2
@@ -14,7 +15,7 @@ DISTNAME= BMRT${PORTVERSION}.linux-glibc2
MAINTAINER= rjoseph@mammalia.org
COMMENT= A collection of rendering programs that use the RenderMan interface
-RUN_DEPENDS= /compat/linux/usr/X11R6/lib/libGL.so:${PORTSDIR}/graphics/linux_mesa3
+RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libGL.so:${PORTSDIR}/graphics/linux_mesa3
USE_LINUX= yes
WRKSRC= ${WRKDIR}/BMRT2.6
diff --git a/graphics/linux-f10-gdk-pixbuf/Makefile b/graphics/linux-f10-gdk-pixbuf/Makefile
index d8404bd796d8..1041587a2d05 100644
--- a/graphics/linux-f10-gdk-pixbuf/Makefile
+++ b/graphics/linux-f10-gdk-pixbuf/Makefile
@@ -7,9 +7,10 @@
PORTNAME= gdk-pixbuf
PORTVERSION= 0.22.0.11.3.5
+PORTREVISION= 1
CATEGORIES= graphics linux
MASTER_SITES= ${MASTER_SITE_FEDORA_LINUX}
-MASTER_SITE_SUBDIR=fedora/fedora/${BASEVERSION}/${MACHINE_ARCH}/RPMS.updates/
+MASTER_SITE_SUBDIR=fedora/fedora/${BASEVERSION}/${MACHINE_ARCH}/RPMS.updates
PKGNAMEPREFIX= linux-
DISTNAME= ${PORTNAME}-${PORTVERSION:C/^([^\.]+\.[^\.]+\.[^\.]+)\./\1-/}.${MACHINE_ARCH}
EXTRACT_SUFX= .rpm
@@ -20,7 +21,10 @@ COMMENT= Linux version of the graphic library for GTK+
BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
+CONFLICTS= linux-gtk2*
+
USE_LINUX_PREFIX=yes
+USE_LINUX= yes
ONLY_FOR_ARCHS= i386
DIST_SUBDIR= rpm
NO_BUILD= yes
diff --git a/graphics/linux-f10-jpeg/Makefile b/graphics/linux-f10-jpeg/Makefile
index 026237ccc42c..a17828596f65 100644
--- a/graphics/linux-f10-jpeg/Makefile
+++ b/graphics/linux-f10-jpeg/Makefile
@@ -7,10 +7,10 @@
PORTNAME= jpeg
PORTVERSION= 6b.15
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics linux
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= RPM of the JPEG lib
RPM_SET= libjpeg-6b-15.${MACHINE_ARCH}.rpm
diff --git a/graphics/linux-f10-libmng/Makefile b/graphics/linux-f10-libmng/Makefile
index 150caf7ef18b..7082c44c5534 100644
--- a/graphics/linux-f10-libmng/Makefile
+++ b/graphics/linux-f10-libmng/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libmng
PORTVERSION= 1.0.4
+PORTREVISION= 1
CATEGORIES= graphics linux
MASTER_SITES?= ${RPM_MIRRORS:S/__DIR__/${STDDIR}/g}
PKGNAMEPREFIX= linux-
@@ -23,6 +24,7 @@ RUN_DEPENDS= ${LINUXBASE}/usr/lib/libjpeg.so.62:${PORTSDIR}/graphics/linux-jpeg
BASEVERSION= 8.0
USE_LINUX_RPM= yes
USE_LINUX_PREFIX= yes
+USE_LINUX= yes
ONLY_FOR_ARCHS= i386
DIST_SUBDIR= rpm
diff --git a/graphics/linux-f10-png/Makefile b/graphics/linux-f10-png/Makefile
index 87ddd8a8f85a..029959b20ada 100644
--- a/graphics/linux-f10-png/Makefile
+++ b/graphics/linux-f10-png/Makefile
@@ -7,11 +7,12 @@
PORTNAME= png
PORTVERSION= 1.2.7
+PORTREVISION= 1
CATEGORIES= graphics linux
MASTER_SITES= http://mirrors.xmission.com/fedora/core/3/i386/os/Fedora/RPMS/ \
http://fedora.cat.pdx.edu/linux/core/3/i386/os/Fedora/RPMS/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= RPM of the PNG lib
DIST_SUBDIR= rpm/i386/fc3
diff --git a/graphics/linux-f10-png10/Makefile b/graphics/linux-f10-png10/Makefile
index 0a69d6a3fab8..b817efb03ff9 100644
--- a/graphics/linux-f10-png10/Makefile
+++ b/graphics/linux-f10-png10/Makefile
@@ -7,11 +7,12 @@
PORTNAME= png
PORTVERSION= 1.0.16
+PORTREVISION= 1
CATEGORIES= graphics linux
MASTER_SITES= http://mirrors.xmission.com/fedora/core/3/i386/os/Fedora/RPMS/ \
http://fedora.cat.pdx.edu/linux/core/3/i386/os/Fedora/RPMS/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= RPM of the PNG lib (old 1.0 version)
LATEST_LINK= linux-png10
diff --git a/graphics/linux-f10-sdl_image/Makefile b/graphics/linux-f10-sdl_image/Makefile
index c8607b6daf25..a7d1248095a3 100644
--- a/graphics/linux-f10-sdl_image/Makefile
+++ b/graphics/linux-f10-sdl_image/Makefile
@@ -21,8 +21,8 @@ COMMENT= A simple library to load images as SDL interfaces (linux version)
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
+USE_LINUX= yes
USE_LINUX_PREFIX= yes
-USE_LINUX_RPM= yes
LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
ONLY_FOR_ARCHS= i386
diff --git a/graphics/linux-f10-tiff/Makefile b/graphics/linux-f10-tiff/Makefile
index 40e581bee8d4..034ff66d61ab 100644
--- a/graphics/linux-f10-tiff/Makefile
+++ b/graphics/linux-f10-tiff/Makefile
@@ -7,10 +7,10 @@
PORTNAME= tiff
PORTVERSION= 3.5.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics linux
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= RPM of tiff lib
RPM_SET= libtiff-${PORTVERSION}-10.${MACHINE_ARCH}.rpm
diff --git a/graphics/linux-f10-ungif/Makefile b/graphics/linux-f10-ungif/Makefile
index d13e7b3021cf..479616796878 100644
--- a/graphics/linux-f10-ungif/Makefile
+++ b/graphics/linux-f10-ungif/Makefile
@@ -5,7 +5,7 @@
#
PORTNAME= ungif
PORTVERSION= 4.1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics linux
MAINTAINTER= maho@FreeBSD.org
diff --git a/graphics/linux-f8-gdk-pixbuf/Makefile b/graphics/linux-f8-gdk-pixbuf/Makefile
index d8404bd796d8..1041587a2d05 100644
--- a/graphics/linux-f8-gdk-pixbuf/Makefile
+++ b/graphics/linux-f8-gdk-pixbuf/Makefile
@@ -7,9 +7,10 @@
PORTNAME= gdk-pixbuf
PORTVERSION= 0.22.0.11.3.5
+PORTREVISION= 1
CATEGORIES= graphics linux
MASTER_SITES= ${MASTER_SITE_FEDORA_LINUX}
-MASTER_SITE_SUBDIR=fedora/fedora/${BASEVERSION}/${MACHINE_ARCH}/RPMS.updates/
+MASTER_SITE_SUBDIR=fedora/fedora/${BASEVERSION}/${MACHINE_ARCH}/RPMS.updates
PKGNAMEPREFIX= linux-
DISTNAME= ${PORTNAME}-${PORTVERSION:C/^([^\.]+\.[^\.]+\.[^\.]+)\./\1-/}.${MACHINE_ARCH}
EXTRACT_SUFX= .rpm
@@ -20,7 +21,10 @@ COMMENT= Linux version of the graphic library for GTK+
BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
+CONFLICTS= linux-gtk2*
+
USE_LINUX_PREFIX=yes
+USE_LINUX= yes
ONLY_FOR_ARCHS= i386
DIST_SUBDIR= rpm
NO_BUILD= yes
diff --git a/graphics/linux-f8-jpeg/Makefile b/graphics/linux-f8-jpeg/Makefile
index 026237ccc42c..a17828596f65 100644
--- a/graphics/linux-f8-jpeg/Makefile
+++ b/graphics/linux-f8-jpeg/Makefile
@@ -7,10 +7,10 @@
PORTNAME= jpeg
PORTVERSION= 6b.15
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics linux
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= RPM of the JPEG lib
RPM_SET= libjpeg-6b-15.${MACHINE_ARCH}.rpm
diff --git a/graphics/linux-f8-libmng/Makefile b/graphics/linux-f8-libmng/Makefile
index 150caf7ef18b..7082c44c5534 100644
--- a/graphics/linux-f8-libmng/Makefile
+++ b/graphics/linux-f8-libmng/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libmng
PORTVERSION= 1.0.4
+PORTREVISION= 1
CATEGORIES= graphics linux
MASTER_SITES?= ${RPM_MIRRORS:S/__DIR__/${STDDIR}/g}
PKGNAMEPREFIX= linux-
@@ -23,6 +24,7 @@ RUN_DEPENDS= ${LINUXBASE}/usr/lib/libjpeg.so.62:${PORTSDIR}/graphics/linux-jpeg
BASEVERSION= 8.0
USE_LINUX_RPM= yes
USE_LINUX_PREFIX= yes
+USE_LINUX= yes
ONLY_FOR_ARCHS= i386
DIST_SUBDIR= rpm
diff --git a/graphics/linux-f8-png/Makefile b/graphics/linux-f8-png/Makefile
index 87ddd8a8f85a..029959b20ada 100644
--- a/graphics/linux-f8-png/Makefile
+++ b/graphics/linux-f8-png/Makefile
@@ -7,11 +7,12 @@
PORTNAME= png
PORTVERSION= 1.2.7
+PORTREVISION= 1
CATEGORIES= graphics linux
MASTER_SITES= http://mirrors.xmission.com/fedora/core/3/i386/os/Fedora/RPMS/ \
http://fedora.cat.pdx.edu/linux/core/3/i386/os/Fedora/RPMS/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= RPM of the PNG lib
DIST_SUBDIR= rpm/i386/fc3
diff --git a/graphics/linux-f8-png10/Makefile b/graphics/linux-f8-png10/Makefile
index 0a69d6a3fab8..b817efb03ff9 100644
--- a/graphics/linux-f8-png10/Makefile
+++ b/graphics/linux-f8-png10/Makefile
@@ -7,11 +7,12 @@
PORTNAME= png
PORTVERSION= 1.0.16
+PORTREVISION= 1
CATEGORIES= graphics linux
MASTER_SITES= http://mirrors.xmission.com/fedora/core/3/i386/os/Fedora/RPMS/ \
http://fedora.cat.pdx.edu/linux/core/3/i386/os/Fedora/RPMS/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= RPM of the PNG lib (old 1.0 version)
LATEST_LINK= linux-png10
diff --git a/graphics/linux-f8-sdl_image/Makefile b/graphics/linux-f8-sdl_image/Makefile
index c8607b6daf25..a7d1248095a3 100644
--- a/graphics/linux-f8-sdl_image/Makefile
+++ b/graphics/linux-f8-sdl_image/Makefile
@@ -21,8 +21,8 @@ COMMENT= A simple library to load images as SDL interfaces (linux version)
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
+USE_LINUX= yes
USE_LINUX_PREFIX= yes
-USE_LINUX_RPM= yes
LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
ONLY_FOR_ARCHS= i386
diff --git a/graphics/linux-f8-tiff/Makefile b/graphics/linux-f8-tiff/Makefile
index 40e581bee8d4..034ff66d61ab 100644
--- a/graphics/linux-f8-tiff/Makefile
+++ b/graphics/linux-f8-tiff/Makefile
@@ -7,10 +7,10 @@
PORTNAME= tiff
PORTVERSION= 3.5.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics linux
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= RPM of tiff lib
RPM_SET= libtiff-${PORTVERSION}-10.${MACHINE_ARCH}.rpm
diff --git a/graphics/linux-f8-ungif/Makefile b/graphics/linux-f8-ungif/Makefile
index d13e7b3021cf..479616796878 100644
--- a/graphics/linux-f8-ungif/Makefile
+++ b/graphics/linux-f8-ungif/Makefile
@@ -5,7 +5,7 @@
#
PORTNAME= ungif
PORTVERSION= 4.1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics linux
MAINTAINTER= maho@FreeBSD.org
diff --git a/graphics/linux-gdk-pixbuf/Makefile b/graphics/linux-gdk-pixbuf/Makefile
index d8404bd796d8..1041587a2d05 100644
--- a/graphics/linux-gdk-pixbuf/Makefile
+++ b/graphics/linux-gdk-pixbuf/Makefile
@@ -7,9 +7,10 @@
PORTNAME= gdk-pixbuf
PORTVERSION= 0.22.0.11.3.5
+PORTREVISION= 1
CATEGORIES= graphics linux
MASTER_SITES= ${MASTER_SITE_FEDORA_LINUX}
-MASTER_SITE_SUBDIR=fedora/fedora/${BASEVERSION}/${MACHINE_ARCH}/RPMS.updates/
+MASTER_SITE_SUBDIR=fedora/fedora/${BASEVERSION}/${MACHINE_ARCH}/RPMS.updates
PKGNAMEPREFIX= linux-
DISTNAME= ${PORTNAME}-${PORTVERSION:C/^([^\.]+\.[^\.]+\.[^\.]+)\./\1-/}.${MACHINE_ARCH}
EXTRACT_SUFX= .rpm
@@ -20,7 +21,10 @@ COMMENT= Linux version of the graphic library for GTK+
BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
+CONFLICTS= linux-gtk2*
+
USE_LINUX_PREFIX=yes
+USE_LINUX= yes
ONLY_FOR_ARCHS= i386
DIST_SUBDIR= rpm
NO_BUILD= yes
diff --git a/graphics/linux-jpeg/Makefile b/graphics/linux-jpeg/Makefile
index 026237ccc42c..a17828596f65 100644
--- a/graphics/linux-jpeg/Makefile
+++ b/graphics/linux-jpeg/Makefile
@@ -7,10 +7,10 @@
PORTNAME= jpeg
PORTVERSION= 6b.15
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics linux
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= RPM of the JPEG lib
RPM_SET= libjpeg-6b-15.${MACHINE_ARCH}.rpm
diff --git a/graphics/linux-libmng/Makefile b/graphics/linux-libmng/Makefile
index 150caf7ef18b..7082c44c5534 100644
--- a/graphics/linux-libmng/Makefile
+++ b/graphics/linux-libmng/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libmng
PORTVERSION= 1.0.4
+PORTREVISION= 1
CATEGORIES= graphics linux
MASTER_SITES?= ${RPM_MIRRORS:S/__DIR__/${STDDIR}/g}
PKGNAMEPREFIX= linux-
@@ -23,6 +24,7 @@ RUN_DEPENDS= ${LINUXBASE}/usr/lib/libjpeg.so.62:${PORTSDIR}/graphics/linux-jpeg
BASEVERSION= 8.0
USE_LINUX_RPM= yes
USE_LINUX_PREFIX= yes
+USE_LINUX= yes
ONLY_FOR_ARCHS= i386
DIST_SUBDIR= rpm
diff --git a/graphics/linux-panorama-tools/Makefile b/graphics/linux-panorama-tools/Makefile
index 17c521f3b23f..008a8e6d071d 100644
--- a/graphics/linux-panorama-tools/Makefile
+++ b/graphics/linux-panorama-tools/Makefile
@@ -23,7 +23,7 @@ COMMENT= Software to View, Create, Edit and Remap Panoramic Images
RUN_DEPENDS= ${LINUXBASE}/usr/bin/jpegtran:${PORTSDIR}/graphics/linux-jpeg \
${LINUXBASE}/usr/bin/tiffcmp:${PORTSDIR}/graphics/linux-tiff \
- ${LINUXBASE}/usr/lib/libpng.so.3:${PORTSDIR}/graphics/linux-png
+ ${LINUXBASE}/usr/lib/libpng12.so.0.1.2.7:${PORTSDIR}/graphics/linux-png
USE_LINUX= yes
NO_BUILD= yes
diff --git a/graphics/linux-png/Makefile b/graphics/linux-png/Makefile
index 87ddd8a8f85a..029959b20ada 100644
--- a/graphics/linux-png/Makefile
+++ b/graphics/linux-png/Makefile
@@ -7,11 +7,12 @@
PORTNAME= png
PORTVERSION= 1.2.7
+PORTREVISION= 1
CATEGORIES= graphics linux
MASTER_SITES= http://mirrors.xmission.com/fedora/core/3/i386/os/Fedora/RPMS/ \
http://fedora.cat.pdx.edu/linux/core/3/i386/os/Fedora/RPMS/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= RPM of the PNG lib
DIST_SUBDIR= rpm/i386/fc3
diff --git a/graphics/linux-png10/Makefile b/graphics/linux-png10/Makefile
index 0a69d6a3fab8..b817efb03ff9 100644
--- a/graphics/linux-png10/Makefile
+++ b/graphics/linux-png10/Makefile
@@ -7,11 +7,12 @@
PORTNAME= png
PORTVERSION= 1.0.16
+PORTREVISION= 1
CATEGORIES= graphics linux
MASTER_SITES= http://mirrors.xmission.com/fedora/core/3/i386/os/Fedora/RPMS/ \
http://fedora.cat.pdx.edu/linux/core/3/i386/os/Fedora/RPMS/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= RPM of the PNG lib (old 1.0 version)
LATEST_LINK= linux-png10
diff --git a/graphics/linux-sdl_image/Makefile b/graphics/linux-sdl_image/Makefile
index c8607b6daf25..a7d1248095a3 100644
--- a/graphics/linux-sdl_image/Makefile
+++ b/graphics/linux-sdl_image/Makefile
@@ -21,8 +21,8 @@ COMMENT= A simple library to load images as SDL interfaces (linux version)
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
+USE_LINUX= yes
USE_LINUX_PREFIX= yes
-USE_LINUX_RPM= yes
LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
ONLY_FOR_ARCHS= i386
diff --git a/graphics/linux-tiff/Makefile b/graphics/linux-tiff/Makefile
index 40e581bee8d4..034ff66d61ab 100644
--- a/graphics/linux-tiff/Makefile
+++ b/graphics/linux-tiff/Makefile
@@ -7,10 +7,10 @@
PORTNAME= tiff
PORTVERSION= 3.5.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics linux
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= RPM of tiff lib
RPM_SET= libtiff-${PORTVERSION}-10.${MACHINE_ARCH}.rpm
diff --git a/graphics/linux-ungif/Makefile b/graphics/linux-ungif/Makefile
index d13e7b3021cf..479616796878 100644
--- a/graphics/linux-ungif/Makefile
+++ b/graphics/linux-ungif/Makefile
@@ -5,7 +5,7 @@
#
PORTNAME= ungif
PORTVERSION= 4.1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics linux
MAINTAINTER= maho@FreeBSD.org
diff --git a/graphics/linux_dri/Makefile b/graphics/linux_dri/Makefile
index 618c21745e8d..a60758d06be6 100644
--- a/graphics/linux_dri/Makefile
+++ b/graphics/linux_dri/Makefile
@@ -7,7 +7,7 @@
PORTNAME= linux_dri
PORTVERSION= 4.3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics linux
MASTER_SITES= ftp://ftp.xfree86.org/pub/XFree86/${PORTVERSION}/binaries/Linux-ix86-glibc21/:x \
http://people.freebsd.org/~anholt/dri/files/:anholt
@@ -17,12 +17,15 @@ DISTFILES= Xbin.tgz:x \
linux-dri-tools.tar.gz:anholt
DIST_SUBDIR= linux_dri-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= Binary Linux DRI libraries for 3D hardware acceleration of linux apps
+RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libX11.so.6:${PORTSDIR}/x11/linux-XFree86-libs
+
WRKSRC= ${WRKDIR}/lib
NO_BUILD= yes
USE_LINUX_PREFIX= yes
+USE_LINUX= yes
ONLY_FOR_ARCHS= i386
diff --git a/graphics/linux_glide/Makefile b/graphics/linux_glide/Makefile
index 2240e4a3fbf1..599f4fb62974 100644
--- a/graphics/linux_glide/Makefile
+++ b/graphics/linux_glide/Makefile
@@ -8,6 +8,7 @@
PORTNAME= glide
PORTVERSION= 2.4
+PORTREVISION= 1
CATEGORIES= graphics linux
MASTER_SITES= http://www2.cons.org/freebsd-distfiles/ \
${MASTER_SITE_LOCAL}
@@ -21,6 +22,7 @@ COMMENT= Linux library implementing the GLIDE interface to 3dfx video cards
ONLY_FOR_ARCHS= i386
USE_LINUX_PREFIX=yes
+USE_LINUX= yes
NO_MTREE= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/Glide2.4
diff --git a/graphics/linux_glx/Makefile b/graphics/linux_glx/Makefile
index 97eed90295ee..0a9c33a1abb5 100644
--- a/graphics/linux_glx/Makefile
+++ b/graphics/linux_glx/Makefile
@@ -7,21 +7,22 @@
PORTNAME= glx
PORTVERSION= 991127
+PORTREVISION= 1
CATEGORIES= graphics linux
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= 3d/glx/linux
PKGNAMEPREFIX= linux_
DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= Libraries to make use of glx-aware Linux apps
-BUILD_DEPENDS= /compat/linux/sbin/ldconfig:${PORTSDIR}/emulators/linux_base
+BUILD_DEPENDS= ${LINUXBASE}/sbin/ldconfig:${PORTSDIR}/emulators/linux_base-8
USE_BZIP2= yes
NO_BUILD= yes
-PREFIX= /compat/linux
+USE_LINUX_PREFIX=yes
NO_MTREE= yes
WRKSRC= ${WRKDIR}/linux_glx
diff --git a/graphics/linux_mesa3/Makefile b/graphics/linux_mesa3/Makefile
index 5ec9159b0f68..029870d73d86 100644
--- a/graphics/linux_mesa3/Makefile
+++ b/graphics/linux_mesa3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mesa
PORTVERSION= 3.4.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics linux
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.fu-berlin.de/pub/unix/X11/graphics/Mesa/
@@ -16,7 +16,7 @@ PKGNAMEPREFIX= linux_
DISTFILES= MesaLib-${PORTVERSION}${EXTRACT_SUFX} \
MesaDemos-${PORTVERSION}${EXTRACT_SUFX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= A graphics library similar to SGI's OpenGL, used from Linux programs
USE_BZIP2= yes
@@ -63,8 +63,10 @@ BUILD_DEPENDS+= ${LINUXBASE}/lib/ld-linux.so.2:${PORTSDIR}/emulators/linux_base-
BUILD_DEPENDS+= ${LINUXBASE}/lib/ld-linux.so.2:${PORTSDIR}/emulators/linux_base-6 \
${LINUXBASE}/usr/bin/gcc:${PORTSDIR}/devel/linux_devtools-6
.else
-BUILD_DEPENDS+= ${LINUXBASE}/lib/ld-linux.so.2:${PORTSDIR}/emulators/linux_base \
- ${LINUXBASE}/usr/bin/gcc:${PORTSDIR}/devel/linux_devtools-7
+BUILD_DEPENDS+= ${LINUXBASE}/lib/ld-linux.so.2:${PORTSDIR}/emulators/linux_base-8 \
+ ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs \
+ ${LINUXBASE}/usr/bin/gcc:${PORTSDIR}/devel/linux_devtools
+RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
.endif
post-install: