aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-22 17:44:08 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-22 17:44:08 +0000
commit08367443576956fec7cc80a52f74f46df2edc206 (patch)
tree647531703f796d12e1897620418422f2a9f47f81 /graphics
parented9a86da78dba666b1563a832ece9813947ac26d (diff)
downloadports-08367443576956fec7cc80a52f74f46df2edc206.tar.gz
ports-08367443576956fec7cc80a52f74f46df2edc206.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/p5-CAD-Drawing-Template/Makefile32
-rw-r--r--graphics/p5-CAD-Drawing-Template/distinfo3
-rw-r--r--graphics/p5-CAD-Drawing-Template/pkg-descr4
-rw-r--r--graphics/p5-CAD-Drawing-Template/pkg-plist3
5 files changed, 43 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 482e018bbad0..aac504675e53 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -400,6 +400,7 @@
SUBDIR += orca
SUBDIR += osg
SUBDIR += p5-CAD-Drawing
+ SUBDIR += p5-CAD-Drawing-Template
SUBDIR += p5-Cairo
SUBDIR += p5-Chart-Graph
SUBDIR += p5-Chart-PNGgraph
diff --git a/graphics/p5-CAD-Drawing-Template/Makefile b/graphics/p5-CAD-Drawing-Template/Makefile
new file mode 100644
index 000000000000..ba35d27588ee
--- /dev/null
+++ b/graphics/p5-CAD-Drawing-Template/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: CAD-Drawing-Template
+# Date created: 22 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CAD-Drawing-Template
+PORTVERSION= 0.01
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CAD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Replace tags with text and geometry
+
+BUILD_DEPENDS= ${SITE_PERL}/CAD/Drawing.pm:${PORTSDIR}/graphics/p5-CAD-Drawing \
+ ${SITE_PERL}/CAD/Calc.pm:${PORTSDIR}/math/p5-CAD-Calc
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= CAD::Drawing::Template.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/p5-CAD-Drawing-Template/distinfo b/graphics/p5-CAD-Drawing-Template/distinfo
new file mode 100644
index 000000000000..de16f5aedad1
--- /dev/null
+++ b/graphics/p5-CAD-Drawing-Template/distinfo
@@ -0,0 +1,3 @@
+MD5 (CAD-Drawing-Template-0.01.tar.gz) = 8c10198ec6fb09991753cf1b7c6097d7
+SHA256 (CAD-Drawing-Template-0.01.tar.gz) = b93852c4d61c6f483cada057e38508a898fe2501695e204426481291ca6a4511
+SIZE (CAD-Drawing-Template-0.01.tar.gz) = 7560
diff --git a/graphics/p5-CAD-Drawing-Template/pkg-descr b/graphics/p5-CAD-Drawing-Template/pkg-descr
new file mode 100644
index 000000000000..0d62c7b11eb2
--- /dev/null
+++ b/graphics/p5-CAD-Drawing-Template/pkg-descr
@@ -0,0 +1,4 @@
+Tag replacement framework for graphics/p5-CAD-Drawing.
+
+WWW: http://search.cpan.org/dist/CAD-Drawing-Template
+Author: Eric L. Wilhelm <ewilhelm at cpan dot org>
diff --git a/graphics/p5-CAD-Drawing-Template/pkg-plist b/graphics/p5-CAD-Drawing-Template/pkg-plist
new file mode 100644
index 000000000000..b78cd75ce7f1
--- /dev/null
+++ b/graphics/p5-CAD-Drawing-Template/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/CAD/Drawing/Template.pm
+@dirrmtry %%SITE_PERL%%/CAD/Drawing
+@dirrmtry %%SITE_PERL%%/CAD