aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-03-20 12:11:02 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-03-20 12:11:02 +0000
commit102ed1e628f3c99956c3a58907479d693998cf3f (patch)
tree16aacf34cc6a1a52d44e97632728ef943567da98 /graphics
parentddf765fee06608a66e4453aab1433e392b0007e2 (diff)
downloadports-102ed1e628f3c99956c3a58907479d693998cf3f.tar.gz
ports-102ed1e628f3c99956c3a58907479d693998cf3f.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/rigsofrods-pagedgeometry/Makefile33
-rw-r--r--graphics/rigsofrods-pagedgeometry/distinfo2
-rw-r--r--graphics/rigsofrods-pagedgeometry/files/patch-CMakeDependenciesConfig.txt40
-rw-r--r--graphics/rigsofrods-pagedgeometry/pkg-descr7
-rw-r--r--graphics/rigsofrods-pagedgeometry/pkg-plist16
6 files changed, 99 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 0ff40b4d2801..f3850789fe0c 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -919,6 +919,7 @@
SUBDIR += repng2jpeg
SUBDIR += rgbpaint
SUBDIR += rigsofrods-caelum
+ SUBDIR += rigsofrods-pagedgeometry
SUBDIR += ristretto
SUBDIR += ruby-gd
SUBDIR += ruby-gdal
diff --git a/graphics/rigsofrods-pagedgeometry/Makefile b/graphics/rigsofrods-pagedgeometry/Makefile
new file mode 100644
index 000000000000..4e8b4e000f09
--- /dev/null
+++ b/graphics/rigsofrods-pagedgeometry/Makefile
@@ -0,0 +1,33 @@
+# Created by: Thibault Payet <monwarez@mailoo.org>
+# $FreeBSD$
+
+PORTNAME= rigsofrods-pagedgeometry
+PORTVERSION= 1.2.0
+DISTVERSIONPREFIX= v
+CATEGORIES= graphics
+
+MAINTAINER= monwarez@mailoo.org
+COMMENT= OGRE plugin for real-time dense forests
+
+LICENSE= ZLIB
+LICENSE_FILE= ${WRKSRC}/zlib.txt
+
+LIB_DEPENDS= libOgreMain.so:graphics/ogre3d
+
+USE_GITHUB= yes
+GH_ACCOUNT= RigsOfRods
+GH_PROJECT= ogre-pagedgeometry
+
+USES= cmake dos2unix pathfix pkgconfig
+DOS2UNIX_GLOB= *.cpp *.h *.txt
+CMAKE_ARGS= -DPAGEDGEOMETRY_BUILD_SAMPLES=FALSE
+USE_LDCONFIG= yes
+
+# XXX dialog(1) doesn't like ^M in LICENSE_FILE
+post-extract: dos2unix
+
+post-patch:
+ @${REINPLACE_CMD} -e '/install.*DOC_FILES/d' \
+ ${WRKSRC}/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/graphics/rigsofrods-pagedgeometry/distinfo b/graphics/rigsofrods-pagedgeometry/distinfo
new file mode 100644
index 000000000000..7ecc00d12877
--- /dev/null
+++ b/graphics/rigsofrods-pagedgeometry/distinfo
@@ -0,0 +1,2 @@
+SHA256 (RigsOfRods-ogre-pagedgeometry-v1.2.0_GH0.tar.gz) = 02f9b73e468e0a6b658cc9cad2b6584f592b1f1e5e5151e1ead6cfc513cf479e
+SIZE (RigsOfRods-ogre-pagedgeometry-v1.2.0_GH0.tar.gz) = 11357734
diff --git a/graphics/rigsofrods-pagedgeometry/files/patch-CMakeDependenciesConfig.txt b/graphics/rigsofrods-pagedgeometry/files/patch-CMakeDependenciesConfig.txt
new file mode 100644
index 000000000000..973594fae503
--- /dev/null
+++ b/graphics/rigsofrods-pagedgeometry/files/patch-CMakeDependenciesConfig.txt
@@ -0,0 +1,40 @@
+--- CMakeDependenciesConfig.txt.orig 2016-01-10 10:54:34 UTC
++++ CMakeDependenciesConfig.txt
+@@ -2,11 +2,13 @@ IF(WIN32)
+ set(Ogre_INCLUDE_DIRS "include/Ogre" CACHE PATH "The ogre include path to use")
+ set(Ogre_LIBRARY_DIRS "lib" CACHE PATH "The ogre lib path to use")
+ set(Ogre_LIBRARIES "OgreMain" CACHE STRING "The ogre lib to link against")
++ if(PAGEDGEOMETRY_BUILD_SAMPLES)
+ set(Ois_INCLUDE_DIRS "include/ois" CACHE PATH "The OIS include path to use")
+ set(Ois_LIBRARY_DIRS "lib" CACHE PATH "The OIS lib path to use")
+ set(Ois_LIBRARIES "ois" CACHE STRING "The ogre lib to link against")
+ # add includes to check directories
+ set(CMAKE_REQUIRED_INCLUDES ${Ogre_INCLUDE_DIRS} ${Ois_INCLUDE_DIRS})
++ endif(PAGEDGEOMETRY_BUILD_SAMPLES)
+
+ # check for libs and include files we want to use
+ CHECK_INCLUDE_FILE(windows.h HAVE_WINDOWS_INCLUDES)
+@@ -22,7 +24,9 @@ ELSEIF(UNIX)
+ PKG_CHECK_MODULES (Ogre OGRE REQUIRED)
+ PKG_CHECK_MODULES (Ogre-Terrain OGRE-Terrain REQUIRED)
+ PKG_CHECK_MODULES (Ogre-Paging OGRE-Paging REQUIRED)
++ if(PAGEDGEOMETRY_BUILD_SAMPLES)
+ PKG_CHECK_MODULES (Ois OIS REQUIRED)
++ endif(PAGEDGEOMETRY_BUILD_SAMPLES)
+ # add includes to check directories
+ set(CMAKE_REQUIRED_INCLUDES ${Ogre_INCLUDE_DIRS} ${Ois_INCLUDE_DIRS})
+ # check for libs and include files we want to use
+@@ -46,6 +50,7 @@ IF(NOT WIN32)
+ message("could not find the Ogre includes. Please install them.")
+ endif()
+
++ if(PAGEDGEOMETRY_BUILD_SAMPLES)
+ CHECK_INCLUDE_FILE_CXX(OIS/OIS.h HAVE_OIS_DIR_INCLUDES)
+ if(HAVE_OIS_DIR_INCLUDES)
+ set(OIS_INCLUDE "OIS/OIS.h")
+@@ -65,4 +70,5 @@ IF(NOT WIN32)
+ else()
+ set(OIS_USING_DIR FALSE)
+ endif()
++ endif(PAGEDGEOMETRY_BUILD_SAMPLES)
+ endif()
diff --git a/graphics/rigsofrods-pagedgeometry/pkg-descr b/graphics/rigsofrods-pagedgeometry/pkg-descr
new file mode 100644
index 000000000000..bd74126dad64
--- /dev/null
+++ b/graphics/rigsofrods-pagedgeometry/pkg-descr
@@ -0,0 +1,7 @@
+The PagedGeometry engine is an add-on to Ogre which provides highly
+optimized methods for rendering massive amounts of small meshes,
+covering a possibly infinite area. This is especially well suited for
+dense forests and outdoor scenes, with millions of trees, bushes,
+grass, rocks, etc.
+
+WWW: http://www.ogre3d.org/tikiwiki/PagedGeometry+Engine
diff --git a/graphics/rigsofrods-pagedgeometry/pkg-plist b/graphics/rigsofrods-pagedgeometry/pkg-plist
new file mode 100644
index 000000000000..ee469d70130a
--- /dev/null
+++ b/graphics/rigsofrods-pagedgeometry/pkg-plist
@@ -0,0 +1,16 @@
+include/PagedGeometry/BatchPage.h
+include/PagedGeometry/BatchedGeometry.h
+include/PagedGeometry/GrassLoader.h
+include/PagedGeometry/ImpostorPage.h
+include/PagedGeometry/MersenneTwister.h
+include/PagedGeometry/PagedGeometry.h
+include/PagedGeometry/PagedGeometryConfig.h
+include/PagedGeometry/PropertyMaps.h
+include/PagedGeometry/RandomTable.h
+include/PagedGeometry/StaticBillboardSet.h
+include/PagedGeometry/TreeLoader2D.h
+include/PagedGeometry/TreeLoader3D.h
+include/PagedGeometry/WindBatchPage.h
+include/PagedGeometry/WindBatchedGeometry.h
+lib/libPagedGeometry.a
+libdata/pkgconfig/PagedGeometry.pc