aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
commit216b5a285fdcc1456a307fcc60f3507c20d613eb (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /graphics
parentb829518a7d432b7cc2546fde7f032238d1db13dc (diff)
downloadports-216b5a285fdcc1456a307fcc60f3507c20d613eb.tar.gz
ports-216b5a285fdcc1456a307fcc60f3507c20d613eb.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cfdg/files/patch-Makefile2
-rw-r--r--graphics/cinepaint/Makefile1
-rw-r--r--graphics/cinepaint/files/patch-app__Makefile.am8
-rw-r--r--graphics/cinepaint/files/patch-app__menus.c25
-rw-r--r--graphics/cinepaint/files/patch-lib__fl_i18n__Makefile.am12
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__blur__Makefile.am12
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__bracketing_to_hdr__Makefile.am12
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__bracketing_to_hdr__jhead__Makefile.am11
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__compose__Makefile.am12
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__dbbrowser__Makefile.am12
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__decompose__Makefile.am13
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__dicom__Makefile.am12
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__fits__Makefile.am12
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__gbr__Makefile.am12
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__hdr__Makefile.am12
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__iff__Makefile.am13
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__jpeg__Makefile.am12
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__median__Makefile.am12
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__minimum__Makefile.am12
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__noisify__Makefile.am12
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__openexr__Makefile.am12
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__pdf__Makefile.am12
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__pic__Makefile.am12
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__png__Makefile.am12
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__pnm__Makefile.am12
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__psd_save__Makefile.am12
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__screenshot__Makefile.am12
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__sgi__Makefile.am13
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__tga__Makefile.am13
-rw-r--r--graphics/cinepaint/files/patch-plug-ins__xwd__Makefile.am12
-rw-r--r--graphics/exiftran/files/Makefile.exiftran2
-rw-r--r--graphics/gimageview/Makefile1
-rw-r--r--graphics/gimp-wavelet-denoise-plugin/Makefile1
-rw-r--r--graphics/gimp-wavelet-sharpen-plugin/Makefile1
-rw-r--r--graphics/gpaint/Makefile3
-rw-r--r--graphics/gqview/Makefile2
-rw-r--r--graphics/inventor/Makefile6
-rw-r--r--graphics/inventor/files/patch-lib-GNUmakefile2
-rw-r--r--graphics/klatexformula/Makefile7
-rw-r--r--graphics/kudu/Makefile2
-rw-r--r--graphics/lprof-devel/files/patch-src-CMakeLists.txt7
-rw-r--r--graphics/nomacs/files/patch-CMakeLists.txt2
-rw-r--r--graphics/panoglview/Makefile9
-rw-r--r--graphics/pornview/Makefile4
-rw-r--r--graphics/reallyslick/Makefile10
-rw-r--r--graphics/rgbpaint/Makefile2
-rw-r--r--graphics/separate/Makefile5
-rw-r--r--graphics/vp/Makefile3
-rw-r--r--graphics/xzgv/Makefile2
49 files changed, 55 insertions, 367 deletions
diff --git a/graphics/cfdg/files/patch-Makefile b/graphics/cfdg/files/patch-Makefile
index b232448bbaed..c99dea41750e 100644
--- a/graphics/cfdg/files/patch-Makefile
+++ b/graphics/cfdg/files/patch-Makefile
@@ -5,7 +5,7 @@
cfdg: $(OBJS)
- $(LINK.o) $^ -L/usr/local/lib -lstdc++ -lpng -lz -fexceptions -o $@
-+ $(LINK.o) $^ $(shell libpng-config --ldflags) -lstdc++ -fexceptions -o $@
++ $(CXX) $^ $(shell libpng-config --ldflags) -lm -fexceptions -o $@
strip $@
diff --git a/graphics/cinepaint/Makefile b/graphics/cinepaint/Makefile
index 17f9ae7c2232..8bb58f53d3e0 100644
--- a/graphics/cinepaint/Makefile
+++ b/graphics/cinepaint/Makefile
@@ -31,7 +31,6 @@ USE_GNOME= gtk20
USE_GHOSTSCRIPT_RUN=yes
USE_PYTHON= yes
USE_AUTOTOOLS= libtoolize aclocal automake autoconf
-LIBTOOLIZE_ARGS=--force
ACLOCAL_ARGS= -I aclocal
AUTOMAKE_ARGS= --copy --force-missing --foreign --add-missing
USE_LDCONFIG= yes
diff --git a/graphics/cinepaint/files/patch-app__Makefile.am b/graphics/cinepaint/files/patch-app__Makefile.am
index 2e75bd0c166f..e6b9be903345 100644
--- a/graphics/cinepaint/files/patch-app__Makefile.am
+++ b/graphics/cinepaint/files/patch-app__Makefile.am
@@ -1,12 +1,18 @@
--- app/Makefile.am.orig
+++ app/Makefile.am
-@@ -420,7 +420,8 @@
+@@ -420,11 +420,14 @@
$(GTK_LIBS) \
$(X_LIBS) \
$(OYRANOS_LIBS) \
- $(LCMS_LIB)
+ $(LCMS_LIB) \
++ -lX11 \
+ -lm
cinepaint_remote_LDADD = \
$(GTK_LIBS) \
+ $(X_LIBS) \
++ -lX11 \
+ $(XMU_LIB)
+
+ ## DEPS = $(top_builddir)/lib/libcinepainti.a
diff --git a/graphics/cinepaint/files/patch-app__menus.c b/graphics/cinepaint/files/patch-app__menus.c
deleted file mode 100644
index 815843f66478..000000000000
--- a/graphics/cinepaint/files/patch-app__menus.c
+++ /dev/null
@@ -1,25 +0,0 @@
---- app/menus.c.orig
-+++ app/menus.c
-@@ -1597,7 +1597,7 @@
- char*
- menu_entry_translate (const char* entry)
- {
-- char *text = (char*) calloc (1024, sizeof(char)),
-+ char *text = (char*) calloc (sizeof(char), 1024),
- *word = 0;
- const char *tmp = 0;
-
-@@ -1647,11 +1647,11 @@
- // resize memory
- if(strlen(text))
- {
-- word = (char*) calloc( strlen(text) + 1, sizeof(char) );
-+ word = (char*) calloc( sizeof(char), strlen(text) + 4 );
- memcpy( word, text, strlen( text ) + 1 );
- free (text);
- return word;
- }
- else
-- return (char*) calloc(1,sizeof(char));
-+ return (char*) calloc(sizeof(char),1);
- }
diff --git a/graphics/cinepaint/files/patch-lib__fl_i18n__Makefile.am b/graphics/cinepaint/files/patch-lib__fl_i18n__Makefile.am
deleted file mode 100644
index 17db1bc0f1ac..000000000000
--- a/graphics/cinepaint/files/patch-lib__fl_i18n__Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- lib/fl_i18n/Makefile.am.orig
-+++ lib/fl_i18n/Makefile.am
-@@ -26,8 +26,7 @@
- -I$(top_srcdir) -I$(includedir)
-
- libcinepaint_fl_i18n_la_LIBADD = \
-- $(FLTK_LIBS_PURE) \
-- -lc
-+ $(FLTK_LIBS_PURE)
-
- .PHONY: files
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__blur__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__blur__Makefile.am
deleted file mode 100644
index e1f0c5654bf0..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__blur__Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- plug-ins/blur/Makefile.am.orig
-+++ plug-ins/blur/Makefile.am
-@@ -18,8 +18,7 @@
- $(top_builddir)/lib/libcinepaint.la \
- $(X_LIBS) \
- $(top_builddir)/libhalf/cinepaint_half.lo \
-- $(OPENEXR_LIBS) \
-- -lc
-+ $(OPENEXR_LIBS)
-
- DEPS = $(top_builddir)/lib/libcinepaint.la
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__bracketing_to_hdr__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__bracketing_to_hdr__Makefile.am
deleted file mode 100644
index c3ee5cadfd0a..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__bracketing_to_hdr__Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- plug-ins/bracketing_to_hdr/Makefile.am.orig
-+++ plug-ins/bracketing_to_hdr/Makefile.am
-@@ -51,8 +51,7 @@
- ./FL_adds/libfl_adds.la \
- ./gui/libgui.la \
- $(FLTK_LIBS) \
-- $(GTK_LIBS) \
-- -lc
-+ $(GTK_LIBS)
-
- DEPS = \
- ./br_core/libbr_core.la \
diff --git a/graphics/cinepaint/files/patch-plug-ins__bracketing_to_hdr__jhead__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__bracketing_to_hdr__jhead__Makefile.am
deleted file mode 100644
index 00ffbcf10fb4..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__bracketing_to_hdr__jhead__Makefile.am
+++ /dev/null
@@ -1,11 +0,0 @@
---- plug-ins/bracketing_to_hdr/jhead/Makefile.am.orig
-+++ plug-ins/bracketing_to_hdr/jhead/Makefile.am
-@@ -31,7 +31,7 @@
- -I$(includedir)
-
- LDADD = \
-- -lc -lm
-+ -lm
-
- .PHONY: files
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__compose__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__compose__Makefile.am
deleted file mode 100644
index 7f90e9c9c0d5..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__compose__Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- plug-ins/compose/Makefile.am.orig
-+++ plug-ins/compose/Makefile.am
-@@ -14,8 +14,7 @@
-
- LDADD = \
- $(top_builddir)/lib/libcinepaint.la \
-- $(X_LIBS) \
-- -lc
-+ $(X_LIBS)
-
- DEPS = $(top_builddir)/lib/libcinepaint.la
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__dbbrowser__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__dbbrowser__Makefile.am
deleted file mode 100644
index 8fbd6662405a..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__dbbrowser__Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- plug-ins/dbbrowser/Makefile.am.orig
-+++ plug-ins/dbbrowser/Makefile.am
-@@ -19,8 +19,7 @@
-
- LDADD = \
- $(top_builddir)/lib/libcinepaint.la \
-- $(X_LIBS) \
-- -lc
-+ $(X_LIBS)
-
- DEPS = $(top_builddir)/lib/libcinepaint.la
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__decompose__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__decompose__Makefile.am
deleted file mode 100644
index 17da554dcc04..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__decompose__Makefile.am
+++ /dev/null
@@ -1,13 +0,0 @@
---- plug-ins/decompose/Makefile.am.orig
-+++ plug-ins/decompose/Makefile.am
-@@ -14,9 +14,7 @@
-
- LDADD = \
- $(top_builddir)/lib/libcinepaint.la \
-- $(X_LIBS) \
-- \
-- -lc
-+ $(X_LIBS)
-
- DEPS = $(top_builddir)/lib/libcinepaint.la
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__dicom__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__dicom__Makefile.am
deleted file mode 100644
index aeeef7bd1685..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__dicom__Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- plug-ins/dicom/Makefile.am.orig
-+++ plug-ins/dicom/Makefile.am
-@@ -14,8 +14,7 @@
-
- LDADD = \
- $(top_builddir)/lib/libcinepaint.la \
-- $(X_LIBS) \
-- -lc
-+ $(X_LIBS)
-
- DEPS = $(top_builddir)/lib/libcinepaint.la
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__fits__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__fits__Makefile.am
deleted file mode 100644
index 9849135d9047..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__fits__Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- plug-ins/fits/Makefile.am.orig
-+++ plug-ins/fits/Makefile.am
-@@ -16,8 +16,7 @@
-
- LDADD = \
- $(top_builddir)/lib/libcinepaint.la \
-- $(X_LIBS) \
-- -lc
-+ $(X_LIBS)
-
- DEPS = $(top_builddir)/lib/libcinepaint.la
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__gbr__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__gbr__Makefile.am
deleted file mode 100644
index c81df9a63bf7..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__gbr__Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- plug-ins/gbr/Makefile.am.orig
-+++ plug-ins/gbr/Makefile.am
-@@ -16,8 +16,7 @@
- $(top_builddir)/lib/libcinepaint.la \
- $(X_LIBS) \
- $(top_builddir)/libhalf/cinepaint_half.lo \
-- $(OPENEXR_LIBS) \
-- -lc
-+ $(OPENEXR_LIBS)
-
- DEPS = $(top_builddir)/lib/libcinepaint.la
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__hdr__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__hdr__Makefile.am
deleted file mode 100644
index f2e0b79f0e45..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__hdr__Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- plug-ins/hdr/Makefile.am.orig
-+++ plug-ins/hdr/Makefile.am
-@@ -20,8 +20,7 @@
-
- LDADD = \
- $(top_builddir)/lib/libcinepaint.la \
-- $(X_LIBS) \
-- -lc
-+ $(X_LIBS)
-
- DEPS = $(top_builddir)/lib/libcinepaint.la
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__iff__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__iff__Makefile.am
deleted file mode 100644
index 5054e7afb236..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__iff__Makefile.am
+++ /dev/null
@@ -1,13 +0,0 @@
---- plug-ins/iff/Makefile.am.orig
-+++ plug-ins/iff/Makefile.am
-@@ -14,9 +14,7 @@
-
- LDADD = \
- $(top_builddir)/lib/libcinepaint.la \
-- $(X_LIBS) \
-- \
-- -lc
-+ $(X_LIBS)
-
- DEPS = $(top_builddir)/lib/libcinepaint.la
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__jpeg__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__jpeg__Makefile.am
deleted file mode 100644
index 9458bfcbdced..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__jpeg__Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- plug-ins/jpeg/Makefile.am.orig
-+++ plug-ins/jpeg/Makefile.am
-@@ -22,8 +22,7 @@
- @LCMS_LIB@ \
- @LIBJPEG_LIB@ \
- $(top_builddir)/libhalf/cinepaint_half.lo \
-- $(OPENEXR_LIBS) \
-- -lc
-+ $(OPENEXR_LIBS)
-
- DEPS = $(top_builddir)/lib/libcinepaint.la
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__median__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__median__Makefile.am
deleted file mode 100644
index 4cfcbae324bd..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__median__Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- plug-ins/median/Makefile.am.orig
-+++ plug-ins/median/Makefile.am
-@@ -16,8 +16,7 @@
-
- LDADD = \
- $(top_builddir)/lib/libcinepaint.la \
-- $(X_LIBS) \
-- -lc
-+ $(X_LIBS)
-
- DEPS = $(top_builddir)/lib/libcinepaint.la
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__minimum__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__minimum__Makefile.am
deleted file mode 100644
index 34b916e277ff..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__minimum__Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- plug-ins/minimum/Makefile.am.orig
-+++ plug-ins/minimum/Makefile.am
-@@ -16,8 +16,7 @@
-
- LDADD = \
- $(top_builddir)/lib/libcinepaint.la \
-- $(X_LIBS) \
-- -lc
-+ $(X_LIBS)
-
- DEPS = $(top_builddir)/lib/libcinepaint.la
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__noisify__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__noisify__Makefile.am
deleted file mode 100644
index c9ee523df032..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__noisify__Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- plug-ins/noisify/Makefile.am.orig
-+++ plug-ins/noisify/Makefile.am
-@@ -16,8 +16,7 @@
- $(top_builddir)/lib/libcinepaint.la \
- $(X_LIBS) \
- $(top_builddir)/libhalf/cinepaint_half.lo \
-- $(OPENEXR_LIBS) \
-- -lc
-+ $(OPENEXR_LIBS)
-
- DEPS = $(top_builddir)/lib/libcinepaint.la
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__openexr__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__openexr__Makefile.am
deleted file mode 100644
index 6d937d1856f9..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__openexr__Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- plug-ins/openexr/Makefile.am.orig
-+++ plug-ins/openexr/Makefile.am
-@@ -27,8 +27,7 @@
- $(top_builddir)/lib/libcinepaint.la \
- $(X_LIBS) \
- $(OPENEXR_LIBS) \
-- @LCMS_LIB@ \
-- -lc
-+ @LCMS_LIB@
-
- DEPS = $(top_builddir)/lib/libcinepaint.la
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__pdf__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__pdf__Makefile.am
deleted file mode 100644
index 41f14a2621bc..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__pdf__Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- plug-ins/pdf/Makefile.am.orig
-+++ plug-ins/pdf/Makefile.am
-@@ -31,8 +31,7 @@
- $(top_builddir)/lib/libcinepaint.la \
- $(X_LIBS) \
- $(FLTK_LIBS) \
-- $(OYRANOS_LIBS) \
-- -lc
-+ $(OYRANOS_LIBS)
-
- DEPS = $(top_builddir)/lib/libcinepaint.la
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__pic__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__pic__Makefile.am
deleted file mode 100644
index 825e165eaab5..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__pic__Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- plug-ins/pic/Makefile.am.orig
-+++ plug-ins/pic/Makefile.am
-@@ -21,8 +21,7 @@
-
- LDADD = \
- $(top_builddir)/lib/libcinepaint.la \
-- $(X_LIBS) \
-- -lc
-+ $(X_LIBS)
-
- DEPS = $(top_builddir)/lib/libcinepaint.la
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__png__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__png__Makefile.am
deleted file mode 100644
index 7c0f1f53679b..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__png__Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- plug-ins/png/Makefile.am.orig
-+++ plug-ins/png/Makefile.am
-@@ -17,8 +17,7 @@
- $(top_builddir)/lib/libcinepaint.la \
- $(LIBPNG) \
- $(GTK_LIBS) \
-- $(X_LIBS) \
-- -lc
-+ $(X_LIBS)
-
- DEPS = $(top_builddir)/lib/libcinepaint.la
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__pnm__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__pnm__Makefile.am
deleted file mode 100644
index 288fd51b026d..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__pnm__Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- plug-ins/pnm/Makefile.am.orig
-+++ plug-ins/pnm/Makefile.am
-@@ -14,8 +14,7 @@
-
- LDADD = \
- $(top_builddir)/lib/libcinepaint.la \
-- $(X_LIBS) \
-- -lc
-+ $(X_LIBS)
-
- DEPS = $(top_builddir)/lib/libcinepaint.la
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__psd_save__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__psd_save__Makefile.am
deleted file mode 100644
index 950ccec57ea0..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__psd_save__Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- plug-ins/psd_save/Makefile.am.orig
-+++ plug-ins/psd_save/Makefile.am
-@@ -14,8 +14,7 @@
-
- LDADD = \
- $(top_builddir)/lib/libcinepaint.la \
-- $(X_LIBS) \
-- -lc
-+ $(X_LIBS)
-
- DEPS = \
- $(top_builddir)/lib/libcinepaint.la
diff --git a/graphics/cinepaint/files/patch-plug-ins__screenshot__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__screenshot__Makefile.am
deleted file mode 100644
index 26005e2fa709..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__screenshot__Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- plug-ins/screenshot/Makefile.am.orig
-+++ plug-ins/screenshot/Makefile.am
-@@ -22,8 +22,7 @@
-
- LDADD = \
- $(top_builddir)/lib/libcinepaint.la \
-- $(X_LIBS) \
-- -lc
-+ $(X_LIBS)
-
- DEPS = $(top_builddir)/lib/libcinepaint.la
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__sgi__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__sgi__Makefile.am
deleted file mode 100644
index 27658fe76b5b..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__sgi__Makefile.am
+++ /dev/null
@@ -1,13 +0,0 @@
---- plug-ins/sgi/Makefile.am.orig
-+++ plug-ins/sgi/Makefile.am
-@@ -14,9 +14,7 @@
-
- LDADD = \
- $(top_builddir)/lib/libcinepaint.la \
-- $(X_LIBS) \
-- \
-- -lc
-+ $(X_LIBS)
-
- DEPS = $(top_builddir)/lib/libcinepaint.la
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__tga__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__tga__Makefile.am
deleted file mode 100644
index fbe9b12cf6ed..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__tga__Makefile.am
+++ /dev/null
@@ -1,13 +0,0 @@
---- plug-ins/tga/Makefile.am.orig
-+++ plug-ins/tga/Makefile.am
-@@ -14,9 +14,7 @@
-
- LDADD = \
- $(top_builddir)/lib/libcinepaint.la \
-- $(X_LIBS) \
-- \
-- -lc
-+ $(X_LIBS)
-
- DEPS = $(top_builddir)/lib/libcinepaint.la
-
diff --git a/graphics/cinepaint/files/patch-plug-ins__xwd__Makefile.am b/graphics/cinepaint/files/patch-plug-ins__xwd__Makefile.am
deleted file mode 100644
index 2780e3803054..000000000000
--- a/graphics/cinepaint/files/patch-plug-ins__xwd__Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- plug-ins/xwd/Makefile.am.orig
-+++ plug-ins/xwd/Makefile.am
-@@ -18,8 +18,7 @@
-
- LDADD = \
- $(top_builddir)/lib/libcinepaint.la \
-- $(X_LIBS) \
-- -lc
-+ $(X_LIBS)
-
- DEPS = $(top_builddir)/lib/libcinepaint.la
-
diff --git a/graphics/exiftran/files/Makefile.exiftran b/graphics/exiftran/files/Makefile.exiftran
index 23e5ab7c7968..bf74e5fb3202 100644
--- a/graphics/exiftran/files/Makefile.exiftran
+++ b/graphics/exiftran/files/Makefile.exiftran
@@ -10,7 +10,7 @@ SRCS+= transupp.c
.PATH: ${.CURDIR}/../../rd
SRCS+= read-jpeg.c
-LDADD= -L${PREFIX}/lib -ljpeg -lexif
+LDADD= -L${PREFIX}/lib -ljpeg -lexif -lm
CFLAGS+= -I${PREFIX}/include -I${.CURDIR}/../../jpeg/80 \
-I${.CURDIR}/../.. -DHAVE_NEW_EXIF
diff --git a/graphics/gimageview/Makefile b/graphics/gimageview/Makefile
index fa8096df838c..1fdb4376a1c5 100644
--- a/graphics/gimageview/Makefile
+++ b/graphics/gimageview/Makefile
@@ -59,6 +59,7 @@ LIBXINE_LIB_DEPENDS= libxine.so:${PORTSDIR}/multimedia/libxine
post-patch:
@${REINPLACE_CMD} '/^desktopdir =/s|=.*|= ${DESKTOPDIR}|' \
${WRKSRC}/etc/Makefile.in
+ @${REINPLACE_CMD} '/^gimv_LDADD =/s/=/= -lm/' ${WRKSRC}/src/Makefile.in
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} \
-e 's|= $$(DESTDIR)|= |' -e '/^CPPFLAGS =/s/\\/@CPPFLAGS@ \\/'
diff --git a/graphics/gimp-wavelet-denoise-plugin/Makefile b/graphics/gimp-wavelet-denoise-plugin/Makefile
index bd79a1a1205e..c680aa1138ff 100644
--- a/graphics/gimp-wavelet-denoise-plugin/Makefile
+++ b/graphics/gimp-wavelet-denoise-plugin/Makefile
@@ -39,6 +39,7 @@ CFLAGS+= -O3
post-patch:
@${REINPLACE_CMD} \
-e 's|gimptool-2.0|${LOCALBASE}/bin/gimptool-2.0|' \
+ -e '/^LIBS =/s/$$/ -lm/' \
${WRKSRC}/src/Makefile
#
## l10n
diff --git a/graphics/gimp-wavelet-sharpen-plugin/Makefile b/graphics/gimp-wavelet-sharpen-plugin/Makefile
index 1d4b389b79a9..4f1746c821d3 100644
--- a/graphics/gimp-wavelet-sharpen-plugin/Makefile
+++ b/graphics/gimp-wavelet-sharpen-plugin/Makefile
@@ -39,6 +39,7 @@ CFLAGS+= -O3
post-patch:
@${REINPLACE_CMD} \
-e 's|gimptool-2.0|${LOCALBASE}/bin/gimptool-2.0|' \
+ -e '/^LIBS =/s/$$/ -lm/' \
${WRKSRC}/src/Makefile
#
## l10n
diff --git a/graphics/gpaint/Makefile b/graphics/gpaint/Makefile
index 34269a87b7fb..857e518f22ab 100644
--- a/graphics/gpaint/Makefile
+++ b/graphics/gpaint/Makefile
@@ -12,9 +12,10 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Small-scale painting program for GNOME
-USES= pkgconfig
+USES= libtool pkgconfig
USE_GNOME= libgnomeprint libgnomeprintui
GNU_CONFIGURE= yes
+LIBS+= -lm
PLIST_FILES= bin/gpaint-2 %%DATADIR%%/glade/gpaint.glade
PLIST_DIRS= %%DATADIR%%/glade %%DATADIR%%
diff --git a/graphics/gqview/Makefile b/graphics/gqview/Makefile
index d48a0051b554..63676a5c3598 100644
--- a/graphics/gqview/Makefile
+++ b/graphics/gqview/Makefile
@@ -16,7 +16,7 @@ USES= pkgconfig
USE_GNOME= gnomehier gtk20
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+LIBS+= -L${LOCALBASE}/lib -lm
# Restrict to stable (even) versions, indicated by the second component.
PORTSCOUT= limitw:1,even
diff --git a/graphics/inventor/Makefile b/graphics/inventor/Makefile
index 82cbd367f366..0a76650e6fcd 100644
--- a/graphics/inventor/Makefile
+++ b/graphics/inventor/Makefile
@@ -38,6 +38,12 @@ OPTIONS_DEFINE= DEBUG
DEBUG_MAKE_ENV= LIBTYPE=debug
+.include <bsd.port.options.mk>
+
+.if !(${OPSYS} == FreeBSD && ${OSVERSION} < 900033)
+MAKE_ENV+= VLDOPTS=-Wl,--add-needed
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%CC%%|${CC}|g ;\
s|%%CXX%%|${CXX}|g ; \
diff --git a/graphics/inventor/files/patch-lib-GNUmakefile b/graphics/inventor/files/patch-lib-GNUmakefile
index 2d734737fd9d..46ef35ed0981 100644
--- a/graphics/inventor/files/patch-lib-GNUmakefile
+++ b/graphics/inventor/files/patch-lib-GNUmakefile
@@ -5,7 +5,7 @@
-lGLU -lGL
+ifeq ($(usingFreeBSD), 1)
-+LLDLIBS += -lXext %%ICONV_LIB%%
++LLDLIBS += %%ICONV_LIB%%
+endif
+
OBJECTS = \
diff --git a/graphics/klatexformula/Makefile b/graphics/klatexformula/Makefile
index 41d630c6c82e..5950c452582b 100644
--- a/graphics/klatexformula/Makefile
+++ b/graphics/klatexformula/Makefile
@@ -19,8 +19,13 @@ CMAKE_ARGS= -DQT_QMAKE_EXECUTABLE_FINDQT=${QMAKE} \
-DKLF_BUILD_KTEXTEDITORPLUGIN=off \
-DKLF_INSTALL_POST_UPDATEMIMEDATABASE=off \
-DKLF_INSTALL_SHARE_MAN1_DIR=man/man1
-CXXFLAGS= -I${LOCALBASE}/include
+CXXFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB= VERSION=${PORTVERSION}
+post-patch:
+ @${REINPLACE_CMD} '/link_libraries(klatexformula /s/)/ -lX11)/' \
+ ${WRKSRC}/src/CMakeLists.txt
+
.include <bsd.port.mk>
diff --git a/graphics/kudu/Makefile b/graphics/kudu/Makefile
index d827189a82b1..152c924d0df8 100644
--- a/graphics/kudu/Makefile
+++ b/graphics/kudu/Makefile
@@ -20,7 +20,7 @@ USE_GL= gl
USE_PYTHON= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib -lcompat
+LIBS+= -L${LOCALBASE}/lib -lcompat -lm
PLIST_FILES= bin/${PORTNAME}
PORTDATA= *
diff --git a/graphics/lprof-devel/files/patch-src-CMakeLists.txt b/graphics/lprof-devel/files/patch-src-CMakeLists.txt
index 7cbccbd27908..924fff15317c 100644
--- a/graphics/lprof-devel/files/patch-src-CMakeLists.txt
+++ b/graphics/lprof-devel/files/patch-src-CMakeLists.txt
@@ -9,7 +9,7 @@
IF(NOT LIBVIGRAIMPEX_FOUND)
-@@ -143,9 +143,18 @@ ELSE(NOT LIBVIGRAIMPEX_FOUND)
+@@ -143,12 +143,21 @@ ELSE(NOT LIBVIGRAIMPEX_FOUND)
# Static/nonstatic flag should've been added by find script
ENDIF(NOT LIBVIGRAIMPEX_FOUND)
@@ -30,3 +30,8 @@
+ ${CMAKE_CURRENT_BINARY_DIR}
)
+-TARGET_LINK_LIBRARIES(lprof liblprof lcmslocal argyll ${X11_VIDMODE_LIBRARIES} ${X11_LIBRARIES} ${impex_lib} ${LIBUSB_LIBRARIES} ${QT_LIBRARIES} ${JPEG_LIBRARIES} ${TIFF_LIBRARIES} ${ZLIB_LIBRARIES} ${COMMON_PLATFORM_LIBS} ${WINDDK_LIBRARIES})
++TARGET_LINK_LIBRARIES(lprof liblprof lcmslocal argyll ${X11_VIDMODE_LIBRARIES} ${X11_LIBRARIES} ${impex_lib} ${LIBUSB_LIBRARIES} ${QT_LIBRARIES} ${JPEG_LIBRARIES} ${TIFF_LIBRARIES} ${ZLIB_LIBRARIES} ${COMMON_PLATFORM_LIBS} ${WINDDK_LIBRARIES} -pthread)
+
+ SET_TARGET_PROPERTIES(lprof
+ PROPERTIES
diff --git a/graphics/nomacs/files/patch-CMakeLists.txt b/graphics/nomacs/files/patch-CMakeLists.txt
index be003e9b802f..31bf96f8f8e6 100644
--- a/graphics/nomacs/files/patch-CMakeLists.txt
+++ b/graphics/nomacs/files/patch-CMakeLists.txt
@@ -36,7 +36,7 @@
link_directories(${LIBRAW_LIBRARY_DIRS} ${OpenCV_LIBRARY_DIRS} ${EXIV2_LIBRARY_DIRS})
add_executable(${EXE_NAME} WIN32 MACOSX_BUNDLE ${NOMACS_SOURCES} ${NOMACS_UI} ${NOMACS_MOC_SRC} ${NOMACS_RCC} ${NOMACS_HEADERS} ${NOMACS_RC} ${NOMACS_QM} ${NOMACS_TRANSLATIONS} ${LIBQPSD_SOURCES} ${LIBQPSD_HEADERS} ${LIBQPSD_MOC_SRC} ${WEBP_SOURCE})
- target_link_libraries(${EXE_NAME} ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY} ${QT_QTNETWORK_LIBRARY} ${QT_QTMAIN_LIBRARY} ${EXIV2_LIBRARIES} ${LIBRAW_LIBRARIES} ${OpenCV_LIBS} ${VERSION_LIB} ${TIFF_LIBRARIES})
-+ target_link_libraries(${EXE_NAME} ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY} ${QT_QTNETWORK_LIBRARY} ${QT_QTMAIN_LIBRARY} ${EXIV2_LIBRARIES} ${LIBRAW_LIBRARIES} ${OpenCV_LIBS} ${VERSION_LIB} ${TIFF_LIBRARIES} ${SYSINFO_LIBRARY})
++ target_link_libraries(${EXE_NAME} ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY} ${QT_QTNETWORK_LIBRARY} ${QT_QTMAIN_LIBRARY} ${EXIV2_LIBRARIES} ${LIBRAW_LIBRARIES} ${OpenCV_LIBS} ${VERSION_LIB} ${TIFF_LIBRARIES} ${SYSINFO_LIBRARY} -pthread)
IF (CMAKE_SYSTEM_NAME MATCHES "Linux")
SET_TARGET_PROPERTIES(${EXE_NAME} PROPERTIES LINK_FLAGS -fopenmp)
diff --git a/graphics/panoglview/Makefile b/graphics/panoglview/Makefile
index daafe28996f5..f36f1d748592 100644
--- a/graphics/panoglview/Makefile
+++ b/graphics/panoglview/Makefile
@@ -11,13 +11,14 @@ MAINTAINER= ii@any.com.ru
COMMENT= Panorama viewer using OpenGL
USES= gmake
+USE_GL= glu
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-unicode
CONFIGURE_ENV= WX_CONFIG_NAME=${WX_CONFIG} \
PATH="$${PATH}:${LOCALBASE}/bin"
-LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
-CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
-CXXFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include -ftemplate-depth-64
-CONFIGURE_ARGS= --with-unicode
+CFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS+= -I${LOCALBASE}/include -ftemplate-depth-64
+LIBS+= -L${LOCALBASE}/lib -lGLU -lGL
USE_WX= 2.8
WX_UNICODE= yes
diff --git a/graphics/pornview/Makefile b/graphics/pornview/Makefile
index eddb104d1054..77b057766737 100644
--- a/graphics/pornview/Makefile
+++ b/graphics/pornview/Makefile
@@ -15,13 +15,13 @@ LIB_DEPENDS= libexif.so:${PORTSDIR}/graphics/libexif \
libpng15.so:${PORTSDIR}/graphics/png \
libxcb-render-util.so:${PORTSDIR}/x11/xcb-util-renderutil
+USES= libtool pkgconfig
USE_XORG= x11 xi xext xinerama
-USES= pkgconfig
USE_GNOME= gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gtk2
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lm
+LIBS+= -L${LOCALBASE}/lib -lXext -lX11 -lm
OPTIONS_DEFINE= LIBXINE MPLAYER NLS
OPTIONS_DEFAULT= LIBXINE
diff --git a/graphics/reallyslick/Makefile b/graphics/reallyslick/Makefile
index 5de27c7d6147..6ebe867d2042 100644
--- a/graphics/reallyslick/Makefile
+++ b/graphics/reallyslick/Makefile
@@ -19,7 +19,7 @@ USES= gmake pathfix pkgconfig tar:bzip2 libtool
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lXext
+LIBS+= -L${LOCALBASE}/lib -lXext
OPTIONS_DEFINE= FREEALUT GLEW
@@ -29,11 +29,9 @@ FREEALUT_USES= openal:alut
GLEW_DESC= Enable GLEW support
GLEW_USE= GL=glew
+GLEW_CONFIGURE_ENV_OFF= ac_cv_header_GL_glew_h=no
-.include <bsd.port.options.mk>
-
-.if ! ${PORT_OPTIONS:MGLEW}
-CONFIGURE_ENV+= ac_cv_header_GL_glew_h=no
-.endif
+post-patch:
+ @${REINPLACE_CMD} '/LINK.*pixelcity/s/LINK/CXXLINK/' ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>
diff --git a/graphics/rgbpaint/Makefile b/graphics/rgbpaint/Makefile
index 0e25441075f2..214a6f24903d 100644
--- a/graphics/rgbpaint/Makefile
+++ b/graphics/rgbpaint/Makefile
@@ -30,7 +30,7 @@ post-patch:
@${REINPLACE_CMD} 's|$$(MT_LANG_DEST)|$$(DESTDIR)&|g' \
${WRKSRC}/po/Makefile
@${REINPLACE_CMD} 's|$$(BIN_INSTALL)|$$(DESTDIR)&|g ; \
- /^LDFLAGS/s|)$$|) -lm -lintl|' \
+ /^LDFLAGS/s|$$| -lX11 -lm -lintl|' \
${WRKSRC}/src/Makefile
post-install:
diff --git a/graphics/separate/Makefile b/graphics/separate/Makefile
index fa5a77798fce..29271080b6ec 100644
--- a/graphics/separate/Makefile
+++ b/graphics/separate/Makefile
@@ -42,8 +42,9 @@ MAKE_ENV+= TARGETS="${BIN_TARGETS}" \
.include <bsd.port.options.mk>
post-patch:
- @${REINPLACE_CMD} -e '/^CC/s|=|?=|; s| make| ${MAKE_CMD}|;' \
- ${WRKSRC}/Makefile ${WRKSRC}/po/Makefile
+ @${REINPLACE_CMD} \
+ '/^CC/s|=|?=|; s| make| ${MAKE_CMD}|; /^LIBS/s/$$/ -lm/;' \
+ ${WRKSRC}/Makefile ${WRKSRC}/po/Makefile
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/libexec/gimp/2.2/plug-ins
diff --git a/graphics/vp/Makefile b/graphics/vp/Makefile
index ffc7ff40b788..e65a4fb2fec8 100644
--- a/graphics/vp/Makefile
+++ b/graphics/vp/Makefile
@@ -9,9 +9,10 @@ MASTER_SITES= http://elfga.com/~erik/files/
MAINTAINER= erik@elfga.com
COMMENT= Image viewer for X
-USE_SDL= image
GNU_CONFIGURE= yes
+LIBS+= -lm
USES= tar:xz
+USE_SDL= image
PLIST_FILES= bin/vp man/man1/vp.1.gz
diff --git a/graphics/xzgv/Makefile b/graphics/xzgv/Makefile
index c93a40fb1d50..966415543dda 100644
--- a/graphics/xzgv/Makefile
+++ b/graphics/xzgv/Makefile
@@ -14,6 +14,8 @@ BUILD_DEPENDS= gawk:${PORTSDIR}/lang/gawk
USES= gmake pkgconfig
USE_GNOME= imlib gdkpixbuf gtk20
+USE_XORG= x11
+LDFLAGS+= -L${LOCALBASE}/lib -lX11 -lm
PLIST_FILES= bin/xzgv man/man1/xzgv.1.gz