aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-11-01 22:14:07 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-11-01 22:14:07 +0000
commit44d0dc12bbff17cfbbb9d182235924dbd7d86a45 (patch)
treeb260b05e7fe7e534f08af61d8504ddf8a7ab5a49 /graphics
parent96998c6a224d934b8d937663652dc498c7e4cdfd (diff)
downloadports-44d0dc12bbff17cfbbb9d182235924dbd7d86a45.tar.gz
ports-44d0dc12bbff17cfbbb9d182235924dbd7d86a45.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gstreamer-plugins-aalib/Makefile1
-rw-r--r--graphics/gstreamer-plugins-cairo/Makefile1
-rw-r--r--graphics/gstreamer-plugins-gdkpixbuf/Makefile1
-rw-r--r--graphics/gstreamer-plugins-gl/Makefile9
-rw-r--r--graphics/gstreamer-plugins-jpeg/Makefile1
-rw-r--r--graphics/gstreamer-plugins-libcaca/Makefile1
-rw-r--r--graphics/gstreamer-plugins-libpng/Makefile1
-rw-r--r--graphics/gstreamer-plugins-libvisual/Makefile1
-rw-r--r--graphics/gstreamer-plugins-opencv/Makefile1
-rw-r--r--graphics/gstreamer1-plugins-aalib/Makefile1
-rw-r--r--graphics/gstreamer1-plugins-cairo/Makefile1
-rw-r--r--graphics/gstreamer1-plugins-gdkpixbuf/Makefile1
-rw-r--r--graphics/gstreamer1-plugins-jpeg/Makefile1
-rw-r--r--graphics/gstreamer1-plugins-libcaca/Makefile1
-rw-r--r--graphics/gstreamer1-plugins-libvisual/Makefile1
-rw-r--r--graphics/gstreamer1-plugins-opencv/Makefile1
-rw-r--r--graphics/gstreamer1-plugins-png/Makefile1
-rw-r--r--graphics/gstreamer1-plugins-zbar/Makefile1
18 files changed, 6 insertions, 20 deletions
diff --git a/graphics/gstreamer-plugins-aalib/Makefile b/graphics/gstreamer-plugins-aalib/Makefile
index 7f81df63f7d4..2d35c5d43662 100644
--- a/graphics/gstreamer-plugins-aalib/Makefile
+++ b/graphics/gstreamer-plugins-aalib/Makefile
@@ -11,5 +11,4 @@ GST_PLUGIN= aalib
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer-plugins-cairo/Makefile b/graphics/gstreamer-plugins-cairo/Makefile
index 6a9f7899e781..d0b5aa4f2644 100644
--- a/graphics/gstreamer-plugins-cairo/Makefile
+++ b/graphics/gstreamer-plugins-cairo/Makefile
@@ -11,5 +11,4 @@ GST_PLUGIN= cairo
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer-plugins-gdkpixbuf/Makefile b/graphics/gstreamer-plugins-gdkpixbuf/Makefile
index 13ac38311e26..282970bcfd39 100644
--- a/graphics/gstreamer-plugins-gdkpixbuf/Makefile
+++ b/graphics/gstreamer-plugins-gdkpixbuf/Makefile
@@ -12,5 +12,4 @@ GST_PLUGIN= gdk_pixbuf
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer-plugins-gl/Makefile b/graphics/gstreamer-plugins-gl/Makefile
index e89cc8d2fe0b..39e862282c1e 100644
--- a/graphics/gstreamer-plugins-gl/Makefile
+++ b/graphics/gstreamer-plugins-gl/Makefile
@@ -11,8 +11,8 @@ DISTNAME= ${PORTNAME:S/gstreamer/gst/}-${PORTVERSION}
MAINTAINER= multimedia@FreeBSD.org
COMMENT= GStreamer OpenGL video plugin
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- jpeg.11:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg
USE_BZIP2= yes
USE_LDCONFIG= yes
@@ -27,5 +27,8 @@ CONFIGURE_ARGS=--disable-examples
PLIST_SUB= VERSION="0.10"
-NO_STAGE= yes
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgstgl-0.10.so.1
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/gstreamer-0.10/libgst*.so
+
.include <bsd.port.mk>
diff --git a/graphics/gstreamer-plugins-jpeg/Makefile b/graphics/gstreamer-plugins-jpeg/Makefile
index e750c6d2c654..dde7d90a2e50 100644
--- a/graphics/gstreamer-plugins-jpeg/Makefile
+++ b/graphics/gstreamer-plugins-jpeg/Makefile
@@ -11,5 +11,4 @@ GST_PLUGIN= jpeg
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer-plugins-libcaca/Makefile b/graphics/gstreamer-plugins-libcaca/Makefile
index 77093421ce6b..b194bcbc140a 100644
--- a/graphics/gstreamer-plugins-libcaca/Makefile
+++ b/graphics/gstreamer-plugins-libcaca/Makefile
@@ -11,5 +11,4 @@ GST_PLUGIN= libcaca
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer-plugins-libpng/Makefile b/graphics/gstreamer-plugins-libpng/Makefile
index fac6ed0b103c..740a4a4038a2 100644
--- a/graphics/gstreamer-plugins-libpng/Makefile
+++ b/graphics/gstreamer-plugins-libpng/Makefile
@@ -11,5 +11,4 @@ GST_PLUGIN= libpng
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer-plugins-libvisual/Makefile b/graphics/gstreamer-plugins-libvisual/Makefile
index fa51ddd57a16..7137b84847a0 100644
--- a/graphics/gstreamer-plugins-libvisual/Makefile
+++ b/graphics/gstreamer-plugins-libvisual/Makefile
@@ -11,5 +11,4 @@ GST_PLUGIN= libvisual
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer-plugins-opencv/Makefile b/graphics/gstreamer-plugins-opencv/Makefile
index 329b68f9ee02..61e83791ef33 100644
--- a/graphics/gstreamer-plugins-opencv/Makefile
+++ b/graphics/gstreamer-plugins-opencv/Makefile
@@ -10,5 +10,4 @@ GST_PLUGIN= opencv
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-aalib/Makefile b/graphics/gstreamer1-plugins-aalib/Makefile
index aa8f04a76817..e997dd6bbbd2 100644
--- a/graphics/gstreamer1-plugins-aalib/Makefile
+++ b/graphics/gstreamer1-plugins-aalib/Makefile
@@ -10,5 +10,4 @@ DIST= good
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-cairo/Makefile b/graphics/gstreamer1-plugins-cairo/Makefile
index c2f380a85b1e..9fd5a125d029 100644
--- a/graphics/gstreamer1-plugins-cairo/Makefile
+++ b/graphics/gstreamer1-plugins-cairo/Makefile
@@ -10,5 +10,4 @@ DIST= good
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-gdkpixbuf/Makefile b/graphics/gstreamer1-plugins-gdkpixbuf/Makefile
index 6e7f3ddf11fe..db433bc32bc8 100644
--- a/graphics/gstreamer1-plugins-gdkpixbuf/Makefile
+++ b/graphics/gstreamer1-plugins-gdkpixbuf/Makefile
@@ -11,5 +11,4 @@ DIST= good
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-jpeg/Makefile b/graphics/gstreamer1-plugins-jpeg/Makefile
index fb8fb4e707b6..96a1fc8b912e 100644
--- a/graphics/gstreamer1-plugins-jpeg/Makefile
+++ b/graphics/gstreamer1-plugins-jpeg/Makefile
@@ -10,5 +10,4 @@ DIST= good
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-libcaca/Makefile b/graphics/gstreamer1-plugins-libcaca/Makefile
index 23b42e5593c9..779a0e869f5d 100644
--- a/graphics/gstreamer1-plugins-libcaca/Makefile
+++ b/graphics/gstreamer1-plugins-libcaca/Makefile
@@ -10,5 +10,4 @@ DIST= good
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-libvisual/Makefile b/graphics/gstreamer1-plugins-libvisual/Makefile
index 03b6b0e3ba85..27fce809821c 100644
--- a/graphics/gstreamer1-plugins-libvisual/Makefile
+++ b/graphics/gstreamer1-plugins-libvisual/Makefile
@@ -10,5 +10,4 @@ DIST= base
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-opencv/Makefile b/graphics/gstreamer1-plugins-opencv/Makefile
index b2460c22e32c..6887f7bfc3d0 100644
--- a/graphics/gstreamer1-plugins-opencv/Makefile
+++ b/graphics/gstreamer1-plugins-opencv/Makefile
@@ -10,5 +10,4 @@ DIST= bad
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-png/Makefile b/graphics/gstreamer1-plugins-png/Makefile
index 22087879e8f6..668a1f8aabb8 100644
--- a/graphics/gstreamer1-plugins-png/Makefile
+++ b/graphics/gstreamer1-plugins-png/Makefile
@@ -11,5 +11,4 @@ DIST= good
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-zbar/Makefile b/graphics/gstreamer1-plugins-zbar/Makefile
index 7b154de7733b..59da68f189f5 100644
--- a/graphics/gstreamer1-plugins-zbar/Makefile
+++ b/graphics/gstreamer1-plugins-zbar/Makefile
@@ -10,5 +10,4 @@ DIST= bad
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"