aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-12-23 11:15:34 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-12-23 11:15:34 +0000
commit4f20a6b0d34db3fcb75b3a7092b1676655c007ad (patch)
tree356b477d6491e3289f1101d8559fa6badd446ebb /graphics
parenta6d79142f2291f65cfc9d1289bf0a8484d116bb1 (diff)
downloadports-4f20a6b0d34db3fcb75b3a7092b1676655c007ad.tar.gz
ports-4f20a6b0d34db3fcb75b3a7092b1676655c007ad.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/sdl_image/Makefile6
-rw-r--r--graphics/sdl_image/distinfo4
-rw-r--r--graphics/sdl_image/files/patch-ab23
3 files changed, 22 insertions, 11 deletions
diff --git a/graphics/sdl_image/Makefile b/graphics/sdl_image/Makefile
index fddd7df73f14..490813ee4fa3 100644
--- a/graphics/sdl_image/Makefile
+++ b/graphics/sdl_image/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sdl_image
-PORTVERSION= 1.2.3
-PORTREVISION= 2
+PORTVERSION= 1.2.4
CATEGORIES= graphics
MASTER_SITES= http://www.libsdl.org/projects/SDL_image/release/
DISTNAME= SDL_image-${PORTVERSION}
@@ -21,8 +20,9 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
USE_SDL= sdl
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm"
CONFIGURE_ARGS= --enable-tif --enable-xcf
diff --git a/graphics/sdl_image/distinfo b/graphics/sdl_image/distinfo
index be1abb6eb4c1..f77b526ed031 100644
--- a/graphics/sdl_image/distinfo
+++ b/graphics/sdl_image/distinfo
@@ -1,2 +1,2 @@
-MD5 (SDL_image-1.2.3.tar.gz) = d55826ffbd2bdc48b09cc64a9ed9e59e
-SIZE (SDL_image-1.2.3.tar.gz) = 636747
+MD5 (SDL_image-1.2.4.tar.gz) = 70bf617f99e51a2c94550fc79d542f0b
+SIZE (SDL_image-1.2.4.tar.gz) = 841885
diff --git a/graphics/sdl_image/files/patch-ab b/graphics/sdl_image/files/patch-ab
index 120401df90d7..34ba119ef93d 100644
--- a/graphics/sdl_image/files/patch-ab
+++ b/graphics/sdl_image/files/patch-ab
@@ -1,11 +1,22 @@
---- Makefile.in 2000/09/20 07:05:33 1.1
-+++ Makefile.in 2000/09/20 07:06:00
-@@ -89,7 +89,7 @@
-
+
+$FreeBSD$
+
+--- Makefile.in.orig
++++ Makefile.in
+@@ -225,7 +225,7 @@
+ target_os = @target_os@
+ target_vendor = @target_vendor@
lib_LTLIBRARIES = libSDL_image.la
-
-libSDL_imageincludedir = $(includedir)/SDL
+libSDL_imageincludedir = $(includedir)/SDL11
- libSDL_imageinclude_HEADERS = SDL_image.h
+ libSDL_imageinclude_HEADERS = \
+ SDL_image.h
+
+@@ -255,7 +255,6 @@
+ libSDL_image_la_LDFLAGS = \
+ -no-undefined \
+- -release $(LT_RELEASE) \
+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
+ libSDL_image_la_LIBADD = @IMG_LIBS@