aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2012-05-29 21:32:05 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2012-05-29 21:32:05 +0000
commit69c779778164bc8506d6e72af770ec03d072f969 (patch)
tree646549d7ecb12faa1d0c63151c95c73def7ed62d /graphics
parent09c70cf0368ecab8d57721cc354851e534e2c560 (diff)
downloadports-69c779778164bc8506d6e72af770ec03d072f969.tar.gz
ports-69c779778164bc8506d6e72af770ec03d072f969.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/volpack/Makefile37
-rw-r--r--graphics/volpack/distinfo2
-rw-r--r--graphics/volpack/files/patch-Makefile.in11
-rw-r--r--graphics/volpack/files/patch-vp_global.h20
-rw-r--r--graphics/volpack/pkg-descr4
6 files changed, 75 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index bd099f52ca63..73da3cc0a874 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -977,6 +977,7 @@
SUBDIR += vips
SUBDIR += visionworkbench
SUBDIR += visprint
+ SUBDIR += volpack
SUBDIR += vp
SUBDIR += webp
SUBDIR += whirlgif
diff --git a/graphics/volpack/Makefile b/graphics/volpack/Makefile
new file mode 100644
index 000000000000..f245bfabb02e
--- /dev/null
+++ b/graphics/volpack/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: volpack
+# Date created: 2012-05-29
+# Whom: Guido Falsi <madpilot@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= volpack
+PORTVERSION= 1.0b3
+CATEGORIES= graphics
+MASTER_SITES= http://www-graphics.stanford.edu/software/volpack/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= madpilot@FreeBSD.org
+COMMENT= Portable software library for volume rendering
+
+LICENCE= BSD
+
+GNU_CONFIGURE= yes
+
+PLIST_FILES= lib/libvolpack.a \
+ include/volpack.h
+
+MAN3= BruteForce.3 Callback.3 ClientData.3 ClsfyScalar.3 \
+ ClsfyScan.3 ClsfyTable.3 ClsfyVolume.3 Context.3 \
+ CurrentMatrix.3 Debug.3 DepthCueing.3 Enable.3 Error.3 \
+ Extract.3 Filter.3 FilterTab.3 Get.3 GetImage.3 \
+ GetLight.3 GetMaterial.3 GetMatrix.3 Identity.3 \
+ Image.3 Light.3 LinAlgebra.3 Load.3 LookupShader.3 \
+ Material.3 MinMaxOctree.3 MultMatrix.3 NormalIndex.3 \
+ OctreeMask.3 Ramp.3 RawVoxels.3 Render.3 Resample.3 \
+ Rotate.3 Scale.3 ScanNormals.3 Set.3 SetMatrix.3 \
+ ShadeTable.3 Shadow.3 Store.3 Timer.3 TracePixel.3 \
+ Translate.3 Transpose.3 VolPack.3 VolumeNormals.3 \
+ VolumeSize.3 VoxelField.3 VoxelSize.3 Window.3 WindowPHIGS.3
+
+.include <bsd.port.mk>
diff --git a/graphics/volpack/distinfo b/graphics/volpack/distinfo
new file mode 100644
index 000000000000..c4289fd314e9
--- /dev/null
+++ b/graphics/volpack/distinfo
@@ -0,0 +1,2 @@
+SHA256 (volpack-1.0b3.tar.Z) = d7cfd5f6819cccf88363d2270377e547a07f35da6a0dac45845ecc1640e410fa
+SIZE (volpack-1.0b3.tar.Z) = 1048685
diff --git a/graphics/volpack/files/patch-Makefile.in b/graphics/volpack/files/patch-Makefile.in
new file mode 100644
index 000000000000..c809a0e545f6
--- /dev/null
+++ b/graphics/volpack/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2012-05-29 12:53:53.868426143 +0200
++++ Makefile.in 2012-05-29 12:54:07.467425832 +0200
+@@ -175,7 +175,7 @@
+ cc -o makeopts makeopts.c
+
+ vp_opts.c: makeopts Makefile
+- makeopts vp_opts.c $(CFLAGS)
++ ./makeopts vp_opts.c $(CFLAGS)
+
+ $(COMP_SRCS): $(COMP_IN)
+ @for i in $(COMP_SRCS) ; \
diff --git a/graphics/volpack/files/patch-vp_global.h b/graphics/volpack/files/patch-vp_global.h
new file mode 100644
index 000000000000..bfd917fc2cf4
--- /dev/null
+++ b/graphics/volpack/files/patch-vp_global.h
@@ -0,0 +1,20 @@
+--- vp_global.h.orig 1994-12-31 00:53:14.000000000 +0100
++++ vp_global.h 2012-05-29 12:52:59.931425126 +0200
+@@ -36,7 +36,7 @@
+ #include "volpack.h"
+
+ #include <stdio.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <math.h>
+ extern double rint ANSI_ARGS((double x)); /* missing from Ultrix math.h */
+
+@@ -168,7 +168,7 @@
+ * Macros. *
+ *******************************************************************/
+
+-#define NULL 0
++/* #define NULL 0 */
+
+ #define MAX(a,b) (((a)<(b)) ? (b) : (a))
+ #define MIN(a,b) (((a)>(b)) ? (b) : (a))
diff --git a/graphics/volpack/pkg-descr b/graphics/volpack/pkg-descr
new file mode 100644
index 000000000000..c926a92766df
--- /dev/null
+++ b/graphics/volpack/pkg-descr
@@ -0,0 +1,4 @@
+VolPack is a portable software library for volume rendering, written
+by Philippe Lacroute.
+
+WWW: http://www-graphics.stanford.edu/software/volpack/