aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2007-04-19 17:08:04 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2007-04-19 17:08:04 +0000
commit7aeef3e5194acb6b59e88472be78b4d7f2a7014f (patch)
tree616dfe53e60011f08ba0fd9e44d23086ed7704a2 /graphics
parent70b438b4348e8e5786613051e3c8e890dd2d18f9 (diff)
Rename all binaries in qt4 which conflict with binaries installed by
qt33 to ($binary)-qt4 and adjust dependencies accordingly. This avoids conflicts once X11BASE has been changed to /usr/local and incidentally makes the naming scheme of the qt4 executables in ports equal to that of the Fedora Core and Debian packages.
Notes
Notes: svn path=/head/; revision=190368
Diffstat (limited to 'graphics')
-rw-r--r--graphics/qt4-iconengines/Makefile4
-rw-r--r--graphics/qt4-imageformats/Makefile4
-rw-r--r--graphics/qt4-pixeltool/Makefile8
-rw-r--r--graphics/qt4-svg/Makefile4
4 files changed, 10 insertions, 10 deletions
diff --git a/graphics/qt4-iconengines/Makefile b/graphics/qt4-iconengines/Makefile
index 4370b93f0542..4ab58fda0a76 100644
--- a/graphics/qt4-iconengines/Makefile
+++ b/graphics/qt4-iconengines/Makefile
@@ -18,7 +18,7 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt SVG icon engine plugin
-BUILD_DEPENDS= moc4:${PORTSDIR}/devel/qt4-moc \
+BUILD_DEPENDS= moc-qt4:${PORTSDIR}/devel/qt4-moc \
qmake-qt4:${PORTSDIR}/devel/qmake4
LIB_DEPENDS= QtCore:${PORTSDIR}/devel/qt4-corelib \
QtGui:${PORTSDIR}/x11-toolkits/qt4-gui \
@@ -64,6 +64,6 @@ pre-configure:
${WRKSRC}/svgiconengine/svgiconengine.pro
${MKDIR} ${WRKSRC}/../../../mkspecs
${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../../bin/qmake
- ${LN} -sf ${LOCALBASE}/bin/moc4 ${WRKSRC}/../../../bin/moc
+ ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../../bin/moc
.include <bsd.port.post.mk>
diff --git a/graphics/qt4-imageformats/Makefile b/graphics/qt4-imageformats/Makefile
index 3e9d0bc08c19..52ff4d85d2e7 100644
--- a/graphics/qt4-imageformats/Makefile
+++ b/graphics/qt4-imageformats/Makefile
@@ -18,7 +18,7 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt imageformat plugins for GIF, JPEG, MNG and SVG
-BUILD_DEPENDS= moc4:${PORTSDIR}/devel/qt4-moc \
+BUILD_DEPENDS= moc-qt4:${PORTSDIR}/devel/qt4-moc \
qmake-qt4:${PORTSDIR}/devel/qmake4 \
rcc:${PORTSDIR}/devel/qt4-rcc
LIB_DEPENDS= QtCore:${PORTSDIR}/devel/qt4-corelib \
@@ -67,7 +67,7 @@ pre-configure:
${WRKSRC}/jpeg/jpeg.pro
${MKDIR} ${WRKSRC}/../../../mkspecs
${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../../bin/qmake
- ${LN} -sf ${LOCALBASE}/bin/moc4 ${WRKSRC}/../../../bin/moc
+ ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../../bin/moc
${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/../../../bin/rcc
post-build:
diff --git a/graphics/qt4-pixeltool/Makefile b/graphics/qt4-pixeltool/Makefile
index 2fd661bcc5d5..e34cb45a1845 100644
--- a/graphics/qt4-pixeltool/Makefile
+++ b/graphics/qt4-pixeltool/Makefile
@@ -18,9 +18,9 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt screen magnification utility
-BUILD_DEPENDS= moc4:${PORTSDIR}/devel/qt4-moc \
+BUILD_DEPENDS= moc-qt4:${PORTSDIR}/devel/qt4-moc \
qmake-qt4:${PORTSDIR}/devel/qmake4 \
- uic4:${PORTSDIR}/devel/qt4-uic
+ uic-qt4:${PORTSDIR}/devel/qt4-uic
LIB_DEPENDS= QtAssistantClient:${PORTSDIR}/devel/qt4-libqtassistantclient \
QtCore:${PORTSDIR}/devel/qt4-corelib \
@@ -64,7 +64,7 @@ pre-configure:
${WRKSRC}/${PORTNAME}.pro
${MKDIR} ${WRKSRC}/../../mkspecs
${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../bin/qmake
- ${LN} -sf ${LOCALBASE}/bin/moc4 ${WRKSRC}/../../bin/moc
- ${LN} -sf ${LOCALBASE}/bin/uic4 ${WRKSRC}/../../bin/uic
+ ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../bin/moc
+ ${LN} -sf ${LOCALBASE}/bin/uic-qt4 ${WRKSRC}/../../bin/uic
.include <bsd.port.mk>
diff --git a/graphics/qt4-svg/Makefile b/graphics/qt4-svg/Makefile
index 7b1df1aff09d..176410c57c81 100644
--- a/graphics/qt4-svg/Makefile
+++ b/graphics/qt4-svg/Makefile
@@ -18,7 +18,7 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt SVG library
-BUILD_DEPENDS= moc4:${PORTSDIR}/devel/qt4-moc \
+BUILD_DEPENDS= moc-qt4:${PORTSDIR}/devel/qt4-moc \
qmake-qt4:${PORTSDIR}/devel/qmake4
LIB_DEPENDS?= QtCore:${PORTSDIR}/devel/qt4-corelib \
QtGui:${PORTSDIR}/x11-toolkits/qt4-gui \
@@ -74,7 +74,7 @@ pre-configure:
${WRKSRC}/${PORTNAME}.pro ${WRKSRC}/../qt_install.pri
${MKDIR} ${WRKSRC}/../../mkspecs
${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../bin/qmake
- ${LN} -sf ${LOCALBASE}/bin/moc4 ${WRKSRC}/../../bin/moc
+ ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../bin/moc
post-configure:
${REINPLACE_CMD} -e 's|${PREFIX}/lib/QtSvg.pc|${PREFIX}/libdata/pkgconfig/QtSvg.pc|g' \