aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-04-21 09:37:13 +0000
committerJohn Marino <marino@FreeBSD.org>2015-04-21 09:37:13 +0000
commit7afd9ae9f94a92894f08e47d48197f2d92d4a2a3 (patch)
tree2e8251022d1e09aca7acb48667a4282d825b5620 /graphics
parent51faa29c31dcd8e0cf22fe31daf940ee9fa82d36 (diff)
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/iulib/Makefile3
-rw-r--r--graphics/iulib/files/patch-imglib_imgops.cc11
-rw-r--r--graphics/iulib/files/patch-imglib_imgops.h12
3 files changed, 24 insertions, 2 deletions
diff --git a/graphics/iulib/Makefile b/graphics/iulib/Makefile
index 94cfdb298a9f..e0816e1ad223 100644
--- a/graphics/iulib/Makefile
+++ b/graphics/iulib/Makefile
@@ -3,7 +3,7 @@
PORTNAME= iulib
PORTVERSION= 0.4
-PORTREVISION= 16
+PORTREVISION= 17
CATEGORIES= graphics
MASTER_SITES= GOOGLE_CODE
@@ -21,7 +21,6 @@ SDL_DESC= Enable SDL for graphical debugging
VIDIO_DESC= Enable Video Input/Output (using ffmpeg)
USES= autoreconf libtool python:build tar:tgz
-USE_GCC= any
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/graphics/iulib/files/patch-imglib_imgops.cc b/graphics/iulib/files/patch-imglib_imgops.cc
new file mode 100644
index 000000000000..d00e356d59ad
--- /dev/null
+++ b/graphics/iulib/files/patch-imglib_imgops.cc
@@ -0,0 +1,11 @@
+--- imglib/imgops.cc.orig 2009-06-09 22:32:20 UTC
++++ imglib/imgops.cc
+@@ -133,7 +133,7 @@ namespace iulib {
+
+ template<class T,class V>
+ void addscaled(narray<T> &dest,narray<T> &src,
+- V scale=1,int dx=0,int dy=0) {
++ V scale,int dx,int dy) {
+ for (int i=0; i<dest.dim(0); i++)
+ for (int j=0; j<dest.dim(1); j++)
+ dest.unsafe_at(i,j) += (T)(scale*xref(src,i+dx,j+dy));
diff --git a/graphics/iulib/files/patch-imglib_imgops.h b/graphics/iulib/files/patch-imglib_imgops.h
new file mode 100644
index 000000000000..471ffb32830a
--- /dev/null
+++ b/graphics/iulib/files/patch-imglib_imgops.h
@@ -0,0 +1,12 @@
+--- imglib/imgops.h.orig 2009-06-09 22:32:20 UTC
++++ imglib/imgops.h
+@@ -67,7 +67,8 @@ namespace iulib {
+ }
+
+ template<class T, class V>
+- void addscaled(colib::narray<T> &, colib::narray<T> &, V, int, int);
++ void addscaled(colib::narray<T> &dest, colib::narray<T> &src,
++ V scale=1, int dx=0, int dy=0);
+ template<class T>
+ void tighten(colib::narray<T> &image);
+ template<class T>