aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-09-20 12:54:54 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-09-20 12:54:54 +0000
commitc93dfc2e9f8b7b990c22c6baa6cdab361cd12e16 (patch)
treee61ab76efa292f985d8e20e449572329fa964c1c /graphics
parentb10d5a64b7ea8bb32e9735304272e7344926e3b2 (diff)
SSP support has been added to ports with WITH_SSP for i386 and amd64
on FreeBSD 10, and amd64 on earlier versions. SSP_UNSAFE is added to disable in a port if it fails to build, but this should only be used in rare circumstances such as kernel modules. Otherwise, the port may just be failing due to lack of respecting LDFLAGS. On FreeBSD 10, this uses an ldscript in /usr/lib/libc.so to pull in libssp_nonshared.a to address issues linking on i386 [1]. On earlier FreeBSD versions the WITH_SSP knob will add -lssp_nonshared to LDFLAGS on i386. This is not needed on amd64. However, several hundred ports do not currently respect LDFLAGS, so this support is disabled currently as it causes build failures if a dependency is looking for the stack_chk symbols. Many thanks to jlh@ for this as he had many years of patience in getting all of the necessary pieces [1][2] in. [1] http://svnweb.freebsd.org/base/head/lib/libc/libc.ldscript?revision=251668&view=markup PR: ports/138228 [2] Submitted by: jlh (bsd.ssp.mk based on) Reviewed by: bapt With hat: portmgr exp-runs done: 37 over a month on 91i386,91amd64,10i386,10amd64
Notes
Notes: svn path=/head/; revision=327697
Diffstat (limited to 'graphics')
-rw-r--r--graphics/kix-kmod/Makefile8
-rw-r--r--graphics/plasma-kmod/Makefile8
2 files changed, 6 insertions, 10 deletions
diff --git a/graphics/kix-kmod/Makefile b/graphics/kix-kmod/Makefile
index 0de7eb0f06b2..cb3dc9bd21a3 100644
--- a/graphics/kix-kmod/Makefile
+++ b/graphics/kix-kmod/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: kix-kmod
-# Date created: 4 January 2003
-# Whom: Jonathan Belson <jon@witchspace.com>
-#
+# Created by: Jonathan Belson <jon@witchspace.com>
# $FreeBSD$
-#
PORTNAME= kix
PORTVERSION= 1.0
@@ -16,6 +12,8 @@ PKGNAMESUFFIX= -kmod
MAINTAINER= jon@witchspace.com
COMMENT= A graphical screensaver kernel module
+SSP_UNSAFE= kernel module does not support ssp
+
.include <bsd.port.pre.mk>
SYSDIR?= ${SRC_BASE}/sys
diff --git a/graphics/plasma-kmod/Makefile b/graphics/plasma-kmod/Makefile
index 3c6c20c5d7c1..54dac001f530 100644
--- a/graphics/plasma-kmod/Makefile
+++ b/graphics/plasma-kmod/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: plasma-kmod
-# Date created: 24 January 2001
-# Whom: George Reid <greid@ukug.uk.freebsd.org>
-#
+# Created by: George Reid <greid@ukug.uk.freebsd.org>
# $FreeBSD$
-#
PORTNAME= plasma
PORTVERSION= 0.1
@@ -17,6 +13,8 @@ COMMENT= A plasma-effect screensaver kernel module
LICENSE= BSD
+SSP_UNSAFE= kernel module does not support ssp
+
.include <bsd.port.pre.mk>
.if !exists(${SRC_BASE}/sys/dev/syscons/syscons.h)